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Introduction

In this book, you will learn all about animation and a new software, Toon Boom Animate
Pro. As well as learning the basic interface and functionality of Animate Pro, you will
learn how to design structured characters. After that, you will continue to learn and
improve your animation skills by experimenting with valuable animation concepts such
as timing and squash and stretch.
Next, you will also learn about various walk-cycles; human, animal, two-legged, fourlegged.
Following that, you will see more advanced animation subjects like layout, posing, jump
animation, sceneplanning, multiplaning and camera moves. As you progress, you will
also learn to manipulate some of the more advanced features of Animate Pro. Your
scenes will start coming together!
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You will move on to advanced animation techniques, like lip-synching, acting, mouth
charts and voice breakdown. As you progress, more of the advanced sound features of
Toon Boom Animate Pro will be explained to you, and you will get to animate a character
based on your own recorded voice!
Then, you will learn how to add lighting and special effects to your animation.
Finally, you will learn one of the most advanced animation techniques available in
Animate Pro: digital cut-out animation. As you progress, you will learn about designing
a cut-out character, building and rigging it, then animating it. You will then animate your
own design, and also a four-legged cut-out animal!

About This Workbook
Your workbook is divided into several modules. Each one of these modules covers a very
specific aspect of the world of animation.
Each module starts with a theory section. You should become familiar with this before
continuing with the exercises, which are located at the end of the module.
Some of these exercises come with sample material. You will need to follow your
teacher’s instructions to use these files and templates.
Here is a list of all the modules contained in your workbook:
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•

M1: History of Animation, on page 15

•

M2: Animation Techniques, on page 23

•

M3: Animation Workflow, on page 33

•

M4: Introduction to Animate Pro, on page 55

•

M5: Character Design and Construction Sheet, on page 73

•

M6: Colour, on page 99

•

M7: Timing, on page 125
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M8: Squash and Stretch, on page 141
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M9: Anticipation, Drag and Overlapping Action, on page 147

•

M10: Animating a Walk-cycle, on page 155

•

M11: Four Legged Walk-cycle, on page 201

•

M12: Animating a Character Jumping, on page 223

•

M13: Scanning and Timing, on page 233

•

M14: Acting, on page 275

•

M15: Visual Breakdown and Lip-sync, on page 289

•

M16: Morphing, on page 305

•

M17: Layout Posing, on page 325
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M18: Gathering Content and Scene Setup, on page 351
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M19: Camera and Trajectory, on page 391
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M20: Basic Multiplaning and Camera Movement, on page 435
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M23: Effects in Animate Pro, on page 495
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M25: Building a Cut-out Puppet, on page 557
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M26: Library and Symbol Management, on page 611
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M27: Animating a Cut-out Puppet, on page 625
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M28: Sound and Lip-sync in Cut-Out Animation, on page 663
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M29: Cut-out Four-legged Walk-cycle, on page 671
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M30: Output and Rendering Options, on page 699
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M1: History of Animation

This module is divided into the following topics:
•

The History of Animation, on page 16

•

Activity 1: Build Your Own Thaumatrope, on page 21
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The History of Animation
Animation has a history of many innovations and discoveries from the 1800s to today. It
first started with optical toys, until the creation of films, of cinema and cameras as we
know today.

In the Beginning
Many early inventions designed to animate images were created as amusements for
children in the 1800's. Most of them were optical toys and later on, became more
sophisticated and used as entertainment for everyone. These toys are:
•

The Zoetrope

•

The Thaumatrope

•

The Flip Book

•

The Praxinoscope

What's an Optical Toy?
An optical toy is an item that uses persistence of vision to fool the eye and make you
believe that an image moves or is not what it seems.

What is Persistence of Vision?
Persistence of vision is when your eye's retina retains an image for a fraction of a second
before replacing it with a new image. If the images you are looking at are moving fast
enough, you will have the impression that you are seeing both images at the same time.
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The Zoetrope

The zoetrope creates the illusion of a moving picture. The first zoetrope was created in
China. The modern zoetrope was invented in England in 1834 by William George
Horner. It is a cylinder with vertical openings around the sides. On the inside edge of the
cylinder a series of pictures sit and when it spins anyone looking through the opening
sees a moving picture.

The Thaumatrope

This optical toy was invented by an English physician John A. Paris in 1825. The
Thaumatrope is a simple disc with two different pictures on each sides. Strings are also
attached at each ends of the disc. When the user spins the strings, the images appear
to merge and create a single illustration.
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The Flip Book

The first flip book was invented in 1868 by John Barnes Linnet. This was another device
used to create the illusion of movement. A flip book is a set of pictures printed or drawn
in a sequence inside a book. When the book is flipped at high speed, it creates the
moving effect.

The Praxinoscope
The praxinoscope was invented by French photographer Emile Reynaud in 1831. This
device was a more advanced version of the zoetrope. It was made of spinning cylinder
and a series of mirrors. Reynaud also developed a larger version of the praxinoscope so
that he could project the moving pictures onto a screen.

The Movie Camera
In the early 1900's the movie camera was invented. With this camera, a crank was
included in the mechanism which allowed the user to start and stop from filming when
they wanted. Quickly, people discovered the frame-by-frame technique which would
allow them to draw animation on paper. One of the first to use drawn cartoons to do
animation was Emile Cohl.
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Winsor McCay and Gertie the Dinosaur

In February 1914, Winsor McCay created an animated film of a dinosaur he called Gertie.
It was the first time that an animated character had a personality. Gertie the Dinosaur
would hide behind rocks, drink water, dance or even cry!
Winsor McCay drew thousands of drawings on paper of Gertie to bring her to life. He
would carefully flip through the drawings to make sure the animation was smooth and
fluid.

The Peg Bar

Around 1915, French Canadian Painter Raoul Barré created standard perforations in the
drawing paper and the peg bar that is still used today. The holes in the paper would
allow each drawing to be perfectly aligned on the peg bar and prevent any jerkiness in
the animation when it was filmed.
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The Rotoscope
Around 1915, Max Fleischer invented the rotoscope. This machine allowed the user to
transfer a live-action film into frame-by-frame drawings to create animation.

The Many Innovations of Disney Studios
Walt Disney was a pioneer in what was to become the standard methods of production
in an animation studio. They introduced the storyboard, a drawn script that would help
to visually understand what was going on in a film while they were creating it.
Many animated short movies from the Disney studios made history. In 1928, Steamboat
Willie was the first cartoon with synchronized sound. In this movie Mickey Mouse would
whistle, the boat would make noise and the characters movement was in-sync with the
music of the film. In 1932, the movie Flowers and Trees was the first animation to
introduce the Technicolor process technology.

One of the former Walt Disney Studios animator, Ub Iwerks also invented in 1933, the
multiplane camera. This special camera is used to move a number of different layers in
a scene to create depth.
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Activity 1: Build Your Own Thaumatrope
In this activity, you will create your very own optical toy.

You will need:
•

A circle cardboard of 100mm (approx. 4 inches) in diameter

•

A paper punch

•

2 pieces of 150mm (approx. 6 inches) of string

•

Coloured pencils

How to make a Thaumatrope
1. With the paper punch, make two holes, one on each side of the circle cardboard

2. Use your coloured pencils to draw a little bird on one side of the cardboard. Make
sure the bird is in the middle of the circle.
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3. Use your coloured pencils to draw a bird cage on the other side of the cardboard.
Make sure the cage is also in the middle of the circle.

4. Attach the strings on each side of the circle using the holes you punched at the
beginning of the exercise.

5. Using the ends of each string hold the thaumatrope in front of you. Start twisting
the strings in between your fingers, As you twist the string pull on the ends of the
stings, the cardboard disc will to spin quickly.

6. What do you see the bird and the cage doing?
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This module is divided into the following topics:
•

Animation Techniques, on page 24

•

Activity 1: Research a New Animation Technique, on page 31
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Animation Techniques
There are many different animation techniques that an animator can use to bring his
ideas to life.
Animation can be created using very simple tools such as a pencil and paper, advanced
computer systems or everything in between.
Here is an introduction to the various techniques available when it comes to creating an
animated movie.
•

Traditional Animation, on page 24

•

Digital Animation, on page 26

•

Stop-Motion Animation, on page 28

•

Sand Animation, on page 30

Traditional Animation

Traditional animation usually refers to animation hand-drawn on paper. It was the
process used for most of the productions in the 20th Century.
The animators would first draw characters, layout and backgrounds on paper. Each
drawing in the animation would be slightly different from the one before and the
drawing after, creating the illusion of movement when everything is put onto film.
Once the animation is all drawn on paper, it would then be photocopied or retraced on
transparent acetate sheets, called cels. After the line art is transferred on the cels, the
images would be painted using a colour chart that was pre-determined for each
character or element of the movie. Cels were essential to drawn animation since it
allowed the animator freedom from having to draw every element in the film on one
single layer of paper. Instead, by using cels, each element had its own layer and could
be animated separately.
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With today's technology, this traditional animation technique of using cels to colour
animation drawings is outdated. It is now possible to hand-draw animation, then scan
the drawings to finally colour them digitally using computer software such as Toon
Boom’s. So, it has become a mix of traditional techniques and digital techniques.
Traditional animation can be divided in three groups:
•

Full Animation

•

Limited Animation

•

Rotoscoping

Full Animation
Animators will refer to full animation when they are working on a high-quality animated
film. Often they will work with a high level of detail in the design and will try to animate
characters and elements so that they are believable, almost coming to life.
This type of animation often requires a huge number of drawings to make it very fluid
and realistic.

Limited Animation
Limited animation applies to animated films that will use fewer details. It is usually a very
stylized and expressive type of animation and rarely realistic. It was introduced by the
artists of the American studio United Productions of America (often called UPA).
The method was primarily invented as a cost-effective way to create animated television
series, but soon became a style of its own with its funky characters and background
designs and its original use of colour.

Rotoscoping

This particular technique is used by animators when they want to trace live action
sequence movement and turn them into drawings. They will often use the action
sequence as a basis and as an inspiration for character animation.
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Digital Animation
Digital Animation encompasses all the animation techniques that are done exclusively
with the use of computers. With digital animation, it is possible to do both 2D (twodimensional) and 3D (three-dimensional) animation.
Here are some of the digital animation techniques:
•

Digital Cut-Out Animation

•

Paperless Animation

•

3D Animation

•

Motion Capture

Digital Cut-Out Animation
Digital Cut-out Animation is done using cut-out puppets for character animation. The
characters are created using a separate drawing for each part of its body (head, neck,
torso, arms, legs, etc) and rigged together, inside the computer software, like a puppet.
Once the puppet is created, it can be added to the scene to be animated frame-byframe.

Paperless Animation

With Paperless Animation, the animator will often need to hand-draw characters,
frames, background and layout directly in the computer using an electronic pressuresensitive drawing tablet. This technique is very similar to traditional animation in its
process, the main difference is that it is all done in the computer.
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3D Animation

Three-dimensional animation requires that, before animating it, a character must be built
and modeled in the 3D animation software. They are then rigged with a virtual skeleton.
From there, a character can be integrated in a scene and animated like a digital puppet
frame-by-frame.

Motion Capture
The motion capture technique consists of recording the movement of a person, often
the performance of an actor, and using the recorded information to animate a digital 2D
or 3D character.
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Stop-Motion Animation
Stop-motion animation is made using real-world objects and photographing these
objects frame-by frame to create the illusion of movement on the screen. We can easily
divide stop-motion animation in a few categories. They are:
•

Puppet Animation

•

Clay Animation

•

Cut-Out and Silhouette Animation

•

Object Animation

Puppet Animation

Puppet Animation is a type of stop-motion animation which involves puppet figures that
are animated frame-by-frame. Usually the animators will first create a physical threedimensional scene, kind of like a small theatre, where the action will take place. The
puppets will generally have an armature (flexible skeleton) inside of them to allow them
to be positioned and animated smoothly. This also prevents the puppet from moving
and allows it to stay steady when the animator has to take a frame of the scene.
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Clay Animation

Clay Animation can sometimes be similar to puppet animation. The figures and
characters are made out of clay but they can also have an armature or a wire frame inside
of them to help them keep their pose a little better while shooting a scene. But with clay,
it is also possible that the figure be made entirely of clay and be animated like they are
morphing into different shapes instead of just moving like a puppet.

Cut-Out and Silhouette Animation

Cut-out Animation refers to animation made of out two-dimensional pieces of material.
More often than not, it is paper that is cut into different shapes. But it can also be fabric.
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The characters will usually be divided into different parts (head, neck, arm, leg, torso,
etc) and moved piece by piece to create the animation. Silhouette animation uses the
very same technique, except that characters and items in the scene will be completely
in black and only the background will have colours, so that it looks like a scene in
silhouette. The silhouette technique was invented by German animator Lotte Reiniger.

Object Animation

Object Animation is the term used when an animator uses regular inanimate objects as
props, characters and layout elements in their animation.

Sand Animation
This is another very interesting and different animation technique. Usually, Sand
Animation is done over a light box. In a completely dark room, the light box is then
turned on and sand is poured over the light box to hide the light. Then, using a brush or
a stick, the animator will start tracing a drawing in the sand to let the light come through,
at the same time creating a frame of animation. A picture is taken, and then the animator
will move the sand around a little bit for the next frame, thus creating movement.
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Activity 1: Research a New Animation Technique

In this chapter, we have covered the most common animation techniques, but there are
many more. Alone or in a group, do a little research on a new animation technique and
present it to your classmates. Bring photos to show visual examples of that technique or
better yet, bring the material you need and do a demonstration.
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M3: Animation Workflow

Studios follow a meticulous setup to get their movie from script to the big screen. Each
step must be done at a particular moment in the production for it to come to
completion. In this book, you will see a list of all the required staff and also, the different
types of workflow studios follow while in production.
This module is divided into the following topics:
•

Production Staff and Outsourcing, on page 34

•

Traditional Workflow, on page 42

•

Cut-out Workflow, on page 46

•

Tradigital Workflow, on page 50
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Production Staff and Outsourcing

Someone making a short animated film at home might be able to do their film from start
to finish, but on a big movie or TV production, this is not the case at all. In the following
section, you will see a list of all the staff required to take a full animated movie
production from concept to completion.

Production Staff - Descriptions
Animatic Editor
This person takes storyboard elements and assembles them against the recorded sound
track. The Animatic Editor works with the Director to edit the images, pacing and voice
audio to a certain length. Once that is done the animatic is considered “Locked” and no
more changes will be made.

Animation Director
The animation team is supervised by the Animation Director who will breakdown the
storyboard into sequences for handout, handout and check animation before sending it
forward for director approval. He will be able to help with any animation related issues,
and will co-ordinate the revision and retake process with the animators.

Animation Supervisor
Once the animators have completed their animation, the Animation Supervisor will
review the animation and provide comments before forwarding the animation to the
Animation Director.

34

Animation Workflow

Animator: Cut-out
Cut-out animation is a vast subject. There are many techniques employed by different
studios and animators. Basically, the animator moves the parts frame-by-frame to
animate the puppet. The animator may even start their own pre-compositing, camera
moves and trajectories. This depends on the user workflow. Once the animation is
completed and approved, the scene goes to the final compositing and effects.

Animator: Tradigital
All of the drawings are created digitally, using a pen tablet to optimize work and drawing
ability. Other than the digital aspect, the animation principles are not very different from
classical animation. The animator will use the same animation styles and methods as
would be used on paper. Only the medium is changed. When all of the animation is done
and the drawing timing is completed through the exposure sheet or the timeline view,
the scene can be sent to the animation clean-up process.

Art Director
The Art Director has a key role in production. He sets the look of the show, and is most
often a highly skilled Location/Layout Designer and very skilled BG Painter. In the
Development Process that takes place at the very beginning of the production, this
person works with the Director and Design Supervisor to develop the visual and colour
style of the show, and will maintain that look throughout the production.

Assistant Director
As the name implies, this person assists the Director in all aspects of production. The
Assistant Director’s duties vary, depending on the way the Director likes to work, but
they are aware of all of the creative requirements and will make decisions when the
Director is unavailable.

Background Layout and Posing Artist
The layout and posing process links the storyboard artist and the animator. The layout
artist uses the storyboard and prepares an organized folder for the animator. This folder
contains a field guide that shows the proper camera move and the right size of the
scene. It also includes the character’s main poses from the storyboard following the
official design, the effects, backgrounds and all the other information necessary to the
animator.
The backgrounds are done directly out of the storyboard and the location design. A
background is a section or an angle of a location.
The background artist refers to the storyboard and draws the background for each
scene. Once the background is completed, it will be added to the layout folder. In a cutout or tradigital process, this step can be done digitally or traditionally. This will depend
on the user’s preferences. This step is mainly applied to larger productions. An individual
user can move directly from the storyboard to the animation.
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Background Painting
Once the background layouts are completed, they are ready to be painted. The
background painter will take the final layout and paint them using the palettes created
by the colour stylists. Once the backgrounds are painted, they will be sent to the Scene
Setup team or the Compositing team.

Casting Director
The Casting Director arranges the casting call-out to the performing industry for
auditions and schedules the location and time. The Director usually attends and is
provided copies of the casting recording by the Casting Director. Once the Director has
made a decision, this person will work with the Line Producer to facilitate the contract
negotiations with the actors. The Casting Director will have a more detailed knowledge
of the performance rights and royalty requirements and will be able to advise the Line
Producer.

Voice Director
The Voice Director controls the voice recording session, works with the actors and relays
the Director's information about what is wanted from the actor’s performance. Voice
Directors are very astute and readily pick out any problems in the way that a line is
phrased or spoken by the actor.

Character, Prop and Location Designer
Once the script is completed, the designer can start work. Before any animation,
background or colouring can be done, the design needs to be addressed. The artist has
to decide on the production style, the character’s look, the locations’ complexity, etc.
Once these designs are done and approved, the “Model Pack” is produced, containing
all of the models for all these aspects. The designs and models will be used by the colour
stylist and layout artist, and finally by the animator.

Character and Prop Breakdown Artist
The breakdown step is really important in the cut-out workflow. The person doing the
breakdown has to take the final model and start building the puppet. This means
deciding which parts will be separated and preparing all of the joints and views for the
animators. Once the parts are broken down, the character or prop must be rigged. This
means attaching the parts and assigning the appropriate pivot points. This step must be
done with care because these puppets will be distributed among all the animators later
and you do not want to duplicate mistakes throughout the project. When the character
and prop rigs are ready, the breakdown artist will store them in the library as templates
to be shared with the rest of the team.
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Clean-Up Artist: Tradigital Animation
The animation clean-up consists of transforming the rough tradigital animation into
cleaned and inked drawings. On a new layer, the clean-up artist will trace the animation
following the official model pack. This step must be accurate. When the clean-up is over,
the scene can be passed to the colourist for the ink and paint step.

Colour Editor
This person assembles the colour frames and works with the Director to cut the show to
length. They will render the show and send it on to the Post Facility that will do the final
Picture/Audio Mix. Copies of the Picture Lock will be sent with running timecode to the
Music Composer and Sound Editors so they can begin the creation and assembly of
those elements.

Colour Stylist
Once the black and white designs are done, they are sent to colour styling. The colour
stylist will choose the colours and ambiance for the production and will balance the
characters, props and effects with the locations’ palettes. This contributes to an even
feeling or an emotional contrast where needed in the show. When the colours are
approved, colour models are produced and backgrounds are painted. Colour models
will often be added to the Model Pack. The colour models will be used by the colourists
and the coloured background will be sent to the compositing.

Colourist: Ink and Paint
Now the colour models are ready and the drawings are scanned in and properly
exposed. When the drawings are cleaned, inked and painted, they are ready for
compositing.

Compositor
The compositor imports the coloured background, the animatic reference and the sound
as required. Referring to the exposure sheet, the animatic and the animation, the
compositor assembles all of these elements and creates the camera moves and other
necessary motions. Finally, the compositor adds any digital effects required by the
scene. These can include tones, highlights and shadows. When the compositing is over,
the final step is the rendering.

Director
The creative head of the production who makes all of the main creative decisions
determining the style and look of the show. Keeping the schedule and budget in mind
he has approval over all aspects of the production from development right through to
final picture.
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Editing Co-ordinator
Functioning like the Production Co-ordinator, this person maintains the scheduling and
organization within the Editing Department. In smaller studios with very few
productions, this role can be handled by the Production Co-ordinator, but is probably
necessary in a busy studio with multiple productions.

Editing Department Manager
This person functions like a Line Producer for the Editing Department. Looking at all the
allocated budgets for editing for each production, they maintain the organization and
scheduling for all productions through editing. In a large studio with editing facilities in
house, this is an important role, but if the pre and post editing are contracted to an
outside facility, then this role will be filled by someone there.

Effects Designer: Computer Generated
To maintain a consistent look for any effect throughout an entire show, the Effects
Designer will create effect templates that the compositor will use to composite the
scenes. The Effects Designer will create the look of the effect for the whole project.

Effects Designer: Hand-drawn
When a scene’s animation is completed, it will be sent to the effects department where
the effect designer/animator will add the effects such as smoke or splashes. He will often
hand-draw the effects. Once the effects are completed, it will be sent to the
Compositing department.

Information Technology (IT) Professional
The IT professional has a series of responsibilities from installing applications to building
complex computer networks and information databases. The IT professional also takes
care of the data management, networking, engineering computer hardware, database
and software design, as well as the management and administration of entire systems.
Of course, different studios will have different task definitions for their IT department.

Library Manager
The library is a central element of a digital cut-out production. It contains all of the assets
for the animation and the scene set up. The library is a central location where all these
templates are stored organized and made available to the animators and the scene
setup team. The library should be structured so that everyone using it can easily find the
assets they require. Someone should be assigned to manage the library so that it
remains well organized. This person is often the breakdown artist, but depends on each
studio’s structure. When the library is built, the scene setup person and the animators
will start using the assets.

38

Animation Workflow

Line Producer
This person fills a major organizational role in the production. At the start they usually
create the schedules based on the budget allocated for the series and the contracted
delivery dates to broadcasters. During the course of the production they monitor the
production flow making schedule adjustments as needed, but always keep in mind any
budget limitations and final delivery dates. They are aware of the costs of performance
rights and will negotiate the deals with the Voice Actors. They also control the staffing
of the project, contract negotiations with Second Unit Productions, outside production
facilities (record studios and post production facilities), outsourced processes like
storyboard, Casting Directors, and they provide production and cost reports to the
studio.

Music Director
This person is very knowledgeable about music, and maintains contacts with industry
music writers. At the beginning of a production the Music Director helps audition writers
willing to write the musical score and also helps the Line Producer to negotiate contracts
with them. He also co-ordinates the recording and deliveries of the music for
productions. In large studios the Music Director works for the studio, in smaller studios
this role can be outsourced or be handled by the Line Producer.

Music Editor
This person will take the recorded musical score recorded and, using the timecode
markers provided by the Composer assemble the new music against the picture and
make any adjustments necessary. They will also add any music cues from a music library
for the show where it is needed.

Production Assistant
This is another person who helps with the organization on a production level. They
generally create and distribute Preliminary Design lists for Design Department. They will
track the progress of designs through to completion.
Note: In much larger productions, like feature films, each department has a Production
Assistant to control the tracking and organization of the work through the department.

Production Co-ordinator
This is the Line Producer's assistant who helps with the scheduling and arranging of
duties during production. They will book times with the Recording Studios and Post
Production Facilities based on the delivery schedule, keep track of all deliveries of things
like scripts, storyboards and other production materials. They will track time-sheets for
the crew and deliver them to the Line Producer for signing. The Production Co-ordinator
is highly organized, detail oriented, and is critical in helping to maintain the
organizational structure within the production.
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Scene Organization Manager
To start a project, the Scene Organization Manager will create all the scene files in the
production software and organize the structure to keep control on the project and make
sure that everything is organized properly.

Render Operator
Once the compositing is completed, the only step left is to render the scene as a movie
or an image sequence. Generally, the compositor will be the same person doing the
render.

Scan Operator
The cleaned-up drawings are scanned and imported to the software in a simple step that
incorporates all of the drawings in the scene.When all of the drawings are scanned, they
are ready to be inked and painted.

Scene Setup Artist
The scene setup consists of preparing the scenes for the animators and is similar to the
traditional layout and posing. Following the storyboard and the animatic, the person
working on the scene setup will import the assets needed for the scene animation, as
well as import the animatic reference and often position the camera. When the scene
setup is completed, the scene can be passed on to the animator who can start animating
without having to mount the scene.

Sound Editor
Adds the sound effects and ambient noises for the entire episode.

Supervisor
This person manages the design team that will create the character, location, prop and
sometimes the effects designs in the production. Usually, this person is a very strong
character designer with superior drawing skills.

Storyboard Artist
In TV productions this role is usually outsourced to a freelance Storyboard Artist. They
are responsible for providing the visual blocking and staging for the show based on the
Director's handout.

Storyboard Revision and Clean-Up
Usually a staff position, they will do any visual changes requested by the Director while
preparing the storyboard for the animatic (also called Leica or Story Reel). Once the
Animatic is done, they also conform the storyboard using the new timing available in the
locked animatic.
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Story Editor
This person will supervise all of the writers in the creation of the premises, outlines and
script drafts. The Story Editor is responsible for maintaining storytelling style and
characterization of action and dialogue. This person is brought in very early in the
production and begins developing ideas that are submitted as story suggestions that
may eventually be made into scripts. Some writers are hired through agents and may
negotiate royalties for the works they create.

Technical Director
The Technical Director has many responsibilities in the production. First, he builds scenes
from the EDL (Edit Decision List) provided by Editing. He trouble shoots any technical
issues relating to software, individual work stations and technical problems with scenes.
He makes sure that all scenes are rendered and the final frames delivered to Editing at
final colour. He will work with the Information Technology (IT) Department regarding
network issues, and they will work with Production Engineering Programmers to resolve
Digital Production Assets Management issues that may arise during production.

Xsheet Technician
This controls the timing of the animation. The traditional animator creates a paper
exposure sheet in order to create the timing. The person in charge of the digital
exposure sheet reads the paper version and recreates it in the animation software. Once
the drawings are all in place on the exposure sheet, the scene is ready for the scan.

Production Outsourcing Duties
The Recording Studio
This is the specialized facility where voice and live music will be recorded. They will
provide the Recording Engineer and equipment for the recording, and they will deliver
copies of the recorded audio and Take Sheets to the production.

Post Production Facility
Small studios cannot afford to equip and maintain an industry standard post production
facility, so this is usually something that is hired for the completion of the production.
They will take the final audio and final picture and make a final mix of the show. The
picture will be quality checked for colour balance and to meet broadcast signal
standards. They will provide digital masters or the completed show and versioning for
different markets. They may also provide closed captioning for the final picture if
needed.

Second Unit Production
Any studio or facility that is sub-contracted any of the production of the art or animation
is a Second Unit. They are doing service work for the Producer and delivering the final
elements. If they are doing Animation, they will have a similar crew structure as listed.
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Traditional Workflow
The traditional workflow is a very straight forward pipeline. A lot of the steps cannot be
done simultaneously and so they must be completed before going to the next step in
the process.
In the following graphic, all the purple steps are done in another software (like recording)
or on paper (character designs, animation, backgrounds,...) The storyboard would be
done on paper, but scanned in build in either a specific software or an animation
software. Everything in yellow and gray is done in the animation software.
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Starting the Project
The Script
All projects start with a script. It is the foundation of the whole project. This comes from
either the studio itself or the client requesting the project.
By closely following the script, the design team will begin the character, props and
locations and design. The storyboard artist will start working on the storyboard.

Pre-Production
Designs
The design team will take the character, prop and location in charge as soon as the script
is locked.
For a traditional project, the designs will be done on paper. They will be cleaned up,
added to the Model Pack and sent to colour styling.

Dialogue and Nat Pause
•

Dialogue
The dialogue is recorded from the script. This audio recording step often takes
place outside of the animation studio and is handled by one person in charge of
that task. The dialogue is broken down for the animators and depending on the
planning, also for the storyboard.

•

Nat Pause
Nat Pause is used by the Storyboard Artist to hear what the characters are saying
and how it is said so they could draw the correct expression. It is important to
minimize the revision to the visuals. You don't want an angry expression when
the character sounds happy.

Storyboard
The storyboard is the illustrated script of the film. It can be started in parallel with the
design and the audio recording, but some studios may wait until the designs and the
audio recording are locked.

Animatic
The animatic is created from the storyboard. Each scene is timed along with sounds,
dialogs and music. Before the animatic can be created the storyboard has to be
completed, approved and locked. Only one person is in charge of the animatic
production, this ensures consistency throughout the whole production.
If the storyboard is done on paper, a person will have to be added to the team to scan
the storyboard and prepare it for the animatic.
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Colour Styling
Colour styling can be done before or after the animation. It doesn’t really have an impact
on the pipeline. It can be done on paper, or directly in an animation software.
If the backgrounds are painted in an external software, it is recommended that you do
the locations (key backgrounds) colour styling in that same external software.

Production
Background Layout and Posing
For the traditional production, the layout and posing step is very important to
communicate the storyboard information very clearly to the animators. The layout will
contain all the information needed to do the animation in the scene: background,
overlay, underlay, and key poses (usually referenced from the model pack) that will guide
the animator to what is going on.
In both small and medium studios, background layout and posing will be handled by the
same person. The background layouts will be done by one person or team and the
posing by another one. For the small studio with a limited amount of resources, the
storyboard artist or the animator will create the layout and posing.

Background Colouring
Backgrounds can be painted using the animation software or in an external software. On
a small team, one person can handle the background painting and on a medium team,
there will probably be two people painting the backgrounds.

Animation and Line-test
In a traditional animation, the animation and the clean up are done on paper, assisted
by the layout and posing. The animation is one of the longest steps in a production. So
the main part of the team should be composed of animators and clean up artists.

Line-test
During the animation process, the scenes are regularly passed through the line-testing
process, which consists of quickly testing the rough key poses of an animation to see if
the animation is going in the right direction.

Scan
The Scan step is the gateway between traditional and digital animation. To import the
animation drawings in to the project, a person is assigned to the scan task.
The scan is done prior to the exposure sheet. Once the drawings are scanned in, the
person in charge of the exposure sheet will see the timing.
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Exposure Sheet
The Exposure Sheet person will reproduce the animator’s paper x-sheet either from
scanned drawings or for the drawings to be scanned in. It is a straight forward task
generally handled by one person on a small team. Often, it will be the scan person who
will handle the digital exposure sheet.

Ink and Paint and Compositing
The Ink and Paint process is probably the longest digital step. It requires cleaning all of
the drawings, inking lines and filling all of the colours on all drawings. The length of time
this procedure takes is dependent of the complexity of the drawings, if there are a lot of
details and lines to be inked, the colour step will be longer.
The compositor on the other hand will verify that a scene as been animated and
coloured, and then will apply camera moves, peg moves, effect and final touch up to the
scene.

Post-Production
When all the scenes are rendered out, the user will assemble them in an external
application and add the sound to the project. The final effects and filter will be added.
The final step will be to render out to the master and distribute it, unless there is dubbing
to be done. Very often, the final transfer will be done by an external post-production
company.
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Cut-out Workflow
Other than scripting, and recording, every other step in the cut-out workflow should be
done in the animation software. It is also a type a workflow were multiple assignments
can be done simultaneously, especially during design and development stage.
Since the storyboard doesn’t need to follow model sheets, it’s possible for a team to
both be doing the storyboard and designs at the same time compared to a traditional
workflow where the storyboard artist will need to have all the models ready before
starting.
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A Cut-out production reuses a lot of assets, saves time, keeps a maximum amount of
work in the same studio and reduces the amount of resources and budget needed. We
eliminated as many traditional and hand-drawn steps as possible and keep all of the
steps in an integrated pipeline.
Other than the script writing, audio recording, and post-production, all of the tasks are
accomplished within software.
In a Cut-out animation project, there is no need to do the posing step or even for the
storyboard to be on model because the characters are always on model because they
are puppets and the scene setup step is meant to set the scene elements’ scale and
composition.

Starting the Project
The Script
All projects start with a script. It is the foundation of the whole project. This comes from
either the studio itself or the client requesting the project.
Following the script, the design team will design the character, props and locations and
the storyboard artist will build the storyboard.

Pre-Production Variants
Designs
Designs for the characters, props, and locations are done directly in the software as they
will be broken down and rigged in it. This way, whatever the breakdown technique
chosen, the lines will be the same style, the palette will already be created and it will be
less work to break-down and rig. It is also possible to design them on paper and scan
them in, but this is less efficient in the use of paper resources and time.

Dialogue and Nat Pause
The dialogue is also recorded from the script. This step is often recorded outside of the
studio and handled by one person. If there is dialogue involved in the project, the final
version will have to be recorded soon enough to import it into the project before the
animation. This allows the animator to do the sound breakdown and animate the mouth
and expressions, as well as the storyboard is required.
Nat Pause is used by the Storyboard Artist to hear what the characters are saying and
how it is said so they could draw the correct expression. It is important to minimize the
revision to the visuals. You don't want an angry expression when the character sounds
happy.
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Storyboard
The storyboard is the illustrated script of the film. It can be started in tandem with the
design and the audio recording, but some studios wait until the designs and the audio
recording are finalized.

Animatic Reel
The animatic reel, also known as “leica”, is made from the storyboard. Each scene is
timed along with sounds, dialogs and music.The storyboard must be completed,
approved and locked before the animatic is done. The person in charge of the animatic
must ensure consistency over the entire production.

Colour Styling
The colour styling must be done before the animation and character breakdown.
If the backgrounds are painted in an external software, then the locations (key
backgrounds) colour styling should be done in that same external software.

Production
Background Layout
From the storyboard, we normally go to the layout and posing process. For a Cut-out
project, the storyboard does not even need to be on model as the characters and props
used for the animation are reused puppets that are always on model.

Background Painting
The backgrounds can be painted within the animation software or in an external
software.

Character and Prop Breakdown
The character and prop breakdown can be done in many ways. It is important to do this
step correctly as these puppets will be duplicated over and over through the whole
project. The artist will study the designs made during pre-production, and will then cut
it all in pieces to build puppets out of it.

Library Management
The library is normally managed by the breakdown artists. It is important to keep it
organized because it is a central piece in the animator’s project. So the artist will basically
create folders and organise each needed file so that either the scene setup artist or the
animator doesn’t have to search when looking for particular pieces of material. It is
essential for this job to be done correctly if the team wants to stay efficient throughout
production.
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Scene Setup
The production starts with the scene setup, which is the equivalent of traditional posing.
The scene setup team is a central point in a Cut-out production because they ease the
workload of the animators, keep a consistency over the project, reduce the amount of
retakes and increase the animation quality and speed. Scene setup artists place puppets,
props and camera in a cut-out animation scene so that it is ready for the animator.

Animation
The animation technique has to conform with the rigging technique. The studio has to
establish its profile in order to determine which direction to take.
Here are the choices for the type of animation:
•

Open Rig technique with Motion Keyframe animation.

•

Open Rig or Mixed Rig technique with Stop-Motion or Motion Keyframe
animation.

•

Complete hierarchy rigging technique with Motion Keyframe animation or Open
Rig technique with a mix of Stop-Motion and Motion Keyframe animation.

•

Complete Hierarchy rigging technique with Motion Keyframe animation or Open
Rig with Stop-Motion Keyframe animation.

In certain situations, Tradigital animation features can help increase the quality of your
Cut-out animation.
In a small team, the animators will animate their own effects, whereas a bigger team can
have one effect animator to help the Cut-out animators.

Compositing
Compositing is generally a bit more advanced and complex for a Cut-out production
than for a Traditional or Tradigital one. He will verify that a scene as been animated and
coloured, and then will apply camera moves, peg moves, effect and final touch up to the
scene.
On a small team, the animators will probably do their own compositing. In a medium
studio, there will be two or three compositors.
The rendering step is generally handled by the compositor.

Post-Production
When all the scenes are rendered out, the user will:
1. Assemble the scenes using an external application.
2. Add the sound to the project.
3. Add final effects and filters.
4. Render out to the master.
5. Distribute the scene, unless there is dubbing to be done.
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Tradigital Workflow
The Tradigital workflow is a mix between traditional animation and digital animation
workflow. While some steps can all be done in the animation software and
simultaneously, some other steps, like animation, animation clean-up and ink and paint,
require that the previous steps be done completely before moving to the next.

A Tradigital production is meant to use a very small amount of paper, or to eliminate it
altogether.In this workflow example, we tried to eliminate a maximum number of
Traditional steps and keep all of the steps in an integrated pipeline.
Other than the script, audio recording and post-production, all of the tasks are
accomplished within the animation software.
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Starting the Project
The Script
All projects start with a script. It is the foundation of the whole project. This comes from
either the studio itself or the client requesting the project.
Following the script, the design team will start designing the character, props and
locations and the storyboard artist will start building the storyboard. Again, this process
is similar to any other workflow.

Pre-Production Variants
Designs
We recommend that you design the characters, props and locations directly within the
animation software to keep everything digital and save time. You can also design them
on paper and scan them in, but this requires a bit more work and handling.

Dialogue and Nat Pause
The dialogue is also recorded from the script. This step is often recorded out of the
studio and handled by one person. If there is dialogue involved in the project, the final
version will have to be recorded in time to import it in the project before the animation.
This allows the animator to do the sound breakdown and animate the mouths and
expressions, as well as the storyboard if required.
Nat Pause is used by the Storyboard Artist to hear what the characters are saying and
how it is said so they could draw the correct expression. It is important to minimize the
revision to the visuals. You don't want an angry expression when the character sounds
happy.

Storyboard
The storyboard is the illustrated script of the film. It can be started in tandem with the
design and the audio recording, but some studios will wait until the designs and the
audio recording are finalized.

Animatic
The animatic is created from the storyboard. Each scene is timed along with sounds,
dialogs and music. The storyboard must be completed, approved and locked for the
animatic to be created. There will be a person in charge of the animatic to maintain
consistency over the whole production.
Note that if the storyboard is done on paper, someone will have to scan the storyboard
and prepare it for the animatic. In a small team, the animatic person can take care of the
scan.
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Colour Styling
The colour styling can be done before or after the animation. It does not really have an
impact on the pipeline. This step can be done on paper, directly in the animation
software or in external software.
If the backgrounds are painted in an external software, the colour styling of the locations
(key backgrounds) should also be done in this same external software.

Production
The production part of Tradigital animation can be completely done within the
animation software. This includes the animation, the clean up, the inking and painting,
the background painting, compositing, etc.

Background Layout and Posing
For the Tradigital production, the layout and posing step is very important as it helps to
clearly communicate the storyboard information to the animators. The layout will contain
all the information needed to do the animation in the scene: background, overlay,
underlay, and key poses (usually referenced from the model pack) that will guide the
animator to what is going on.

Background Painting
The backgrounds can be painted in the animation software or in an external software.

Animation and Dialogue
In a Tradigital animation production, the animation and clean up are digitally assisted by
the layout and posing. The animation is one of the longest steps in a production. The
core of the team should be composed of animators and clean up artists.
If there are dialogues to be animated, the animator will import the sound files in the
project and use the sound scrubbing or the automated lip sync detection features to
breakdown the sound and establish which mouths to use and animate.
There is no need to do a traditional sound-break down.

Inking, Painting and Compositing
The ink and paint process is probably the longest digital step. It requires you to clean all
of the drawings, ink the lines and fill all of the colours on all drawings. If there are a lot
of details and lines to be inked, the colour step will take longer.
The compositor on the other hand will verify that a scene as been animated and
coloured, and then will apply camera moves, peg moves, effect and final touch up to the
scene.
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Post-Production
When all of the scenes are rendered out, the user will assemble them in an external
application and add the sound to the project. The final effects and filter will be added.
The final step is to render out to the master and distribute it, unless there is dubbing to
be done.
A single person is sufficient for the final editing. Very often, the final transfer will be done
by an external post-production company.
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M4: Introduction to Animate Pro

This module is divided into the following topics:
•

Theory, on page 56

•

Activity 1: Drawing Basic Shapes, on page 64

•

Activity 2: Drawing Characters, on page 68
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Theory
This topic is divided as follows:
•

Interface Highlights, on page 56

•

Timeline View, on page 58

•

Frequently Used Buttons, on page 59

•

Interface Navigation, on page 61

•

The Basic Drawing Tools, on page 62

Interface Highlights
It is very important that you familiarise yourself with the interface before you start the
activities with Toon Boom Animate Pro.
As you work through this book and learn to use the software, you can come back and
refer to this section whenever you need to.
1

3

2

4

9

8

6

5

7

Note: The numbers in this list correspond to the numbers in the interface diagram.
1. Top Menu
This menu contains most of the commands available in the software.
2. Playback Toolbar
This toolbar is used to play back your animation, loop it, change the playback range
and temporarily modify the frame rate.
3. Workspace Toolbar
This toolbar is used to customize and load different workspaces. Workspaces are
different ways the views in the software are organised.
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4. Colour View
This view is used to select, create and modify colours. You can also create specific
palettes and palette styles for your characters.
5. Library
This view is used to store and reuse Symbols and templates. Anything you create in
Animate Pro, you can store in the Library. It is also where you will take the sample
material needed for certain activities.
6. Tool Properties View
This view contains the options related to the currently selected tool. When you work
with a tool, you will often use the Tool Properties view to either alter a selection or
change the tool’s behaviour. Like for example, resize your brush!
7. Timeline View
This view is mainly used to add layers, change the timing, create effects and select
or order your elements.
8. Tools Toolbar
This toolbar contains most of the drawing and animation tools you will use when
working in Animate Pro. For example, the Brush, Paint and Select tools.
9. Camera View
This view is the centre of your operations. This is where you draw, paint, animate,
position your elements, and view the animation playback and results of any effects
you add!
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Timeline View
The Timeline view is the main view used to adjust the timing of your drawings, connect
effects and select or order layers. This year we will not explore the total possibilities of
the Timeline view, these are the things you should know for now!
1

2

Note: The numbers in this legend correspond to the numbers in the Timeline view.
1. Types of layer used in the Timeline view:
•

Drawing

•

Camera

•

PegMask

•

Effect

•

Sound

2. An exposed drawing is represented by a grey block. Exposing the drawing for
several frames extends the grey block. Exposing a second drawing displays a new
grey block.

The Timeline’s Basics
The timeline is divided in two sections. On the left, you have the names of the layer with
buttons to add, delete, duplicate, show or hide the layers. On the right, you will find the
frames that are included in the those layers.
This is where you find the basic information
about each layer.
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This is where you find all the frames
included in each layer.
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Frequently Used Buttons
In this guide, you will find tools that you will use frequently. Most tools have a button.
Recognizing these allows you access the tools faster. Here are the main ones you will use
in the following activities:
•

Edit: The Edit tools are used to copy, cut, paste, delete a selection and cancel
actions.

•

File: The File tools are used to import images, open, close and save scenes.

•

Selection: The Selection tool is used to select drawing strokes and modify them.

•

Drawing: The Drawing tools are used to draw and design your characters and
backgrounds.

•

Onion Skin: The Onion Skin tool is used to view previous and next images.

•

Paint: The Paint tools are used to paint your drawings.

•

Gap Closing: The Gap Closing tools are used to close gaps while painting.

•

View: The View tools are used to navigate within the Camera and Drawing views.

•

Layers: The Layers tools are used to add different types of layers in the Timeline
view.

•

Playback: The Playback tools are used to play back your animation.
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•

Sound: The Sound tools are used to edit and play back the sound.

•

Layout: The Layout tool lets your organize your workspace.

Introduction to Animate Pro

Interface Navigation
In the different views, you can Zoom In, Zoom Out, Rotate, Pan and Reset View Position.
Do not hesitate to refer to this list whenever you need to:
•

Zoom In:
Zooms into the view. Use the keyboard shortcut [Ctrl]+[=] (Windows) or [a]+[=]
(Mac) or from the top menu, select View > Zoom In.

•

Zoom Out:
Zooms out of the view. Use the keyboard shortcut [Ctrl]+[-] (Windows) or
[a]+[-] (Mac) or from the top menu, select View > Zoom Out.

•

To Zoom In and Zoom Out with the mouse:
Hold down [Spacebar] and your middle mouse button while moving the mouse
up or down.

•

To Pan the view:
Hold down the keyboard shortcut [Spacebar] and drag your mouse in the
direction you want to pan the view.

•

To Recentre the view:
Click on the keyboard shortcut [F12] (Windows) or [a]+[F12] (Mac) to recentre
the view on your mouse cursor.

•

Reset View:
Resets the view to its default position. Use the keyboard shortcut [Shift]+[M] or
from the top menu, select View > Reset View.

•

Reset Rotation:
Resets the view’s rotation to its default position. Use the keyboard shortcut
[Shift]+[X] or from the top menu, select View > Reset Rotation.

•

Reset Pan:
Resets the view’s pan to its default position. Use the keyboard shortcut
[Shift]+[N] or from the top menu, select View > Reset Pan.

•

Reset Zoom:
Resets the view’s zoom to its default position. Use the keyboard shortcut
[Shift]+[Z] or from the top menu, select View > Reset Zoom.

•

Toggle Full Screen:
Enlarges the selected view to full screen. The full screen process is done in three
stages. Use the keyboard shortcut [Ctrl]+[F] (Windows) or [a]+[F] (Mac) or from
the top menu, select View > Toggle Full Screen.

•

Rotate 90 CW:
Rotates the Camera View 90 degrees clockwise, like an animation table,. From
the top menu, select View > Rotate View CW.

•

Rotate 90 CCW:
Rotates the Camera View 90 degrees counter-clockwise, like an animation table.
From the top menu, select View > Rotate View CCW.
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The Basic Drawing Tools
Here is a list of the first drawing tools you will use in the following activity. Make sure you
are familiar with them as you will be using them often.

The Brush Tool
The Brush tool allows you to draw strokes. Just select a colour in the Colour Tab, then
draw a stroke in the Camera View. To change the size shape or smoothness of your
brush, you need to go to the Tool Properties Tab.

The Eraser Tool
The Eraser Tool allows you completely erase or partially erase parts of a stroke. To
change the size shape or smoothness of your eraser, you need to go to the Tool
Properties Tab.
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The Select Tool
With the select tool you can select strokes or fill colour in the Camera View. To select a
stroke, click and drag a selection around it, an orange bounding box appear around it.

This bounding box has handles that you can use to scale or rotate the stroke.

The Paint Tool
The Paint Tool is used to fill a shape or a stroke with colour. For the Paint Tool to work,
the shape must be closed.

This shape is not
closed so the Paint
tool did not fill the
shape.

This shape is closed so the
Paint tool filled the shape.
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Activity 1: Drawing Basic Shapes

The first exercise will consist of drawing simple shapes using Animate Pro. This allows
you to get used to the tools and the interface, as well as drawing with a tablet.
1. Start the software by double-clicking the icon.
2. In the Welcome Screen, name your project Shapes followed by your initials.
3. In the Timeline view, you will see that you will already have a drawing layer available.
Select the first frame.

4. Select the Brush Tool

.

5. In the Colour Tab, select a colour from the palette.

6. In the Camera view, draw different shapes. Keep your hand steady and the shapes
tidy.
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If you feel your strokes are not the way you want them to look, you can always
delete them by selecting with the Select
erase them with the Eraser

tool then pressing the [Delete] key or

tool.

7. Next, you will need to fill your shapes with colour. But to do this, you must first add
new colours to your palette. Go to the Colour tab and click on the
Add Colour

button. A new swatch will be added to the palette.
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8. Double-click on the swatch to make the Colour Picker window to appear. Select a
colour then close the window.

The colour swatch will now be updated and you can use to colour your work.
9. Select the new swatch, then select the Paint
10.Fill in some of your shapes with the new colour.
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11.Repeat Step 6 to Step 8 so that you fill you shapes with at least four different
colours.

12.Make sure that you save your work by clicking the Save

button.
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Activity 2: Drawing Characters
In this activity, you will use Animate Pro draw your own characters. You will start by
creating the appropriate layers, then move on to sketching and clean-up. Finally, adding
colour to your creation.

Creating Your File
1. Start the software by double-clicking the icon.
2. In the Welcome Screen, name your project Characters followed by your initials.

Creating and Renaming Layers
1. In the Timeline view, add another layer. Click the Add Layer
Drawing.

button, then select

You now have two drawing layers.
2. To rename the drawing layers, click once on the name of the layer. The name field
becomes editable and you can type in the new name.

Rename the top layer Clean_Up and the bottom layer Sketch.

Sketching Your Character
You will create your character in three parts. First you will be sketch your idea until you
are happy with your design.
1. In the Timeline view, select the first frame of your Sketch layer.

2. With the Brush
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tool, sketch your character in the Camera view.
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Keep the pose simple and focus on getting the shapes, volume and anatomy
correct. Once the body is blocked in, you can sketch the details like hair, face and
clothes.

3. If you click on the first frame of the Clean_up layer, you will now see that your sketch
will still be visible, but in a lighter shade. You can use that feature to clean your
design.
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Clean-up
Once your sketch is ready, you can do the clean-up.
1. Select the first frame of the Clean_up layer, If you haven’t already done so.

2. With the Brush

tool, clean-up the sketch which you just made.

Select an appropriate colour in the palette, then start cleaning your sketch until you
are satisfied with the result.

3. Finish the full character.
Make sure that all shapes are closed. This will make the colouring step easier
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Colouring
Now that the clean up is done, you are now ready to colour the character.
First you must create colours for your character.
1. In the Colour Tab, click the Add Colour
palette.

button to add a new colour to your

2. Double-click on the new colour for the Colour Picker window to open. You can then
change the colour to the one you want to use.

3. Before closing the Colour Picker window, take the time to rename your colour. Just
change the default name for an appropriate one.

Once this is done, you can close the Colour Picker window and the new colour will
be updated in the Colour Tab.
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4. Repeat Step 1 to Step 3 for all the new colours that you would like to add to your
palette.

Now that you have a complete palette of the colours you want to use, you can
colour your character.
5. Using the Paint
tool and the appropriate colour from the palette, colour your
character until you have the look and colour which you want.

Make sure that you save your work by clicking the Save
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M5: Character Design and
Construction Sheet

This module is divided into the following topics:
•

Theory, on page 74

•

Activity 1: Drawing a Character Construction, on page 78

•

Activity 2: Expanding the Design of the Character, on page 85

•

Activity 3: Tracing a Character, on page 90

•

Activity 4: Deconstructing a Character, on page 98
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Theory
This topic is divided as follows:
•

Character Design, on page 74

•

Character Model Sheets, on page 76

•

Relative Size of Characters and Props, on page 77

Character Design
When designing a character, make sure that you keep the following concepts in mind:
Consider the nature of your character and
think about how his or her characteristics
will be made visible in their shape. Think
about the outstanding characters in
animation and how their physical form
(Popeye’s big forearms, Superman’s big
chest and strong jaw) played a role in the
development of their character.

Head height: a character’s size is usually
recorded in units of “heads”. Use these
guidelines to keep the character in proportion:
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•

A short character is three heads high.

•

A tall character is six heads high.
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Be mindful of using proportion
correctly. You can bend the rules
of proportion when you
understand the basics of
proportion correctly.

These are the five basic steps in character design:
•

Research
During the research, you can search pictures and references to help you figure
out how your character will look like, based on its characteristics.

•

Skeleton
Starting by the skeleton helps you figure how this character can move, and if the
main proportions of its body and limbs are in proportion. Using this skeleton,
you will be later able to quickly figure poses your character can take, and quickly
sketch them when planing an animation.

•

Construction
The construction is the very basis of your character. It will ensure that the
proportions and shape are strong!

•

Sketching
A sketch is a rough version of your design. When you sketch a rough of a new
design for a character you can produce whatever you imagine without being
concerned about the final look of your lines. Making a rough version of your
character helps you build a solid base shape and come up with some new design
ideas.

•

Tracing
Once you have sketched a rough version of your design, the next step is to trace
it. Tracing lets you determine the final look and line style of your drawing and
refine its features.

•

Adding Colours
Once you have your clean design ready, you can add colours to it! This step is
very interesting. You can make some colour research, find colours that best fits
the personality of the character and try out many possibilities.
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Character Model Sheets

Once a character is designed, model sheets are created for it. Character model sheets
are the authoritative reference for a character. They show the character from all angles,
in a variety of poses, and with a bunch of different expressions (happy, sad, surprised,
shy, etc.). These expressions reveal a lot about your character’s personality.
The character model sheet will be your guide and your team’s guide, if you are working
with many animators. To ensure that your character stays the same, or as we say “in
model” for the complete duration of the project!
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Relative Size of Characters and Props

Once many characters and even accessories, or props are designed, a “Line up” is
created, so that everyone on the team stays aware of the difference of size the different
characters and objects have between them.
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Activity 1: Drawing a Character Construction
You will now start the character design process. you will begin by designing a character
with a minimal amount of detail; you should only work on the body shape using the basic
shapes.

Step 1: Imagine a Character
Take a few moment to imagine a character you could draw! Think of its personality, its
physical attribute and even a situation it could be involved in.
If you want, take a piece of paper and quickly sketch some ideas.
Try to be imaginative!

Step 2: Launching Toon Boom Animate Pro
The next step will be done using Toon Boom Animate Pro. This is your first exercise using
this software, so read carefully the step by steps!
Creating your project:
1. Launch Toon Boom Animate Pro.
2. In the Welcome Screen:
a Browse to the location specified by
your teacher. This is where your project
will be saved.

A
B

b Name your project: CharacterDesign,
followed by your initials.
C

c
D

5. Click on the Save
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Make sure NTSC is selected in the
Resolution List.

d Click on the Create button.

button to record your project.
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Step 3: Drawing a Skeleton Foundation
In your Animate Pro project, you will start by drawing the skeleton of your character.
Think about the proportions of your character!
Drawing the skeleton:
1. In Toon Boom Animate Pro, select the first cell of the Drawing layer in the Timeline
view.

2. In the Tools toolbar, select the Brush

tool.

3. In the Tool Properties view, customize the Brush tool:
a Using a Pen tablet, the Brush tool will
work like a real pen on a paper and
produce a thin and thick effect
following the pressure you inflict on the
tablet. Use the Minimum and
Maximum fields to set this thick and
thin effect.
A

B
C

b Animate Pro can automatically smooth
your line as you draw it. Set the level of
smoothness you wish to apply. The
higher the value, the more smoothness
will be applied to your line.
c

The Preview field, gives you a preview
of the type of lines the Brush tool will
produce using the current settings.

There are a lot of options available in the Brush Tool Properties view. In this activity,
we will only see the ones you will need. Do not hesitate to explore on your own or refer
to the Animate Pro User Guide to learn more!
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4. In the Colour view:
a) Click on a Colour pot to select
it.
b) You can double click on a colour
pot to modify its colour using the
Colour Picker view.

A

c) Click to pick a colour.

B

C

5. In the Camera view, sketch your character’s skeleton.



If you need to, use the Eraser

tool. You can customize it using the Tools

Properties view, just like you did with the Brush
6. Save
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your project!

tool.
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Step 4: Attaching Basic Shapes and Volume
Once you have your skeleton ready, you need to add some flesh around the bones! You
are going to build the basic shape of your character.
Attaching basic shapes and volume:
1. Launch Toon Boom Animate Pro.
2. In the Welcome Screen:
A

B

a Your project may appear in the Recent
Scenes section. Click on your scene’s
name to open it.
b If your project does not appear in the
Recent Scenes section, click on Open
Scene and browse for it.

3. In the Timeline view, click on the Add Drawing Layer
Drawing layer.

button to add a new

4. Select the Drawing layer containing the skeleton drawing of your character, and
click on the name to activate the text field. Name the layer Skeleton.

5. Repeat Step 4 for the new Drawing layer and name it Volumes.

6. Click on the Lock
icon of the Skeleton layer. This will lock it
changes to be applied on it!

to prevent any

7. In the Timeline view, select the first cell of the layer Volumes.
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8. Select the Brush

tool.

9. In the Colour view, pick a colour.
10.In the Camera view, draw shapes and volumes around your skeleton.
You will notice that the skeleton
drawing will appear as faded so you
can use it as a guide but that it will not
distract you from your new drawing.

11.You can use the Rotary Table to rotate your workspace in the same way as you
would rotate a sheet of paper you were tracing on:





Press and hold [Ctrl]+[Alt] (Windows®) or [Ctrl]+[a] (Mac OS® X) to display the
rotary table and then click and drag inside the Camera view to rotate the
workspace.
Select View > Reset Rotation or press [Shift]+[X], the default keyboard shortcut.

12.Save
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Step 5: Drawing Different Poses
Now that you have created the basis of your character, you should try to give it a little
bit of life and imagine it in different situations and draw these poses!
1. Launch Toon Boom Animate Pro.
2. Open your CharacterDesign project.
3. In the Timeline view, select the second cell of the Skeleton layer.

4. Click on the Onion Skin

button on the Skeleton layer to enable the Onion Skin

option.

This will let you see your
previous drawing in pale red
as a guide to make sure you
keep your proportions.

You can drag the blue markers to modify the amount
of previous and next drawings the onion skin lets you
see in the Camera view.
5. Select the Brush
tool and pick a colour from the Colour view. Customize your
brush with the Tool Properties view if needed.
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6. In the Camera view, draw the skeleton in a new pose.

7. In the Timeline view, select the next cell of the Skeleton layer, and trace another
skeleton pose in the Camera view. Repeat this until you have at least five poses.
8. Once you have your five poses ready in the Skeleton layer, use the knowledge you
have acquired in Step 4: Attaching Basic Shapes and Volume, to draw the poses
with volumes in the Volumes layer.

9. Save
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Activity 2: Expanding the Design of the Character
Now that you have developed and experimented with the basic construction of your
character, it is time to add the details of the character’s features. This is a fun activity to
do, go ahead and be inventive!

Step 1: Sketching the Character
The first step is to sketch the character’s features! It is important to start with a rough
version as it releases the constraint of trying to achieve the perfect line on the first
stroke.
Starting with a sketch gives better results at the final stage of the character design, it lets
you come up with better organics line and volumes, with less stiffness.
Sketching your character:
1. Launch Toon Boom Animate Pro.
2. Open your CharacterDesign project.
3. In the Timeline view, add a new Drawing layer and call it Sketch.
4. In the Timeline view, you can hide the Skeleton layer if you want. Just click in its
Enable/Disable Layer check box. You should lock

the Volumes layer!

5. Select the Brush
tool and pick a colour from the Colour view. Customize your
brush with the Tool Properties view if needed.
6. In the Timeline view, select the first cell of the Sketch layer.

85

Animate Pro 2 - Student Workbook

7. In the Camera view, sketch you character and its features using the volume drawing
as a guide.
Remember that you can use the Rotary Table
to turn your workspace around!

Be careful to follow and respect your Volume layer!

8. Save

your project!

Step 2: Tracing the Character
Once you are satisfied with the sketch of your character, it is time to clean it up! During
this step, the quality of the line is very important. You have to trace it carefully. You want
your character to be as clean as possible.
Tracing your character:
1. Launch Toon Boom Animate Pro.
2. Open your CharacterDesign project.
3. In the Timeline view, add a new Drawing layer and call it Clean.
4. You should hide all the unnecessary layers and keep only the Sketch and Clean
layers visible. Do not hesitate to lock

the Sketch layer!

5. Select the Brush
tool and pick a black colour from the Colour view. Customize
your brush with the Tool Properties view if needed.
6. In the Timeline view, select the first cell of the Clean layer.
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7. In the Camera view, start tracing the character.

Remember that you can use the Rotary Table
around!

to turn your workspace

8. Once you are comfortable using the Drawing tools, you can improve your line art
using the Contour Editor

tool!

•

In the Drawing Tools toolbar, select the Contour Editor

tool.

•

In the Camera view, click on the line to reshape it.

•

Select one or several points by clicking on them or circling around.
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•
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To modify the shape, you can:
D

Pull on the Bezier handle. Both point’s handles will move as one.

D

Hold [Alt] down and pull on one of the Bezier handles. The point’s handle will
move independently from the other one.

D

Move the selected points to a new area.

D

Pull directly on the line in-between two points. No selection is necessary.
Holding down the [Shift] key will limit the contour modification to the curve
between the two first points.

Character Design and Construction Sheet

D

9. Save

If an anchor point has no visible Bezier, hold down the [Alt] key to get them.

your project!
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Activity 3: Tracing a Character
This activity is divided as follows:
•

Drawing Using the Brush Tool, on page 90

•

Other Useful Drawing Tools, on page 92

•

Adding a New Layer, on page 93

•

Tracing Over Your Character, on page 93

•

Adding Thick and Thin Lines, on page 95

Drawing Using the Brush Tool

The Brush

tool supports pressure sensitivity and several brush tips.

To keep your work organized, rename the default layer with your new character’s name.
1. In the Timeline view, double-click on the layer name and type the new name in the
field.

2. Press [Return] to validate the name.
3. Select the cell where you want to draw.

To get a feeling similar to drawing on paper with blue pencils, you can modify a
colour swatch’s colour and transparency.
4. Double-click on the colour swatch if you want to modify the tint.
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5. To modify the colour’s transparency, slide the Alpha cursor to the right or left.
The Contour Optimization smooths the contour of your line once the line has been
traced.

There are several parameters which you can adjust in the Brush Properties:
•

Minimum Size

•

Maximum Size

•

Smoothness

•

Contour Optimization

•

Brush Tips

You are now ready to put all kinds of ideas onto your canvas, in this case, the
Camera view.
6. In the Camera view, sketch your character.
7. If you want to draw some shading on your character, enable the Draw Behind
option in the Brush Tool Properties.
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Other Useful Drawing Tools

There are several useful drawing tools you can use to perfect your work such as:
•

Select Tool
The Select tool allows to reposition, scale, skew, rotate and delete a selection.

•

Cutter Tool
The Cutter tool allows to select a portion of a drawing to reposition it or delete
it.

•

Eraser Tool
The Eraser tool allows to erase any section of a line or drawing.

•

Rotate View Tool
The Rotate tool allows to turn the workspace the same as an animation table.

To use the Rotate View
[a]+[Alt] on Mac OS.

tool, hold down the [Ctrl]+[Alt] keys on Windows and

The default keyboard shortcut to reset the Camera view rotation is [Shift]+[X]. Or press
the Reset View
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button in the Camera view’s bottom toolbar.
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Adding a New Layer

Now that your sketch is completed, you will learn how to trace over it to get a clean
drawing.
1. In the Timeline view, click on the Add Drawing Layer
for your clean drawing.

button to add a new layer

2. Rename the layer as clean or any other appropriate name.
It is now time to clean your character.

Tracing Over Your Character

There are many ways to clean up your character’s sketch.
We will demonstrate how to use the Pencil
purpose.You could also use the Brush

tool and the Polyline

tool for this

tool for this task.

1. In the Timeline view, in your clean layer, select the cell just above your sketch
drawing.
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Drawing in the clean layer cell does not affect your sketch.
To prevent modification of the original drawing, lock it by clicking on the
Lock

button for this layer.

You may find it confusing if all of the Colour swatches are named sequentially, such
as Colour 1, Colour 2, and so on. To avoid this, rename your swatches with an
appropriate name. To do this double-click on their name, change the name, and
then press the [Return] key to validate the name.
Pressing [Return], when you have a series of colour swatches, selects the next colour
swatch.

Using the Polyline tool

to clean your drawing allows you to shape your lines

easier than if you were tracing them by hand using the Brush
tool.
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tool or the Pencil
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2. Click to set a point along your drawing and then pull away from it while holding
down the left mouse button. You will see the line shape as you move the handles.

3. To fine-tune the lines you created with the Polyline

tool, use the Contour Editor

tool.
4. Click on the line to see the points appear.
5. Then, click on a point to select it and move its Bezier handles to reshape the line.
Use the Pencil

tool to draw the lines you don’t want to draw with the Polyline

tool.

Adding Thick and Thin Lines

The lines you drew using the Polyline and Pencil tools are a central vector type, so your
drawing does not contain thick and thin lines.
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There are different techniques you can use to add thick and thin lines.

The first technique is to use the Brush
tool to draw some of the lines and change
the tip to an oblique shape or use a pen tablet which provides you with pressure
sensitivity and allows you to draw lines of variable thickness.
Drawing with the Brush tool does not allow you to reshape your lines as easily as with
the Polyline or Pencil tool. The Brush tool creates contour vector lines (also known as fills)
where the vector points are situated on the line’s contour, Pencil lines are central vector
lines in which the points follow the centre of the line.
Central vector lines do not support thick and thin lines, but have the same thickness
throughout. Contour lines support thick and thin lines, but take longer to reshape.

The second technique is to convert the central lines to contour lines and to add some
thick and thin lines by using the Contour Editor
1. In the Tools toolbar, select the Select

tool.

tool.

2. In the Camera view, select the lines to convert to contour lines.
3. In the Tool Properties view, click on the Convert Pencil Lines to Brush Lines
button.
4. In the Tools toolbar, select the Contour Editor
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tool.
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5. In the Camera view, push the points and contours to add the desired thickness.

No matter which tools you use to draw with you must finally flatten the lines so that your
character outline is a single shape instead of being built out of many strokes. This makes
it easier and lighter to manipulate.
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select the lines to flatten.
3. In the Tool Properties view, click on the Flatten

tool.
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Activity 4: Deconstructing a Character

Character construction is a huge topic to cover all at once. To get better you need a lot
of practice and observation.
You might want to look at stills from animations as examples that you can deconstruct
and use as a study basis for your own character design!
Find and deconstruct at least one character for each of these types:
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•

Animal and Human

•

Man and Woman

•

Elder and Kids

•

Hero and Villains

•

Big and Small

•

Short and Tall

M6: Colour

This module is divided into the following topics:
•

Theory, on page 100

•

Activity 1: Colouring the Designed Character, on page 116
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Theory
This topic is divided as follows:
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•

Colours, on page 101

•

Adding a Colour Swatch, on page 102

•

Gradient Colour Swatch, on page 104

•

Bitmap Texture Swatch, on page 105

•

Deleting a Colour Swatch, on page 106

•

Colour Display Modes, on page 106

•

Selecting the Current Colour of a Tool, on page 107

•

Selecting a Colour in a Drawing, on page 108

•

Editing Gradients and Textures, on page 108

•

Storing your Favourite Gradient or Texture Settings, on page 109

•

Closing Gaps Manually, on page 110

•

Palettes, on page 110

•

Colour View, on page 111

•

Creating a Colour Palette, on page 112

•

Renaming a Colour Palette, on page 112

•

Removing a Colour Palette, on page 112

•

Cloning a Colour Palette, on page 113

•

Mixing Colours, on page 114

•

Importing a Colour Palette, on page 115

•

Ordering the Palette List, on page 115
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Colours
Animate Pro has some very powerful colouring features when it comes to painting. To
paint your drawings you will use different colour swatches, unlike some paint programs
where you modify one swatch each time you want to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to
paint in your drawing. You can add as many swatches as you want. You can also rename
them and modify existing ones.

When you modify the colour of an existing swatch it automatically updates all the zones
painted with this swatch throughout the entire project. The colour swatch has a unique
ID number that associates it with the painted zones. This way, you can change the look
of your character at anytime without having to repaint it!
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Adding a Colour Swatch
You can use three different types of colour swatches, these are described in the following
sections.

Solid Colour Swatch

To add or modify a solid colour swatch:
1. In the Colour view, click on the New Colour

button.

2. In the Colour View menu, select Colours > Edit. You can also double-click on the
colour pot.
The Colour Picker window opens.

3. To set your colour:


In the colour wheel, select the desired colour.

OR
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Type in the HSV or RGB values in the corresponding fields. Click on the
R,G,B,H,S or V radio buttons to change the look of the colour picking area.

Colour

OR


Click on the Dropper
button to select any colour on your screen. It can be
from the Animate Pro interface, your Operating System or any other open
application.

You can also click on the Multi Wheel Mode button to open the Multiwheel Colour
dialog box. This displays all the picking area styles together and also contains a
picking undo list. Click on the Single Wheel Mode button to go back to the regular
Colour Picker window.

Picking Areas
Display
Options

Picking Undo List

4. If needed, click on the Shade Scale’s swatches to modify the shade of the selected
colour.

5. If necessary, adjust the desired level of transparency with the Alpha slider, or type
the value directly in the Alpha field.
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6. If necessary, click on the Add button to add the current selected colour to the
Colour Storage Library, so you can quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the
colour list by double-clicking on its name.

Gradient Colour Swatch

To create a gradient colour swatch:
1. In the Colour View, select the colour to be modified.
2. In the Colour View menu, select Colours > Edit. You can also double-click on the
colour pot.
The Colour Picker window opens.
3. Enable the Gradient option.

4. Select the Linear or Radial option.
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5. Select the Gradient arrows to modify the colours.





Click between the arrows to add extra colours.
Pull down the arrows to remove them.
Move the arrows left and right to modify the gradient distance.

Bitmap Texture Swatch

To create a texture colour:
1. In the Colour View menu, select Colours > New Texture or click on the New Texture
button.
The Browser window opens.
2. Browse for a PSD or TGA bitmap file created in a third party software.
3. Click on the Open button to create the colour swatch.

You can also replace a texture once it is painted. If you decide to make the character’s
shirt of wool instead of plaid, just update the texture file in the swatch and the entire
project updates. Any transformation previously applied to the texture’s position in your
drawings will be kept.
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To replace a texture swatch:
1. In the Colour view, select the texture swatch you want to change the embedded
bitmap texture file in.
2. In the Colour View menu, select Colours > Edit Texture. You can also double-click
on the swatch.
The Browser window opens.
3. Browse for the new PSD or TGA bitmap file created in a third party software.
4. Click on the Open button to update the colour swatch.

Deleting a Colour Swatch
To delete a colour swatch:
1. In the Colour view, select the colour swatches to delete.
2. In the Colour View menu, select Colours > Delete. You can also click on the Delete
Colour button. The default keyboard shortcut is [Delete].
If the colour swatch is used in a drawing, the Delete Colour dialog box opens.
3. Click on the OK button to delete the colours or click on the Cancel button to abort
the operation.


If you delete colour swatches already in use, the zones painted with them turn
red so you can easily identify them.

Colour Display Modes
By default, the Colour view display is set to Thumbnails which displays the different
colour swatches in a mosaic fashion. You can change this display mode to List, which will
display the different swatches in a list with each swatch’s name.
To switch between thumbnails and list display modes:
1. In the Colour View menu, select Colours > Swatch Mode.
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Selecting the Current Colour of a Tool
While drawing and painting, you can let Animate Pro retain the last colour you selected
for each one of the following tools:
•

Brush

•

Paint

•

Pencil, Ellipse, Line, Rectangle, Polylines

The Colour view has three swatches where you can set a colour for the Brush, Paint and
Pencil tools.
To retain the colour for your individual tools:
1. In the Colour view, if the storage swatches are linked, unlink them. Do this by
clicking on the Linking button.
2. Click on the Brush storage swatch.
3. In the Colour list, select the desired colour.
4. Click on the Pencil storage swatch.
5. In the Colour list, select the desired colour.
6. Click on the Paint storage swatch.
7. In the Colour list, select the desired colour.

If you prefer not to use this behaviour and want Animate Pro to use the same colour
swatches regardless of the selected tool, you can link the three swatches together.
To link the storage swatches:
1. In the Tools toolbar, select one of the following tool:




Brush tool
Paint tool
Pencil tool

2. In the Colour view, if the storage swatches are not linked, link them. Do this by
clicking on the Linking button.

Each time you select a new colour for the current tool, all storage swatches are
updated.
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Selecting a Colour in a Drawing

While working in your Camera or Drawing view, you may need to pick a colour from your
drawing without going to the Colour view. To do so, you will use the Dropper tool.
To use the Dropper tool:
1. In the Tools toolbar, select the Dropper
tool. The default keyboard shortcut is
[Alt]+[I]. You can also select the Dropper tool in the top menu, under
Drawing > Tools > Dropper.
2. In the Camera or Drawing view, click on the desired colour.


If you are using another drawing tool such as the Paint tool, to pick a colour you
can temporarily hold down the [I] key and click in your drawing, then release the
key. Once you let go of the hot key, Animate Pro will go back to your previous
tool.

Editing Gradients and Textures

If you paint a zone with a gradient or texture colour you can use the Edit Gradient/
Texture tool to modify its position in the zone. You can move, scale, rotate and skew. If
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you have to match the colour to the animation, you can set the first texture position and
copy the Edit Gradient/Texture position. When moving to the next drawing, you can
select the next texture and paste the previous position to continue the modifications.
To use Edit Gradient/Texture tool:
1. In the Tools toolbar, select the Edit Gradient/Texture
tool.
You can also select this tool from the top menu
Drawing > Tools > Edit Gradient/Texture. The default keyboard shortcut is
[Shift]+[F].
2. Click on the Gradient or Texture zone to be modified.
To modify several areas at once, hold down the [Shift] key and click in the other
zones to be modified.
3. Move the edit texture’s anchor points to the obtain the desired result.
If the same modification needs to be applied to another gradient in another
drawing or texture zone, you can select the modified zone and select
Edit > Copy. Select the zone to be modified in the other drawing and select
Edit > Paste.

Storing your Favourite Gradient or Texture Settings
If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool
to use your gradient’s position, angle and scale settings instead of the default ones, you
can store your own settings and reuse them afterward.
To store your gradient and texture settings:
1. In the Tools toolbar, select the Select
[Alt]+[V].

tool. The default keyboard shortcut is

2. In the Camera or Drawing view, select the Gradient or Texture zone to store.
3. In the Tool Properties view, click on the Store Colour Gradient

button.

To use the stored gradient and texture settings:
1. In the Tools toolbar, select the Brush or Paint tool.
2. In the Tool Properties view enable the Use Stored Colour Gradient

button.

3. In the Camera or drawing view, draw and paint.
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Closing Gaps Manually

When painting, you will notice that some of your drawing areas are not closed. To close
the zone you can either draw the missing line with the Brush or Pencil tool, but you can
also close the gap with an invisible line. To do so, you will use the Close Gap tool.
The Close Gap tool is used to close small gaps in a drawing. The Paint tool only paints
closed areas. The Close Gap tool will create a small, invisible stroke between the two
closest points to close the colour zone. You do not need to trace directly over the gap.
You can draw it a few millimeters away and Close Gap will automatically choose the two
closest points and close the gap.

Palettes
In colour animation, specific colours are used to paint each particular character. In order
to maintain absolute consistency, a colour palette is created for each character, prop and
effect throughout the production. These are referred to as master palettes.
Master palettes contain a colour pot for each zone to colour with a precise RGBA colour
value.
Using a master colour palette has many benefits, including:
•

Each character consistently retains their dedicated colours.

•

You cannot accidentally use a colour which is not in the master palette.

•

Standardization and colour consistency throughout the production

•

Multiple artists can use the same colour palette and produce the same results.

Animate Pro uses palettes to hold all of the colours needed to paint your elements,
allowing complete control and consistency in your painting process.
A palette is created by assigning a set of colours to each character, prop or effect. You
will create a new palette and add a new colour, known as a colour swatch, for each zone
of the character, such as the skin, hair, tongue, shirt, pants, etc.
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Colour View
The Colour view has two modes: basic and advanced.

Basic Mode

The Colour view’s basic mode only shows the Colour list. When you open Animate Pro,
you only see the colours available in the default palette. This default palette contains six
basic colour swatches and is automatically named the same as your scene. For simple
projects, you can manage with the default palette, but for movies, series or shorts it is
recommended that you create palettes for your characters. To create a palette, you have
to switch to the advanced display of the Colour view and show the Palette list.

Advanced Mode

To create palettes for your characters, you must display the Palette list. Once you display
the Palette list area, a series of new buttons appear.
To show or hide the Palette List area:


In the Colour view, click on the Show/Hide Palette List View button to expand or
collapse the Palette List area.
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Creating a Colour Palette
You can add, delete, import and order palettes in your scene using the Palette menu
buttons.
To create a new palette:
1. In the Colour View menu, select Palettes > New or click on the New Palette
button.
The Create Palette window opens.
2. Enter the Palette Name according to the model.
3. Click on the OK button.
Each palette you add in your scene will appear in the Palette list.

Renaming a Colour Palette
To rename a palette:
1. In the Colour view, select the palette to rename.
2. In the Colour View menu, select Palettes > Rename.
3. In the Rename dialog box, rename the palette.
4. Click on the OK button.

Removing a Colour Palette
You can remove palettes from your Palette list if they are not needed in your scene. The
actual palette file will not be deleted and you will be able to re-import it in your Palette
list later on.
To remove a palette:
1. In the Colour view, select the palette to remove.
2. In the Colour View menu, select Palettes > Remove or click on the Remove Palette
button.
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If the palette was in use in your scene, the zones painted with its colours will turn
red.
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Cloning a Colour Palette

A character usually has only one master palette, although there are times when the
characters are placed in different lighting conditions and require a different colour
shading. The night palette is a popular choice when a scene or sequence changes from
day to night. It can be difficult and time-consuming to repaint everything and creating
two independent palettes can be quite complex. As an alternative, Animate Pro
provides clone palettes.
The clone palette is a copy of the master palette. The colours in each palette have the
same properties. The colours have the same identification number pointing to the same
colour zones, but they can have different names and RGBA values. Depending on the
activated palette (night or day), the painted drawing will update. So there is no need to
repaint the animation, but to create or import a clone palette (palette style).
To clone a palette:
1. In the Colour view, select the palette to be cloned.
2. In the Colour View menu, select Palettes > Clone.
The Palette Browser: Clone Palette window opens.
3. Name the palette. (It is recommended that you keep the suffix “-clone” in the
name.)
4. Click on the OK button to create the palette.
The clone appears in the palette list.
In the Colour View, you can also modify the colours individually by using the Colour
Picker window. To modify all of the colours at the same time use the Tint Panel window.
If there is more than one clone palette loaded, the system will use the one highest in the
palette list.
When you want to see through painted drawings, but still see the outlines, you can
create a clone palette where you set a lower alpha value on all of the fill colours. This can
be useful when setting pivot points on cut-out puppets.
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Mixing Colours
If you want to modify a series of colour simultaneously to blend a tint in them or offset
their RGBA values, you can use the Tint panel. The Tint panel is useful when creating
palette styles such as night and day.
To mix colours:
1. In the palette list, select the palette to offset or blend colours in it.
2. In the Colour View menu, select Palettes > Tint Panel.
The Blend/Offset Tint panel opens.

3. Select the colours in the colour list that you want to modify. You can select all your
colours by pressing [Ctrl]+[A] (Windows) or [a]+[A] (Mac).
4. Offset or Blend the colours using the sliders.
5. Increase the amount of offset or blend using the Amount slider.
6. Click on the colour swatch to change the tint in the Colour Picker window.
If necessary you can reset the transformation by clicking on the Reset button.
7. Click on the Apply button to implement the modification to your palette.
8. Close the Tint Panel window.
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Importing a Colour Palette
If you created a palette in another project and you would like to import it into your
current project, you can browse for the palette file on your computer and add it to your
project.
When the palette is imported in your scene, the file is copied in the project’s directory.
It is not linked to the original file.
To import a palette into your project:
1. In the Colour View menu, select Palettes > Import or click on the Import Palette
button. The Browser window opens.
2. Browse for a palette file located on your hard-drive. You will generally find the
palettes in your projects’ Palette-Library directory.
3. Click on the Open button.
The palette appears in the Palette list.

Ordering the Palette List
When you are using several cloned palettes that are related to the same original palette,
Animate Pro uses the highest palette in the list to determine the colour of the painted
zones.
To reorder palettes in the Palette list:
1. In the Colour View menu, select Palettes > Move Up or Move Down. You can also
use the Up

and Down

icons.
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Activity 1: Colouring the Designed Character
Once you are finished cleaning up your character, it is time to add some colours to it.
For this step, you will use the Paint
tool. Selecting this tool, causes its options to
become available in the Tools Properties view.
Here are a couple of things you should know about this tool that will help you for the
following task:

1

2

1. Painting Mode
2. Automatic Close Gap

Painting Mode
The Paint tool has four different modes available:
Paint Mode
Paint Unpainted Mode
Repaint Mode
Unpaint Mode
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You can also find these tools directly in the
Drawing Tools menu.

Colour

Paint Mode
The Paint mode paints everything it touches, including empty and filled zones.

Paint Unpainted Mode
This mode paints only empty zones. Any line or filled zones remain unchanged.
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Repaint Mode
The Repaint mode paints everything it touches except empty zones. Any zone that is not
painted will remain intact.

Unpaint Mode
The Unpaint mode unpaints everything it touches, including empty and filled zones.

When using the Paint tool, always remember that it will only fill closed shapes. So
be sure there are no unwanted gaps in your design.
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Automatic Close Gap
The Automatic Close Gap option has four modes available:
No Close Gap
Close Small Gap
Close Medium Gap
Close Large Gap
The Automatic Close Gap option is used while painting drawings with small gaps.
Instead of having to close them manually either with the Brush tool or Close Gap tool,
Animate Pro will analyze the drawing and close the gaps while you paint according to
the mode selected.
The automated gap closing
should be done using the zoom
function setting of your Camera or
Drawing view.
If your eye does not see the gap,
Animate Pro won’t either.

Colouring your Character:
1. Launch Animate Pro.
2. Open your CharacterDesign project.
3. In the Timeline view, right-click (Windows®) or [Ctrl]+Click (Mac OS® X) on the layer
Clean and select Duplicate Selected Layers from the pop-up menu.
An identical layer named Clean_1 will be added to the Timeline view.

4. Rename the layer Clean_1 to Colour.
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5. Hide all the unecessary layers and only keep only the Colour layer visible.

6. In the Timeline view, select the first drawing of the Colour layer. You should see your
cleaned up character displayed in the Camera view.

7. In the Colour view, click on the expand button to display the palette list.

Next, you will create a new palette for your character.
8. Click on the New Palette

button.

The Create Palette dialog box opens.
Name the new palette.
You should give it the name of your
character.

The new palette appears in the Palette List.
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9. Select your character’s palette to display the colours it contains.

For now, your new palette should only contain
a black default colour.

10.In the Drawing tools toolbar, select the Paint
Repaint

tool and switch to the

mode in the Tools Properties view.

11.In the Colour view, select the black default colour from your character’s palette.
12.In the Camera view, drag a selection around your whole character.

Dragging the selection around the
entire character will repaint the
character’s outline and make sure all
of its colours are from the same
palette.

13.In the Colour view, click on the New Colour

button. This will create a new

colour pot.
14.Double-click on this new colour pot’s name to enter text edit mode. Name this
colour pot according to the part of the character you are going to colour with it.

15. Press enter to validate the name and exit text edit mode.
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16.Double-click on the colour pot’s colour to open the Colour Picker view and pick the
colour of your choice.

17.In the Paint
Tool Properties view, switch to the Paint Unpainted
This will prevent you from accidently repainting the lines.

mode.

18.In the Camera view, paint the part of your character with the selected colour pot.
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Remember, the colour of the painted shape and the colour pot that was used to
colour it with are linked. They share a Colour ID. This means that if you want to
change a specific colour, you can directly modify the colour pot and all of the
shapes you painted with that colour pot will automatically change to match the new
colour. No need to recolour.
Try it.

19.Repeat the steps until you have a colour pot for each part of your character, and
your character is completely painted.
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M7: Timing

This module is divided into the following topics:
•

Theory, on page 126

•

Activity 1: Experimenting with Space and Time, on page 131

•

Activity 2: Drawing a Pendulum, on page 135

•

Activity 3: Animating Playground, on page 138

•

Activity 4: Observation and Timing, on page 139
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Theory
This topic describes the basics of timing. At the end of this lesson, you should be able
to understand the following:
•

Concept of frames-per-second

•

Arc and path of action

•

Effect of gravity on the action of an animated object

•

Difference between ease-in and ease-out

•

How changes in the exposure of a drawing effect the timing of an element.

This topic is divided as follows:
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•

The Importance of Timing in Animation, on page 127

•

Arcs and Paths of Action, on page 128

•

Laws of Motion and Easing, on page 129

•

Keyframes, In-Betweening and Timing, on page 130

Timing

The Importance of Timing in Animation
Timing is essential to the development of animation. The story, gags, reaction and
character development all depend on a good sense of timing!
Analyzing and establishing timing are a big part of the process of animation. When you
are developing the action of a character in a scene, you determine how the character will
move. For example, the difference in the way a character walks if he or she is dopey,
hasty, hurried or lethargic. The timing will be used to influence the speed and rhythm of
the movement.
The physics of motion
determine how objects move
in the physical world. It would
be hard to convince viewers, if
your animation did not follow
these basic laws of motion. Of
course exaggeration is
essential in the animated
world! It makes it
interesting, but even
exaggerated animation
action still follows the basic
laws of physics!

The frame rate in an animated movie is 24 fps (frames per second). That means that
every seconds, 24 images are displayed to your eyes to create the illusion of movement!
If you do the calculation, it takes as much as 1, 440 frames to create only one minute of
action. Animated series for television have smaller budgets and will often use a frame
rate of 12 fps. The eye will accept this frame rate as a movement, it will just appear a
little less smooth.
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Arcs and Paths of Action
The motion of living things does not usually progress in straight lines. Most action
follows the organic shape of an arc. For example, throwing a ball, swinging a bat or
nodding the head, use arc shaped motions.

The path of action is the direction an action will follow. Think of a ball falling off a table
and bouncing until it comes to a stop. The path of action helps map out the position of
each drawing at each frame!
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Laws of Motion and Easing

Ease-in

Ease-out

Acceleration

Newton’s laws of motion apply in the animated world as well! Basically stated, objects
do not move or step unless acted on by a force large enough to overcome their inertia.
And when they are acted upon by a bigger force, they react in an equal and opposite
manner.
Acceleration due to gravity is constant. This causes falling objects to gain speed until
they are acted upon. At the top of its arc, a pendulum’s velocity is slow, at the bottom it
is high. This kind of speed change is referred to as ease-in and ease-out in animation.
Ease-in means that the object is gradually picking up speed; ease-out means that the
object is gradually slowing down.
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Keyframes, In-Betweening and Timing
Keyframes are significant poses in a character’s action, such as the first and last positions
in a jump.

inbetweens

Key B

Key A

Inbetweens are all of the drawings between the keyframes; they progress the action
from one keyframe to another.
The more drawings there are between keyframes, the slower the action will appear to
take. This is because more drawings means that there is more time to complete the same
action.

Slow

Slow

Fast

In animation, space = time; the more space there is between drawings, the faster the
action will appear to progress; the less space there is between drawings, the slower the
action will appear. Basically when two drawings are far apart the time taken to go
between them appears shorter than the time taken to go between two drawings placed
close together.
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Activity 1: Experimenting with Space and Time

This exercise will let you experiment the effect of spacing on the timing of an animation.
Material Provided for this Lesson:
•

The sample material for this activity contains drawings of a ball as it rolls. Each
template displays drawings at different positions on the path of action to
illustrate the effect that spacing has on timing.

•

In the “mechanical” template, each position of the ball is displayed over 21
frames. The students can use the drawings in this element to experiment with
spacing!

•

The other templates show the different timing setups.
You should not look at these until you have finished your experiments!

Begin the experiment:
1. Launch Toon Boom Animate Pro.
2. In the Welcome Screen:





Browse to the location specified by your teacher. This is where your project will
be saved.
Name your project: Timing, followed by your initials.
Make sure NTSC is selected in the Resolution List.
Click on the Create button.

3. Click on the Save

button to record your project.

4. Click on the Library view tab to display the Library view. It is generally situated
behind the Tool Properties view.
5. In the Library view, browse the template folders indicated by your teacher.




Click on the + sign beside a folder to display the sub-folder it contains.
Click on a folder to display the templates it contains on the right side of the
Library view.
To view the templates as thumbnails, right-click (Windows®) or [Ctrl]+click (Mac
OS® X) in the template section and select View > Thumbnails.
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6. From the Timing folder, select and drag the Mechanical template into the Camera
view.

7. In the Playback toolbar, press the Play
notice that it rolls at a constant speed.
8. Enable the Onion Skin
marker.

button to look at the ball rolling. You will

option on the Mechanical layer and extend the blue

You will notice that all the ball drawings are distributed equally with the same space
between each of them.
9. In the Timeline view, duplicate the Mechanical layer and name it Experiment01.
10.In the Timeline view, select all the exposed drawings (grey rectangles) of the
Experiment01 layer and press the [Delete] key.
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Note that all the drawings are still stored within the layer, they are just removed
from the exposure.
11.You should disable the Mechanical layer, or else it will be displayed in the Camera
view.
You will use the Drawing Substitution section in the Library view to fill the exposure in
the Experiment01 layer. Here how it works:


In the Timeline view, select the first frame of the Experiment01 layer.



In the Library view, you will notice that the Preview section changed for the
DrawingSubstitution section.



Use the slider to select the drawing you want to expose.
A preview of the selected
drawing appears here.

Use the slider to
select a drawing.

The name of the selected
drawing is displayed in this
field



In the Timeline view, you will notice that a grey rectangle appeared. It is the
selected drawing!



Select the next frame you need to change the exposition on and use the
Substitution slider to select a drawing.



Notice that the gap between the first cell and the one that is currently selected
just filled up! It is because the exposure of the previous drawing automatically
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got extended to fill it.



Repeat until you are done filling your layer’s exposure!

12.Clear up again the Experiment01 layer if you tried the Drawing Substitution on it,
and duplicate the layer 3 times. Rename your layers so that you have
Experiment01, Experiment02, Experiment03, Experiment04.
13.Try filling up the following exposures:
•

Experiment01 (Ease-in):
1

•

4

5

7

9 14

21

6 10 13 15 17 18 19 20

21

Experiment03 (Anticipation):
4

•

3

Experiment02 (Ease-out):
1

•

2

2

1

6

9 11 12 13 14 15 16 17 18 19 20

Experiment04 (Choppy):
1

11

21

After you have completed the four experiments, you can import the four other
templates contained in the Library view to compare them with your work!
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•

Ease_in

•

Ease_out

•

Anticipation

•

Choppy

21
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Activity 2: Drawing a Pendulum

This exercise demonstrates the affect of gravity on the swing of a ball, and the spacing
of the drawings in the action.
Using the concept you learned about the arcs, path of action and ease-in and ease-out
concepts, complete the following exercise.
Animating the pendulum:
1. Launch Toon Boom Animate Pro.
2. In the Welcome Screen:





Browse to the location specified by your teacher. This is where your project will
be saved.
Name your project: Pendulum, followed by your initials.
Make sure NTSC is selected in the Resolution List.
Click on the Create button.

3. Click on the Save

button to record your project.

4. In the Timeline view, rename the Drawing layer to Path.
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5. Select the Brush tool and a grey colour.
In the Camera view, draw the path of action of a swinging pendulum.



Draw a red stroke for each 3 key poses of the pendulum on the path of action.
The mark should be positioned where you think the centre of pendulum’s circle
will be.



Place 8 more black strokes along the path of action, positioning the 8
inbetween drawings of the animation.

6. To use your path drawing as a guide while drawing the animation, you will need to
extend its exposure.
To extend the exposure of a drawing in the Timeline view:


Select the cell to which you want the drawing to be exposed to.



Use the default keyboard shortcut [F5].

The exposure will automatically be extended to the selected cell.
7. In the Timeline view, create a new drawing layer
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and name it KeyPoses.
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In the Camera view, draw in red the 3 pendulum keyposes on the same drawing,
using the Path layer as a reference. Try to keep your circles the same size
throughout the drawings! Or else the pendulum will look jiggly.

8. In the Timeline view, create a new drawing layer
PendulumAnimation.

and call it

9. Animate the swinging pendulum in black in this layer. Do not forget to use your
Path and KeyPoses layers as guides and use the Onion Skin
proportion of your pendulum from drawing 1 to 11.

! Try to keep the

10.Once you are done, disable the KeyPoses and Path drawing layers, and playback
your animation!
11.Play on the Loop
12.Do not forget to Save

button to make the pendulum swing in loops.
your project.
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Activity 3: Animating Playground

Now that you animated a swinging pendulum from scratch, how about taking it to the
next level? Take the knowledge and skills you just gained from the previous exercise and
apply it to something else you know. What does it remind you of? How about a kid on a
swing?
Using Animate Pro try animating a child on a swing!
•

Use the Pendulum scene you created.

•

Add a new layer called Swing.

•

Disable the PendulumAnimation layer and use the Path layer to guide your
animation.

•

Instead of a pendulum, draw a boy or a girl on a swing.

Don’t forget these key concepts!
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•

Path of action

•

Key pose

•

Ease-in

•

Ease-out

•

Keep proportion
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Activity 4: Observation and Timing

Observation is the key for a good animation timing. Observe things around you, how
they move. Practicing your sense of observation and visualization will help you a lot to
improve your sense of timing.
While observing moving things and people, try to look for these concepts:
•

Ease-in

•

Ease-out

•

Anticipation
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With a teammate, using a stop-watch, observe and time the following actions:
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•

Jump in place:

•

A long jump:

•

One walking step:

•

Four running steps:

•

The first bounce of a dropped basketball:

•

The first bounce of a dropped tennis ball:

•

Making a complete circle with your arm:

•

Standing up on a chair:

•

Sitting on a chair:

•

Find an action ________________________:

•

Find an action ________________________:

•

Find an action ________________________:

M8: Squash and Stretch

This module is divided into the following topics:
•

Theory, on page 142

•

Activity 1: Drawing a Bouncing Basket Ball and Bowling Ball, on page 144
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Theory
Continuing our analysis of animated motion, we are going to look at the concept of
squash and stretch, then draw a bouncing ball.
At the end of this lesson, you should be able to:
•

Understand how the material of an object can affect how it changes as it moves.

•

Know the difference between pose-to-pose and straight-ahead animation.

•

Draw a ball showing how it changes in shape as it falls, hits the ground and
bounces back up.

•

Draw bouncing shapes with different material properties.

This topic is divided as follows:
•

Squash and Stretch, on page 142

•

Pose-to-Pose vs. Straight-ahead Animation, on page 143

Squash and Stretch
Squash and stretch adds reality to the animated drawing, with more levels of action and
more emotion included in every action.

Normal

Squashed

Stretched

Consider these points:
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•

Living shapes are not plastic and do not progress from position to position
rigidly. Smiling changes the shape of the cheeks, bending an arm causes the
muscles on either side of the elbow to change formation.

•

Exaggeration: the more squash and stretch, the more cartoony the animation
will feel.

•

It is important to consider the composition of the object when squashing and
stretching.

•

Volume must be conserved throughout the operation: you don’t want your
characters to gain weight every time they smile!

Squash and Stretch

Pose-to-Pose vs. Straight-ahead Animation
There are two ways of animating!
•

Pose-to-pose animation is characterized by the process of first drawing your key
poses at significant points in the action, refining the key drawings, and then
doing the inbetweens. This process gives the creator more control and ensures
the accuracy of the final result. This is how you worked when you created the
pendulum animation. You started by creating your key poses!

•

Straight-ahead animation is drawn from the first position to the last in a linear
sequence. There is very little planning in this methodology, and where the
character ends up and how it gets there can be a surprise both for the audience
and the animator. While this approach is a lot more spontaneous and creative, it
can create inaccurate results.
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Activity 1: Drawing a Bouncing Basket Ball and
Bowling Ball

The bouncing ball is the classic animation exercise, demonstrating not only squash and
stretch, but also the effect of gravity and inertia on the spacing and timing of the
animation.
This exercise will let you experiment with basic squash and stretch and see how the
properties of objects affect how they move.
The ball moves fastest just before and after it hits the ground, and decelerates as it
reaches the top of its arc.
The ball stretches as it gains speed, and then squashes on impact with the ground.
If the ball has a solid and rigid consistency such as a bowling ball, the squash and stretch
will be smaller. In reality, the bowling ball does not squash, but in its animation, you need
to add a little bit of squash and stretch to give a better movement and weight illusion.
Animating a bouncing basketball:
1. Launch Toon Boom Animate Pro.
2. In the Welcome Screen:





Browse to the location specified by your teacher. This is where your project will
be saved.
Name your project: BouncingBall, followed by your initials.
Make sure NTSC is selected in the Resolution List.
Click on the Create button.

3. Click on the Save
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button to record your project.

Squash and Stretch

4. Take a moment to visualize the scene in your head:
•

Visualize a basketball bouncing across the screen.

•

Visualize how it bounces when it hits the ground.

•

Visualize how many bounces it does and how much the height of these bounces
slightly decreases from one to another.

•

Did you see the Squash and Stretch?

•

Did you feel the ease-in and ease-out?

5. In the Timeline view, rename the Drawing layer to BasketPath.
6. Select the Brush tool and a grey colour.
7. In the Camera view, draw the path of action of a falling and bouncing basketball.




Draw a red stroke for each key poses. These would be one each time the ball
hits the ground and one at top of each bounce. The marks should be positioned
thinking of where the center of the ball at each position.
Place black strokes along the path of action, positioning the in-between
drawings of the animation. Now is the time to determine the ease-in and easeout.

8. In the Timeline view, extend the exposure of your path drawing to be able to use it
as a guide throughout the animation.
9. In the Timeline view, create a new drawing layer


and name it BasketKey.

In the Camera view, draw in red key poses of your animation, using the
BasketPath layer as a reference. Do not forget to apply the Squash and Stretch
concept!

10.In the Timeline view, create a new drawing layer

and call it BasketAnimation.

11.Animate the bouncing basketball in black in this layer. Do not forget to use your
BasketPath and BasketKey layers as guides and use the Onion Skin
the proportion of your basketball throughout the animation!

. Try to keep

12.Once you are done, disable the BasketPath and BasketKey drawing layers, and
playback

your animation.

13.Do not forget to Save

your project.

Next step is to animate a bouncing bowling ball. A bowling ball react very differently to
the basketball. Due to its volume and weight.
Animating a bouncing Bowling ball:
1. Launch Toon Boom Animate Pro.
2. Open your BouncingBall scene.
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3. Take a moment to visualize the scene in your head:







Visualize a bowling ball being dropped from a fair height.
Visualize how little it bounces when it hits the ground.
Visualize how many bounces it does and how much the height of these bounces
dramatically decreases from one to another.
Visualize how it rolls briefly on the ground before being completely immobilized.
Did you see the slight Squash and Stretch?
Did you feel the ease-in and ease-out and dramatic acceleration?

4. Disable the basketball layers.
5. In the Timeline view, add a new Drawing layer

and name it BowlingPath.

6. Select the Brush tool and a grey colour.
7. In the Camera view, draw the path of action of a falling and bouncing bowling ball.




Draw a red stroke for each key poses. These would be one each time the ball
hits the ground, one at top of each bounce and finally one when the ball stops.
The marks should be positioned at the center of the ball at each position.
Place black strokes along the path of action, positioning the in-between
drawings of the animation. Now is the time to determine the ease-in and easeout and the timing to make it look heavy.

8. In the Timeline view, extend the exposure of your path drawing to be able to use it
as a guide throughout the animation.
9. In the Timeline view, create a new drawing layer


and name it BowlingKey.

In the Camera view, draw in red key poses of your animation, using the
BowlingPath layer as a reference. Do not forget to apply the Squash and Stretch
and weight concepts!

10.In the Timeline view, create a new drawing layer

and call it BowlingAnimation.

11.Animate the bouncing bowling ball in black in this layer. Do not forget to use your
BowlingPath and BowlingKey layers as guides and use the Onion Skin
keep the proportion of your bowling ball throughout the animation.

! Try to

12.Once you are done, disable the BowlingPath and BowlingKey drawing layers, and
playback

your animation.

13.Do not forget to Save
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your project.

M9: Anticipation, Drag and
Overlapping Action

Anticipation, drag and overlapping actions help you to give a natural, realistic feel to
your animation. Anticipation helps the viewer to understand what is coming.
Overlapping give a fluidity to your work. Here is the introduction to these subjects.
This module is divided into the following topics:
•

Theory, on page 148

•

Activity 1: Drawing a Bouncing Ball with a Tail Attached, on page 150

•

Activity 2: Waving a Flag, on page 154
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Theory
This topic is divided as follows:
•

Anticipation, on page 148

•

Drag and Overlapping Action, on page 149

Anticipation

•

Actions in animation happen very fast.
For example, throwing a ball can take only two or three drawings to complete,
which is not really enough time for the viewer to see and understand what is
happening. However, if the character winds-up and then pauses before pitching
the ball, it is easy for the viewer to see what is going on. Anticipation is an
important element of the timing of an animation.

•

Before a character takes any kind of action (unless completely surprised), the
character must think and plan. A character that must jump might first crouch
down and then push off with its feet. Anticipation also gives insight into the
thoughts of a character.

•

Anticipation allows the audience to clearly see what a character is doing and to
understand what the character is planning, so that every action is not an abrupt
surprise.

You may consider getting someone to demonstrate anticipation and resulting actions,
or get into the habit of acting-out the action you want to draw in front of a mirror.
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Drag and Overlapping Action

•

Adding drag and overlapping action to your animation will go a long way to
making them look less mechanical.

•

When a fully developed character runs, not all of his body parts move with the
same speed. The differing characteristics of the body parts or clothing may
cause them to move behind the rest of the body, like ears or a cape. This is
called “drag”.

•

When a character stops moving, not all of the parts of the body or the things
your character is holding will stop at the same moment. The feet may stop first,
the ears and the cape continuing on until they reach the limit of their extension
and then come to a stop. This is overlapping action.

You can demonstrate this concept by thrusting out your arm with a light object in it, like
a shirt or some piece of dangling fabric, and watch as it lags behind and then swings in
front of your fist.
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Activity 1: Drawing a Bouncing Ball with a Tail
Attached
In this exercise you will add a bit of life to the bouncing ball. Turn the ball into a character
with an extra appendage that will drag and then overlap during the course of the
animation. It could be a tail, ears, a cape—whatever you can think of.
1. Launch Animate Pro by double-clicking on the icon.
2. In the Welcome Screen, name your project Ball_with_a_tail followed by your initials.
3. In the Timeline, click the Add Element
drop-down menu.

button, then select Drawing in the

4. Rename both Drawing Elements. The first element should be named Ball, the
second element should be named Path.

5. Using the Brush
tool, draw the path of action for your character, including the
timing in the Path element.

You now need to extend the exposure of the path cell drawing you just did.
6. In the Timeline view, click on the drawing cell, then right-click and select Extend
Exposure. The Extend Exposure window will appear.
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7. In the Extend to Frame field, type 24. This is the number of frames you want to
extend the cell to, then click on OK.

8. Using the Brush
tool, draw the keyposes for your character in the Ball element.
Start by drawing the ball, then drawing the tail.
Remember, because of the overlapping action, the tail will be dragged along by the
ball and should be animated to show this.
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9. Activate the Show Onion Skin
option.
This will allow you to see the previous and next frames of your animation so that you
can draw the inbetweens.
In the Timeline, you can move the blue handles on each side to include the frames
you need in the onion skinning option.

10.Make sure to save the progress of your work by clicking the Save
button.The
Save As window will appear. Name your project Ball_with_a_tail along with your
initials.
11.Play back the animation of the bouncing ball-with-tail with the Play

button and

test/correct your work. You can also activate the Loop
button, to view your
animation in loops while noting the corrections you will have to do.
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When you start an overlapping animation, remember that an element like a tail will
not start moving before the ball has moved a few frames.

When you reach the middle of the animation, the ball will reach the peak of its climb
and start to slow down. Always remember that the tail is a couple of frames late, so
it will be squashed against the ball at the middle frame and be stretched again on
the next frame while keeping the same position on the guide.

At the end of the animation, the ball will stop moving, but the tail’s overlapping
animation will continue until it drops on the floor.
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Activity 2: Waving a Flag

Here is another particular exercise that requires overlapping movement and follow
through: waving a flag!
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•

Try to animate this movement as a cycle.

•

Remember that the flag is being pulled by the stick. The fabric is soft so there
will be a delay between the two elements.

•

If you are unsure how to do it, wave an real flag as reference or have a classmate
to wave a flag and study how it moves.

•

Always start with keyposes, then do inbetweens.

•

Do you think you could animate a pattern on the flag?

M10: Animating a Walk-cycle

The walk-cycle is one of the most common animations you will have to do when creating
films. Get used to observing and analyzing different types of walk when you go outside,
this will provide you with a wealth of information for future reference. Here is an
overview of walk-cycle animation theory.
This module is divided into the following topics:
•

Theory, on page 156

•

Activity 1: Walking Around, on page 159

•

Activity 2: Animating a Rough Walk Cycle, on page 160

•

Theory, on page 164

•

Activity 3: Animating, Cleaning and Painting a Walk-Cycle, on page 187

•

Activity 4: How Do These Characters Walk?, on page 200
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Theory
This topic is divided as follows:
•

Analyzing the Walk, on page 156

•

Walk-cycles, on page 156

•

Deconstructing a Walk-cycle, on page 157

Analyzing the Walk

When animating anything, it is especially important to analyse the action before starting
to draw. One way to do this is to act out different walks study the details (e.g. arm, hand
and head movement).
•

The walk-cycle isn’t just about the legs, the position of the rest of the body says
a lot about the character.

•

Is the character bouncing, strutting, shuffling, or sneaking?

•

What kind of mood is the character in? Hurried? Lazy? Happy-go-lucky? Furtive

Walk-cycles
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•

Cycles are animation shortcuts that reduce the amount of required work.

•

A walk-cycle usually consists of two steps which the animator can reuse to create
an extended walk.

•

During a walk-cycle, the background is moved while the character essentially
walks in place.

Animating a Walk-cycle

Deconstructing a Walk-cycle

•

At the contact positions, both feet are touching the ground. The heel of one
foot and the toe of the other.

The right foot is in
front. The heel and
the toe are both
touching the
ground.

•

At the opposite contact position (after one full stride), the legs exchange
positions.

The left foot is in
front. The heel
and the toe are
both touching the
ground.

The feet of the first and second contact position should be the same distance
apart.
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•

At the passing position, the two legs meet as they exchange positions. The leg
moving to the front is bent.

The left foot is bent
as it passes the
right foot.

•

Between the first contact position and the passing position, is the down
position.
In this position, the character is in the lowest position of the cycle, dropping
down slightly from previous and next drawings. Also in this position, the
character’s hands are at their farthest apart.

Both legs are bent
which makes the
character appear
slightly shorter.

•

Between the passing position and the second contact position is the up position.
The character appears extended here.

The back leg is
pushing up, so the
character appears
extended.
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Activity 1: Walking Around

In this activity, you will team-up with a classmate and take turns at walking around t so
that you can analyze each other’s walk. You should try different styles of walk, to see how
the character’s state of mind and motivation will affect the walk.
Share your observations and take note of these before starting you own walk-cycle
animation.
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Activity 2: Animating a Rough Walk Cycle
Don’t hesitate to ask your classmates to walk around and so that you can see all of the
body parts that move with the feet and the legs. Also, consider how the character’s state
of mind and motivation affect the walk.

•

How should I walk?

•

What’s my personality?

•

Will it affect the way I move?

1. First, you need to plan your character’s walk. What is your character’s personality
and how will it affect the way they walk and move?
For example, a dancer would be light in their step and gait. However, a thief would
be stealthy and may scurry furtively from one place to another. A hunchback would
lurch to one side and have a walk which would drag one foot or limp dramatically.
2. Launch Animate Pro by double-clicking on the icon.
3. In the Welcome Screen, name your project Walk_cycle followed by your initials.
4. In the Timeline, click the Add Element
drop-down menu.

button, then select Drawing in the

5. For the walk-cycle, it is better to work with two drawing elements: one for the
character and one for the measured distance between steps. Rename one element
Character and one element Step.

6. To make this a correct walk-cycle, the character must walk in place. To do this:
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a In the first contact position, measure the distance between the character’s heel
on the front foot and the toes of the back foot.

Back foot

Front foot

Measure the distance between
these two points.

b Divide this distance by the total number of drawings between the first and second contact positions.
c

Reposition your character so that the toe is always one division (unit) behind the
last one.

4. Once you have calculated the step, draw a grid on the Step drawing element.

Now you need to extend the exposure of the step cell drawing you just did.
5. In the Timeline view, click on the drawing cell, then right-click and select Extend
Exposure. The Extend Exposure window will appear.
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6. In the Extend to Frame field, type 24. This is the number of frames you want to
extend the cell to, then click on OK.

7. Using the Brush
Tool, start sketching the keyposes of the walk. Remember to
draw with the basic figures of the character.
Don’t go too much into detail until you’ve sketched the complete walk-cycle.
Draw the following keyposes first:





First and second contact position
Passing position
Down position
Up position

8. Activate the Show Onion Skin
option. This will allow you to see the previous
and next frames of your animation so that you can draw the inbetweens.
In the Timeline, you can move the blue handles on each side to include the frames
you need in the onion skinning option.

9. Repeat Step 5 to Step 7 for the second step the character will take. When you have
finished, draw the next step in the cycle.
You can do this easily by modifying the drawings from the first step to create the
second step.
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10.Make sure to save the progress of your work by clicking the Save
button.The
Save As window will appear. Name your project Walk_cycle along with your initials.
11.Play back the animation of the walk-cycle with the Play

button and test/correct

your work. You can also activate the Loop
button, to view your animation in
loops while noting the corrections you will have to do.
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Theory
This topic is divided as follows:
•

Setting the Preferences, on page 164

•

Traditional Animation Tools, on page 165

•

Setting the Timing, on page 175

•

Renaming Drawings By Frame Position, on page 179

•

Playing Back Your Animation, on page 179

•

Animating Traditionally, on page 179

•

Painting Drawings Simultaneously, on page 184

•

Inking the Lines, on page 185

Setting the Preferences
Before you start your hand-drawn animation set the following preference:
•

Use Current Frame As Drawing Name

This feature allows you to name your drawings based on their frame positions, this
facilitates the creation of key poses.
For example; When a drawing is created on frame 1, the drawing will be called “1;” if
you then move to frame 5, the drawing will be called “5” instead of “2”. This way, you
can keep your drawings organized.
To use this feature, you must enable it in your Preferences.
To enable the Use Current Frame as Drawing Name:
1. In the top menu, select Edit > Preferences.
The Preferences window opens.
2. In the Preferences window, select the Exposure Sheet tab.
3. In the Drawing Creation section, enable Use Current Frame as Drawing Name.
4. Click on the OK button.
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Traditional Animation Tools
When you animate digitally using traditional techniques, there are certain tools you
require in order to work efficiently, as you would do with an animation table, paper and
pencils. These tools are described in this section:
•

Onion Skin

•

Light Table

•

Drawing Identification

•

Create Empty Drawing

•

Animating Traditionally

Onion Skin

The Onion Skin is used to preview the previous and subsequent drawings. When
designing or animating, it is useful to be able to see your previous drawings. By default,
the previous drawings will appear with a shade of red and the next drawings will be
displayed with a shade of green. You can change the display options in the Preferences
panel.
To use the Onion Skin feature:
1. Enable the Onion Skin feature:


In the Tools toolbar, click on the Show Onion Skin



In the Timeline view, click on the Onion Skin
will turn red



button.

icon. When enabled, the icon

.

You can also use the default keyboard shortcut [Ctrl]+[Alt]+[O] (Windows®) or
[a]+[Alt]+[O] (Mac OS® X) or from the top menu,
select View > Onion Skin > Show Onion Skin.
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2. You can select the number of previous and next drawings you want to show:


In the Timeline view, click and drag the Onion Skin blue markers to choose how
many previous and next drawings will be displayed.



Select View > Onion Skin > No Previous Drawing
The default keyboard shortcut is [~].



Select View > Onion Skin > Previous Drawing
The default keyboard shortcut is [!].



Select View > Onion Skin > Previous Two Drawings
The default keyboard shortcut is [@].



Select View > Onion Skin > Previous Three Drawings
The default keyboard shortcut is [#].



Select View > Onion Skin > No Next Drawing
The default keyboard shortcut is [Ctrl]+[‘] (Windows®) or [a]+[‘] (Mac OS® X).



Select View > Onion Skin > Next Drawing
The default keyboard shortcut is [Ctrl]+[1] (Windows®) or [a]+[1] (Mac OS® X).



Select View > Onion Skin > Next Two Drawings
The default keyboard shortcut is [Ctrl]+[2] (Windows®) or [a]+[2] (Mac OS® X).



Select View > Onion Skin > Next Three Drawings
The default keyboard shortcut is [Ctrl]+[3] (Windows®) or [a]+[3] (Mac OS® X).

3. The previous and next drawings will appear in both the Camera and Drawing view.
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Light Table

The Light Table is used to preview the previous and subsequent active layers these are
displayed in faded colours. It is useful to be able to see the other layers when designing,
animating or cleaning up your animation.
In the Camera view, when the Light Table is activated all layers except from the currently
selected one are shown faded. The display returns to the normal mode when the Select
tool or a Scene Setup tool is selected.
By default, only the currently selected drawing is displayed in the Drawing view. When
enabling the Light Table, the other layers appear as a washed-out display and are used
as a reference. You can not select or manipulate these washed-out images.
To use the Light Table feature:
1. Enable the Light Table feature:


In the top menu, select View > Light Table.



In the Drawing View toolbar, click on the Light Table
button.
You can also use the default keyboard shortcut [Shift]+[L].



2. The drawings for the other layers are displayed as washed-out colours in the
Camera and Drawing view.
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3. In the Timeline view, you can disable the layers you wish to hide from the Light
Table.

Drawing Identification
In the Xsheet view, you can identify your drawings as Key, Breakdown or In-between.
This helps to keep your Xsheet well organized while animating.

Key Drawing
A Key drawing is a key pose in a movement, often an extreme position. For example, if
a character is sitting down and then falls on his back, the key poses would be, the
character sitting and the character on his back. This may vary from one animation to
another.

Breakdown Drawing
A Breakdown drawing is a pose between two key poses that will show the movement
better. Most animation moves are arcs: an arm waving, somebody bending, a leg
walking, etc. All of these movements are rotations. The Breakdown pose is used to
describe this curve better.
The Breakdown pose is then used to indicate the secondary moves or the FollowThrough. For example, these actions can be:
•

the jiggle of a character’s large stomach as he jumps,

•

a cloak billowing behind a character who is running,

•

or the movement of a character’s arms following the main body action.

Moves such as these will generally have a different timing than the primary action and
will normally start later and finish later. So, to summarize, the Breakdown drawings are
used to complete the Key drawings.
A Breakdown drawing is not always placed in the middle of two Keys. It will often
be closer to one or the other depending on the timing and the action. Also, you can have
more than one Breakdown pose between two Keys.

In-between Drawing
The In-between drawings can be considered as filling drawings. Once the timing is
established by the Key and Breakdown poses, the In-between drawings will be added to
complete the animation and make it more fluid.
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In-betweens do not necessarily need to be placed exactly in the middle of two other
poses. They can be placed closer to one or the other, doing this will create an ease in or
ease out of the movement.
To mark a drawing as Key, Breakdown or In-between:
1. In the Xsheet view, select the cell you want to identify.
2. In the Xsheet Tools toolbar, press on one of these buttons:


Mark as Key Drawing

button.

If you select this button, a


Mark as Breakdown Drawing
If you select this button, a

icon appears in the cell.
button.
icon appears in the cell.



Mark as In-between Drawing
button.
If you select this button, an icon is not displayed in the cell. This option is used to
remove a Key or Breakdown an identified drawing to a normal in-between
drawing.



You can also select
Drawing > Mark Drawing As > Key Drawing, Breakdown Drawing and
In-between Drawing.

Create Empty Drawing
The Create Empty Drawing command automatically creates a drawing in the selected
cell of the Timeline and Xsheet view. This replaces any drawing that may already be
exposed in that cell and the following ones, until it encounters another drawing.
To create an Empty Drawing:
1. In the Timeline or Xsheet view, select the cell you want to create an empty drawing
in.
2. In the Xsheet View toolbar, click on the Create Empty Drawing
Animation > Create Empty Drawing.
You can also use the default keyboard shortcut [Alt]+[Shift]+[R].

button or select

3. The new drawing will be created in the Xsheet and Timeline views.
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Flip and Easy Flipping Toolbars
Animate Pro provides a Flip feature which allows you to rapidly flip through the drawings
in the same way you would with paper drawings. You can flip through the Key,
Breakdown or In-between drawings individually, or view a combination.
The flipping features only work in the Drawing view.
To flip through your drawings:
1. In the top menu, select Window > Toolbars > Easy Flipping and Flip.

2. In the Easy Flipping toolbar, click on the Previous
previous or next drawing of your animation.

or Next

button to see the

3. To loop your animation during the flip, enable the Loop option. This way, when you
reach the end of your animation, the first drawings will show up again.

4. To use the easy flipping slider:




Move the slider to the right to flip forward through your drawings
Move the slider to the left to flip backward through your drawings.

The quicker you move the slider, the faster the drawings will flip.
5. If you marked some of your drawings as Key, Breakdown or In-between, you can flip
through the markers to avoid seeing all the in-betweens. Enable the Flip Key,
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Breakdown or In-between option in the Flip toolbar, to see only one type or a
combination.

Onion Skin Toolbar

You can setup your onion skin to display only the marked drawings, in the same way that
you flip through your drawings marked as Key, Breakdown or Inbetween drawings.
This Onion Skin feature only operates in the Drawing view.
To display the marked drawings in the onion skin:
1. In the top menu, select Window > Toolbars > Onion Skin.

2. In the Tools toolbar, enable the Onion Skin

feature.

3. In the Timeline view, pull on the blue arrows to extend the number of drawings
displayed in the onion skin preview.
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4. In the Onion Skin toolbar, enable the markers you want to see in your Onion Skin
preview.

More Drawing Layers

Animate Pro has four layers included in its drawings:
•

Overlay

•

Line Art

•

Colour Art

•

Underlay

Each layer can be used for a traditional animation task, this helps to organize your work
and make things easier.
To switch between the drawing layers:
1. In the Camera or Drawing view bottom toolbar, click on either the Overlay

,

Line Art
, Colour Art
or Underlay
buttons.
You can also use the toggle keyboard shortcuts [L] and [:].
2. Click on the Preview
button to display all the layers together. Select Overlay and
Underlay, in the Preview button’s drop-down menu, to display all four layers.
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Overlay
The Overlay layer can be used for many different purposes:
Highlights and Tones

Annotations and Corrections

Sketching

You can also draw in the Overlay layer, as it is a regular layer.

Line Art
In traditional animation, you mainly use the Line Art layer to trace and clean up your
animation. The outline is drawn in the Line Art layer and you paint in the Colour Art layer.
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Colour Art
In traditional animation, you use the Colour Art layer to paint your animation. The outline
is drawn in the Line Art layer and you paint in the Colour Art layer. You need to generate
invisible lines out of your Line Art to be able to do so.

Underlay

The Underlay layer can be used for several things, but it is mainly used for sketching your
rough animation or generating a matte colour when doing line testing.
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Setting the Timing
If you want to change your animation timing, here are a some tools which you can use.

Extending a Single Exposure
The Extend Exposure feature allows you to select an Xsheet’s cell containing a value and
to pull it down to the desired frame.
To extend a cell exposure:
1. In the Xsheet view, select the red arrow in the cell’s right side. Make sure to see the
drag down cursor.
2. Pull down the selected cell to the desired frame.
The red selection box must be visible when releasing the mouse button. If it is not
visible, the action is considered cancelled.

Extending an Exposure Sequence
You can extend and create a sequence using almost the same procedure as you would
when you extend a single exposure. The only differences being that the selected cell
must only contain numbers and that you need to press the [Shift] key while pulling down
on the selection.
The creation of the sequence only works with numbers in the selected cell, not
letters.
To create a sequence:
1. In the Xsheet view, select a cell containing a number.
2. In the selected cell, click on the red arrow on the cell’s right-hand side. Make sure to
see the drag down cursor.
3. Press the [Shift] key and hold it down. Make sure a [+] sign appears.
4. Pull down the selection box to the desired frame.
The red selection box must be visible when releasing the mouse button. If it is not
visible, the action is considered as cancelled.
5. First release the [Shift] key, then release the mouse button.
You can also select a cell and select Animation > Cell > Extend Exposure. In the
dialog box, type the frame number you want to extend the cell to. The default
keyboard shortcut is [F5].
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Dragging Cells
To readjust your timing, you can drag one or several cells to a new location in both
Timeline and Xsheet view. You can drag a cell to any other frame in the same column or
into another column.
To drag a cell to another location in the Timeline view:
1. In the Timeline view, select one or several cells to move.
2. Click on the cells selection and drag it to the new location.




If you drop the selection, it overwrites the existing cells.
If you hold [Ctrl] (Windows) or [a] (Mac) while dropping the selection, the cells
are copied and not moved.
If your press [Shift] while dropping, the selection is inserted between the existing
frames.

To drag a cell to another location in the Xsheet view:
1. In the Xsheet view, select one or more cells.
2. In the Xsheet view, select the small dotted area on the left-hand side of the selected
cells.
3. Drag the selection to any other cell in the same column or in another column.




If you drop the selection, it overwrites the existing cells.
If you hold [Ctrl] (Windows) or [a] (Mac) while dropping the selection, the cells
are copied and not moved.
If your press [Shift] while dropping, the selection is inserted between the existing
frames.

Increase Exposure
Increasing the exposure adds one more exposure to a selected cell, repeating this action
adds an extra cell every time. This is a quick way of extending a drawing exposure and
is always set in the Insert mode. Increasing an exposure always pushes the existing
exposure down.
To use Increase Exposure:
1. In the Timeline or Xsheet view, select a cell.
2. In the top menu, select Animation > Cell > Increase Exposure. You can also rightclick (Windows) or [Ctrl] + Click (Mac) on the selected cell and select
Exposure > Increase Exposure. The default keyboard shortcut is [+].
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You can click on the Increase Exposure button available in the Xsheet View and
Timeline View toolbars’ extra buttons.
Repeat this action to add more cell to your drawing’s exposure.
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Decrease Exposure
Decreasing the exposure removes one exposure from a selected cell, repeating this
action removes an extra cell every time. This is a rapid way to reduce a drawing exposure
and remove the exposed drawing.
To use Decrease Exposure:
1. In the Timeline or Xsheet view, select a cell.
2. In the top menu, select Animation > Cell > Decrease Exposure. You can also rightclick (Windows) or [Ctrl]+Click (Mac) on the selected cell and select
Exposure > Decrease Exposure. The default keyboard shortcut is [-].



You can click on the Increase Exposure button available in the Timeline View
toolbar’s extra buttons.
Repeat this action to add more cell to your drawing’s exposure.

Clear Exposure and Pull
You can reduce a drawing’s exposure using the Clear Exposure and Pull option.
To use the Clear Exposure and Pull feature:
1. In the Timeline or Xsheet view, select a cell.
2. In the top menu, select Animation > Cell > Clear Exposure and Pull. You can also
right-click (Windows) or [Ctrl] + Click (Mac) on the selected cell and select
Exposure > Clear Exposure and Pull.



You can click on the Clear Exposure button available in the Xsheet View and
Timeline View toolbars’ extra buttons.
The default keyboard shortcut is [Z].

Deleting an Exposure
You can delete a drawing’s exposure in several simple ways. Note that when you delete
a drawing’s exposure from the Timeline or Xsheet view, you are not deleting the actual
drawing file. You can always bring it back by typing its name again in a cell.
You can delete the exposure contained in a selected cell range or delete the entire
exposure of a drawing exposed over several cells.
To delete selected exposures:
1. In the Timeline or Xsheet view, select the exposure you want to delete.
2. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Delete.
The default keyboard shortcut is [Delete].
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Inserting Blank Cells
Use the Insert Blank Cell option to place an empty cell between other cells. This is always
done in Insert mode and pushes down existing exposure, even if you are set to
Overwrite mode.
To use Insert Blank Cell:
1. In the Xsheet or Timeline view, select the cell where you want to insert a blank cell.
2. In the top menu, select Animation > Cell > Insert Blank Cell. You can also rightclick (Windows) or [Ctrl]+Click (Mac) on the selected cell and select
Exposure > Insert Blank Cell.



The default keyboard shortcut is [X].
You can click on the Insert Blank Cell button available in the Timeline View and
Xsheet toolbars’ extra buttons.

The blank cell is inserted.

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the
Set Exposure options.
To use the Set Exposure options:
1. In the Timeline or Xsheet view, select the cell range that you want to set the
exposure for.
2. In the top menu, select one of the following:






Animation > Cell > Set Exposure> Set Exposure to 1
Animation > Cell > Set Exposure> Set Exposure to 2
Animation > Cell > Set Exposure> Set Exposure to 3
Animation > Cell > Set Exposure
You can also click on the Set Exposure buttons located in the Timeline View
toolbar’s extra buttons.

If you choose the Set Exposure option, the Set Exposure dialog box opens.
3. Type the amount of frames you want the drawings to be displayed.
4. Click on the OK button
The new timing is displayed in the Xsheet view.
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Renaming Drawings By Frame Position
To rename a drawing, use the Rename Drawing option. Do not double-click on the
frame and write a new name, as this will create a new drawing and hide your actual
drawing. Note that your drawing will not be deleted; it is still contained inside the
element folder. Simply re-enter the name and it will reappear.
If you did not previously set your Preferences to Use the Current Frame as Drawing
Name, you can always rename your drawing sequence later, based on the frame
position.
To rename drawings by their frame position:
1. In the Xsheet View, select the drawing sequence to be renamed.
2. Right-click (Windows) or [Ctrl] + click (Mac) on the selected drawings and select
Drawings > Rename by Frame.

Playing Back Your Animation
You can playback your animation in the Camera view using the Playback toolbar.
To play back your animation:
1. Be sure you are currently using the Camera view, as this feature is not available in
the Drawing view.
2. In the Timeline view, disable the layers you do not want to show during playback.
3. In the Playback toolbar, click on the Loop button if you want the playback to loop.
4. In the Playback toolbar, click on the Play button to start the animation.

Animating Traditionally
In Animate Pro, you can easily animate traditionally and work entirely digitally. Many
tools and features are supplied to help you achieve that traditional animation look easily
and efficiently.

Rough Animation

The first step to complete is the rough animation, this forms the skeleton of your
animation. You would usually start with the main action. For example, to animate a walkcycle, you will start with the torso and the legs. Head, arms and clothes will be added
later, during the secondary animation.
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To obtain the best animation, complete the main action before adding all of the details.
If you start animating the details right away, you will lose a lot of time if you have to do
corrections, and your animation will often look too rigid.
To animate:
1. In the Preferences panel, set your Preferences to Use Current Frame as Drawing
Name.
2. In the Tools toolbar, select the Brush
shortcut [Alt]+[B].

tool, you can also use the default keyboard

3. In the Colour view, select the colour you will use to draw.

Choose a light colour for your rough animation, this helps when you perform the
Clean Up process.
4. In the Timeline or Xsheet view, select the cell where the first drawing is going to
appear.
5. In the Camera view, draw the first key drawing.

6. While keeping the first key drawing selected in the Xsheet view, select
Animation > Mark Drawing As > Key Drawing to identify your drawing.

7. In the Tools toolbar, click on the Enable Onion Skin
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8. In the Timeline view, click and drag the onion skin blue markers to extend the
number of previous and next visible drawings to fit your need.

9. In the Timeline or Xsheet view, select the cell where your next key drawing will
appear.

10.In the Camera view, draw your second key drawing.

11.In the Xsheet view, identify the drawing as a key drawing.

12.In the Xsheet View, select a cell between your two key drawings.

13.In the Timeline or Xsheet view, right-click (Windows®) or [Ctrl]+click (Mac OS® X)
and select Create Empty Drawing or use the keyboard shortcut [Alt]+[Shift]+[R].
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14.Draw your new drawing.

15.If necessary, in the Xsheet view, identify the new drawing as a Key, Breakdown or Inbetween drawing.

16.In the Timeline or Xsheet view, select a new cell and repeat Step 13 to Step 15 for
each new drawing.

Clean-Up

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is
also called tracing. Clean-up, consists of tracing solid and clean lines over the rough
animation to get closed zones. This is the final paperless animation step before the ink
and paint process.
You will need to add a new drawing layer to draw your clean. This is equivalent to taking
a sheet of paper and tracing the rough using the animation disk.
If you plan on tracing your animation in the Drawing view, you will need to enable the
Light Table feature in order to display all the layers of your project.
To trace your animation in a new layer:
1. In the Timeline view toolbar, click on the Add Drawing Layer
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2. In the Timeline view, click on the lock icon of the layer containing your rough
animation to prevent any accidental changes.

3. In the Timeline or Xsheet view, select the new layer’s cell that corresponds to the
first key drawing of your rough animation.
4. In the Tools toolbar, select the drawing tool of your choice.
5. In the Colour view, select the colour you will use to trace your animation. Make sure
to pick a bold dark colour, such as black, to contrast well against the light colour of
your rough animation.
6. In the Camera view, start tracing the first key drawing.

7. If there are some other layers in the way, temporarily disable them from the Timeline
view so that only the rough animation and the clean up layer are displayed in the
Camera view.
8. In the Tools toolbar, click on the Enable Onion Skin
Skin In the Timeline view.

button and extend the Onion

9. In the Timeline or Xsheet view, select the next cell which corresponds to a rough
drawing.
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10.In the Camera view, trace your next drawing.

11.Repeat Step 9 and Step 10 for each drawing.
Using this method allows you to keep the roughs and the cleans intact. You only
need to disable the rough layer to prevent it from appearing in the scene.

Painting Drawings Simultaneously
To speed up your painting process, you can use the Apply to Multiple Drawings option
to paint a zone on many drawings at once. Using the Paint tool in Paint Unpainted mode,
you can trace a selection on the zone you want to paint. All the drawings that have a
closed zone within the selection will be painted at once.
The Apply to Multiple Drawings option is used for hand-drawn animation fast painting.
When you want to paint several drawings in a same layer at once, such as a walk cycle,
you can enable this option and make a selection in your Camera or Drawing view. All the
closed zones located within your Paint tool selection are painted with the selected
colour swatch.
You do not need to enable the Onion Skin preview to use this option. The option will
only stay enabled for the next action. If you want to use it after that, you must click on
the Apply to Multiple Drawings button again.
The default keyboard shortcut to use this option is:
•

[Ctrl]+[Alt]+[A] for (Windows) or [a]+[Alt]+[A] for (Mac).

To use the Apply Tool to All Drawings in Layer option:
1. In the Tools toolbar, select the Paint tool.
2. In the Tool Properties view, enable the Apply to Multiple Drawing option.
3. Select the desired colour on the colour model or in the colour palette.
4. Using your Paint tool, trace a selection in the drawing area that you want to paint at
the same time.
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Inking the Lines
Some animation styles require you to paint the lines. This process can also be called
inking the lines. To ink your lines, you must be in the Line Art mode. You can repaint any
type of lines including the texture lines.
Unless you intend to repaint all of the lines on the whole animation sequence, we do not
recommend using the Apply to Multiple Drawings option. Since the line positions
change a lot over time, you risk painting lines that are not supposed to be.
There are three main tools used to ink the lines:
•

Paint Tool - Repaint Mode

•

Brush Tool - Repaint Brush Mode

•

Protect Colour

Paint Tool - Repaint Mode

The main tool used to ink the lines is the Paint tool is Repaint mode.
During the vectorization process on traditional scanned drawings, triangles are added
on the line intersections to break the artwork into segments. This way, when you paint a
line, it will not repaint the whole drawing but only the chosen segment.
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Brush Tool - Repaint Brush Mode

The Repaint Brush mode is used to paint a specific section by manually painting over the
lines. In traditional animation, this is useful when the vectorization triangles are not
placed as we would like, or you simply need to repaint a section of a segment. It is also
useful for tradigital animation, which has no triangles.
So, the Repaint Brush is used to paint a specific area. It acts like the Brush tool, but will
only show on already painted areas. You can also use this mode in filled colour zones to
draw some tones, highlights or anything else you would need it for.
Unlike the Brush tool, the Repaint Brush mode flattens automatically. The brush strokes
are not added one on top of each other.
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Activity 3: Animating, Cleaning and Painting a WalkCycle

This exercise will focus on the Xsheet view and its functionality, but everything can be
also achieved in the Timeline view if you prefer.
The topics are:
•

Sketching your Rough Keyposes

•

Marking Keyposes in the Xsheet

•

Completing the Animation

•

Setting the Exposure and Testing the Animation

•

Cleaning Up the Animation

•

Painting the Animation
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Sketching your Rough Keyposes

The first step in hand-drawn animation is to draw a rough sketch. This step lets you
create and test your animation. You can concentrate on the flow of movement without
being concerned about the character’s details. You can focus on the details during the
clean up process later on.
To easily draw your animation, first switch to the Hand-Drawn Animation workspace.
1. In the Workspace toolbar, select the Hand-Drawn Animation workspace from the
drop-down menu.

To ensure that your scene is kept well organized, enable the Use Current Frame As
Drawing Name option. This uses the current frame number to name each new drawing.
2. Press [Ctrl]+[U] (Windows) or [ z]+[,] (Mac OS X) to open the Preferences panel.
3. In the Exposure Sheet tab, enable the Use Current Frame as Drawing Name option.
4. In the Tools toolbar, select the Brush tool.
5. In the Colour view, select a colour swatch. This is the colour you are going to use for
your sketch. Sketching with a light colour helps during cleanup.
6. In the Xsheet view, select the first cell in the Drawing column.
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7. In the Camera view, sketch your first keypose.

The first keypose in
the walk cycle
animation is the
character with legs
and arms spread
apart.

To sketch the second keypose of your animation, you will use the Onion Skin feature. The
Onion Skin lets you see the previous and next drawings in washed-out colours. This
mimics the effect of working with a stack of paper on an animation disc and light table.
8. In the Tools toolbar, enable the Onion Skin feature.
9. In the Xsheet view, select cell number 4, this will be the location of the second
keypose.
10.In the Timeline view, click and drag the blue arrows to decide the number of
previous and next drawings that will appear in the Camera view.
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11.In the Camera view, sketch the second keypose.
The second keypose is the highest point of the
walk cycle. The leg that was pointing forward on
the first one should now be straight beneath the
character.

Keypose 1 Keypose Keypose
2
3
Cell 1

Keypose
4

Using this picture as a guide, complete the four
keyposes of the simple walk cycle animation.
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Marking Keyposes in the Xsheet

Once you have sketched your keyposes, you should mark them in the Xsheet view so you
can keep your animation organized. Doing this helps you to rapidly determine which
poses are keyframes, breakdowns or in-betweens.

1. In the Xsheet view, select the cell containing the first keypose.
2. In the Xsheet Tools toolbar, click on the Mark as Key Drawing

button. A Key

marker will appear in the cell.
3. Repeat these steps for each keypose.
You can do the same for breakdown drawings using the Mark as Breakdown Drawing
button. This places a Breakdown
The Mark As In-between Drawing

marker in the selected cell.
option will not add a marker in the Xsheet view.

Another great way to keep organized is by renaming your Xsheet columns.
1. In the Xsheet view, double-click on the Drawing column’s header.
2. In the Layer Properties dialog box, enter a relevant name for the column in the
name field.

191

Animate Pro 2 - Student Workbook

Completing the Animation

It is now time to complete the rough animation. Do this by adding two in-between
drawings between each keyframe.

1. In the Xsheet view, right-click (Windows) or [Ctrl] +click (Mac) on any cell between
two keyposes, and select Drawing > Create Empty Drawing.

This will add a new empty drawing in your layer ready for your next pose to be
drawn in.
2. Add new drawings and sketch your poses with the help of the Onion Skin feature.
Continue until you complete the walk cycle animation. The completed animation
should be composed of a total of twelve different drawings.Your Xsheet should look
like this.

The completed animation should be
composed of a total of twelve different
drawings.Your Xsheet should look like this.
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Setting the Exposure and Testing the Animation

Testing your animation is a crucial step. You will finally see the motion in the Camera view
and decide if it is good or not.
Before testing the animation, set the exposure and reduce the scene length. The correct
timing for this simple walk cycle example is a double exposure.
1. In the Top menu, select Scene > Scene Length.
2. In the Set Scene Length dialog box, extend the scene to 24 frames.
3. In the Xsheet view, select your twelve drawings, right-click and select Exposure >
Set Exposure to > Set Exposure to 2.

4. Use the [F] and [G] keyboard shortcuts to flip through your drawings.

Playing Back your Animation
1. In the Playback toolbar, click on the Loop button to enable the looping feature.
2. To start the playback, click on the Play button in the Playback toolbar.
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Cleaning Up the Animation

When you are satisfied with your animation, you can begin the clean up process.
In the rough sketch layer, start by cleaning up the key poses first and then do the inbetween drawings.
Remember, you can use the Onion Skin feature to verify the accuracy of the line between
the different poses.

1. In the Xsheet view, click on the Add Column

button.

2. In the Add Columns dialog box, name your column Baby_Walk_Clean .
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3. In the Tools toolbars, click on the Brush

button.

4. In the Tools Properties view, click on the Auto Flatten
minimum and maximum brush sizes.

button and modify the

The Auto Flatten option flattens your brush lines as you draw them. It also simplifies
the process of perfecting your lines with the Contour Editor tool.
5. In the Colour view, click on the desired colour swatch. Choose a darker colour that
will contrast with your rough sketch.

6. In the Camera view, carefully trace the poses.
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Painting the Animation

It is time to create a palette for your character and repaint the outlines using the colours
contained in this palette.
1. In the top part of the Colour view, click on the New Palette

button.

2. Name your palette in the Palette Browser window.
3. Rename the default colour swatch and call it Line.
4. In the Tools toolbar, select the Paint

tool.

5. In the Tools Properties view, select the Repaint
Multiple Drawings

mode and click on the Apply to

button.

The Repaint
mode will make sure that only the lines will be repainted, all the
empty zones will remain.
The Apply to Multiple Drawings
drawings at once.
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Use the Onion Skin feature to check that no part of the animation is left outside the
selection.
6. In the Camera view, make a selection around your animation.

Now you can add and customize the different colours that will be painted in your
animation. Be creative! You can work with one colour at a time or create them all at once.
Remember, you can modify them anytime you want without repainting your drawings.

1. In the bottom part of the Colour view, click on the Add Colour

button.

2. In the Colour view, double-click on the new colour swatch.
3. In the Colour Picker dialog box, pick the desired colour and rename your colour
swatch.
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4. Repeat these steps for each colour. In this exercise, you will need a total of five
colours, including the line.

As soon as your palette is completed you can start to fill the zones.
1. In the Tool Properties view, select the Paint Unpainted mode and click on the Apply
to Multiple Drawings button.
The Paint Unpainted mode will only allow the empty zone to be painted, preventing
lines from being accidentally repainted.
The Apply to Multiple Drawings feature is useful when you want to paint the central
body zone on all of your drawings at once. It can also be used on the head zone.
2. In the Tools toolbar, enable the Onion Skin feature.
3. In the Colour view, select the colour of the pyjamas.
4. Click inside the central zone you want to paint.

5. Enable the Apply to Multiple Drawings feature again and repeat these steps for the
head.
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To paint the final details, disable the Onion Skin feature so you can see one drawing at
a time. Use the Paint tool in Paint Unpainted mode to speed up the painting process.

1. In the Colour view, click on the colour swatch.
2. In the Camera view, click on the zone corresponding to the selected colour.
3. Flip through the drawings by pressing [F] and [G], the default keyboard shortcuts.
4. Repeat these steps for each colour until every zone is painted!
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Activity 4: How Do These Characters Walk?

Now that you have animated a full walk-cycle, are you ready to tackle these fellows? With
three other classmates each choose a different one of these characters. How would you
make them walk? Act-out your character’s walk in front of the group. When you feel that
you have analyses the walk of your character enough, animate it following the same
steps as in the previous Activity.
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•

Remember that you only need to do a walk-cycle.

•

The walk should show the character’s personality. All four characters are very
distinct so be sure to show that personality in the animation.

•

Ask a classmate to act-out the walk you want to animate for you so that you have
a good references.

•

Remember to start with the keyposes and then create the inbetweens.

M11: Four Legged Walk-cycle

This module is divided into the following topics:
•

Theory, on page 202

•

Activity 1: Observation, on page 210

•

Activity 2: Animating a Four-Legged Walk-cycle, on page 211

•

Activity 3: Animating a Bear and a Dog, on page 221
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Theory
This topic is divided as follows:
•

Understanding How Four-legged Animals Move, on page 202

•

The Basics of Four-Legged Walk-cycles, on page 203

•

Analyzing The Horse and the Panther Animations, on page 205

•

Rough versus Clean, on page 209

Understanding How Four-legged Animals Move
In order to create a believable animation of any living creature, you must carefully
research and study the creature’s movements when it is in motion and when it is at rest.
Only by doing this will you be able to record, and later animate the subtle differences
that will give your animated character its own specific personality. Even watching a
subject for a few minutes can give you insight into its motion. But where do you start?
There are a many sources of reference for four-legged creatures, and many ways that you
can use this information to enhance your animation. Some of these are mentioned here,
but you just need look around your surroundings and you will soon find examples of fourlegged creatures you can study. For example, if you want to animate a cat or dog, you
may see one roaming outside that you can observe.

Anatomy

Here we have a sketched in the
approximate skeletal structure of the
horse’s legs. This helps to get the
position of the legs correct as they
bend at the joints.

Why study the anatomy of the creature you are trying to animate? First, each creature
looks physically different. This, combined with its weight and size, determines how an
animal moves. For example, a very heavy, lumbering animal such as an hippopotamus
moves in a different way a lightweight cheetah.
Secondly, the underlying skeletal structure is important as this allows the creature to
move and flex its body in different ways. Different skeletal structures allow for different
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levels of agility, limb movement and speed. Studying this structure will allow you to see
how a creature moves through its surroundings.

Photo and Video References

This is a typical example of an
animal locomotion study. You can
see the placement of the feet,
the positioning of the legs and
the body posture from this one
illustration.

If you are going to study creatures moving, such as animals running or leaping, it may
benefit you to watch live-action video. You can find footage on television shows about
animals or wildlife. These may also be available for rental from video stores or local
libraries. Having a live-action video has certain advantages as you can replay the action
and movements you want to study and pause frames to observe certain poses.
Studying the compiled works of Eadweard Muybridge, a photographer who extensively
researched and produced photographic studies of walk-cycles and animal locomotion,
is invaluable. These works are an amazing resource for anyone intent on animating
realistic character movements.
His studies consist of sequences of images of human and animal movements, shown
against a calibrated background, enabling movement over time to be measured. These
should easily be found in bookstores or at local libraries.

The Basics of Four-Legged Walk-cycles
Every animal will walk slightly different than another, but there are a few things that most
four-legged walks will have in common. We’ll use a panther animation to go over the
basics.

Movement with Two Sets of Legs
The panther’s legs work together in two groups; back legs and front legs. The back legs
work together and follow a certain pattern, and the front legs will follow a similar
pattern, but the cycle will be ½ step behind the back legs. At the same time, each one
of the panther’s legs will have its own cycle that is slightly offset from the other legs, but
are all dependent on the others.
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The Contact Positions

Both paws at the front
are in the contact
position.

Both the front and back legs have two contact positions. The contact positions in this
walk-cycle will be when both feet in the set (front or back) are making contact with the
ground.

The Passing Positions

Compared to the previous
image, the front paws are
now in a passing position.

The passing positions show where the leg is going between the contact poses, from the
point when it lifts off the ground to the point when it touches again, between the contact
poses.
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The Keys
Here is what you should reference yourself to before doing Activity 2 of this chapter: the
panther’s walk-cycle keys. Carefully study these poses and see how they are different:

The first key. Passing
position for the back legs, contact for the front.

The second key. Contact position for the back
legs, passing for the front.

The third key. Passing position for the back
legs, contact for the front.

The fourth key. Contact position for the back
legs, passing for the front.

Secondary Actions of the Four-legged Walk
Besides the main movement of the feet that propel the body forward, there are the
secondary elements that have to also be considered, such as the up-and-down
movement of the head, or the side-to-side movement of the tail with the hind-quarters
of the panther.

Analyzing The Horse and the Panther Animations
We’ve included two fully analysed animations of two different four-legged animals. One
shows a panther walking and the other a horse galloping. Study these carefully first.
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The Panther Walking
The panther’s walk is divided into 16 frames.
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The Horse Galloping
The horse’s gallop is only 8 frames.
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Rough versus Clean

When drawing for animation, it can sometimes be overwhelming if you start drawing all
of the small details right away. It is often recommended to start with a very rough sketch,
only with the volumes of the figure, as shown in the example of the panther above.
Always start with the basic shapes and volumes when animating. Once the shapes seem
to move correctly, it’s much easier to work the details around it because you will have a
good foundation to work with.
For the following exercises, it is recommended that you start working roughly and then
test as you go. If one of your drawings doesn’t work in the animation, it will be a lot less
painful to delete it and start over than it would if you had spent hours cleaning it up first.
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Activity 1: Observation
Carry a sketch pad and
pencil with you at all times.

The best way to draw animals correctly, is to learn from real life. Take the time to go to
the zoo, or observe an animal near your home. Start by studying their attitudes and
demeanour, movement and poses and sketching them all on paper. But you have to be
quick, unlike a friend or family, they will not stay put long. So you need to make your
observations quickly and transfer them even more quickly on your sheet of paper!
Sketching from life takes a little practice, but with time, you will develop a good eye for
it. If you carry a sketch book and pencil with you all the time it will soon be full of useful
references and studies of all sorts.
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Activity 2: Animating a Four-Legged Walk-cycle
An animal’s four-legged walk-cycle is a little bit tricker than the regular walk-cycle. Not
only do you have two sets of legs to animate (front and back) but they cannot be
animated separately, both sets need to work as a group. Here are the steps to go
through for a full four-legged walk-cycle:

Create your Scene in the Software
1. Launch Animate Pro by double-clicking on the icon.
2. In the Welcome Screen, name your project Panther followed by your initials.
3. In the Timeline, click the Add Element
drop-down menu.

button, then select Drawing in the

4. Rename both Drawing Elements. The first element should be named Panther, the
second element should be named Path.

5. Now that you know how to prepare a path for a walk-cycle, we suggest that you
come up with your own planning.
6. Use the Brush
tool to sketch the paths. Remember, you will have two sets of
legs to animate, so if you do a path for each leg, that’s four paths!
Don’t forget to extend the exposure of that frame so that you see it throughout
your animation while drawing your panther.

Starting With the Key Poses
On the Panther drawing element, you will sketch all four keyposes that were covered
previously in The Keys, on page 205. Each key pose will be a on different frame.
Refer to Analyzing The Horse and the Panther Animations, on page 205 whenever you
need to. This is valuable information to help you create your own four-legged animal
walk-cycle.
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Remember, not only the paws and legs of the panther are moving, but that the body,
neck, tail and head also move. As the legs go from the passing to the contact position,
the body will move up and down. This will in turn affect the motion of the neck and tail.

Here the back legs are in a passing position, so
the back moves upwards.
But, the front legs are in a contact position, so the
front is moving downwards.
This balancing act will allow you to have a very
believable walk-cycle.

Adjusting the Paws for a Pan Background
In this project you will add a peg movement to the panther, so you will need to animate
the panther walking on one spot first. Because of this, the panther’s paws will have to
slide backwards at the same speed in each frame. This will help when you will need to
adjust the peg movement so that the paws don’t look like they are sliding in an odd way.
For now, you should adjust the panther’s paws so they move in even increments and then
adjust the speed of the peg to match the speed of the walk later. To make these
changes, use some of the following tools and tricks to help you.

The Onion Skinning Feature
As in traditional animation, you’ll use the Onion Skinning feature so that you can see the
drawings on the frames before and after your current selection. This is a great way to
help you to make adjustments to elements in relation to other keyframes.
To enable the Onion Skinning feature:
1. You can activate the Onion Skinning feature on by clicking this button

.

2. To include more frames into the Onion Skinning feature, you will need to drag the
blue handles that are over the frames in the Timeline.
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Depending on how many frames you decide to include in your onion skin, you
should now be able to see the previous and next drawings in Camera View.

3. You can also choose to see your onion skin levels as outlines. From the View menu,
choose Edit > Preferences, then go to the Drawing tab.
4. In the Light Table options, change the Onion Skin Render Style to Outline Only.

Pan Increments
Now that your keys are basically set, you may have to make adjustments to the paws as
they are planted on the ground. Use the Onion Skinning and the Show/Hide tools to
make sure that the paws are evenly spaced.
1. Flip through the keys and make any adjustments necessary to the legs and paws so
that they are evenly spaced. Use the following drawing as reference.
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2. Once you have made all adjustments to the back right leg, adjust the back left leg in
the same way.
3. Use the following drawing to make adjustments to both front legs.

Inbetweens
The keyposes are done and the increments are checked. You are now ready to work on
all those inbetweens. Your animation should either have 16 drawings in double exposure
or 32 drawings in single exposure.
1. Activate the Onion Skinning button
and draw the inbetweens.

. You will then be able to see the key poses

2. Make sure to save the progress of your work by clicking the Save
3. Play back the animation of the walk-cycle with the Play

button.

button and test/correct

your work. You can also activate the Loop
button, to view your animation in
loops while noting the corrections you will have to do.
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Clean-up and Colouring
Your animation is now ready to be cleaned up and coloured.
1. To clean up the panther, you should use the Brush
colour swatch in the Colour Tab.

Tool and pick the black

Pick the Default Line Colour in
your palette for the line art of
your cleaned-up panther.

2. In the Timeline, you will need to create a new Drawing element. Click on the Add
Element

button, then select Drawing.

3. Rename the new element Panther_Cleanup. This is the element where you will
clean the Panther and colour it.

4. Go on the first frame of the new drawing element. You should see the sketched
version of the animation in a light shade of gray. This is because of the light table
feature. Now, with the Brush

Tool, retrace your panther with a clean line.

Here you can see the clean-up
image superimposed over the
sketch of the panther. Take your
time. If a line didn’t come out right,
just undo and retrace.

5. Once you have done your first frame of the cleaned-up animation, check to make
sure that the Onion Skinning feature is activated. If not, click the Onion Skinning
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button to do so. When you start the second frame, you will see the previous
cleaned-up frame.
MAKE SURE TO USE THE CLEANED-UP FRAME AS A REFERENCE. You do not
want your animation to be wobbly once you play it.

6. The next step will be to colour your panther. You get to colour it any way you want,
you could even make it pink!
7. Pick a colour in the palette of the Colour Tab, then use the Paint Bucket
to colour the panther.

8. Make sure to save the progress of your work often by clicking the Save
9. Play back the animation of the walk-cycle with the Play

Tool,

button.

button and test/correct

your work. You can also activate the Loop
button, to view your animation in
loops while noting the corrections you will have to do.
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Create a Background
This is the very last thing you need to draw for this project. You’ve created backgrounds
before, so you should have no problem doing this one. Remember, you have to draw
something related to the panther. The panther will be crossing the scene, so give it
enough space of it to walk in the middle. Use the Brush
then the Paint Bucket

Tool to draw the line art,

tool to add colour.

In this example the
panther can cross
through the scene by
walking along this path.

Setting the Character on a Peg
You are now ready to put the panther on a peg. The peg will be use to move the Full
Drawing Element from left to right so that it looks like the panther is crossing the screen!
1. Before you add a peg, you need to make your scene longer. Crossing the screen will
take around 5 seconds, so you will add frames to your scene by drawing the red
handle at the top of the Timeline.
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2. Next, you also need to duplicate the animation walk-cycle a few times to fill it until
you also have 120 frames of the animation. To do this you first need to select the full
32 frames of animation.

3. Then, you will copy the frames with the Copy
paste the drawings with the Paste

button. Click on Frame 33. Then

button.

4. Repeat Step 3 until all the empty frames are filled up to frame 120.
5. You also need to extend the exposure of the background. Right-click on frame 32 of
the background and select Extend Exposure. Enter 120 into the Extend to Frame
field, then click OK.

6. You are now ready to add the peg to the Panther_Cleanup drawing element. Select
the drawing element, then click the Add Peg button.

7. The Peg Element will be added and the Panther_Cleanup Element will be attached
to it. Select the first frame of the peg element, than click on the Add Keyframe
button. This will add a keyframe to the peg. You will see a little dot appear in the
Timeline.
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8. While still on frame one of the peg, select the Transform
Tool. While holding
Shift on your keyboard, you will drag the panther to the left side of your scene, out
of the camera window.

9. In the Timeline view, go to the very last frame of the peg, frame 120. Then, using
the Transform
camera frame.

tool, drag the panther to the right side of the scene out of the

10.Make sure to save the progress of your work often by clicking the Save

button.
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11.Play back the animation of the walk-cycle with the Play

button and test/correct

your work. You can also activate the Loop
button, to view your animation in
loops while noting the corrections you will have to do.
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Activity 3: Animating a Bear and a Dog

Now that you have done a full four-legged walk-cycle, do you think you can tackle a few
more animals? Here are the two you need to research and animate:
•

A walking bear: The bear is a very distinct animal! It doesn’t quite walk like a
horse or a panther. Do some research and find what is so different about its walk.
Once you have enough information, animate a full walk-cycle for a bear.

•

A running dog: The dog’s walk is very similar to the panther’s. But this time, the
goal is not to actually make him walk, but instead to make him run. Do some
research on how dogs move and run. When you are ready, animate the dog.
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M12: Animating a Character Jumping

This module is divided into the following topics:
•

Theory, on page 224

•

Activity 1: Jumping Around, on page 228

•

Activity 2: Making a Character Jump, on page 229

•

Activity 3: Animating a Four-legged Animal Jumping, on page 232
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Theory
This topic is divided as follows:
•

Deconstructing a Jump, on page 224

•

Analyzing Another Jump Animation, on page 227

Deconstructing a Jump

The jump is another very frequent type of animation to do for a character. Just as we did
with previous animations, we will take the time to review each key pose in the animated
jump before you actually do the animation with one of your characters. Here is a break
down of those poses:
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Anticipation

You’ve seen this in a lot of animation by now,
before the character will take action, he will
anticipate that action. This will show up in the
actual animation and you need to plan it out.
In the case of the jump, the character prepares
himself with a good swing.

Push

The push is the opposite of the anticipation.
Instead of crouching to take in the energy
needed to jump, the character will now
push it all toward its destination (in this case,
he is jumping straight up).
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Stretch

The stretch is that very moment
where all the energy is released
and the character is at its highest.
Then, as the second image is
showing, the character will start
being pulled again by gravity.

Impact

The impact will then come and
the character needs to squash
again because of the weight of its
body hitting the ground. After
the impact, he can get back up
again.

226

Animating a Character Jumping

Analyzing Another Jump Animation
Here is another version of the jump that you can analyse before doing the exercise. In
this particular animation, the character is moving forward while jumping.

Frames 1 to 10...

...frames 11 to 20
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Activity 1: Jumping Around

In this activity, you will act out a jump to become aware of all of the elements involved
when you jump such as crouching and arm and leg motion. Watch another classmate and
see how he jumps. Can you draw thumbnail of the keyposes of the jump animation after
observing the jump? It will help you with the following activity.
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Activity 2: Making a Character Jump
This activity will require a lot of observation and practise. Make sure to go through the
previous activity to study the jump carefully.

1. First, you need to plan what type of jump the character will do. Is he running while
jumping? Is he jumping over a rock? A fence? Or maybe he is jumping into
something like a pool?
If you need to, also plan the layout. Do you need any accessories for this scene? Or
a background?
2. Launch Animate Pro by double-clicking on the icon.
3. In the Welcome Screen, name your project Jump followed by your initials.
4. In the Timeline, click the Add Element
drop-down menu.

button, then select Drawing in the

5. For the jump, it is better to work with two drawing elements: one for the character
and one to create a guide. Rename one element Character and one element Guide.

Of course, if you planned that you needed an accessory or a background, you also
need drawing layers for each of these items. Take the time to organise your scene.
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6. To help you through your animation, make sure you draw a guide that will tell you
where your character needs to go.

You now need to extend the exposure of the guide cell drawing you just did.
7. In the timeline, click on the drawing cell.
8. Right-click and select Extend Exposure. The Extend Exposure window will appear.

9. Extend the cell to frame 24.
10.Click on OK.
Note that the number of frames to be added will really depend on the size of your
animation. If you need more frames, you can extend the cell further by using the
same option.
11.Using the Brush

Tool, start sketching the keyposes of the jump.

Remember to draw with the basic figures of the character. Don’t go into too much
detail until you’ve sketched the complete animation.
Go with the following keyposes first:
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•

Anticipation.

•

Push

•

Stretch

•

Impact

Animating a Character Jumping

12.Activate the Show Onion Skin
option. This will allow you to see the previous
and next frames of your animation so that you can draw the inbetweens.
In the Timeline, you can move the blue handles on each side to include the frames
you need in the onion skinning option.

13.Make sure to save the progress of your work by clicking the Save
button.The
Save As window will appear. Name your project Walk_cycle along with your initials.
14.Play back the animation of the jump with the Play

button and test/correct your

work. You can also activate the Loop
button, to view your animation in loops
while noting the corrections you will have to do.
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Activity 3: Animating a Four-legged Animal Jumping

This activity is a little trickier than the previous one. Instead of making a two-legged
character jump, you will need to animate a four-legged animal.
•

A four-legged animal will have the same 4 key poses as a two-legged character:
D
D
D
D
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Anticipation
Push
Stretch
Impact.

•

Study videos or pictures of animals jumping. Can you point out what is different
between these and a the way a human jumps?

•

Remember to use a guide to plan out your animation.

M13: Scanning and Timing

In this lesson, you will learn how to create computer generated in-betweens for your
simple hand-drawn animation.
This module is divided into the following topics:
•

Theory, on page 234

•

Activity 1: Scanning An Animation - Chasse-Galerie Project, on page 243

•

Activity 2: Scanning an Animation - Short Project, on page 244

•

Theory, on page 245

•

Activity 1: Timing an Animation - Chasse-Galerie Project, on page 274
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Theory
This topic is divided as follows:
•

From Sketching Table to Animate Pro, on page 234

From Sketching Table to Animate Pro

Animate Pro lets you scan and import your sketches, draw directly in the application
using textured lines, bring in your colourful illustrations and keep your bitmap colours as
well as fully vectorizing your cleaned up drawings.
You can play around with textures, vector and bitmap graphics to get the high quality
look you are wishing for.
Once your traditional animation sequences are completed and cleaned up, you are
ready to scan them and import them in Animate Pro. The scan process is the point where
the traditional production becomes digital.

Scanning

One of the first techniques you can use to get your drawings into Animate Pro is to scan
them using a TWAIN device. You can adjust the import settings to match the style you
are looking for.
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Follow these main steps to get your sketches into Animate Pro:
•

Make sure a TWAIN device is installed on your computer and working correctly.

•

In Animate Pro, create a new project or open the scene where you want to
import your artwork.

•

Scan your drawings.

•

Set the vectorization parameters.

•

Import your images.

You can scan one of your own designs, try to find a drawing with a few rough lines where
you see the pencil texture. Then, follow the next steps in this lesson.

Scanning Process
To scan your drawings, make sure your scanner is connected and you are ready to go!
To scan your drawings:
1. In the Top Menu, select File > Import > From Scanner.
The Scan Drawings dialog box opens.
2. In the Scanner section, select your scanner from the list of scanners.
3. Click on the Scan button to begin the scanning process using the scanner’s
interface.

2
3
5
6

7
8
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4. Once the scan is completed, the Scanner Album opens to let you organize the
scanned images.

5. In the Scan Drawings window, enable the Create Layer(s) option and name your new
layer in the Name field.
6. Make sure the Vectorize Imported Items option is enabled.
If you do not want the new layer to be encapsulated in a Symbol, disable the Create
Symbol for the Imported Items option.
7. To keep the pencil line’s texture, select the Grey default vectorization parameters.
8. Click on the OK button and let the system import and vectorize your images.
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Colours as Textures

If you created illustrations and drawing pieces in a third-party software such as Adobe®
Photoshop®, you have two options available when you import these images in Animate
Pro. You can either import them as bitmap images or vectorize them using the Colour as
Texture option.
If your image is to be used as a background or an overlay, there is no need to vectorize
them. Although, if you are planning on building a photo puppet or using Animate Pro
drawing tools to modify the imported artwork, vectorizing your images using the Colour
as Texture parameters will be quite useful.
Note: your image will remain a bitmap, but it will be contained in a vector frame. This
way, you can modify the contours using the Contour Editor tool or draw over with the
Brush tool or even erase areas.
In the Sample Material package, you can find a complete image of the same monster
character as well as a multi-layered PSD file containing its body divided into five main
pieces. You can use those to try out the colour vectorization.
Once the pieces are imported, you can move on to the next lesson to learn how you can
connect them.
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To Vectorize Bitmap Images:

2
3
4

5
6
1. In the top menu, select File > Import > Images.
2. In the Import Drawings dialog box, click on the Browse button and select the
images to import.
3. Enable the Create Layer(s) and the Create Layer(s) Based on Filename options to
make a new layer with the same name as your file.
4. Make sure the Vectorize Imported Items and the Create Symbol for Imported Items
options are enabled.
5. In the Vectorization area, select the Colour option.
6. Click on the OK button.
7. If your image is a multi-layer PSD file, the Multilayer Image Import Settings dialog
box opens.

8. Select the All Layer Images option and set the Transparency type to match the
source file.
9. Click on the OK button and let the system import and vectorize your images.
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Cleaning Scanned Drawings
When paper drawings are passed through a scanner, there may be some hair and dirt
scattered across them. These lines and dots need to be cleaned. Animate Pro provides
different tools to quickly remove them.

Remove Dirt

The Remove Dirt tool selects small dots and hairs on the drawing. Increasing the Remove
Dirt level selects larger dots for removal, but be careful not to lose small details like
pupils and nostrils. Once the removal level is chosen, you can apply it to either the
current drawing or to the whole animation sequence.
This is a fast way to get rid of most dirt and dust.
To use the Remove Dirt tool:
1. In the Timeline or Xsheet view, select the drawing to clean.
2. In the top menu, select Drawing > Clean Up > Remove Dirt. The default keyboard
shortcut is [Shift]+[D].
The Remove Dirt dialog box opens.
3. Increase the Remove Dirt value by moving the slider to the right.
4. Enable the Apply to Multiple Drawings option if you want to apply the operation on
all the drawings in the layer.
5. Click on the OK button.
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Remove Art Outside Selection

The Remove Art Outside Selection option is used to delete any art existing outside a
selection.
Also clean your Colour Art level. If you have an accumulation of strokes in your Colour
Art, it can result in large output files, especially if you work in high definition resolution.
Simultaneously apply this operation to all of your drawings in the layer by using the
Remover Art Outside Selection On All Drawings command.

To clean dirt with Remove Art Outside Selection:
1. In the Tools toolbar, select the Select tool. The default keyboard shortcut is [Alt]+[V].
2. If you want to apply the action on your entire animation, enable the Permanent
Selection option in the Tool Properties view.
3. In the Camera or Drawing view, draw a selection around the animation. (Make the
area large enough to include the whole animation sequence).
4. In the top menu, select Drawing > Clean up > Remove Art Outside Selection
option to delete artwork outside your selection on one single drawing. The default
keyboard shortcut is [Shift]+[Del].
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To apply the action to all the drawings contained in the layer, in the top menu,
select Drawing > Clean up > Remove Art Outside Selection on All Drawings
option to delete artwork outside your selection on all the drawings. The default
keyboard shortcut is [Ctrl]+[Shift]+[Del] (Windows) or [a]+[Shift]+[Del] (Mac).

Scanning and Timing

Remove Art Inside Selection

The Remove Art Inside Selection option is used to delete any art inside a selection. We
recommend that you clean your Colour Art level as well. If you have a stroke
accumulation in your Colour Art, it can result in large output files, especially if you work
in high definition resolutions.
You can simultaneously apply this operation to all of your drawings in the layer by using
the Remove Art Inside Selection On All Drawings command.
To clean dirt with Remove Art Inside Selection:
1. In the Tools toolbar, select the Select tool. The default keyboard shortcut is [Alt]+[V].
2. If you want to apply the action on your entire animation, in the Tool Properties view,
enable the Permanent Selection option in the Tool Properties view.
3. In the Camera or Drawing view, draw a selection around the animation. (Make sure
the area is large enough to include all the zones to be cleaned up on all drawings).
4. In the top menu, select Drawing > Clean up > Remove Art Inside Selection option
to delete artwork inside your selection on one single drawing. The default keyboard
shortcut is [Del].


To apply the action on all your drawings contained in the layer, in the top menu,
select Drawing > Clean up > Remove Art Inside Selection on All Drawings
option to delete artwork inside your selection on all the drawings.

Remove Hair

The Remove Hair command is used to remove any small strokes created in the Colour
Art from very thick lines or filled zones.
Increasing the Remove Hair level value will select larger strokes for removal from the
drawing. You can also select the Apply to All Drawings option to remove them on all
drawings.
To use the Remove Hair tool:
1. In the Timeline or Xsheet view, select the drawing containing the drawing to clean.
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2. In the top menu, select View > Show > Show Strokes to display the invisible lines.
The default keyboard shortcut is [D].
3. In the top menu, select Drawing > Clean Up > Remove Hair.
The Remove Hair dialog box opens.
4. Move the Hair Selection slider to the right to increase the number and length of
hairs to be selected.
5. Enable the Apply to All Drawings option if you want to apply the operation to all the
drawings in the layer.
6. Click on the OK button.
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Activity 1: Scanning An Animation - Chasse-Galerie
Project

Instructions:
Using the sample drawings provided by the teacher, scan or import, vectorize and clean
them.
1. Create an Animate Pro scene and name it: CG_17_Scanning_StudentName.
2. Scan the drawings provided to you, vectorize them and import them in your scene.
3. If you are not scanning, but are importing and vectorizing digital drawings import
the following files from the Learning Material Package:


Learning_Material_Pack > A17-Scanning > DrawingToVectorize > Dancers

4. Using the skills that you learned in this module, clean up the drawings.
5. Create a template from your scene and store it in your personal library.
6. Export a FLV, SWF or QuickTime movie.
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Activity 2: Scanning an Animation - Short Project

Instructions:
Using the sample drawings provided by the teacher, scan or import, vectorize and clean
them.
1. Create an Animate Pro scene and name it: A17_1702_Scanning_StudentName.
2. Scan the drawings, vectorize them and import them in your scene.
3. If you are not scanning, but importing and vectorizing digital drawing import the
following files from the Learning Material Package:


Learning_Material_Pack > A17-Scanning > DrawingToVectorize > Bat

To use the Optical Registration parameter, you must enter 240 DPI for these
particular images.
4. Using the skills your learned in this module, clean up the drawings.
5. Create a template out of your scene and store it in your personal library.
6. Export a FLV, SWF or QuickTime movie.
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Theory
This topic is divided as follows:
•

Timing, on page 245

•

Understanding the Timeline and Xsheet View, on page 245

•

Frames, on page 248

•

Layers, on page 250

•

Layer Properties, on page 254

•

Xsheet Thumbnails, on page 256

•

Filling Exposure, on page 256

•

Navigating Between Frames and Columns, on page 270

•

Managing Drawings, on page 272

Timing
In this lesson, you will learn how to work on your drawing’s exposure and length.

Understanding the Timeline and Xsheet View
To set your animation timing, you will mostly work with the Timeline and Xsheet views.
This section will help you become familiar with these views, how they work and the
differences between them.

Timeline View

The Timeline view allows you to read your timing from left to right. It represents the
scene’s elements in their simplest form.

In the Timeline view you can see your layers and their names as well as the drawing’s
exposure. The drawing name is displayed when you place your cursor above the
drawing’s exposure.
You can also see the drawing name once you display the Data view.
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The Timeline view has three main sections:
•

Layer Section

•

Timing Section

•

Data View Section

Layer Section

The Layer section is located to the left of the Timeline view. This is where you can add,
delete, rename, reorder and parent layers. Any operation you do that affects the layer
globally is done in this section.

Timing Section

The Timing section is located on the right side of the Timeline view. This is where you
can increase and decrease a drawing’s exposure, duplicate drawings, add blank cells,
etc. Any operation you do that affects a drawing or its timing is done in this section.

Data View Section

The Data View section is part of the Layer section. By default, the Data view is hidden.
You need to press the Show Data View button to display it.
The Data view allows you to create new drawings by typing a new name in the Drawing
Substitution field. You can also swap between existing drawings by sliding your cursor
to the left or right.

Xsheet View
In Animate Pro, you will find the Xsheet View menu button in the top left corner. This
button allows you to access commands related to the Xsheet view.
The Timeline view lets you read your timing vertically, displays the drawing layers as
columns and shows the drawing’s name. You also see the functions and keyframes of the
motion paths. The value of each keyframe is shown in the Xsheet view, these are black
squares in the Timeline view The Xsheet view has more details than the Timeline view,
which is faster and easier to read.
246

Scanning and Timing

Xsheet Main Section

The Xsheet view has three sections. By default, only the main section is visible. It displays
the drawing layers, also known as drawing columns.

Functions Section

The Functions section is used for more advanced techniques. This section displays the
functions (paths) related to the selected layer in the Timeline view.
By default, the Functions section is hidden.
To display the Functions section:


In the Xsheet view, click on the Expand button located on the right side of the main
section. To collapse it you click on the same button. You can also use the Show
Column List button in the Xsheet View toolbar.

NOTE: If you select a drawing column in the main section of the Xsheet view, the
function columns will not be displayed. You must select the layer from the Timeline view.
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Column List Section

The Column List section allows you to show and hide columns from your Xsheet view.
When you hide a layer using your Xsheet view, it is also disabled in the Timeline view.
You can use the Column List to hide individual columns or hide an entire column type
(drawing or function) from your Xsheet view. By default, the Functions section is hidden.
To display the Column List section:
1. In the Xsheet view, click on the Expand button located on the right side of the main
section to show the Functions section. Click on the same button to collapse it. You
can also use the Show Column List


button in the Xsheet View toolbar.

In Animate Pro, you can also go to the Xsheet View menu and select
View > Show Column List.

2. Click on the Expand button on the right side of the Functions section to display the
Column List section.

Frames
One of the first things that you have to learn in Animate Pro is how to add or delete
frames in your scene.
248

Scanning and Timing

Adding Frames
There are several ways to add frames to your scene:
•

Setting the Scene Length

•

Extending the Timeline View

•

Adding Frames Before or After a Selection

Setting the Scene Length
You can set the global scene length from the top menu.
To set the set scene length:
1. Select Scene > Set Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, type how many frames are needed.
3. Click on the OK button.

Extending the Timeline View
You can quickly extend your scene length in the Timeline view.
To extend your scene in the Timeline view:


In the Timeline view, drag the scene length bracket to the right to add more frames
to your scene.

249

Animate Pro 2 - Student Workbook

Adding Frames Before or After a Selection
You can add frames anywhere in the middle of the scene. If you select a frame row in the
Xsheet view, the system will add the new frames before or after the selection, depending
on your choice.
To add frames before or after selection:
1. In the Xsheet view, select a frame row.

2. Select Scene > Frame > Add Frames Before Selection or Add Frames After
Selection. The default keyboard shortcuts are [Ctrl]+[G] and [Ctrl]+[H] (Windows) or
[a]+[G] and [Ctrl]+[H] (Mac OS X).
The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the amount of frames needed in the
scene.
4. Click on the OK button.

Layers
In Animate Pro there are three ways to see your layers:
•

As horizontal layers in the Timeline view

•

As vertical columns in the Xsheet view.

•

You can also see your layers displayed in the Network view as modules.

Whether you work in the Timeline or Xsheet view, they are the same and any
modification you do to one or the other will be applied to both.

Layer Concepts
In order to understand what happens when you duplicate a drawing, extend an
exposure, create cycles or delete a drawing, it is important to know how a layer works.
Each layer is linked to a directory where all of the drawings created in it are saved. This
directory has the same name as the layer. When a value or drawing name is typed in a
layer’s cell, the system looks in the layer’s directory for the corresponding drawing to
display. If there is no corresponding drawing, a new one is created.
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The layer’s cells are not used for storage, but are linked to the drawings contained in the
layer’s directory. If you remove a drawing from the layer exposure, it is not deleted, but
is simply not displayed.

When you create a drawing cycle, all of the repeated drawings are linked to the same
original files. This means that when you modify, repaint or correct a drawing named “1,”
all drawings named “1” are updated simultaneously. In order to modify a drawing
independently from its other exposures, you must duplicate the drawing.

Adding New Drawing Layers
You can add a new layer in the Timeline view in two different ways; using the Layer
toolbar or using the Add Layers dialog box. In Animate Pro, you can use the Timeline
View menu and select Insert > Drawing.
To add a Drawing layer using the Timeline’s Layer toolbar:
1. In the Timeline’s Layer toolbar, click on the Add Layers

button.

The default keyboard shortcut is [Ctrl]+[R] (Windows) or [a]+[R] (Mac OS X).
2. In the drop-down menu, select the Drawing option.
A new layer appears in the Timeline and Xsheet view.
3. You can also click on the Add Drawing Layer button in the Timeline’s Layer toolbar.
The default keyboard shortcut is [Ctrl]+[R] (Windows) or [a]+[R] (Mac OS X).
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Deleting Layers
There are two ways to delete a layer in the Timeline view, using the Delete Layers button
and using the quick access menu.
In Animate Pro, the steps are the same to delete layers from the Network view.
To delete layers in the Timeline view:
1. In the Timeline view, select the layers to be deleted.

2. In the Timeline’s Layer toolbar, click on the Delete Layers

button.

The Confirm Delete dialog box opens.


You can also right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and
select Delete. The default keyboard shortcut is [Delete].

In Animate Pro, the Delete dialog box looks like the following example:




Enable the Delete Elements and Directories option to delete all drawings and
folder linked to this layer.
Enable the Delete Xsheet Columns option if you also want to delete the existing
column in the Xsheet view.

3. To complete the operation:



Click on the OK button to delete the selected layers.
Click on the Cancel button to cancel the operation.

Modifying Layers
Once you added layers to your project, you can modify their properties, name or
ordering.

Ordering Layers
You can change the order of your layers in the Timeline view. When you change the order
of your layers in this view, the order in the Xsheet view is updated.
Reordering Layers in the Timeline View
To reorder layers in the Timeline view:
1. In the Timeline view, select the layers to move.
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2. Drag the selection to the new location and drop it in between the existing layers.




Dropping the selection on an existing layer would create a hierarchy.
Layers located on top of the Timeline view are displayed in front of the other
ones.
Layers located at the bottom are displayed behind.

Show and Hide Layers
As you work in the Drawing or Camera view, some layers may be in the way or are used
as references. You can hide these layers to make your work area easier and less cluttered.
To show or hide individual layers in the Timeline view:
1. In the Timeline’s Layer toolbar, uncheck the layer’s checkbox to disable a particular
layer.
2. Check the layer’s checkbox to enable a particular layer. You can also click on the
Enable/Disable button located in the Timeline View toolbar’s extra buttons.
When you disable a layer in the Timeline view, the corresponding column is hidden
in the Xsheet view.
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Layer Properties

Each layer has its own set of properties that can be modified.
To display the Layer Properties Editor from the Timeline view:


In the Timeline view, double-click on the layer you want to edit the parameters of.
You can also right-click (Windows) or [Ctrl]+click (Mac OS X) and select Editor. The
default keyboard shortcut is [Shift]+[E].

To display the Layer Properties Editor in the Layer Properties view:
1. In the top menu, select Windows > Layer Properties.
2. In the Timeline or Xsheet view, select the layer your want to see the properties of.
To display the Layer Properties Editor in the Network view:


In the Network view, click on the module’s yellow properties button.

Renaming a Layer
You can rename a layer in two different ways; in the Layer Properties editor or directly
on the Timeline’s layer.
To rename a layer in the Timeline view:
1. In the Timeline view, double-click on the name of the layer to rename.
2. In the Name field rename the layer and press [Return] to validate the modifications.
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To rename a layer in the Layer Properties editor:
1. In the Timeline view, double-click on the layer to rename.
The Layer Properties editor opens.
2. In the Name field, rename the layer.

3. Click on the Close button.

Duplicating Layers
Duplicating a layer provides you with an independent copy of the drawings and their
exposure. You can modify anything you want in the duplicated layer without affecting
the original one.
To duplicate a layer:
1. In the Timeline or Xsheet view, click on the layer you want to duplicate.

2. Select Edit > Duplicate.
You can also click on the Duplicate Layer
button situated in the Xsheet View
toolbar and Timeline View toolbar. The default keyboard shortcut is [Ctrl]+[D]
(Windows) or [a]+[D] (Mac OS X).
The new duplicated layer appears.
In Animate Pro, you can duplicate the selected modules the same way.
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Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it is not always easy
to quickly identify a particular column. Displaying the column thumbnails makes this
easier. This option displays a small thumbnail picture of the current frame below the
column header.
To display the thumbnails:


In the Xsheet view, click on the Show Thumbnails

button.

The thumbnails appear.

Filling Exposure
Animate Pro provides different tools to fill-in exposures and values, create cycles and set
increments with.

Typing Exposure
To fill-in your exposure, you can directly type the values in the Xsheet and Timeline view.

Typing a Value in the Timeline View
If you want to type a precise drawing name or value in the Timeline view, you must use
the Data view section of the Timeline.
NOTE: You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).
To type a value in the Timeline view:
1. In the Timeline view, click on the Show Data View

button.

2. In the Drawing Substitution field, type the name of the drawing you want to create.

3. Press [Return] to validate the entry
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Typing a value in the Xsheet View
To enter a value in a column’s cell, double-click in the cell and type in the numbers or
letters.
NOTE: You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).
•

If you press the keyboard shortcut [Return], you move on to the next cell.

•

If you press the keyboard shortcut [ESC], you exit the typing mode to return to
normal mode.

To type values in the Xsheet view:
1. In an Xsheet column, double-click on one cell.

2. Type a value or drawing name in the cell.

3. Press [Return] to move on to the next cell.

4. Press [ESC] to quit the typing mode.

Extending a Single Exposure
The Extend Exposure feature allows you to select an Xsheet’s cell containing a value and
to pull it down to the desired frame.
To extend a cell exposure:
1. In the Xsheet view, select the red arrow
to see the drag down
cursor.

in the cell’s right side. Make sure
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2. Pull down the selected cell to the desired frame.

NOTE: The red selection box must be visible when releasing the mouse button. If it is
not visible, the action is considered cancelled.

Extending an Exposure Sequence
You can extend and create a sequence using almost the same procedure as you would
when you extend a single exposure. The only differences being that the selected cell
must only contain numbers and that you need to press the [Shift] key while pulling down
on the selection.
NOTE: The creation of the sequence only works with numbers in the selected cell, not
letters.
To create a sequence:
1. In the Xsheet view, select a cell containing a number.
2. In the selected cell, click on the red arrow
Make sure to see the drag down
cursor.

on the cell’s right-hand side.

3. Press the [Shift] key and hold it down. Make sure a [+] sign appears.
4. Pull down the selection box to the desired frame.

NOTE: The red selection box must be visible when releasing the mouse button. If it is
not visible, the action is considered as cancelled.
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5. First release the [Shift] key, then release the mouse button.

NOTE: You can also select a cell and select Animation > Cell > Extend Exposure. In the
dialog box, type the frame number you want to extend the cell to. The default keyboard
shortcut is [F5].

Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Xsheet view, you can increase and decrease
its exposure.

Increase Exposure
Increasing the exposure adds one more exposure to a selected cell, repeating this action
adds an extra cell every time. This is a quick way of extending a drawing exposure and
is always set in the Insert mode. Increasing an exposure always pushes the existing
exposure down.
To use Increase Exposure:
1. In the Timeline or Xsheet view, select a cell.

2. In the top menu, select Animation > Cell > Increase Exposure. You can also rightclick (Windows) or [Ctrl] + Click (Mac OS X) on the selected cell and select
Exposure > Increase Exposure. The default keyboard shortcut is [+].



You can click on the Increase Exposure
button available in the Xsheet View
and Timeline View toolbar extra buttons.
Repeat this action to add more cells to your drawing’s exposure.
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Decrease Exposure
Decreasing the exposure removes one exposure from a selected cell, repeating this
action removes an extra cell every time. This is a fast way of reducing a drawing exposure
and removing the exposed drawing.
To use Decrease Exposure:
1. In the Timeline or Xsheet view, select a cell.

2. In the top menu, select Animation > Cell > Decrease Exposure.
You can also right-click (Windows) or [Ctrl] + Click (Mac OS X) on the selected cell
and select Exposure > Decrease Exposure. The default keyboard shortcut is [-].



You can click on the Increase Exposure
button available in the Timeline View
toolbar’s extra buttons.
Repeat this action to add more cell to your drawing’s exposure.

Increase/Decrease Exposure Field
Another technique you can use to quickly increase or decrease the exposure of a
selected drawing is by making use of the Increase/Decrease Exposure field available in
the Xsheet view.
To increase and decrease exposure using the Increase/Decrease Exposure field:
1. In the Xsheet view, select the cell to modify.
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2. In the Xsheet’s bottom right-hand corner, increase or decrease the drawing’s
exposure by clicking on the up or down arrows.

Click on the small
arrows here to increase
or decrease the
drawing’s exposure

Clear Exposure and Pull
You can reduce a drawing’s exposure using the Clear Exposure and Pull option.
To use the Clear Exposure and Pull feature:
1. In the Timeline or Xsheet view, select a cell.

2. In the top menu, select Animation > Cell > Clear Exposure and Pull. You can also
right-click (Windows) or [Ctrl] + Click (Mac OS X) on the selected cell and select
Exposure > Clear Exposure and Pull.



You can click on the Clear Exposure
button available in the Xsheet View and
Timeline View toolbars’ extra buttons.
The default keyboard shortcut is [Z].

Deleting Exposure
You can delete a drawing’s exposure in several simple ways. Note that when you delete
a drawing’s exposure from the Timeline or Xsheet view, you are not deleting the actual
drawing file. You can always bring it back by typing its name again in a cell.
You can delete the exposure contained in a selected cell range or delete the entire
exposure of a drawing exposed over several cells.
To delete selected exposures:
1. In the Timeline or Xsheet view, select the exposure you want to delete.
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2. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Delete.
The default keyboard shortcut is [Delete].
To entirely clear the exposure of a drawing:
1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.
2. In the top menu, select Animation > Cell > Clear Exposure.


In the Timeline view, you can also right-click (Windows) or [Ctrl]+click (Mac OS X)
on the selection and select Exposure > Clear Exposure.



You can click on the Clear Exposure
toolbar’s extra buttons.

button available in the Timeline View

Inserting Blank Cells
Use the Insert Blank Cell option to place an empty cell between other cells. This is always
done in Insert mode and pushes down existing exposure, even if you are set to
Overwrite mode.
To use Insert Blank Cell:
1. In the Xsheet or Timeline view, select the cell where you want to insert a blank cell.

2. In the top menu, select Animation > Cell > Insert Blank Cell.
You can also right-click (Windows) or [Ctrl] + Click (Mac OS X) on the selected cell
and select Exposure > Insert Blank Cell.


The default keyboard shortcut is [X].



You can click on the Insert Blank Cell
and Xsheet toolbars’ extra buttons.

The blank cell is inserted.
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To clear a selected cell range without deleting the exposure:
1. In the Xsheet view, select the frame range to clear.

2. Right-click (Windows) or [Ctrl] + Click (Mac OS X) on the selected cells and select
Clear.

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the
Set Exposure options.
To use the Set Exposure options:
1. In the Timeline or Xsheet view, select the cell range that you want to set the
exposure for.
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2. In the top menu, select one of the following:





Animation > Cell > Set Exposure> Set Exposure to 1
Animation > Cell > Set Exposure> Set Exposure to 2
Animation > Cell > Set Exposure> Set Exposure to 3
Animation > Cell > Set Exposure

3. You can also click on the Set Exposure
View toolbar’s extra buttons.

buttons located in the Timeline

4. If you choose the Set Exposure option, the Set Exposure dialog box opens.

5. Type the number of frames that you want the drawings to be displayed for.
6. Click on the OK button
The new timing is displayed in the Xsheet view.
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Filling a Selection with a Sequence
The Sequence Fill option is used to create a number sequence over a selection. The
number sequence can be upward, downward, single, double or higher increment, as a
cycle, etc. The selection can be over one cell, cell range in one column, cell range over
many columns, an entire column or several entire columns.
To use Sequence Fill:
1. In the Xsheet, select a cell range.

2. Select Animation >Cell > Sequence Fill.
The default keyboard shortcut is [Ctrl]+[M] (Windows) or [a]+[M] (Mac OS X).


You can also click on the Sequence Fill
button available in the Xsheet View
and Timeline View toolbars’ extra buttons.

The Sequence Fill dialog box opens.

3. In the Starting Value field, type the starting number for the number sequence.
4. In the Increment field, choose an increment from the name changing range (1-2-3-4,
1-3-5-7, 10-9-8-7-6-5-4-3-2-1). The value can be positive or negative.
5. In the Hold field, choose an exposure holding value.
6. Enable the Cycle option if you want a cycle; type the number of cells required for
the cycle’s duration.

NOTE: If you choose a two-cell hold, a cycle of three drawings will last six cells
7. If you selected a larger range than the number of frames needed, enable the End
Frame and type the last frame needed.
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8. If you want to have more than one digit in your numbers such as “001” instead of
“1”, enable the Padding option and add as many pound signs “#” as digits needed.
Also, you can type a letter or word in the field for it to be added in front of the
drawing number.

9. Click on the OK button.

Creating Cycles
After entering a series of drawings and exposures, there are several ways that you can
create cycles out of them.
You can loop your drawings using the following commands:
•

Paste Cycle

•

Paste Reverse

•

Create Cycle

When you create a drawing cycle, all of the repeated drawings are linked to the same
original files. This means that when you modify, repaint or correct a drawing named “1,”
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all drawings named “1” are updated simultaneously. In order to modify a drawing
independently from its other exposures, you must duplicate the drawing.

To use the Paste Cycle command:
1. In the Xsheet or Timeline view, select the cell range to loop.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Cycle. The default keyboard shortcut is
[Ctrl]+[/] (Windows) or [a]+[/] (Mac OS X).
The Paste Cycle dialog box opens.

5. In the Number of Cycles field, use the up and down arrow to increase or decrease
the number of cycles you want to paste. You can also directly type the value.
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6. In the Cycle Type drop-down menu, select the type of cycle you want to paste.






Normal (forward): This pastes your selection as it is, starting with the first cell and
ending with the last one.
Reverse: This pastes your selection reversed, starting with the last cell and
ending with the first one.
Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first
cell, going to the last one and ending with the first cell.
Reverse -> Forward: This pastes your selection as a reversed yo-yo, starting with
the last cell, going to the first one and ending with the last cell.

7. Click on the OK button to paste your cycles.
NOTE: You can do the same operation using the Paste Special dialog box. To open the
Paste Special dialog box, select Edit > Paste Special.

To use the Paste Reverse command:
1. In the Xsheet or Timeline view, select the cell range to paste inverted.

2. In the top menu, select Edit > Copy.
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3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Reverse. The default keyboard shortcut is
[Ctrl]+[?] (Windows) or [..]+[?] (Mac OS X).

To use the Create Cycle command:
1. In the Timeline view, select the cell range to loop.

2. In the Timeline View toolbar, click on the Create Cycle
toolbar’s extra buttons.

button located in the

3. The Create Cycle dialog box opens.

4. Enter the number of cycles you want, including the current selection.
5. Click on the OK button.
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Navigating Between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the
layers, frames and drawings using keyboard shortcuts that are effective in the Camera,
Drawing, Timeline and Xsheet view.
You can navigate through:
•

Columns

•

Drawings

•

Frames

To navigate through the drawings, frames and columns:
1. In the Timeline or Xsheet view, select a cell.
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2. Once the cell is selected, you can navigate between:


Previous and next layers using the keyboard shortcut [H] and [J] or from the top
menu, you can select Edit > Previous Layer and Next Layer.
H



J

Previous and next drawings using the keyboard shortcut [F] and [G] or from the
top menu, select Edit > Previous Drawing and Next Drawing or Drawing >
Previous Drawing and Next Drawing.
F
G



Previous and next frames using the keyboard shortcut [,] and [.] or from the top
menu, select Play > Previous Frame and Next Frame.
[,]
[.]
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Managing Drawings
Drawings that are created in Animate Pro are not encapsulated in their cells. They are
actual files stored in the project’s folder. If you want to rename a drawing or delete a
drawing from your project, you need to edit the file and not the cells.

Renaming a Drawing
To rename a drawing, you do not type the new name in the cell. You need to select the
cell containing the drawing and use the Rename Drawing command.
To rename a drawing:
1. In the Timeline or Xsheet view, select the drawing to rename.

2. In the top menu, select Drawing > Rename Drawing. The default keyboard
shortcut is [Ctrl]+[Alt]+[D] (Windows) or [a]+[Alt]+[D] (Mac OS X).
You can also use the Rename Drawing
Xsheet View toolbars’ extra buttons.

button located in the Timeline View or

The Rename Drawing dialog box opens.

3. In the New Name field, type the new drawing name.
4. Click on the OK button.

Deleting a Drawing
To permanently delete a drawing file, select the drawing you want to delete and use the
Delete Selected Drawings command. This operation cannot be undone.
To delete a drawing:
1. In the Timeline or Xsheet view, select the drawings to delete.

2. In the top menu, select Drawing > Delete Selected Drawings. The drawing is
deleted.
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Duplicating a Drawing
If you want to modify an existing drawing and keep the original drawing intact, you can
duplicate the drawing and work on the copy. When duplicating a drawing, the selected
cell is replaced with the new drawing. The exposure of the original drawing that was on
the current cell is removed. The drawing is not deleted.
To duplicate a drawing:
1. In the Timeline or Xsheet view, select the drawing to duplicate.

2. In the top menu, select Drawing > Duplicate Drawing or use the keyboard shortcut
[Alt]+[Shift]+[D].

With Animate Pro you can create a keyframe at the same time as you duplicate your
drawing. This way you can modify and reposition your drawings without affecting the
original drawing.
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Activity 1: Timing an Animation - Chasse-Galerie
Project

Instructions:
Using the drawings you scanned and cleaned during the “Scanning an Animation Chasse-Galerie Project”, recreate the exposure sheet using the sample provided.
1. Create an Animate Pro scene and name it: CG_18_Timing_StudentName.
2. From the Learning Material Package, open the following files:


Learning_Material_Pack > A18-Timing > ExposureSheet > Dancers_Xsheet

3. Using the skills you learned in this module, set the timing for the scanned drawings.
4. Create a template out of your scene and store it in your personal library.
5. Export a FLV, SWF or QuickTime movie.
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M14: Acting

This module is divided into the following topics:
•

Theory, on page 276

•

Activity 1: Performing Different Takes, on page 279

•

Activity 2: The Flour Bag’s Expressions, on page 280

•

Activity 3: Animating the Flour Bag’s Take Shot, on page 281

•

Activity 4: How should these Characters Act?, on page 286
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Theory
This topic is divided as follows:
•

Acting, on page 276

•

Understanding The Take, on page 277

Acting

Seeing your characters jump and walk is one thing. Seeing them think is something even
more magical. In this lesson, we’ll take a break from the physics of motion for a short
while to focus more on the acting required to make animated characters appear to think.
To be able to animate a character you must get under the character’s skin and begin
understanding the importance of acting in the process. Because an animation is not
alive, acting becomes even more important to breathe life into characters. With acting,
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you will be able to give your character a chance to experience a variety of emotions: they
could laugh, cry, scream, be happy or be shocked.

There are also many movements or actions that a character might do while acting out an
emotion. For example, while being angry, they might shake their fist, or if they are
uncomfortable, they might play with a strand of hair, twisting it around their finger. But
it’s not always easy to think about all these little elements, unless you take the time to
act them out.

Understanding The Take
The “Take” will be one of those actions that you will have your characters act out
frequently. It is the shot in a scene where your character suddenly realizes that what they
are seeing is somehow shocking or surprising.
The take is usually done in two steps: The Anticipation, and the Reaction.

Anticipation

The take needs an anticipating action, in the same way that a jump does. The viewer
must understand what is going to happen. At the same time, the anticipation is also the
moment where the character seems to take in the information of what is actually going
on, before reacting to it. The anticipation will often look like the character is squashing.

277

Animate Pro 2 - Student Workbook

Reaction

The reaction is the moment when the character really looks shocked or surprised.
Remember, that this phase can be acted in a variety of ways. A character might be
shocked, but doesn’t want the others to see it, so it can be very subtle. Or the reaction
might be grand and everyone hears and sees it! While the anticipation is more of a
squash, the reaction is really where the character will stretch.
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Activity 1: Performing Different Takes

In this activity, you will need to act different takes. With a group of classmates, each will
have at least three different takes to act. Here is a list for you to follow:
•

Start with a regular take. Just being shocked.

•

Do a subtle take.

•

Do a very flamboyant take.

•

How would a princess do a take?

•

How would an angry king do a take?

•

How would a superhero do a take?

•

How would a fish do a take?

•

How about a dinosaur?

•

Or an alien?

Once you have acted your takes, pick your favourite, and take the time to sketch it on a
sheet of paper. Do both the anticipation and the reaction steps. Are you able to use what
you’ve acted to put it on paper? Would you be able to use all these new sketches for an
animation?
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Activity 2: The Flour Bag’s Expressions

This activity will really help you push your acting skills to a new level. You will be drawing
expression for a flour bag. But here is the catch, the flour bag cannot have a face. The
only way to have it express something will be with its body and the poses he will take.
You will need to do at least 15 expressions, 10 of which are given. The other 5 are up to
you. Make sure you write the name of the expression under the pose.
The 10 expressions are:
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•

Happy

•

Sad

•

The Take

•

Heroic

•

Depressed

•

Angry

•

Scared

•

Curious

•

Doubtful

•

Shy

Acting

Activity 3: Animating the Flour Bag’s Take Shot

In this activity, we will move the acting of the take to a new level. You will use the Flour
Bag character again for this exercise. To goal is to animate a small scene where the Flour
Bag sees something, does a take than reacts to what is happening. You can keep it very
simple! The goal is really to have the flour bag look alive.
1. You will first need to storyboard your idea. Take the time to detail the actions that
the Flour Bag will do and to plan the timing of your animation. Make sure that it
doesn’t take more than 10 seconds for the whole scene.
2. Once everything is planned, you are ready to start your scene in Animate Pro. Start
the software by double-clicking the icon.
3. In the Welcome Screen, name your project Flour_Bag followed by your initials.
4. Start your work by creating all the drawing levels that you will need for your scene.
You should have a least a level for the background, the flour bag and a foreground.
If you have another character or an accessory, you should create a new drawing level
for these too. To do so, go in the Timeline and click the Add Element
then select Drawing in the drop-down menu.

button,

5. With the Brush
Tool, draw your background and foreground first. This is where
your animation takes place. You will need to know where your character will move
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before you can actually animate it. In our example, the action will take place in the
kitchen.

6. Extend your background and foreground frames for all 10 seconds of your
animation. To do so, right click the frame then select Extend Exposure.
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7. Now that your scene is set up, you can animate your Flour Bag. Start with the key
poses of your action and check to see if the timing of your animation is correct.
Keep it rough. Your goal is to learn acting.

8. Activate the Show Onion Skin
option. This will allow you to see the previous
and next frames of your animation so that you can draw the inbetweens.
In the Timeline, you can move the blue handles on each side to include the frames
you need in the onion skinning option.
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9. If you have a second character or another object that moves in your scene, animate
it also. Again keep it rough and alive. Don’t try to clean everything that you draw
right away.
10.When everything is animated, you are ready to clean-up the frames. In the Timeline,
click the Add Element
button, then select Drawing in the drop-down menu to
create new drawing layers that will be for the clean-up. Create as many as you need.
You should also take the time to rename them.

11.Start cleaning up your animation drawings using the Brush
Paint Bucket

Tool. Then use the

Tool to colour your frames.

12.Make sure to save your work as you progress by clicking the Save
button.The
Save As window will appear. Name your project Walk_cycle along with your initials.
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13.Play back the animation of the walk cycle with the Play

button and test/correct

your work. You can also activate the Loop
button, to view your animation in
loops while noting the corrections you will have to do.
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Activity 4: How should these Characters Act?
Here is a list of characters along with their special attributes. The goal is to pick at least
one and act it out in front of your class or a group of classmates. It’s important to take
all of the attributes into account as it will give your character personality. Do at least one
character. For more practice though, you should try all of the characters listed. If you
have props in class to help you act the character, integrate them into the activity.
Here are some settings, situations or actions to try out:
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•

Act out a take

•

Act out your character walking casually, then seeing something that scares him
away

•

Act out your character being skeptical about an object

•

Act out a scene where your character start angry, then because of an event,
becomes suddenly sweet and understanding

•

Act out a scene where your character is crying, then sees something that will
comfort them
•

Motherly

•

Polite

•

Calm and composed

•

Will always think before acting

•

Protective

•

Is always very excited

•

Loves adventure games, always seems
to be in his own world

•

High spirited

•

Always happy and smiling

•

Clumsy

Acting

•

Always depressed and gloomy

•

Lazy

•

Slow to react

•

Hands and feet seem to be able to stretch
forever

•

Can easily be fooled

•

Neurotic

•

Almost blind

•

Means well but never gets it right

•

Hard-working

•

Shy
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M15: Visual Breakdown and Lip-sync

This module is divided into the following topics:
•

Theory, on page 290

•

Activity 1: Creating a Mouth Chart, on page 295

•

Activity 2: Breakdown and Lip-sync, on page 299

•

Activity 3: Animating a Dialogue, on page 304
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Theory
This topic is divided as follows:
•

Visual Breakdown, on page 290

•

Phrasing and Lip-synching, on page 292

Visual Breakdown

When adding dialogue to a scene, there is a lot of preparation and analysing involved.
First, it’s important to know that the dialogue should be recorded before starting any
animation. You need the sound file so that you can breakdown the dialogue into syllables
and after that turn those syllables into mouth shapes that will be draw on each frame.
This must be included in the Xsheet before starting your drawings.
Once the actual dialogue is broken down, than you have to analyse it on a second level:
what do you want to convey with it? You need to understand what your character is
saying and how exactly you want the character to say it when they become animated.
The last thing you want to do is have them stand and do nothing while they talk.
Here are some things to look out for:
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•

What is the timing of the dialogue? Quick, choppy speech, or slow and sloppy?

•

How is the mood of the character going to be reflected in the dialogue?

•

Where will the rest of the body be?

•

How will the body anticipate the dialogue?

•

What is the character doing and why?

•

Get into your character.

Visual Breakdown and Lip-sync

Then...

Were dancing...

Me.

Little green men...

Around.

Singing!
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Phrasing and Lip-synching

With Animate Pro, you can automatically generate a lip chart based on the phonemes in
a character’s dialogue track.
However, there is more to animating dialogue than just drawing the right lip positions.
The lip chart is an important and useful reference, but it does not dictate absolutely how
you will animate dialogue.
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•

People don’t enunciate every syllable. They “smudge” phrases.

•

It’s not necessary to animate every single letter. It’s more important to look at the
entire word and consider how it is emphasized in the dialogue—try to feel the
word.

•

Every person has a unique way of talking. What is the nature of your character’s
speech? (Does your character show it’s top teeth, bottom teeth or both when
talking? Do the lips curl?)

•

Design interesting mouth shapes that reflect the qualities of your character.

•

Teeth: the top or bottom teeth are usually visible. Since they are solid, they
should not change as the character speaks (there’s no squash and stretch on
teeth). Well, unless you want. They are cartoons after all!

•

Acting again: what is the mood of the character or the scene and how does this
influence the dialogue?

Visual Breakdown and Lip-sync

One of the very useful tools of the animators when animating dialogue is the mouth
chart. This breaks down the mouth movements to at least 8 different mouths. But you
can do even more if you feel you will need a wider range of references for your film.

Here is an approximation of which sound each mouth shape can produce:
•

Mouth Shape A: b,m, p

•

Mouth Shape B: d, h, i, j, k, s, t

•

Mouth Shape C: a, e

•

Mouth Shape D: A, E

•

Mouth Shape E: o

•

Mouth Shape F: oo, u

•

Mouth Shape G: f, ph

•

Mouth Shape X: Silence, undetermined sound

The mouth charts are usually standardised in studios so that a mouth shape is always
called the same letter. This makes it easier for animators when they check the Xsheet
breakdown of the dialogue.
You can easily map the mouth chart in Animate Pro. Once you have imported the sound
file in your scene, right-click on the sound layer, on the right side of the Timeline, then
select Lip-Sync > Map Lip-Sync.
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By default, the mouth image and the mapped chart
letter are the same, but if you have a different
setting on your mouth chart model sheet, you can
map them accordingly in Animate Pro.

When it comes to animating, you have to be careful not to overdo it. It’s easy to start
doing a different mouth for each letter the character is pronouncing, but this is a
mistake. Try it out yourself.If you can film yourself and analyse it afterwords even better.
Say a simple sentence as naturally as possible. You will notice that you do not emphasize
every letter or even every syllable in that sentence. What happens if you do? It sounds a
little bit silly doesn’t it? And it’s slower too.
If you want your character to sound natural, you have to animate its mouth the same way
you would do it: only emphasizing where it is needed in the dialogue. So a sentence like
“Good Morning!” should look something like this:

Instead of this, which is a little too much:
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Activity 1: Creating a Mouth Chart
For the two following activities, you will make a small animation with a character talking.
Start planning right away. You will need a small scene with a short dialogue. It shouldn’t
be more than 6 seconds in length. A simple sentence will do.
This also means you will require a character design and a mouth chart for this character.
1. You will be creating the mouth chart in Animate Pro. Start the software by doubleclicking the icon.
2. In the Welcome Screen, name your project Mouth_Chart followed by your initials.
3. Start your work by creating a drawing level for your sketches. To do so, go in the
Timeline and click the Add Element
button, then select Drawing in the dropdown menu. You can call the layer Mouth_Chart.

4. With the Brush

Tool, draw the 3/4 head of your character, without the mouth.
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5. With the Select Tool, select the head your just sketched. Then click the Copy
Button.

6. You can now click the Paste
Button. This will create a new head sketch. Drag it
to the appropriate position on the model sheet. You will do this at least six more
times for an eight-head mouth chart. You can do more if you think you will need
more mouth references.
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7. With the Brush

Tool again, you can now sketch the mouths for each headshot.

8. Once all your mouths are done, you are ready to cleanup. Create a new Drawing
layer with the Add Element
button, then select Drawing in the drop-down
menu. You can call the layer Mouth_Chart_Cleanup.

9. With the Brush

Tool, clean up one of the heads without the mouth again.
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10.As in Step 5 and Step 6, select the cleaned up head, and copy

and paste

it multiple times. Then, place them on your model sheet using the Select

Tool.

11.With the Brush Tool, you can now finish cleaning up all the mouths. Then with the
Paint Bucket

Tool, you can colour your mouth chart.

12.Make sure to save the progress of your work by clicking the Save
button.The
Save As window will appear. Name your project Mouth_Chart along with your
initials.
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Activity 2: Breakdown and Lip-sync

1. Write down one or two lines that your character will say and then record them. You
can use a basic microphone and a sound recording program, which you will find on
most multimedia computers.
2. Listen to your sentence and plan the breakdown. What are the important parts of
the sentence? How will your character act while he is saying these things?
3. Once your planning is done, you are ready to start animating. Start the software by
double-clicking the icon.
4. In the Welcome Screen, name your project Monologue followed by your initials.
5. Start your work by creating 3 drawing levels for your project. To do so, go in the
Timeline and click the Add Element
button, then select Drawing in the dropdown menu. You can call one layer Character, the second Voice_Breakdown and the
third should be Background.
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6. With the Brush

Tool, sketch your background.

7. You can now import the recording of your voice. To do so, go to File > Import >
Sound, in the Animate Pro top Menu. The Select Sound File window will appear.
Select the file then click on Open.
8. A new Sound layer will be added to the Timeline. If you go to the Layer Properties
Tab. You will be able to have all the tools you need to do your lip-synching.

All the tools you will need to modify or update your
lip-synching can be found in this window.

9. Start by clicking the Detect Button. Animate Pro will start decoding the sound file
and apply the appropriate mouth to each frame.
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10.Next, click on the Map Button. This will open the Lip-Sync Mapping window. In this
window, change the Destination Layer for the Voice_Breakdown layer, then click on
OK.

Your Timeline will be updated with the updated lip-synching information in the
Voice_Breakdown layer.

If you go to the Xsheet, you will see that the Voice_Breakdown layer is updated with
the mouth codes. This is a great reference to use when comes the time to animate
the mouth. You can reference back to your mouth chart model sheet with a quick
glance.

11. Of course, the automatic decoding might not be exactly what you wanted, so you
can modify the information by using the Layer Properties tab and the Timeline. In
the Timeline, you can simply scroll through the scene, then when you are a frame
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where you want to change the mouth coding, simply stop and go to the Layer
Properties tab and click on a new mouth image.

Apply all the changes you need, and once you are done, make sure you update the
mapping on the Voice_Breakdown layer by clicking the Map Button again.
12.Once the mapping and decoding is done, you can start your animation! Start
sketching the key poses with the Brush
Tool. Keep this animation in the rough
stage. The goal is to animate the mouth and also add a bit of acting to make the
character alive.
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13. When the key poses are done, you can go one to the inbetweens. Remember to go
look at the Voice_Breakdown layer to see what mouth you should be drawing to
your character on each frame.

14.Make sure to save the progress of your work by clicking the Save
button.The
Save As window will appear. Name your project Walk_cycle along with your initials.
15.Play back the animation of the monologue with the Play

button and test/

correct your work. You can also activate the Loop
button, to view your
animation in loops while noting the corrections you will have to do.
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Activity 3: Animating a Dialogue

For this activity, you will spice things up. You will be animating a dialogue. You will need
two characters. Two mouth charts and a recording of two characters talking to each
other.
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•

If you are not too sure of the steps, go back to Activity 2: Breakdown and Lipsync, on page 299 to help you through it.

•

Keep the dialogue very simple. The full scene shouldn’t be more than 10
seconds long.

•

Remember that the characters are not only talking, they are interacting. Both
should be animated so that we feel they are talking to the character in front of
them.

•

Do not try to clean up or colour the scene. Focus on animating the dialogue and
keep it at a rough stage.

•

Go back to your mouth chart to make sure it is consistent throughout your
scene.

•

Even when doing dialogue, you should start with key poses, then do inbetweens.
You can even animate body movement first, then do the mouths. Do one step at
a time.

M16: Morphing

In this lesson, you will learn how to create computer generated in-betweens for your
simple hand-drawn animation.
This module is divided into the following topics:
•

Theory, on page 306

•

Activity 1: Morphing a Flag, on page 319
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Theory
This topic is divided as follows:
•

Morphing, on page 306

•

Understanding Morphing, on page 306

•

Morphing Rules, on page 308

•

Morphing Tool and Hints, on page 311

•

Tips and Tricks, on page 318

Morphing
Hand-drawn animation requires a lot of time tracing in-between drawings. Animate Pro
speeds up the process using its helpful Morphing feature. This powerful and useful
feature creates computer generated drawings and places them between vector
drawings to save time and increase quality. Animation created with the Morphing
feature can be reused in different projects. You can easily modify the timing and velocity
(ease in and ease out).
One of the main uses of the Morphing feature is for effect animation. For example,
animating smoke or water can be time-consuming because these types of effects are
usually slow moving requiring a large number of closely placed in-betweens.

Understanding Morphing
The Morphing feature is used to animate similar simple shapes such as hair or smoke. It
helps you by saving time when you are working on tedious in-betweening and tracing
tasks. This, in turn, provides you with more time to spend on complex animation tasks
such as walk-cycles or acrobatic sequences.

Ideas Behind Morphing
When learning how to morph drawings, it is better to start with basic shapes such as
circles and rectangles. Once you are more familiar with the tool, you can experiment to
increase your knowledge and expertise. In a very short time you will be producing some
remarkable effects.
It is helpful to know the pros and cons of morphing before you start. Understanding what
you can do and which drawing lines can give you a problem will enable you to design
your key drawings so they morph efficiently. The more complex the shape is, the longer
it takes to morph.
If it takes more time to morph a drawing than to hand draw it, then it is better to
animate it instead of morphing.
However, if you spot an occasion when you can morph your drawings, do it. It allows you
to fix your timing and velocity in no time without having to create any extra drawings.
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Locating Problem Zones
Sometimes simple details that look easy to morph can be more difficult than they initially
appear. For example, when you rotate a head, the nose can often be a problem. The
drawings need to be similar in their number of shapes. When you rotate a head, the
source nose is positioned in the centre of the face but in the destination, the nose line
becomes part of the face outline. This means that in the source drawing, the nose and
the face outline are two separate shapes, but they form one shape in the destination
drawing.
Morphing a full face, as shown in the figure below, causes the source nose to slowly
vanish as the destination nose grows from the character’s cheek.

Any shape that is contained inside another one and has to morph out of that shape will
be a problem for the same reasons as the nose is. At some point during the morphing
sequence, the shape contained inside the face will merge with the face outline, then
become a separate shape again.
Take a look at this example and try to determine why the owl’s claws are a problem.

1

2

1

2

On the first drawing, there is one claw outside of the body; in the second drawing, that
same claw is inside of the body. Also, in the first drawing, the two claws are touching but
not in the second one. Splitting shapes are not so simple to handle. When dealing with
drawings like that, it is better to separate them in two drawing layers and create two
independent morphing sequences.
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Source and Destination Drawings

Source Drawing

Destination Drawing

The Morphing feature matches similar shapes in two drawings. These are the source and
destination drawings. Animate Pro evaluates the source’s shape properties and matches
them to the most similar one in the destination drawing.
Morphing works between similar shapes, which are drawings that have the same palette,
colours and number of shapes. A rabbit can change into an elephant, as long as the
source and destination keep the same colours and number of shapes.

Morphing Rules
Animate Pro follows a set of rules as it evaluates the shapes. Familiarize yourself with
these basic morphing rules before you start morphing.

Closest Similar Shape
A colour, line shape or zone will morph with the closest similar one in the destination
drawing. This means it will morph with the zone nearest to it, as long as that zone uses
the same palette’s colour swatch (Colour ID) and has the same vector properties (Central
or Contour).
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Pencil Line to Pencil Line
If you trace a shape using a pencil line such as the Ellipse

, Rectangle

, Polyline

,

Line
or Pencil
tool, you have to morph it with another pencil line. Make sure that
both drawings are pencil shapes (central vector).

A pencil line will never morph with a brush stroke.
If you have pencil lines in your source drawing, the same number of pencil lines must
be present in the destination drawings. A pencil line will appear if it is not found in the
destination drawing. It will pop out on the last frame.
1
2

If two pencil lines cross one another, they are considered to be four
lines and not two lines anymore. In this case, you must have four
pencil lines in your destination drawing for your morphing to work
correctly.

4
3

Fill Shape to Fill Shape
If you have a Brush line or a Colour fill zone which are contour vectors, make sure that
you morph it with another Fill or Brush line. Contour vectors will not morph with pencil
lines (central vectors). A Brush line can morph into a colour fill zone and vice versa.
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Colour Swatch to Same Colour Swatch
Animate Pro does not morph colours. If you want to perform a colour transition, you
have to create the effect at the compositing level. A colour palette is composed of
colour swatches. Each colour swatch has its own unique identification number, even if
two colours pots are the same shade of red, they are identified independently. A colour
zone or shape will morph with another one painted with the same colour swatch.

Vanishing and Appearing
If a colour zone does not find a match in the first or the second drawing, it will
progressively appear or disappear.

Colour Art to Colour Art and Line Art to Line Art
In Animate Pro, there is an advanced concept for painting your drawings called Line Art
and Colour Art. Basically, an extra layer is added in your drawings so that you can fill the
colour zones on a separate layer. The regular layer on which you are drawing is called
Line Art and the extra layer under the Line Art is the Colour Art.

310

•

A shape drawn in Colour Art can only be morphed with another shape existing in
the Colour Art.

•

A shape drawn in Line Art can only be morphed with another shape existing in
the Line Art.

•

A shape created in Colour Art can never morph with a shape created in Line Art.

Morphing

Morphing Tool and Hints

Animate Pro provides the Morphing
tool to control your morphing sequence, this
works by placing different types of hints to help the system morph the animation the way
that you want it.
Hints are points which are placed in both the source and destination drawings, they
associate zones and lines between the two drawings. Hints are used to fix problem
zones, such as a line that is not following the colour fill zone.

Corners and points generally give the most problems. The software does not necessarily
understand the animation curves and may be unable to match corners. It will generally
associate a corner with the nearest one, this is not always correct and it is why we use
hint points to determine what goes with what.
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Using the Morphing Tool
Hints are identification points existing in both the source and destination drawings to
create associations between the two of them.
To correct morphing distortions, Animate Pro has different types of hints available for
controlling different types of problems:
•

Contour Hint

•

Zone Hint

•

Pencil Hint

•

Appearing Point Hint

•

Vanishing Point Hint

Each type of hint has a different purpose and they can all be used in the same drawing.
Use the Morphing tool to add hints to your morphing sequences. You can add different
hints to your source and destination drawings and combine all types of hints in the same
drawing.
A hint will automatically appear in both the source and destination drawings when it is
added. A hint cannot exist in a single drawing. If you delete a hint from one drawing, it
will be also deleted from the other.
The key to placing your hints is to put them where the biggest problem is. Fix the largest
distortions first, this may also fix the smaller ones at the same time.
Small bumps and
distortions are fixed at the
same time that zones 1 and

1
2
Do not add too many hints, this is a common mistake when morphing, it takes some
practice to learn how to correctly use and place hints.
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To add and remove hints:
1. In the Timeline or Xsheet View, select the source or destination drawing of your
morphing sequence.

2. In the Tools toolbar, select the Morphing
[F3].

tool. The default keyboard shortcut is

Use your other morphing key drawing, shown in the Drawing view’s bottom right
corner, as a reference.

3. In the Tool Properties view, select the type of hint you want to use.







Select Contour Hint to correct a brush line or colour zone’s contour (Contour
vector).
Select Pencil Hint to correct a pencil line (Central vector).
Select Zone Hint to correct a colour zone morphing match.
Select Vanishing Point Hint to correct a vanishing shape’s trajectory.
Select Appearing Point Hint to correct an appearing shape’s trajectory.
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4. In the Camera or Drawing View, click on the drawing near the area to add a hint.

5. Select the hint’s point and move it to its correct position.

6. Select one or many hints and press [Delete] to remove extra or unused hints.


To delete all of the hint points at once, use the default keyboard shortcut
[Shift]+[Delete].

7. In the Playback toolbar, press the Play
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button to see the result.
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Contour Hint

The Contour Hint is used on the colour fill zone and brush lines; in other words, on
Contour vectors. It allows the control of line thickness and contour position. Also, if a
contour is not animated the way that it should be you can use hints to correct the
animation. For example, if a flag is not waving properly.
When adding a Contour Hint, make sure that you place it far enough away from the
contour so that you can see it snap to the contour.
NOTE: Do not place the Contour Hint directly on the line as it may look like it has
snapped to the contour, when it has not and the morphing will remain unchanged.
The Contour Hint points are yellow.
To correct a brush stroke, place a hint on both sides of the line to indicate its
thickness variations over time.

Zone Hint

The Zone Hint is used on a colour zone to control the proximity rule. The Zone Hint is
placed in the centre of the colour zone. Sometimes a colour zone is not associated with
the corresponding one by default. For example, in a splash animation there are many
water droplets that are the same colour. The system automatically morphs the droplet
to the nearest one. This is not always correct. A Zone Hint will force a colour zone to
morph with another one.
Zone Hint points are cyan in colour so you can easily see them.
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Pencil Hint

A Pencil Hint is used to control a pencil line, also known as central vector. It can be used
on drawings that were done using the Pencil, Polyline, Ellipse, Line and Rectangle tools.
Like the Contour Hint, the Pencil Hint snaps to the central vector. Make sure to place it
far enough away from the line so you will see it snap when you move it.
Pencil Hint points are magenta in colour so you can easily see them.

Vanishing Point Hint

A Vanishing Point Hint is used to control the trajectory of a vanishing shape. A shape will
vanish from the source drawing when there is no corresponding shape in the destination
drawing. If you do not place a Vanishing Hint to control the point of disappearance, the
shape will vanish into its centre.
Vanishing Hint points are green in colour so you can easily see them.
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Appearing Point Hint

An Appearing Point Hint is used to control the trajectory of an appearing shape. A shape
will appear in the destination drawing when there is no corresponding shape in the
source drawing. If you do not place an Appearing Hint to control the point of
appearance, the shape will appear from its centre and expand outwards.
Appearing Hint points are violet in colour so you can easily see them.
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Tips and Tricks
This section provides a list of easy tips and tricks to help you morph your drawings more
efficiently.

Morphing Similar Shapes
Similar shapes have the same number of colour zones. This only applies to the number
of zones and lines and not the number of points on a curve.

Avoiding Crossing Zones During Morphing
If a zone inside a larger zone on the source drawing ends up outside on the destination
drawing, the morphing will fail.
A line cannot cross another line during a morphing sequence.
For example, if you are morphing a face so it turns from the front to the side, the nose
is located in the middle of the face on the source drawing. However, after morphing, if
the nose ends up outside or merged with the face profile line on the destination
drawing, this will give undesirable results.

Using the Brush Tool as a Beginner
When learning morphing use the brush tool. You can use the Pencil line for simple closed
shapes.

Using the Contour Hint on Pencil Lines
If you are using pencil lines, use Contour Hints instead of Pencil Hints. Use Pencil Hint if
you want the Pencil line to switch direction.

Flattening Drawings
Flatten your drawing before starting a morphing sequence.

Cleaning-up your Drawings
Drawings must be cleaned completely, if you leave even a small dot your morphing may
malfunction and create odd shapes. If the source line is closer to the dot than the
destination line, the source line will morph into the dot and the destination line will
disappear.

Using the Same Colour Swatch
Use the same colour swatch between two drawings. You cannot morph between two
different colour swatches even if they have the same RGB values. This can be turned to
your advantage for complex morphing.
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Activity 1: Morphing a Flag

For this activity, you will be introduced to the morphing tools while animating a waving
flag!

Preparing Your Morphing Keys

1.

2.

3.

The Morphing feature can be used to create computer generated drawings between
simple shapes. Your drawings can have outlines or not. It is up to you!
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Your key drawings have to follow these basic rules:
•

Drawings must be painted with the same colour swatches.

•

Drawings must have the same number of zones.

•

If a colour zone does not exist in one of the two key drawings, it will
progressively appear or vanish.

•

Drawings must be flattened.

•

A contour line (fill) must be morphed with a contour line, and a centre line
(pencil) must be morphed with a pencil line.

•

You can have several colours in a morphing key.

•

You cannot morph colour tints.

To create your first morphing sequence, try using simple shapes without an outline.
Once you master the feature, you can experiment as much as you want.
1

2

3

To morph the flag, first draw three keyposes and set their approximate timing. Note,
once your morphing sequence is done you can always increase or decrease your timing.
We added a flagpole layer. You can do the same.
1. In the Timeline view, add a drawing layer and name it “Flag”
2. In the Tools toolbar, select the Brush

tool.

3. In the Colour view, select a solid colour.
4. In the Camera view, draw your first flag.
5. In the Tools toolbar, select the Paint
colour.
6. In the Tools toolbar, select the Select

tool and paint your flag using the same

tool.

7. In the Camera view, select your entire flag.
8. In the Tools Properties view, click on the Flatten
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9. Repeat the same steps for the two other flag drawings. Create your drawings on
frames 10 and 20.

Once your are done creating your key drawings, you can transform your solid colour into
a gradient to make the flag even more interesting. You can then add several gradient
arrows to simulate highlights and shadows.
From the Tools toolbar, use the Edit Gradient/Texture
gradient zones the way you want.

tool to reposition your

10.Copy your first key drawing and paste it at frame 30.

Creating the Morphing Sequences

You are now ready to create your first morphing sequence!
1. In the Timeline view, select your first key drawing.
2. Right-click (Windows) or [Ctrl] + click (Mac OS) and 2. select Morphing > Create
Morphing.
3. Repeat the process for each key drawing.
You now have three morphing sequence.
4. In the Playback toolbar, press the Play button to see the result.
As you probably noticed, there are in-between drawings, but they are not necessarily
going the way you want. Your flag probably looks like a piece of cardboard bending
instead of smoothly flapping in the wind. Also, it is most likely that you will have strange
corners and points.
All that is because the system is always looking for the closest similar line, corner or curve
to morph the drawing.
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To fix random
results like this one,
you will place
morphing hints
along the flag’s
contours.

To fix a morphing sequence, you need to control its behaviour with Morphing Hint
points. Hint points associate areas from the key drawings together so that the system
knows how to control the drawings.
You can control different aspects of your animation. Here, we will focus on controlling
the contour using Contour Hint points.
When fixing a morphing sequence, you will add points all across the screen. This is done
progressively. To fix the flag, will take you three passes:
•

Blocking the corners

•

Animating the wind waves

•

Fixing the remaining details

When you add points on the corners and tips, you will see that most of the shape
problems are resolved. Fixing one big problem will often fix all the small ones.
1. In the Tools toolbar, select the Morphing

tool.

2. In the Timeline view, select the first key drawing.
3. In the Tool Properties, select the Contour Hint

option.

4. In the Camera view, click in the screen to add a new Contour hint.
5. Select the hint point and drag it toward the flag’s contour until it snaps.
6. Position the hint on a corner to lock it in place.
7. Repeat these steps for all of the corners.
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8. Press [F4] to switch to the other key drawing.

9. Select the existing hint points and snap them to the corresponding corners.

10.In the first and second key drawings, associate the wind waves so that it will slide to
the right instead of up and down.
After fixing the corners and waves, there should only be a few details left to fix.
11.Set your hint points on the other morphing sequence in the same way you did for
the first one.
This hint point associates these
two waves together. It makes
the wave slide from left to right
instead of going up and down
as it was originally doing.

This hint point associates
these two corners
together and locks the
flag’s corner on the spot
instead of having it wrap
around.
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Adjusting the Ease

1

2

3

4

5

6

Once your morphing sequence is completed, you can adjust the ease so that your
animation does not look too mechanical.

1. In the Tools toolbar, select the Morphing

tool.

2. In the Timeline view, select the first key drawing.
3. In the Tool Properties view, set the Ease In and Ease Out values by clicking on the
Increase and Decrease arrows.
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M17: Layout Posing

This chapter is divided as follows:
•

Theory, on page 326

•

Activity 1: Creating Layout and Posing, on page 345

•

Activity 2: The 10 Layer Scene, on page 349
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Theory
This topic is divided as follows:
•

Layout and Posing, on page 326

•

About Layout and Posing, on page 326

•

Importing the References, on page 327

•

Importing the Storyboard, on page 328

Layout and Posing
If you are working on either a traditional or tradigital (digitally hand-drawn animation)
animation project in a team environment, or if you are working with other people, it is
important to communicate information clearly and keep your work well organized.
In this chapter, you will learn how to make a smooth transition from the storyboard to an
animation by making use of a production step known as Layout and Posing.
To find out more about the steps described in this article, please refer to the Animate
Pro User Guide.

About Layout and Posing

The Layout and Posing process comes from traditional animation where it is done on
paper and then passed on to the animator.
The Layout and Posing step translates the storyboard information into a format which
the animators can use.
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Since the storyboard is not always accurate, the Layout Artist will:
•

Reproduce the storyboard scene to the correct scale

•

Draw the animation poses on the model (posing)

•

Plan the camera moves

•

Create the black and white background (background layout)

The background is a section from the location design, also called key background.
Background layout is different from the location design. The Background Artist will draw
the appropriate background for the scene by referring to the storyboard and the
location design.
For tradigital animation projects the Layout and Posing is done in the animation
software, since the main purpose of this technique is to save paper and transfer most of
the work to digital media.
With Animate Pro you create your layouts and posing digitally, there is no need to use
paper or scan elements in. Simply open your Drawing or Camera view and draw your
background and posing, as well as the camera move references.

Importing the References

The first step in drawing the background and posing is to import your references from
digital or paper format.
The main reference for the layout is the storyboard. You can also import an animatic and
a location design, if you have one available.
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Importing the Storyboard

The layout and posing process is based on the storyboard. In order to start layout and
posing, you need to import your storyboard into the scene from digital or paper format.
•

A digital storyboard can be created using Toon Boom Storyboard Pro and
imported to Toon Boom Animate Pro.

•

A paper storyboard can be scanned using third party software and imported into
Toon Boom Animate Pro as a bitmap image.

Exporting Toon Boom Storyboard Pro Files into Animate Pro

Toon Boom Storyboard Pro provides an export bridge to Toon Boom Animate Pro. The
export process creates your scenes for you and inserts the necessary data in it, but what
happens to your camera motion, scene length and drawings?
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How to Export Your Storyboard to Toon Boom
Once your storyboard is completed in Toon Boom Storyboard Pro, you can create your
Animate Pro content using the Export menu. A few options are available to choose from.
When you export from Toon Boom Storyboard Pro, the export process creates a
separate scene from each shot in your storyboard.
These projects are compatible with Animate Pro.
To export a storyboard to Toon Boom Animate Pro:
1. Open you storyboard project in Toon Boom Storyboard Pro.
2. In the top menu, select File > Export > To Animate.
The Export to Animate/Animate Pro dialog box opens.

3. In the Destination Path section, specify the location and name of the folder that will
contain the storyboard's assets in Animate Pro.
4. Click the Browse button to display a window to select a location.
5. In the Export Range section:






All: Select this option to export your entire storyboard.
Selected Scenes: Select this option to export only the Scenes listed in the
adjacent text field.
D When you enter a list of scenes in the text field you should separate them
using a comma, e.g. 1,2,3
D When you enter a range of scenes in the text field you should use a hyphen
to list the range, e.g. 1-3.
D In the following example: 1,2,5-7; scenes 1 and 2, and 5, 6 and 7 will be
exported.

Current Scene: Select this option to export only the scene that is currently
displayed in the Toon Boom Storyboard Pro Camera View.
Tracked Panels: Select this option to only export panels which are marked as
Tracked.
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6. To view the location and contents of the exported folder when they are ready,
enable the Open Folder After Export option.
7. Click Export to confirm your settings and begin the export.
Depending on the size and length of your storyboard, this process may take several
minutes. Make sure to complete the entire export process so that no elements are
missing.

Moving On to Animate or Animate Pro
Scene Folders
On completing the export process, you will find all of your Animate Pro scenes in the
export folder which you specified earlier. Each scene is created using the shot name.
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Open the first folder, which contains all elements for shot 1 of the storyboard.

•

Notice that the scene created is a *.digital file (and not the expected
*.anim). This is normal.
Note: that any exported scenes in Toon Boom Storyboard Pro 2 can only be
opened Toon Boom Animate Pro 2.

•

The elements folder contains all the .tvg files that were extracted from your
storyboard scene.

•

If you have sound in your original shot, there will be an audio folder with the
corresponding sound. If you do not have sound in the original shot, there will not
be a folder.

Opening Your Scene in Animate Pro
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When you open your scene in Animate Pro you will find the following material:

•

Each Sound file will be included in its own layer.

•

The Drawing layer named TopLayer contains all the drawn material from the
Toon Boom Storyboard Pro scene. You will notice that this layer is actually a
Symbol.

•

D

In the Timeline, double-click on one of the frames to see what the Symbol
contains.

D

All drawing layers will be kept as they were in Storyboard and are vector
based. If you didn’t flatten your drawings in Toon Boom Storyboard Pro, you
will have all the strokes in your drawing. Textured strokes will also be kept as
is.

The Camera layer and its Peg will also be included. If there was a camera move
assigned in Toon Boom Storyboard Pro, the Peg will contain keyframes.

In the Animate Pro Network View, modules are kept simple. You will find the Drawing
module and the Camera module attached to it’s Peg module.
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Working with Storyboard Material in your Animated Scene (Animate Pro
only)
Once you are ready to work on the layout and animation of your scene, we recommend
that you first group all of your storyboard material in the Network View.
To group modules:
1. Using the Select

Tool, select all of your modules.

2. Right-click on the selection, then select Group > Group Selection from the menu.
A new Group Module will be created containing all the storyboard modules.
3. Click on the Group Module’s yellow square to access the Layer Properties and
change its name to Storyboard.

Importing Location Designs

The location design can be designed directly in Toon Boom Animate Pro or done on
paper and scanned in.
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Importing an Animatic

If you have an animatic available, you may decide to import it. The animatic will give you
the correct timing to expose your animation poses.

Setting the Camera

Now that all references are in place, you are ready to add and set your camera. It is very
important to set the camera frame before adding any more elements so that you can
correctly place the characters, backgrounds and props.
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To set your camera position, follow these three steps:

Step1: Adding a Camera
In order to set the camera, you must add a Camera layer to your scene if it is not already
present.
To add a Camera:
•

In the top menu, select Insert > Camera. A camera layer will be added to the
Timeline.

•

Or in the Timeline, click the Add Layers
Button, then select Camera. A
camera layer will be added to the Timeline.

Step2: Adding a Peg
The camera will often be animated. If you plan to not only draw a camera move, but also
to create it, you will have to add and attach a peg to the camera.
To add a new peg in the Timeline view:
1. In the Timeline view, select the Camera layer.

2. In the Timeline View Layer toolbar, click on the Add Peg button. The Peg will be
added, along with the selected Camera layer attached to it.

Step 3: Setting the Camera Position
Once you have set and positioned your camera you can position other elements,
characters, and background. Position the camera while referring to the storyboard or
animatic. Depending on how you select and move the camera it can be static or
animated.
Static Camera
To position your camera without animating it:
1. In the Tools toolbar, disable the Animate mode
tool.

and select the Transform
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2. In the Timeline view, select the Camera Peg.

3. In the Camera, Top or Side View, position the camera.

The red V shape is the
static camera.

Animated Camera
To position your camera and animate it:
1. In the Tools toolbar, enable the Animate mode
tool.

and select the Transform

2. In the Timeline view, select the Camera Peg.

3. In the Timeline view, go to the first frame where the camera will start moving.
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4. In the Camera, Top or Side View, position the camera.

The yellow V shape is the
animated camera.

5. In the Timeline view, go to the last frame where the camera will move.

6. In the Camera, Top or Side View, position the camera.

7. In the Timeline view, make sure the first keyframe is set as Motion Keyframe. Just
right-click the frame and select Set to Motion Keyframe.
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Sketching the Layout and Posing

Now that the references and the camera have been set, you can start drawing your
background layout and posing.
Create a rough sketch of the scene background and each character pose, base these on
the location design and the storyboard. If the storyboard has three different character
poses, draw each pose at the correct scale and position referring to the official character
model.
To sketch:
1. In the Timeline or Xsheet view, select the cell in which you want to draw.
2. In the Tools toolbar, select the drawing tools of choice like the Brush
Pencil

tool or the

tool.

3. In the Drawing or Camera view, display the grid. Go to View > Grid > Show Grid.
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4. In the Colour View, select the colour which you require.

5. In the Camera or Drawing view, begin to sketch your drawing.

6. If you draw in the next cell and wish to see your previous drawing, enable the Onion
Skin

.
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Cleaning and Inking the Layout and Posing

When your layout and posing sketches are ready, it is time to clean them up. To keep
your rough drawings, add a new drawing layer to trace over the sketches using the Light
Table. This process is similar to using an animation disk to clean paper drawings.
To trace your background and poses:
1. In the Timeline view, add a new layer. Click the Add Layers
Drawing in the drop-down menu.

button, then select

2. Rename the new Drawing layer accordingly.

3. Tools toolbar, select the drawing tool of your choice, like the Brush
Pencil

tool.

4. In the Timeline or Xsheet view, select the cell in which you want to draw.
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5. Trace over your sketch. This method allows you to keep the rough and clean
drawings intact.

6. Disable the rough layer to prevent it from appearing in the scene by unchecking the
Enable/Disable box on the left of the layer’s name in the Timeline.

Indicating the Camera Positions

To show changes in camera position, or if you have a position indicator other than the
Animate Pro camera frame, you can draw a sample showing the actual moves. This can
be stored in the library and reused for all of your scenes.
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Drawing the Camera Frame Sample
In the Camera View, you can use the Rectangle tool to draw over the camera frame. You
only need to do this once as it can be stored in the library and accessed as many times
as needed throughout the scene.
To draw a camera frame:
1. In the Camera View’s bottom toolbar, click on the Camera Options drop-down
menu and enable the Safe Area option.
2. In the Timeline or Xsheet View, add a new drawing layer and name it appropriately.

3. In the Timeline or Xsheet View, select the cell in which you want to draw.

4. In the Colour View, click the New Palette
button to create a palette for the
camera frame. Make sure to rename it appropriately.

5. In the Tools toolbar, select the Rectangle
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6. In the Camera view, trace over the camera frame. You can also trace over the Safe
TV frame.

7. In the Tools toolbar, select the Brush
, Line
tools and trace the camera frame centre.

, Pencil

or Polyline

Creating the Camera Frame Template
Once your camera frame drawing is completed, you can store it in the Library view and
drag it into scenes any time you need it.

If you use a colour code for your different camera frames, such as Start Frame and End
Frame, you can create two or three different templates painted with different colours.
Simply add the extra colours to your palette and repaint the camera frame before
storing it in the Library view.
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To create and import templates for a camera frame:
1. Library, select the library directory where the template will be stored.

2. Right-click (Windows) or [Ctrl]+click (Mac) and select Right to Modify.

3. In the Timeline View, select the camera frame layer or drawing and drag it to the
Library view.

4. The Rename window will appear, make sure to name the template appropriately.

5. In the scene where you need to indicate the camera frame, from the Library view,
drag and drop the reference template to the Timeline’s left side.
6. In the Camera view, using the Transform
template.
344

tool, position the Camera Frame

Layout Posing

Activity 1: Creating Layout and Posing
After all this theory on layout and posing, you should be prepared to build your own
scene. Before you start, you need to have a small storyboard and scripted scene that you
would like to layout in Animate Pro. Take the time to plan something out, and then start
the following steps:
1. Launch Animate Pro by double-clicking on the icon.
2. In the Welcome Screen, name your project Layout_Posing followed by your initials.
3. For this exercise, you will be creating a scene that includes 4 layers:





Overlay layer
Character layer
Underlay layer
Background layer

You will need to create all 4 layers in your Timeline. Remember that you need to
sketch your idea first, so you will create a sketch version of each layer first.
4. To create a drawing layer, go in the Timeline and click the Add Layers
Select Drawing. A new drawing layer is added to the Timeline.

button.

5. Repeat Step 4 until you have a total of 4 drawing layers in your Timeline. Then
rename them as listed below:





overlay_sketch
character_sketch
underlay_sketch
background_sketch

6. In each layer, you will illustrate the elements needed for your scene using the Brush
tool.
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Remember that this is the rough stage. You will clean and colour them later on.
Here is a good example of what you could do:

In this scene:
•

The wall is the
background

•

The boy is the
character

•

The bed is the
underlay

•

The footboard is
the overlay

You might have noticed the sketchy feel to the scene. We created a special colour
swatch to give a pencil feeling to our sketches. To do this, all you need to do is to go
to the Colour tab and click the Add New Colour
appear in your palette.

button. A new colour will

Double-click on that colour for the Colour Picker window to appear. In that window,
you can pick the colour black, then go change the alpha to 101. This is what will give
the transparent and sketchy feel to your brush!
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7. The next step will be to create new layers. These will be where you will cleanup your
scene. Each of the previous layers, now need a cleanup version. So create and
rename them as done below:

8. Now you can clean up your scene. Using the Brush Tool, retrace what you have done
on your sketch layers.

9. Once you are done with the line art, you can take the time to colour them with the
Paint Bucket

Tool.
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10.Make sure to frequently save the progress of your work by clicking the Save
button. The Save As window will appear. Name your project Layout_Posing along
with your initials.
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Activity 2: The 10 Layer Scene

Using four layers or more in an animation scene is fairly common. For this activity, you
will create the layout for a scene with 10 layers.
•

Come up with a scene planning that will allow you do to 10 layers.

•

In Animate Pro, build your scene and draw each layer.

•

As in the previous activity: take the time to draw rough sketches of each
element, place them in your scene, then clean them on new layers. Make sure to
name the roughs accordingly in the layer’s name field.Take the time to colour
each layer also.

In our example, the 10 layers are:
•

Background colour

•

Stars

•

Planets - five layers, one layer for each planet

•

Asteroid

•

Moon

•

Spaceship
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M18: Gathering Content and
Scene Setup

In this lesson, you will learn how to setup a basic scene and import external content.
This module is divided into the following topics:
•

Theory, on page 352

•

Activity 1: Gathering Content, on page 383
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Theory
This topic is divided as follows:
•

Importing Bitmap Images, on page 352

•

Importing and Vectorizing Images, on page 356

•

Importing PSD Files as Separate Layers, on page 359

•

Setting the Camera Frame, on page 361

•

Positioning the Scene Components, on page 362

•

Selecting a Layer, on page 362

•

Positioning an Element using the Transform Tool, on page 363

•

Transform Tool Properties, on page 365

•

Locking Layers in the Timeline View, on page 367

•

Flipping an Element, on page 368

•

Resetting a Transformation, on page 370

•

Cloning and Duplicating Layers, on page 371

•

Setting Up the Network, on page 373

•

Setting Up the Living Room, on page 384

Importing Bitmap Images

Images come in many different file formats and are usually saved in a format that retains
the original specifications set by the creator of the image. Some formats are able to
preserve transparency or transparent layers, while others are not resolution dependent
due to their vector nature. Animate Pro supports the following formats: JPEG, BMP,
PNG, TGA, PSD, TIFF, SGI, TVG, OMF, PAL, SCAN, YUV.
In this section, you will cover the following topics:
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•

Importing a Bitmap Image without Vectorization, on page 353

•

Importing and Vectorizing Images, on page 356
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Importing a Bitmap Image without Vectorization
A bitmap image is an image composed of pixels that is both size and resolutiondependant.
To import a bitmap image:
1. From the top menu select File > Import > Images. You can also click on the Import
Images
button in the File toolbar.


In the Xsheet view, you can right-click (Windows®) or [Ctrl]+click (Mac OS® X)
anywhere in the frame area and select Import > Images.

The Import Drawings dialog box opens.

2

3

4
5

2. In the Files section, click on the Browse button to find and select one or several
images on your computer.
3. In the Layer section, you now have the option of creating a new layer for your image
or adding the image to an existing layer.


To create a new layer, select Layer > Create Layer(s) > Create Single Layer
Named and name your layer accordingly.

OR


To create a new layer using the file name, select Layer > Create Layer(s) >
Create Layer(s) Based on Filenames.

OR


To add the image to an existing layer, select Layer > Add to Existing Layer and
select the layer, already created in your Animate Pro scene, from the drop-down
menu. If only vector
layers are available in your scene (and therefore the
drop-down menu), you will either have to Vectorize Imported Items, Create

353

Animate Pro 2 - Student Workbook

Symbols for imported Items or check both options to put your bitmap image on
a vector layer.
NOTE: To mix bitmap images with vector drawings on the same layer, the bitmap
image must be encapsulated in a Symbol and vice versa. When you check the option
Create Symbol for Imported Items, these Symbols will also automatically be added to
your Symbol Library.
4. In this case, uncheck the Vectorize Imported Items option.
The Vectorization options are hidden and the Transparency section appears.

5. In Animate Pro, if you want your bitmap images to be encapsulated in a Symbol,
enable the Create Symbol for Imported Items option. If not, disable the option. If
you chose to add your image to an existing vector layer then the Create Symbol for
Imported Items will automatically be checked and greyed out.
6. Next, in the Alignment section, you must decide on the size and placement of your
image within the camera frame. Depending on the Scene Settings (the height and
width in pixels that you chose for your project), an image that you import may get
scaled to the point where all its individual pixels become visible.
Be sure that you are in the Camera view’s Render Mode
imported image, otherwise it may appear blurry.

when judging an

The following options are available:
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Alignment > Rules > Fit
D If your image orientation is portrait format, this selection will enlarge or
shrink (but not distort) to your image’s height to match the full height of the
camera frame.
D If your image orientation is landscape format, this selection will enlarge or
shrink (but not distort) your image’s size so that its width matches that of the
camera frame.
Alignment > Rules > Pan
This selection achieves the opposite result of the Fit command.
D If your image orientation is portrait, its width will be made to match the width
of the camera frame. As a result, part of the image’s height will extend
beyond the height of the frame.
D If your image orientation is landscape, the image will extend beyond the
width of the camera frame.
This can be useful if you want to make your background move up and down, or
from left to right to make it appear as if the camera is panning, or to actually
perform a camera pan.

Gathering Content and Scene Setup



Alignment > Rules > Project Resolution
This selection will scale the image up or down in proportion to the scene's
resolution. It looks at the resolution of the bitmap image, for example 4000 x
2000, then compares it to the scene's resolution, for example 1920 x 1080 and
adjusts the scale factor in proportion. So in this example the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is 960 x 540 it will be
displayed at 50% (960/1920) of the size of the project resolution.

7. The last step is to decide on the image’s Transparency from the Alpha drop-down.
For this, there are four options available. These options deal with the way that the
bitmap image will be antialiased, more specifically the way that the pixels along the
edge are blended in the RGBA (red, green, blue, alpha (transparent)) channels.

The options are:





Premultiplied with White
Individual pixels at the edge of an image are blended with white.
Premultiplied with Black
Pixels at the edge of an image are blended with black.
Straight
Pixels at the edge of an image are blended with black, white and greys.
Clamp Colour to Alpha
Select this option if you want to premultiply the colour value with the alpha
value. When the colour is clamped to the alpha, the colour value cannot be
higher than the alpha value. If you have a pixel of value R=247, G=188, B=29
and the alpha is 50% (the image is 50% transparent), then the actual RGB value
outputs would be half of the amounts listed above.

8. Click on the OK button.
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Bitmap Image Quality
If the bitmap images that you have imported look blurry or slightly pixelated, follow the
steps below to clean-up the image. These steps effect the quality of the preview in
Camera view, but have no effect on the final render.
1. In the Camera view, double-click on the bitmap image to enter its Symbol if the
image is encapsulated or simply select the bitmap image layer in the Timeline if it
isn’t.
2. In the top menu, select View > Bitmap Image Quality or use the keyboard shortcut
[Ctrl]+[Q] (Windows®) or [Alt]+[Q] (Mac OS® X).
3. The Bitmap Image Quality dialog box opens.

4. Click and drag the Bitmap Image Quality slider to the right to improve the quality.
5. Click on the OK button.
6. If you are inside a Symbol, go to the top of the Camera View and click on “Top” to
exit the Symbol and return to your scene.

Importing and Vectorizing Images

You can turn your images into vector drawings, while still maintaining the sketchiness of
a pencil line or into vector images with a bitmap fill. Both of these options can add life
to an animation, which straight vectorization with smoothing does not usually afford.
To import and vectorize a bitmap image:
1. In the top menu, select File > Import > Images. Or click on the Import Image
button in the File toolbar.
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The Import Images dialog box opens.

2

3
4
5

2. Click on the Browse button to find and select one or several images on your
computer.
3. You now have the option of creating a whole new layer for your image or adding the
image to an existing layer.


To create a new layer, select
Layer > Create Layer(s) > Create Single Layer Named and name your layer
accordingly.

OR


To create a new layer using the file name, select
Layer > Create Layer(s) > Create Layer(s) Based on Filenames.

OR


To add the image to an existing layer, select Layer > Add to Existing Layer and
select the layer already created in your Animate Pro scene from the drop-down
menu. If only vector
layers are available in your scene (and therefore the
drop-down menu), you will either have to Vectorize Imported Items, Create
Symbols for imported Items or check both options to put your bitmap image on
a vector layer.

NOTE: To mix bitmap images with vector drawings on the same layer, the bitmap
image must be encapsulated in a Symbol and vice versa. When you check the option
Create Symbol for Imported Items, these Symbols will also automatically be added to
your Symbol Library.
4. In this case, enable the Vectorize Imported Items option.
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5. Under the Vectorization section, decide whether you would like to import your
image in colour or black and white, or if you would like to add a new preset.

OR




Black and White: this style vectorizes your drawings as a solid black line. This
creates a 100% vector-based drawing.
Colour: this style vectorizes your image as a colourful bitmap texture within a
vector frame.



New Preset: the New Preset option or button allows you to create your own
custom vectorization parameters via the Vectorization Parameters interface.
The Vectorization Parameters dialog box will open automatically once you click
on this button.



Delete Preset: the Delete Preset button allows you to delete any preset
available in the list.

You can double-click on any of the presets at any time to open the Vectorization
Parameters dialog box to customize your option.
The vectorized images are painted with the Vectorize Line colour swatch from the
Colour Palette.
6. Click on the OK button.

Black and White Preset

Colour Preset

You should now have a Symbol or new layer that contains the vector drawing. If your
image is contained in a Symbol, in order to edit the image, you must double-click on the
image’s first cell in the Timeline view to enter the Symbol.
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Importing PSD Files as Separate Layers

PSD files (a format exportable exclusively from Adobe® Photoshop®) are unique in that
they are able to retain multiple layers. This is advantageous as the image remains fully
editable in terms of any colour correction, effects, masking, transparency or compositing
that were made to the PSD file in Adobe® Photoshop®.
To import the separated layers of a PSD file:
1. Organize your Adobe® Photoshop® file so that all your layers are “grouped” into
individual folders, or that all the elements you want to import as a single layer in
Animate Pro are grouped together in their own folder. Any layer that is not in a
folder group, by itself or otherwise, will not be imported into Animate Pro.

2. In Animate Pro, go to the top menu and select File > Import > Images or click on
the Import Image
button.
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The Import Drawings dialog box opens.

3

4
5
6

7

3. Click on the Browse button to find and select the PSD image on your computer.
4. Select Layer > Create Layer(s) > Create Single Layer Named or Create Layer(s)
Based on Filenames.
5. Decide whether to check or uncheck the Vectorize Imported Items option.
6. Enable or disable the Create Symbol for Imported Items if you want your layers to
be contained in Symbols or not.
7. Click on the OK button.
The Multilayer Image Import Settings dialog box opens.

8. In the Image to Load field, select



Composite Image to flatten your layers.
All Layers Image to keep your layers separated.

9. Select the Transparency Type if applicable. Refer to the Importing a Bitmap Image
without Vectorization section to learn more the different Transparency Type options.
10.Click on the OK button.
Your image should appear as separate layers in the Timeline view, corresponding to the
PSD layer group folders.
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The artwork displayed in every one of your layers as a result of a multilayer PSD file
import, are linked to the same source image. This means that if you use the command
Drawing > Delete Selected Drawings to physically delete the drawing from the project
folder, the exposed drawing will be deleted in every of the layers at once. Once deleted
from the project folder, the image can not be retrieved unless you re-import your psd
file.

Setting the Camera Frame
The scene action occurs inside the camera frame, so it’s really important to set it up
correctly.
The Camera layer is static which means that if you need to animate it, you will have to
add a peg which will be shown in a further module.

Adding a Camera Layer
To set the camera frame, you need to add a Camera layer into your scene so that you
can edit the default camera frame.
To add a Camera layer in the Timeline view:
1. In the Timeline view, click on the Add Layer
Insert > Camera from the top menu.

button. You can also select

2. Select Camera from the drop-down menu.
A new Camera layer will be added to your scene and will appear in the Timeline
view.

361

Animate Pro 2 - Student Workbook

Positioning the Scene Components
Setting up the scene also involves positioning the different scene elements within the
camera frame.

Animate Mode
When positioning elements, make sure that the Animate Mode is disabled, or it will
create a keyframe within the drawing layer.
To disable Animate Mode:
1. In the Tools toolbar, click on the Animate Mode
shortcut is [Shift]+[A].

button. The default keyboard



When the Animate Mode button is pushed in and highlighted it means it is
enabled.



When the Animate Mode button is popped up it means it is disabled.

Selecting a Layer
There are different ways of selecting the layers you want to reposition in the Camera
view.

Selecting a Layer from the Camera View using the Transform Tool
You can select your elements directly in the Camera view using the Transform
When you select the Transform

tool.

tool, its properties and options appear in the Tool

Properties view. When using the Transform

tool to select element in the Camera

view, always make sure that the Peg Selection
Mode option in the Transform Tool
Properties view is disabled or else it will limit the selection to peg only.
To select from the Camera view:
1. In the Tools toolbar, select the Transform
[Shift]+[T].

tool. The default keyboard shortcut is

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode
disabled.

is

3. In the Camera view, select the element to be repositioned. You can select more than
one element at a time.
The corresponding layers and columns will be highlighted in the Timeline and Xsheet
views.
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Positioning an Element using the Transform Tool
You can easily reposition, scale, rotate and even skew the layers directly in the Camera
view by making use of the Transform tool. When positioning a drawing layer using the
Transform tool, always make sure that the Peg Selection Mode is disabled in the
Transform Tool Properties view, or it will limit the selection to pegs in the Camera view.

Panning a Drawing Layer
To pan a layer using the Transform tool:
1.In the Tools toolbar, select the Transform

tool.

2.In the Transform Tool Properties view, make sure that
the Peg Selection Mode

is disabled.

3.In the Camera view, select a drawing layer and drag
the selection to a new area.
You can select multiple layers to reposition them at
once.

Rotating a drawing layer
To rotate a layer using the Transform tool:
1.In the Tools toolbar, select the Transform

tool.

2.In the Transform Tool Properties view, make sure that
the Peg Selection Mode

is disabled.

3.In the Camera view, select the drawing layer and
rotate the transform bonding box handle.
You can select multiple layers to rotate them together.

Scaling an Element
To scale a layer using the Transform tool:
1.In the Tools toolbar, select the Transform

tool.

2.In the Transform Tool Properties view, make sure that
the Peg Selection Mode

is disabled.

3.In the Camera view, select the drawing layer and then
pull or push either on the size, top or corner control
point. Hold down [Shift] to lock the selection’s ratio.
You can select multiple layers to rotate them together.
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Skewing an Element
To skew a layer using the Transform tool:
1.In the Tools toolbar, select the Transform

tool.

2.In the Transform Tool Properties view, make sure that
the Peg Selection Mode

is disabled.

3.In the Camera view, select the drawing layer and
drag sideway or up and down the sides or top and
bottom segments, between the control points.
You can select multiple layers to rotate them together.

Temporarily Repositioning the Pivot Point
Some transformations are made relative to the pivot point position such as rotation,
scale, skew and flip. You can use the Transform
tool to temporarily reposition this
pivot point for each transformation.
To temporarily reposition the pivot point:
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode
disabled.

is

3. In the Camera view, click on your element to select it.
The pivot point will appear in the Camera view.
4. Click on the pivot point and drag it to a new position.
This will be the new position of the pivot point for the current transformation. It will
remain in this new position as long as you do not deselect the drawing.
NOTE: Using the Transform tool to reposition your pivot will temporarily override the
existing pivot point position until you complete the current transformation, it then
returns automatically to its original position.
When you translate the pivot using the Transform tool, the permanent pivot appears as
a ghost indicating its location and from where the animation will be interpolated when
you create motion paths. The animation is always interpolated from the original pivot
and not the temporary pivot.
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Transform Tool Properties

Select and Transform Tool
Switch between the Transform and Select tools directly from the Transform or Select Tool
Properties views.

Lasso and Marquee Modes
Choose between the Lasso and the Marquee modes to change the selection style of the
Transform tool.
•

Click and hold [Alt] to temporarily switch from the current selected mode to the
other.

Peg Selection Mode
Enable this option to limit the selection in the Camera view to pegs. When disabled, the
Transform tool selects the drawing layers.

Flip Horizontal and Flip Vertical
Use these buttons to flip the selected element horizontally or vertically.
•

You can also select Animation > Flip > Flip Horizontal or Flip Vertical or use the
default keyboard shortcuts [4] and [5].

Rotate 90 CC and Rotate CCW
Use these buttons to rotate the selected element 90 degrees clockwise or counterclockwise.
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Width and Height
Use these fields to enter specific values when you want to accurately resize the selected
layer.
3

•Width: type a width value in this field to resize the width of

1
2

4

your selection.

•Height: type a width value in this field to resize the height of

your selection.

•Use the up and down arrows to modify the value contained in

either the Width or Height value field.
•

Lock icon: Click on the lock icon to either lock or unlock the ratio between the
width and height values.

•

Offset X and Y: Use these fields to enter specific values to reposition the
selected layer accurately.

•

X: type a width value in this field to reposition the selected layer.

•

Y: type a width value in this field to reposition the selected layer.

Use the up and down arrows to modify the value contained in either the X or Y value
field.

Angle
Use this field to enter specific values to rotate the selected layer accurately.
2 •Angle: type a degree value in this field to rotate the selected layer.

1

Use the up and down arrows to modify the value contained in the
Angle value field.

Snap Option
When transforming or repositioning your layer using the Transform tool, you can enable
different snap options to help you.

Snap and Align
Snaps the selected layer to any existing line, while automatically displaying temporary
rulers that guide you and that you can also snap your object to.

Snap to Grid
Snaps your selection according to the currently enabled grid.
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Locking Layers in the Timeline View
You can prevent correctly positioned layers from being selected by locking them in the
Timeline view. Useful for making a multiple selection inside the Camera view and leaving
them visible.

Lock
Use the Lock option to lock one or a multiple selection of layers.
To lock a layer or a selection of layers:
1. In the Timeline view, select one or many layers.

2. In the top menu, select Animation > Lock > Lock. You can also click on one of the
selected layer’s Lock icon or use the default keyboard shortcut [Ctrl]+[Alt]+[L]
(Windows) or [a]+[Alt]+[L] (Mac).
This will automatically lock all the selected layers.

Permanently Repositioning the Pivot Point
Some transformations, such as the rotation, scale, skew and flip, are made relative to the
pivot point position. Reposition this pivot point anywhere using the current advanced
animation tool.
To permanently reposition the pivot point:
1. In the Advanced Animation toolbar, select the Rotate

, Scale

or Skew

tool.

2. In the Camera view, [Ctrl]+Click (Windows) or [a]+Click (Mac) to select your
element. The pivot point will appear in the Camera view.
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3. Click on the pivot point and drag it to a new position.

This new pivot point position is used for any future transformations until you
reposition it.
NOTE: Using the Advanced Animation tools to permanently reposition your pivot
overrides the existing pivot point position until you change its position again.

Flipping an Element
There are two different options you can use when you want to flip your element.

Flip Horizontal and Flip Vertical
The Flip Horizontal and Flip Vertical options flip your drawing layer along Camera view’s
horizontal and vertical axis.
To flip a layer:
1.In the Transform Tool Properties view, make sure that the
Peg Selection Mode

is disabled.

2.In the Camera view, select the drawing layer you want to
flip using the Transform

tool.

3.Select Animation > Flip > Flip Horizontal or Flip Vertical.
You can also use the keyboard shortcuts [4] and [5].
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Flip Scale X and Flip Scale Y
Once your drawing layer has been rotated, the original horizontal and vertical axes
change. The Flip Scale X and Flip Scale Y will perform a flip on your drawing layer
following its original axis.
•

The Flip Horizontal command flips the Layer following the Camera view X-axis.

•

The Flip Scale X command remembers the original X-axis of the layer and flips
the element following it.
The red bar represents the
original X-axis

Flip Horizontal
The Flip Horizontal command flips the
Layer following the Camera view X-axis.

Flip Scale X
The Flip Scale X command remembers the original Xaxis of the layer and flips the element following it.

To flip an element following its original axis:
1. In the Transform Tool Properties view, make sure that the Peg Selection Mode
disabled.
2. In the Camera view, using the Transform
already been transformed.

is

tool, select your element that has

3. Select Animation > Flip > Flip Scale X or Flip Scale Y.
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Resetting a Transformation
You can easily reset layers to their original position in the Camera view. Use the Select
command to reset the value of the selected element to the initial value of the active tool.
For example, if the Rotate
and if the Transform

tool is active, the transformation angle will be reset to 0

tool is active, the entire transformation values will be reset.

When using the Transform
tool to select element in the Camera view, always make
sure that the Peg Selection Mode
option in the Transform Tool Properties view is
disabled or else it will limit the selection to peg only.
To reset the layers position:
1. In the Tools toolbar, select the Transform
[Alt]+[Q].

tool. The default keyboard shortcut is

2. In the Timeline or directly in the Camera view, select the drawing layers you wish to
reset. You can select more than one layer at a time.
3. Select Animation > Reset. You can also use the default keyboard shortcut
[Ctrl]+[Shift]+[Z] (Windows) or [a]+[Shift]+[Z] (Mac).
The selected layers will automatically return to their original position.
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In the Timeline view, you can also use the Reset All Values command to reset all
transformation values on the selected layers. Select Layers > Reset All Values
from the Timeline View menu.
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Cloning and Duplicating Layers
You may need to clone or duplicate a layer during a production. This allows you to
modify the layers drawings or the timing independently from the original column.

Clone Layer
A cloned layer is linked to the original element directory. If a drawing is modified in the
original or cloned layer, both will be updated. However, clone layers can have different
timings.
For example, if you make a walk-cycle for a soldier and want to use it for a whole army,
you may want to have fifty layers with fifty different drawing exposures to produce a
slight difference in the timing. You don’t necessarily want the same drawing fifty times.
If you copy your layers and their drawings fifty times over, it will create a very heavy scene
(large file size). It is better to clone the fifty layers from the same initial layer and have
them all linked to the same walk cycle drawings. This produces fifty layers but only one
drawing directory. This also lets you correct the drawings in one layer and have the
others update simultaneously.
When you clone a layer that is already linked to a function, the cloned layers are
automatically linked to the same function, so if you reposition the layers while in Animate
Mode, they are all repositioned to the same place because a keyframe is added to
this function.
If you want the layers to move on a trajectory that is independent, make sure to unlink
the function before cloning.

To clone a layer:
1. In the Timeline view, select the layer to clone.
2. In the Timeline View menu, select Layers > Clone Selected Layers.
The cloned layer appears in the Timeline view.
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Duplicate Layer
You can duplicate a layer to have a copy of the drawings that are independent from the
original column, as well as an independent timing (exposure). When you need the
drawings to be modified independently, you will want to duplicate the layer instead of
cloning it.

To duplicate a layer:
1. In the Timeline view, select the layer to duplicate.
2. In the Timeline View menu, select Layers > Duplicate Selected Layers.
The duplicated layer appears in the Timeline view
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Setting Up the Network

In Animate Pro, you are introduced to the Network view. The Network View uses a set
of connections to show how each element in the scene is brought to the final image. It
allows you to add extra elements and effects, and to move beyond the possibilities
offered by Timeline and Xsheet capabilities.

Network Navigation and Basic Rules
The basic rules of the Network View are quite simple and can be used to accomplish
significant results.

Modules

Each element in the Network View is called a module. There are different types of
modules; Drawing Element Module for transferring drawing information, Effect Modules
for processing effects on drawings and transferring drawing information, Input/Output
Modules, Movement Modules, and Compositing Modules.
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This is what they look like:
•

Drawing modules transfer drawing information.

•

Effect modules process effects on drawings and transfer drawing information.

•

Input/Output modules are the interface between each module and network.

•

Move modules control the camera and element transformations over time.

•

Compositing modules combine multiple source images.

Input and Output
There is an Input port at the top and an Output port at the bottom of each module.
Some ports are blue while others are light green or bright green.
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•

Blue denotes drawing information

•

Light Green denotes position and movement
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•

Bright green shows the element on top of the composition and outputs that
element’s Z position to the Composite module. When many elements have
different Z positions (multiplane, different distances from the camera) and are
placed through a Composite module that flattens them together (producing one
image with one Z value), the system needs to give a Z position to this new
image. It uses the bright green port element information.

Finally, some modules contain more than one Input port. These are usually Effects
modules needing different drawing or position information in order to perform their
calculation. When the two ports are blue, the Drawing is on the right and Matte is on the
left. If it is light green, the drawing needs extra position information.
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Adding Modules
Each module used to build a network is available in the Module Library view. In addition,
each time you create a layer from the Timeline or Xsheet views, the corresponding
module is created in the Network view.
To import modules from the Module Library:


In the Module Library, select the desired module and drag it in the Network
View.

Organizing the Modules
When you are working in the Network view, and adding many modules, your scene
might look a bit messy and be hard to follow. To fix this, Animate Pro provides the Order
Network script which organizes and displays the modules in a more orderly fashion.
To use the Order Network script to organize your network:
1. In the Network View, select some or all your modules.

2. Display the Scripting toolbar and click on the Order Network Up
Network Down
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button. The Order Network dialog box opens.

or Order
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3. Set an X Overlap% value.
4. Set a Layer Spacing value.
5. Set a Vertical Spacing value.
6. Click on the OK button and the network is reordered.

Connecting and Disconnecting Modules
Making or removing connections between the modules is as easy as a click and drag.
To connect modules:
1. In the Network view, extend a cable from the first module’s output port and connect
it in the second module’s input port.


You can also select the module to connect, hold down the [Alt] key and drag the
module on an existing cable.

[Alt]

To disconnect modules:
1. In the Network view, pull a cable away from the module’s input port.


You can also select the module to disconnect, hold down the [Alt] key and drag
the module away.

[Alt]
[Alt]
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Grouping Modules
With so many connections and modules possible, the network can quickly become
overcrowded, keep things organized by grouping your modules.

Grouping A Selection
To group selected modules:
1. In the Network view, drag a selection around the modules you want to group.

2. In the Network View menu, select Edit > Group > Group Selected Layers. You can
also use the default keyboard shortcut [Ctrl]+[G] (Windows) or [a]+[G] (Mac).
Your modules are grouped.

Including a Composite module into your selection and then making sure that it is
connected to the main Composite module of your scene before grouping it, ensures that
you have a Multi-Port Out Module in your group and that your group remains
connected.
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Ungrouping a Selected Group
To ungroup a selected group:
1. In the Network view, select the group module you want to explode.

2. In the Network View menu, select Edit > Group > Ungroup.
Your modules are ungrouped.
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Entering and Exiting a Group Module
Once you create a group module, it is easy to enter into or exit from.
To enter a Group module:
1. In the Network view, click on the right dark arrow on the group module you want to
enter.



Inside the group module, the Multi-Port In and Multi-Port Out modules ensure
that your connections continue beyond the group.

To exit a Group module:
1. In the Network view, click on the destination in the Group Hierarchy Menu. You can
also select Modules > Exit Group from the Network View Menu. The default
keyboard shortcut is [Backspace].

To exit a group, click on Top Group
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When you enter a group, the Group Hierarchy Menu displays the path to where
you are. In this example, we are inside the group named group. To exit this
group, click on Top Group.
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Enabling and Disabling Modules
As with the Timeline layers, you can enable and disable the Network view modules.
Disabling a module in the Network view will also disable its corresponding layer in the
Timeline view. Disabled modules are displayed in red.
To enable modules:
1. In the Network view, select the disabled module(s) you want to enable.

2. In the Network View menu, select Modules > Enable. You can also use the default
keyboard shortcut [A].

To enable all modules:
1. In the Network View menu, select Modules > Enable All.

To enable modules:
1. In the Network view, select the module(s) you want to enable.
2. In the Network View menu, select Modules > Disable. You can also use the default
keyboard shortcut [D].
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To disable all others:
1. In the Network view, select the module(s) to remain enabled.

2. In the Network View menu, select Modules > Disable All Others.
All modules are disabled except for those selected.
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Activity 1: Gathering Content

Animate Pro allows you to draw directly in the software, and import external content.
You can import QuickTime videos, pictures, multi-layered PSD files, as well as AI, SWF
and PDF files.
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Setting Up the Living Room

For some of your projects, you will probably want to paint your backgrounds in a bitmap
editing software such as Adobe® Photoshop®. With Animate Pro, you can import multilayered PSD backgrounds and keep the layers separated.
To start building the scene, we will import a living room background. This background
has three layers; a wall, a television and a chair. We will import the file so that each one
of these PSD layers will be inserted in a separate timeline layer.
To do this, you must group your layers in Adobe® Photoshop®.

1. In Adobe® Photoshop®, group your layers. Each PSD layer you want on a separate
timeline layer must be in a different group.


If you want some of your PSD layers to be integrated in the same timeline layer,
insert them in the same group.

If you name your groups, their name will be preserved once your import the file in
Animate Pro.
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2. In Animate Pro, select Files > Import > Images.
3. In the Import Drawings dialog box, browse for the PSD file to import.
4. In the Layer section, enable the Create Layer(s) and the Create Single Layer Named
options.
5. Disable the Vectorize the Imported Items option.
6. Click on the OK button.
7. In the Image to Load field of the Multilayer Image Import Settings dialog box, select
the All Layer Images option.

8. Select the Transparency Type if applicable.
9. Press the OK button.

Your background appears in the Timeline view and the new layers are named as
your PSD groups. The only thing left to do is to extend their exposure.
10.In the Timeline view, select the last cell of each layers and press [F5] to extend their
exposure.
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Importing a QuickTime Movie

If you have a live-action clip you want to integrate into your project, you can do it with
Animate Pro. Using Animate Pro you can import QuickTime movies. This allows you to
integrate your videos with your animation.
If your clip is not a QuickTime movie you need to convert it to *.mov format first. You can
do this using an editing software.
In this example, we import a Happy New Year fireworks clip that we will position inside
the television.
To import a QuickTime movie:
1. In the top menu, select Files > Import > Movie.
2. In the Import QuickTime Movie dialog box, browse for the movie to import.
3. Click on the Open button.
Note: Your movie will be transformed into an image sequence and a sound layer will
be added to contain the sound if there is any.

Once the import process is completed, you will be asked where and how you want
to insert your movie’s images.
4. In the Import Images dialog box, enable the Create Layer(s) and the Create Single
Layer Named options.
5. Name your new layer with a relevant name.
6. Disable the Vectorize the Imported Items option.
7. Enable the Create Symbol for Imported Items option if you want your movie to be a
Symbol.
8. Click on the OK button to import your image sequence.
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9. In the Timeline view, drag and drop the fireworks layer below the TV one.

10.In the Tools toolbar, select the Transform
mode.

tool and disable the Animate

11.In the Timeline view, select your QuickTime Movie layer.

12.In the Camera view, resize your clip to the tv screen size.


Hold the [Shift] key down to maintain aspect ratio of the movie.
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Getting the Limpa Character to Celebrate

Now that the living room is ready for the celebration and the television is switched on,
you can locate the Limpa character’s template in the Library and import him in the
scene.Limpa was previously designed and stored in the sample library as a template.
A template is a small scene or container that you can import into any of your projects
and its content will be copied in your scene.
1. In the Library, select the Templates folder and then select the Limpa.tpl template.
2. Drag the selected template to your Timeline view.
3. Use the Transform
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tool to position Limpa on the stage.
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4. In the Playback toolbar, press the Play

button to play back your animation.

389

Animate Pro 2 - Student Workbook

390

M19: Camera and Trajectory

In this lesson, you will learn how to work with the camera and create animation paths.
Movement is the essence of creating an animation; it is essentially what animation is:
bringing drawings to life. Sometimes this movement comes from the characters or
objects themselves, while other times, it is the camera moving through elements set-up
on the camera “stage”. Often these movements can be complex, such as a helicopter
flying across the screen with its rotor blades turning, as the helicopter disappears into
the distance it appears to get smaller in size as it recedes further into the distance.
Although this seems like a simple motion, you must coordinate three movements to
produce the correct effect.
This module is divided into the following topics:
•

Theory, on page 392

•

Activity 1: Spaceship and Planets, on page 422
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Theory
This topic is divided as follows:
•

Animating a Layer, on page 392

•

Animated Layers and Pegs, on page 394

•

Adding and Deleting Keyframes, on page 401

•

Motion and Stop-Motion Keyframes, on page 403

•

Animating the Camera, on page 406

•

Modifying a Path in the Camera View, on page 409

•

Modifying a Path in the Timeline View, on page 414

•

Copying and Pasting a Motion, on page 417

•

Adjusting the Velocity, on page 419

Animating a Layer
This section describes the basics of animating a layer. Animate Pro’s wide range of
features will let you produce accurate trajectories. However, before reaching this level
you must learn how to create a simple motion and practice everything you learn in this
lesson.
In this topic, you will find out about the two key elements in creating a motion:
•

Animate Mode

•

Animating the layer

Animate Mode
Enable this mode when you animate layers and Animate Pro will apply a transformation
to the current frame. If you don’t, it will apply a transformation on the entire layer instead
of only the current frame.
To enable the Animate Mode:
1. In the Tools toolbar, click on the Animate Mode
shortcut is [Shift]+[A].
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button. The default keyboard



When the Animate Mode button looks pushed in and highlighted it is enabled.



When the Animate Mode button is not highlighted it is disabled.
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Animating a Layer
Follow these steps to perform a basic layer animation.
To animate a layer:
1. In the Tools toolbar, select the Transform
[Alt]+[Q].

tool. The default keyboard shortcut is

In the Tool Properties view, make sure the Peg Selection Mode
button is
disabled so you can select your drawing layer directly and not the pegs.
2. In the Tools toolbar, enable the Animate Mode

.

3. In the Timeline view, go to the first frame.

4. In the Camera view, select the element to animate and move it to its first position.

5. In the Timeline view, go to the frame where you would like to set the second
position.

6. In the Camera view, move the selected element to its new position.

7. In the Playback toolbar, press on the Play

button to view your work.
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Enabling the Playback
To see your motion animations in the Top, Side or Perspective views while you playback,
you must enable the Playback option.
To enable the Playback option:


In the top menu, select Play > Enable Playback > Top View, or Side View or
Perspective View.

Animated Layers and Pegs
To animate the position of your drawings you need to create motion paths. Motion paths
are trajectories on which you can hook your drawing objects to. You will use keyframes
to record the key positions along the trajectory.
There are two ways in which to create motion paths:
•

Animated Layers

•

Pegs

Animated drawing layers and pegs have different purposes which you will discover in the
following topics.

Animated Layers

You can create your motion path directly on your layers.
Drawing layers can house drawings and Symbols. Also, in that same layer you can create
a motion path using keyframes and all the artwork contained in the layer will follow.
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You can control and define your trajectory using several different parameters. These
parameters are:
•

X, Y and Z positions

•

Angle (rotation)

•

Skew

•

X and Y scales

Each parameter has its own function curve where you can add keyframes and control the
easing.
Do not worry about using graphs and function curves if you are not familiar with this
concept. Animate Pro has a series of easy-to-use tools for visually controlling your
trajectories in the Camera view.
To animate a simple object such as a flying arrow or a spinning wheel, you will use the
integrated trajectory. Also, each part of a cut-out puppet will be animated directly on
the drawing layer.

Pegs
A Peg layer is a trajectory that contains no drawings, on which you can hook your
drawings to.

Why Use a Peg Layer?
A Peg is composed of many customizable parameters. These parameters are:
•

X, Y and Z positions

•

Angle (rotation)

•

Skew

•

X and Y scales

•

3D Rotation (When the 3D option is enabled)

You can control a Peg’s trajectory the same way as the animated drawing layer.
A peg layer is mainly used to control a series of drawing layer. If you have several drawing
layers such as clouds or a character split into many parts, you can hook those to a peg
layer and have them follow a trajectory as a unit. When building a puppet, you will most
of the time add a master peg to control your puppet as one object.
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The Origin of a Peg

Pegs are used in traditional animation to align and register the paper so that every sheet
fits in the same position. Each sheet of animation paper has a set of identical peg holes
at the top or bottom of the sheet. When placed on the peg bar each sheet aligns exactly.
There are three peg holes in regular animation paper. The centre peg hole is circular
while the left and right ones are rectangular. These rectangular peg holes are situated,
one on each side and four inches away from the centre peg hole.
To keep the drawings together, the animator uses a peg bar. This peg bar has three pins
corresponding to the shape and location of the peg holes. Peg bars are found at the top
and bottom of animation discs.
Before digital compositing, the peg bars were also used to move levels under the
camera stand. They were the equivalent of the digital trajectories. Animate Pro makes
use of these concepts to create animation and camera moves.
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Adding a Peg to the Timeline
To add a Peg:
1. Select the layer which you intend to attach to the peg.

2. Add the peg in one of three ways:





From the Timeline View layers toolbar, click on the Add Peg button.
From the top menu, select Insert > Peg.
Right-click (Windows) or [Ctrl]+Click (Mac OS X) on the layer and from the popup menu, select Add > Peg.
In Animate Pro, select a Peg module from the Module Library and drag it to your
Network view.

3. The layer that was originally selected will become a child of the new parent Peg
layer. The new Peg layer will automatically take the name of its child layer, with the
addition of the suffix -P.
The indentation of the layer, along with the L-shaped line indicates
hierarchy and that the layer is attached to the Peg layer. Their
relationship is known as Parent-Child

4. If you intend adding multiple pegs, or if the layer name that was added to the Peg
does not accurately represent the content of the Peg layer, you can rename it. Do
this by clicking on the layer name and typing in the editable field, or double-click on
the layer and entering the new name into the dialog box.

5. If you didn’t create your peg layer directly above the layer you intended on
parenting it to, then click and drag the layer you want to attach to the peg and drop
it directly below the Peg layer. The indentation of the layer below the Peg layer will
be an indication of whether it was correctly attached or not.
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Layer Parameters
A layer is composed of many customizable parameters, such as the X, Y and Z positions,
angle (rotation), skew and scales. Each parameter has its own function. A function is a
mathematical formula expressing the relation between position values. You can view
each function on a graph as a simple curve such as this one.
Frame

Easing
Keyframe
Value

Easing
Keyframe

To display the Layer parameters in the Timeline View:
1. In the Timeline’s left-hand side, click on the Expand Function
keyboard shortcut is [Alt]+[F].
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button. The default

In Animate Pro, you can select the layer you want to display the functions for, go
to the Timeline View menu and select View > Show Functions.
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2. There are six options available for setting up function parameters:







Locked Positions (3D Path)
Separate Positions
Locked Scales
Separate Scales
Quaternion (3D Rotation)
Euler Angles (3D Rotation)

Locked Positions

Separate Positions

Locked Scale

Separate Scale

Quaternion
(Locked 3DRotation)

Euler Angles
(Separate 3D Rotation)

You can set the preferences to suit your way of working. In your general preferences,
enable Default Separate Positions to get separate X, Y and Z positions, or disable it to
get a 3D path. The 3D path is set by default. Enable the Default Separate Scale to get
separate X and Y scales. It is highly recommended that you use default separate scales.
You have to lock or unlock your functions before starting the animation. When you lock
or unlock parameters, this does not convert the functions from one to the other, but
creates new ones.
This topic is divided as follows:
•

3D Path

•

Separate Positions

•

Locked Scales and Separated Scales

•

Setting the Parameters
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3D Path
In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity
function. When you add a keyframe, it is added on all three trajectories at once, as is the
velocity. This is very useful for long, smooth trajectories.

Separate Positions
When the Separate Positions option is used, the X, Y and Z curves are independent and
have velocity controls directly on their function curve. This is useful when you want to set
keyframes on one of the curves without affecting the others.

Locked Scales and Separated Scales
When using the scale function, you can have a single function curve controlling both the
vertical and horizontal scale, or have the two scales separate. This means that when
using the single function, the values will be the same for the X (horizontal) and the Y
(vertical) axes, enabling a uniform size change without distortion. However, if you
separate the scale functions, you will be able to squash, stretch and skew your elements.

Setting the Parameters
This topic will cover the 2D motion parameters.
To set the parameters:
1. In the Timeline view, double-click on the layer on which you want the parameter set.
The Layer Properties editor opens.
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2. Go to the Transformation tab.
3. In the Position section, enable either the 3D Path or the Separate options.
4. In the Scale section, enable either the Locked or the Separate options.
5. Click on the close button.

Adding and Deleting Keyframes
You can create a keyframe in several different ways.
You can add a coordinate keyframe, position keyframe or a keyframe along with your
drawing duplication.
•

Coordinate Keyframe

•

Add Keyframe and Duplicate Drawing

•

Delete Keyframe

Coordinate Keyframe
To create keyframes:
1. In the Timeline view, select the cell where you want to add a keyframe.

2. Here are the different ways to add a keyframe to your timeline:






In the top menu, select Insert > Keyframe.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Add
Keyframe.
The default keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X).
You can also click on the Add Keyframe
button available in the Timeline View
toolbar.
In the Camera view, if the Animate mode is enabled, as soon as you move the
selected element, a keyframe will be automatically created on the current frame.
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Add Keyframe and Duplicate Drawing
The method described previously only creates a keyframe without a drawing. It adds
new coordinate points but the drawing in the layer stays the same. You may want to
duplicate your drawing at the same time if you need to modify it and do not want to
modify the original one. In this case, you can use the Add Keyframe and Duplicate
Drawing function.
To create a keyframe and duplicate your drawing at once:
1. In the Timeline view, select the cell containing the drawing where you want to add a
keyframe and duplicate.

2. Here are the different ways to add a keyframe and duplicate:




In the top menu, select Insert > Keyframe and Duplicate Drawing.
Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select
Insert Keyframe and Duplicate Drawing.
The default keyboard shortcut is [F6].

Delete Keyframe
To delete a keyframe:


With the Transform Tool
selected, choose the Keyframe to be deleted from
the trajectory in the Camera View and press the [Delete] key.

OR
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In the Timeline view, click on the keyframe to be deleted, right-click (Windows)
or [Ctrl]+click (Mac OS X) and select Delete Keyframes. The default shortcut is
[F7].
You can also select Animation > Delete Keyframe from the top menu.
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Motion and Stop-Motion Keyframes
Interpolation is the computer-generated motion between two keyframes. Some
animators and compositors like to create their own inbetweens, while others like to have
the computer do it. Animate Pro lets you have Stop-Motion and Motion keyframes.

Stop-Motion Keyframes
A Stop-Motion keyframe means that there is no computer-generated motion between
two keyframes. The segment is constant or flat.

Constant Segment
Keyframe
Pops to next
position

Keyframe

Motion Keyframes
A Motion keyframe means that there is computer-generated motion between two
keyframes. The segment has a variation over time.

Keyframe
Gradually moves to
the next position

Keyframe

Keyframe
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Toggling Between Motion and Stop-Motion Keyframes
You can switch a keyframe between Stop Motion and Motion at any time in the Timeline
view and Function Editor.
To toggle between Motion and Stop-Motion in Timeline View:
1. On the right-hand side of the Timeline, select one or more keyframes to be
modified.

2. To toggle between Motion and Stop-Motion:






Right-click (Windows) or [Ctrl] + Click (Mac OS X) on the selected keyframes and
select Set Motion Keyframes or Set Stop-Motion Keyframes.
The default keyboard shortcut are [Ctrl]+[K] (Windows) or [a]+[K] (Mac OS X)
and [Ctrl]+[L] (Windows) or [a]+[L] (Mac OS X).
You can also click on the Motion Keyframe
and Stop-Motion Keyframe
buttons available in the Timeline View toolbar.
In the Camera view, select the keyframe to convert and in the Coordinates and
Control Point view, enable or disable the Stop-Motion Keyframe option.

To toggle between Motion and Stop-Motion keyframes in the Function Editor:
1. Open the Function Editor
2. In the Timeline view, double-click on the layer that contains the keyframes that you
wish to convert.
The Layer Properties dialog box opens.
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3. In the Transformation tab, click on the Function Editor
Editor Window.

button to display the

OR
1. In the Timeline view, click on the Expand Function
function to edit.

button and double-click on the

The default keyboard shortcut is [Alt]+[F].
2. Select one or more keyframes to be modified on the Function Curve.

3. Enable or disable the Stop-Motion Keyframe option to set a Stop-Motion or Motion
keyframe.
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Animating the Camera
Just as in a live-action film, scenes are not only composed of characters moving around
in a static camera field, but also of camera movements. Although it is not always
something that we think about, often it is the exact opposite, the character is static while
the camera moves through elements on the stage. Camera pans, jumps, cuts and zooms
are as important to storytelling as the story itself.
Animate Pro has a camera that can move along the X, Y and Z axes. Having the camera
move on the Z-axis offers the possibility to create truck in and truck out, as well as
multiplane camera moves. The default camera position is centred and backed up to 12
fields.

The camera is treated the same way as any other element. The same tools and selection
modes are used to offset or animate it. To animate the camera, you need to connect it
to a peg element.

This means that you can animate the camera visually, with the function curve, or by
typing values in the Xsheet column.
To add a camera with a peg to your scene:
1. If you do not already have a camera layer, add one in one of two ways:


From the top menu, select Insert > Camera



From the Timeline view layers toolbar, click on the Add Layers
button and
select Camera from the menu that appears.
In Animate Pro, you can select a Camera module from the Library view and drag
it to your Network view.



A new camera layer will be added to your scene and will appear in the Timeline
view.
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2. From the Timeline View Layer toolbar, click on the Add Peg

button.

A Peg layer appears directly above the Camera layer so that the Camera layer is
automatically attached to it.
The Peg layer automatically takes on the name of the camera and adds the suffix -P
to indicate that it is a peg layer, for example Camera-P.

If the new Peg layer did not appear directly above the camera, you may have clicked
elsewhere in the scene, deactivating the layer you wanted to add the Peg layer to.


Select the Camera layer and drag and drop it under the new Peg layer.

OR




Delete the misplaced Peg layer, select the Camera layer and re-click on the Add
Peg
button.
In Animate Pro, you can select a Peg module from the Library view and drag it to
your Network view and then you can connect the Peg’s Out Port to the Camera’s
Input port.

You are now ready to animate your camera.
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Make use of both the Top view and Camera view while making camera moves. You can
open this view is one of two ways:



From the top menu, select Windows > Top.
From any existing window already open in your project, click on the Drop-Down
Arrow

button from the top right-hand corner and select Top from the menu.

The Top view now appears as a tab in that view.

Camera

To animate your camera:
1. Make sure that both the Animate
activated.

button and the Transform

Tool are

2. In the Top view, select the camera (the large V-shape on the right-hand side) and
move it to the desired position.

3. In the Timeline view, click on a cell in the Camera Peg layer where you would like the
camera move to begin.
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4. Right-click (Windows) or [Ctrl]+ Click (Mac OS X) and select Insert Keyframe from
the menu that appears.

A keyframe now appears in that cell. Any frames preceding this keyframe cell will
hold the same camera position as in this keyframe.
5. Click on another cell, further down your scene’s Timeline, where you would like the
camera move to end.
6. Select the camera in the Top View and move it to the position you desire.

A second keyframe appears and a line is created between the two frames to
indicate that the subsequent motion between the frames will be calculated and
rendered by the program.
7. Play back

the camera move in the Camera view to watch the results.

Modifying a Path in the Camera View
Although the example cited in the Animating the Camera section seems simple enough,
camera moves and motion paths can become complex, especially with moves through
3D space. That is why Toon Boom has developed a way to view your camera’s path and
make adjustments to it from both a 2D and 3D perspective.

Displaying a Path in the Camera View
You can display the trajectory for your motion path when you select an object in the
Timeline or Camera view.
To view your layer’s trajectory using the Control command:
1. Verify that the Camera view (click on its tab) is selected and that the layer that you
wish to display the trajectory of is selected in the Timeline view.
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2. From the Top menu, select View > Show > Control. The default keyboard shortcut
is [Shift]+F11.

NOTE: If nothing appears in the Camera view, you may not have animated or selected
the layer.
To hide your layer’s trajectory:
1. Verify that the Camera view (click on its tab) is selected and that the layer that you
wish to hide the trajectory of is selected in the Timeline or Camera view.

2. From the top menu, select View > Show > Control. The default keyboard shortcut
is [Shift]+F11.
3. If you want to hide all of your trajectories at once without selecting any layer, select
View > Hide All Controls. The default keyboard shortcut is [Shift]+[C].
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Shaping a Path
A motion path is as easy to manipulate as shaping the vector points of a drawing layer
in the Camera view. One important concept to understand is that a trajectory contains
both Keyframes and Control points. Both can be used to shape a path, each have their
own significance and behaviour, however only keyframes appear in the Timeline view.
Their descriptions, in terms of their use along a path, are listed below:
•

Keyframe: a marker that signifies a change (size, position, direction, etc.) along
the normal of a path or function and has an exact position and frame.

•

Control Point: has a position but no fixed frame or timing. It is mainly used to
deform a trajectory. There are no velocity handles available on a control point.
The velocity segments are set between keyframes only, making curves and
trajectories much smoother. Control Points can only be added on 3D Path.

To resize an entire animation path so it fits into your scene’s composition better, convert
the animation into a Symbol, then resize the Symbol itself.

Adding Control Points
A Control Point has a position but no fixed frame or timing. It is mainly used to deform
a trajectory. There are no velocity handles available on a control point. The velocity
segments are set between keyframes only, making curves and trajectories much
smoother.
A Control Point will not show in the Timeline view because it has no precise frame to be
displayed on. It will appear on the function curve and in the Camera view. There are
different ways to add control points:
•

Display the trajectory in the Camera view and pressing the keyboard shortcut [P].

•

Add a keyframe on the function curve and disabling the Lock in Time option.

The Control Point is displayed as a circle.
You can display your trajectories in the Camera, Top and Side views to better understand
the way that your elements move in your scene. This also makes it easier to modify them.
You can display a peg or layer’s control to be able to see where your elements are going,
modify the curve and add keyframes and control points.
To add a Control Point on a trajectory:
1. In the Timeline or Camera view, select the peg or layer you want to add the control
point on.
2. If the selected element’s trajectory is not displayed, select View > Show > Control
in the top menu. The default keyboard shortcut is [Shift]+[F11].
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The Trajectory appears in the Camera, Top, Side and Perspective views.

3. You can add control points on a 3D path trajectory by placing your mouse where
you want to add the point and pressing the keyboard shortcut [P].

Adjusting the Tension, Bias and Continuity
You can edit keyframes and control point parameters, such as the position, continuity,
bias, tension and lock in time using the Coordinates and Control Point view.
Each time a keyframe or a control point is selected in the Camera, Timeline or Xsheet
view, its parameters appear in the Coordinates and Control Point view. You can also see
the same information in the Coordinate and Control Point toolbars
You can adjust these parameters on existing Control Points and Keyframes by selecting
the point in the Camera View with the Transform
Tool.
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•

Continuity: controls the smoothness of a transition between the segments
joined by a point.

•

Tension: controls how sharply the path bends as it passes through a control
point or keyframe.

•

Bias: controls the slope of the path so that it flows towards one side of the
motion point or the other.

If you find that you are using the same Continuity, Tension and Bias settings, you can set
a preference to remember your settings.
To adjust the Point Setting Preferences:
1. From the top menu, select Edit > Preferences (Windows) or
Animate Pro > Preferences (Mac OS X).
The Preferences window opens.
2. From the top of the Preferences window, select the Camera tab and look to the
entire right-hand section of that panel.
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Modifying a Path in the Timeline View
When you select a peg or drawing layer in the Camera view and move it around, Animate
Pro will automatically create the corresponding function curves.
If you would then like to modify these functions, you can always do it through the Peg
or Layer parameters in the Timeline view.

Creating a Function
To create the function curve in the Timeline view:
1. Double-click on either a drawing or peg layer.
The Layer Properties dialog box appears.

2. Identify the section of the type of function that you want to create.
3. Click on the Function Arrow button at the end of the corresponding row.

4. Choose Create a Bezier or Ease curve from the menu.
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Adding and Deleting Keyframes in the Timeline View
To insert a Keyframe:
1. On the right-hand side of the Timeline, select a cell on the layer’s function that you
want to animate.

2. Right-click (Windows) or [Ctrl]+Click (Mac OS X) the selected cell and select Insert
Keyframe. The default keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac
OS X).
To delete a Keyframe:
1. On the right-hand side of the Timeline, select a cell with the Keyframe that you want
to delete.
2. Right-click (Windows) or [Ctrl]+Click (Mac OS X) on the selected Keyframe and
select Delete Keyframes from the menu that appears.
3. You can [Shift]+Click on several keyframes to select a group before selected the
Delete Keyframes option.
4. If you select a Keyframe or group of Keyframes and press [Delete], it will also delete
the corresponding drawings on that cell.

Changing Keyframe Values
To change the keyframe values in the Timeline:
1. Open the layer’s parameters by clicking on the Expand Function button next the
layer’s name. The default keyboard shortcut is [Alt]+[F].
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2. Click on the Show/Hide Data View
button at the top of the Timeline view,
between the layer names and the timeline fields.

3. Select the parameter that you want to create a function curve for: Path, Velocity,
Scale; x or y, Angle or Skew. For this example we will use Velocity.
4. Pass the cursor over the blue number value of the parameter layer being modified.


Wait until the cursor changes to a white hand with a two-way arrow and then
click and drag the hand slightly to the left or right to decrease or increase the
value.

OR
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Click directly on the blue number and enter a value into the field that appears.
If you selected the keyframe in the Camera view, you can modify the values in
the Coordinate and Control Points view.
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A function automatically is created as soon as the values have changed from zero.
In Animate Pro, you can see the same information in the Coordinates and Control
Points view.
5. Press [Enter] or click on the Play
the Camera View.

button to view the changes you have made in

Copying and Pasting a Motion
In the Timeline view, you can easily drag keyframes to change the animation timing,
delete them, cycle them and even copy them.
You can use the Paste Cycle and Paste Reverse feature to cycle your selection including
keyframes and drawings.

Paste Cycle
If you want to cycle a portion of your animation, you can use the Paste Cycle command.
To use the Paste Cycle command:
1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.
2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Cycle. The default keyboard shortcut is
[Ctrl]+[/] (Windows) or [a]+[/] (Mac OS X).
The Paste Cycle dialog box opens.

5. In the Number of Cycles field, use the up and down arrow to increase or decrease
the amount of cycles you want to paste. You can also directly type the value.
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6. In the Cycle Type drop-down menu, select the type of cycle you want to paste.






Normal (forward): This pastes your selection as it is, starting with the first cell and
ending with the last one.
Reverse: This pastes your selection reversed, starting with the last cell and
ending with the first one.
Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first
cell, going to the last one and ending with the first cell.
Reverse -> Forward: This pastes your selection as a reversed yo-yo, starting with
the last cell, going to the first one and ending with the last cell.

7. Click on the OK button to paste your cycles.

Paste Reverse
You can also use the Paste Reverse command to completely reverse the flow of your
animation.
To use the Paste Reverse command:
1. In the Xsheet or Timeline view, select the cell range and keyframes to paste
inverted.

2. In the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.
4. In the top menu, select Edit > Paste Reverse. The default keyboard shortcut is
[Ctrl]+[?] (Windows) or [a]+[?] (Mac OS X).
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Adjusting the Velocity
To add ease in and ease out on your motion paths, you can display the function curve
and modify the Bezier or Ease curve. To apply an ease to multiple functions and
keyframes, you can use the Set Ease For Multiple Parameters script and set the amount
desired.
The Velocity, or ease, is used on motion keyframes. The Velocity has to be adjusted
directly on the function curve in either the Function view or the Function editor. When a
keyframe is selected, easing values appear in the right handle and left handle fields, as
well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them to
adjust the ease in and ease out, or type values in the fields.
To display the velocity curve:
1. In the Timeline View, click on the Expand Function
functions.

button to display the layer’s

2. Double-click on the desired function.

The Function Editor opens.
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The editor will not be displayed if the function does not already exist.
You can reshape the function using either the Bezier or Ease controls.

To reshape a function using Bezier controls:
1. Click on the keyframe to select it.
2. Drag the handles to modify the shape of the curve.
3. The Continuity options, Corner, Straight and Smooth, influence how you can move
the handles.




Straight: allows you to move the handles together, maintaining the same angle
to the point.
Corner: allows you to move the handles independently.
Smooth: allows you to move the handles together, maintaining the same
distance and angle to the point.

To hold the same value over several frames:
1. Click the Hold Value Editor

button.

The Hold Value editor opens.

2. In the Hold Value Editor, enter the following values:
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In the Start field, enter the starting frame for the effect.
In the Stop field, enter the last frame for the effect.
In the Step field, enter the number of frames that you want to hold the value for.
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The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity so that the values are interpolated
(tweened) consistently between keyframes (that is, there is no acceleration in the effect).

421

Animate Pro 2 - Student Workbook

Activity 1: Spaceship and Planets

This advanced activity will provide you with a good overview of many compositing
settings and also show you some useful tricks which will help when you are working on
an animated scene.
We will be working on a space project, in which a spaceship will travel through a scene
filled with planets, asteroids and stars.
To open the sample project:
1. First, launch Animate Pro.
2. In the Welcome Screen, click on Open Scene, and select the
Spaceship_and_Planets.anim project from the sample material provided.
3. In the sample material you will find a scene with several layers. All of these layers are
already named. Make sure you become familiar with all of them.
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Positioning the Elements
You will also notice that all the elements are out of position and placed in the middle of
the scene. As you go through this activity you will need to reposition and organize them.

To position the elements:
1. To position the elements, you will use the Transform

Tool.

Before you use the Transform tool, make sure the Animate
OFF.

mode is turned

2. Now, move all of the elements and place them in the positions where you want
them in the scene.
As you move them, remember that your spaceship will be flying through the scene,
so overlap the planets a little to make the animation more interesting.
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Setting the Exposure
The whole scene should last at least 4 seconds. That’s 96 frames.
To set the exposure
1. In the Timeline view, extend your scene by dragging the red bracket to frame 96.

At the moment, all of the elements in the scene have only 1 frame. You will need to
extend the exposure of each of those drawing layers, except for the Propulsion layer
which we will do differently.
2. In the Timeline View, select the last frame of all the drawing layers, except for the
Propulsion layer.

3. Right-click (Windows) or [Ctrl] + click (Mac) and select Extend Exposure. All of your
drawing layers should now extend up to frame 96.

Now you have extended the drawing layers it is time to work on the Propulsion layer.
4. The Propulsion layer is an animation cycle, so you will have to repeat the cycle all
the way to frame 96. Select the drawing cells in the Propulsion layer. Right-click
(Windows) or [Ctrl] + click (Mac) the selection and select Create Cycle.
The Create Cycle window opens.
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5. In the Number of Cycles text field, enter 12, then click on OK.

The Propulsion animation cycle should now be extended up to frame 96.

Adding the Camera
Notice that the Camera layer is not included in the scene. You should go ahead and add
that layer now.
To add the Camera layer:
1. In the Timeline view, click on the Add Layer
the list.

button, then select Camera from

2. The Camera will also need a Peg. First, select the Camera layer.
3. Then in the Timeline view, click on the Add Peg

button.

The Peg will be automatically attached to the camera and renamed as Camera-P.
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Creating a Multiplane
For the camera to travel through the scene, the planets need to be positioned on
the Z-axis.
To set the multiplane:
1. Open the Top view, if you haven’t done so already. You will also need the Advanced
Animation toolbar.

2. Select the Maintain Size
back to the Top view.

tool from the Advanced Animation toolbar and go

3. In the Top view, you will move each element into its correct position.
It should look something like this:

Remember that this is your first setup.
If, during the exercise, you notice that one or more elements need to be moved
closer or further away from the camera, you can always go back and make changes.
But remember to use the Maintain Size
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Animating the Camera
You are now ready to make the camera move in the scene.
To animate the Camera
1. In the Timeline view, go the first frame of the Camera Peg layer.

2. Right-click (Windows) or [Ctrl] + click (Mac) and select Insert Keyframe.
3. Repeat this step for the last frame of the peg.
4. With the Transform

Tool, move the camera on the Z-axis.

Before you use the Transform tool, make sure the Animate
ON.

mode is turned

5. In the Timeline view, go to frame 96 of the Camera Peg.
6. In the Top view, move the Camera Peg until you have passed most of the planets.
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The two keyframes are now set.


To see the camera move, you will need to set the keyframes to motion
keyframes. In the Timeline view, right-click (Windows) or [Ctrl] + click (Mac)
keyframe on frame 1 and select Set to Motion Keyframe.

7. You can play your animation with the Play
truck in.

button for a preview of the camera

Animating the Spaceship
You probably remember at the start of the exercise that the spaceship, and not just the
camera, was supposed to travel through the scene. This is easy to do.
To animate the spaceship:
1. Go to the Network View. You will see the Camera and it’s Peg are connected
together. All you have to do is to connect the Spaceship module and the Propulsion
module to the Camera-P module.
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2. Go back to the Camera view and play your animation once again, you will see that
the spaceship and the camera are now travelling through the scene.

The camera’s trajectory is straight ahead, next you will add a curve to the camera
move.
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3. In the Top menu, select View > Show > Control. This will make the Camera Peg’s
path appear in the Top and Side views. Make sure your Camera Peg layer is selected
before choosing this option.

4. To add control points to the path, in the Top view, place your mouse pointer on the
correct section, then press [P] on your keyboard.
You can then click and drag the control point to give a nice curve to the path, as
shown in this example:

Control points
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5. Go to the Side View. Notice that the control points are shown here as well. You can
move the control points around to create a nice up and down movement.

6. Click on the Play
button to check your animated scene and see whether or not
the spaceship moves the way you want it to. Notice how much smoother your
spaceship moves.
If you don’t like the way the spaceship moves, you should change the position of the
control points now.
At this point you may notice that the spaceship goes right through some of the planets.
This is not what you want. The spaceship should rotate to pass around the planet as it is
moving forward. Well, that is easy to fix by adding an extra peg to the Spaceship and
Propulsion layers.
7. In the Timeline view, select the Spaceship layer, then click on the Add Peg
button.
8. In the Timeline or Network views, connect the Propulsion layer to the Spaceship-P
peg layer.

Now your spaceship has its own peg. You can make it rotate left and right
throughout the scene.
9. In the Timeline view, right-click (Windows) or [Ctrl] + click (Mac) on a frame from the
peg.
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10. Select Insert Keyframe from the pop-up menu to set keyframes on the spaceship’s
movement at specific moments in your scene.

11.While on one of those keyframes, go to the Camera view, and rotate the spaceship.
To rotate your spaceship, use the Transform

tool.

Before you use the Transform tool, make sure the Animate

mode is ON.

12.Once the keyframes are ready, you can set all those keyframes to Motion
Keyframes.

If you play back your animation again, you will see that the rotations need some fine
tuning. Do this by going to the Bezier Editor.
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13.In the Timeline view, click on the Expand

button for the Spaceship-P peg.

14.From the list, double-click on the Rotation:Angle_z layer.

This will display the Bezier Editor for rotation only.

You will notice in the Bezier Editor, that each of the keyframes on the peg has a
control point.
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15.Drag the handles to give it a smooth curve, this will give the spaceship a more fluid
rotation.

16.Click on Close when you have finished editing the Bezier curves.
17.Preview your animation again to see if there are any more adjustments to be made.
18. Save your work by clicking on the Save
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button.

M20: Basic Multiplaning and Camera
Movement

Multiplane is one of the most exciting effects you can add in a project. In the Multiplane
you can create backgrounds in several layers, spread them on the Z-axis, add depth, and
then move the camera through this environment to create an impressive perspective
illusion.
This module is divided into the following topics:
•

Theory, on page 436

•

Activity 1: Setting the Multiplane Space, on page 437

•

Activity 2: Moving the Camera, on page 441
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Theory

To construct a multiplane, you must imagine what a real environment is like. Take a look
at this picture and imagine the camera moving across the space. You will notice that
objects in the picture will move at different speeds depending on where they are in
relation to the camera lens.
In this picture the moon is almost stationary and the tower in front of it is moving very
slowly. But the tower closest to the foreground is moving faster and the plant in the
foreground is flying by really quickly.
Building a multiplane requires an understanding of your background and which object
should be placed in the different layers. You want to separate all the main elements, but
not every small object.
For example, in this background, the main objects to be separated are:
•

Fern

•

Front tower

•

Second tower

•

Moon

•

Stars

•

Sky

However, some objects are not separated, such as the plants and the front tower or the
roof and the second tower. Each layer must be a complete drawing. For example, even
if the bottom of the tower is hidden behind the plant and the ladder at the moment, you
may need the hidden portions later on in the scene.
If you move a camera over a drawing, all the objects in the drawing move at the
same speed. If you move the camera across the room, you will see all the objects are
moving at different speeds, producing a depth effect.
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Activity 1: Setting the Multiplane Space
In this activity, you will learn how to use a multiplane scenes for further use with camera
moves.
Material provided for this Lesson:
•

The sample material for this activity contains the drawings of a background
separated on several layers. You will use this background to experiment with
multiplaning and camera movements.

•

There is also a completed multiplane scene that you can compare your work with
once it is finished.
You should not look at these until you have finished your experiments.

Prepare your Material
Begin the experiment:
1. Launch Toon Boom Animate Pro.
2. In the Welcome Screen:





Browse to the location specified by your teacher. This is where your project will
be saved.
Name your project: Multiplane, followed by your initials.
Make sure to select the resolution the Resolution List.
Click on the Create button.

3. Click on the Save

button to record your project.

4. Click on the Library view tab to display the Library view. It is situated behind the
Tool Properties view.

5. In the Library view, browse the template folders.
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6. From the Multiplane folder, select and drag the Multiplane template into the
Camera view.

7. The background will appear in the Camera view and the different drawing layers will
be made available to you in the Timeline view.
8. Save
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your project.
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Setting the Multiplane Space

By default, all of your layers are set at the same distance. They are all located at “0”. You
can see it better in the Perspective view.
1. To open the Perspective view, select Windows > Perspective.
2. In the Tools toolbar, select the Rotate View
tool. The default keyboard shortcut
is [Ctrl]+[Alt] for Windows® or [a]+[Alt] for Mac OS® X.
3. In the Perspective view, rotate the stage to view the 3D space.

Use the default keyboard
shortcut [Ctrl]+[Alt] in Windows® or
[a]+[Alt] in Mac OS® X to rotate the
Perspective view.

4. Save

your project!
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Using the Top view
To set the Multiplane, you will use the Top view.
In the Top view, you can see the camera
cone and all the layers set at the same
distance.

This is the camera cone!

1. To display the Top view, select Windows > Top.
2. In the Tools toolbar, disable the Animate
mode. This is very important, if you
do not disable the Animate mode, you will create a keyframe and a movement on
your layer.
3. To display the Advanced Animation toolbar, select
Windows > Toolbars >Advanced Animation.
4. In the Advanced Animation toolbar, select the Maintain Size
tool. This tool
scales your layer as you move forward or backward in the Top view.
5. In the Top view’s left side, select the layer you want to move.

6. In the Top view’s right side, move the selected layer up to push it backward, or
down to bring it forward. It is possible that you will not see the selected layer, but
you can still move it.
7. Save
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your project!
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Activity 2: Moving the Camera

Since you will animate the camera over time, you will need to extend your layers’
exposure. The camera is a static element, to animate it you will need to add a trajectory
layer called a Peg.

Extending the Exposure and Preparing the Camera
1. In the Timeline view, select the last frame of each layer and press [F5] to extend the
exposure until the end.

[F5]

2. In the Timeline view, click on the Add Layer
the drop-down menu.

button and select the Camera from

3. In the Timeline view, select the Camera layer.
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4. In the Timeline toolbar, click on the Add Peg

5. Save

your project!

You can animate the camera using the Translate
Scale

button.

tool, Rotate

tool and

tool available in the Advanced Animation toolbar.

Animating the Camera
1. In the Tools toolbar, enable the Animate

mode.

2. In the Advanced Animation toolbar, select the Translate

tool.

3. In the Timeline view, go to the first frame and select the Camera’s Peg.
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4. In the Top and Camera view, reposition the Camera’s Peg.

Be careful so that you do not show parts of your graphics that
you should not! Everything within the yellow rectangle will be shown
in the final project.
5. In the Timeline view, go to the last frame.

6. Select the Camera’s Peg and position it closer to the background in the Top view
and Camera view.
7. In the Playback toolbar, click on the Play
8. Save

button to view your animation.

your project.
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M21: Setting up 3D Space

In this lesson, you will learn how to set up your scene in the 3D Space to create a
multiplane or a 3D set. Toon Boom is well known for its multiplane space, or Z-depth. In
the Multiplane you can create backgrounds in several layers, spread them on the Z-axis,
add depth, and then move the camera through this environment to create an impressive
perspective illusion. You can create backgrounds, use a layered PSD file or use a project
from the sample material package.
Animate Pro brings you a true three-dimensional space where you can actually rotate
your camera and layers on all axes. This permits you to perform a 360 degree rotation
around your elements, create a floor and even build sets.
This module is divided into the following topics:
•

Theory, on page 446

•

Activity 1: The 3D Room, on page 471
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Theory
This topic is divided as follows:
•

Top View and Side View, on page 446

•

Perspective View, on page 447

•

Setting Up the Multiplane, on page 448

•

Distributing Elements on the Z-Axis, on page 449

•

Enabling the 3D Option, on page 450

•

3D Tools, on page 455

•

Positioning Elements in 3D Space, on page 460

•

Using Complex Sets in Production Scenes, on page 463

•

3D Camera Motion, on page 467

Top View and Side View
The Top and Side views are used mainly for multiplane scenes and to position elements
in 3D Space. They allow the scene’s stage to be seen from the top or the side. This allows
the camera cone and the spacing between the different elements to be seen.
1. The camera cone represents the camera’s field-of-view (FOV).
2. A thumbnail of each drawing layer in your scene. The order of the thumbnail images
is based on each element’s FB position in the scene space. You can see a
representation of the Forward Backward position of each layers within the camera
cone.
3. The Top and Side View toolbars include five buttons by default:
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No Z Dragging: Enable this button to prevent reposition the Z-axis value of your
drawing layers. You can also select Animation > No Z Dragging from the top
menu.
Insert Keyframe and Remove Keyframes: Use these buttons to insert of delete a
keyframe for your animation.
You can also select Insert > Keyframe from the top menu, the default keyboard
shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X).
You can also select Animation > Delete Keyframe from the top menu, the
default keyboard shortcuts are [Shift]+[F6] or [F7].
Select Previous Keyframe/Point and Select Next Keyframe/Point: Use these
buttons to navigate through your keyframes and control point on your animation
path.
You can also select Animation > Select Previous Keyframe/Point from the top
menu, the default keyboard shortcut is [;].
You can also select Animation > Select Next Keyframe/Point from the top
menu, the default keyboard shortcut is [‘].

Setting up 3D Space

Perspective View
The Perspective view is used during scene setup. It allows you to see your multiplane
scene’s orientation. The Perspective view is similar to a 3D display, as it lets you rotate
your scene through all possible angles to understand the spacing between the elements.
You can also position and rotate your layers and the camera inside the 3D display to
achieve some 3D setup and camera moves.
1. The blue circle represents a rotation of the X and Y axis plane.
2. The red circle represents the rotation of the Y and Z axis plane.
3. The green circle represents the rotation of the X and Z axis plane.
4. The grid is a perspective grid reference.
5. The axis reference arrows let you maintain your orientation when navigating inside
the Perspective view.
6. There are three view option buttons displayed in the lower left corner of the view.




Show/Hide Camera: Use this button to show or hide the camera frame in the
Perspective view.
Reset View: Use this button to reset the Pan, Rotation and Zoom of the
Perspective view.
Reset Rotation: Use this button to reset the rotation of the Perspective view.

7. The first field at the bottom of the window displays the current zoom level in the
Perspective view. You can use the Zoom level drop-down menu to select a specific
zoom level from the list. Zoom levels from 2.5% to 6400% are available, you can also
select Fit To View to automatically use a zoom level that lets you see all of your
scene layers and information in the Perspective view at once.
8. The second field displays the currently selected layer and drawing name.
9. The third field displays the currently selected tool.
10.The fourth field displays the currently selected frame of your animation.
11.The fifth field displays the current position of your cursor inside the Perspective
view.
To rotate a scene in the Perspective view:
1. In the Tools toolbar, select the Rotate View tool.



Click in the view, and drag your cursor around to rotate the view.
Press and hold [Alt]+[Shift] and click and drag to rotate the view one axis at a
time.
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Setting Up the Multiplane
To construct a multiplane, you must imagine what a real environment is like. Take a look
at your background picture and imagine a camera moving across the space. You will
notice that objects in the picture would move at different speeds depending on where
they are in relation to the camera lens.
Building a multiplane requires an understanding of your background and which object
should be placed in the different layers. You want to separate all the main elements, but
not every small object.

For example, in this background, the main objects to be separated are:
1. Fern
2. Front tower
3. Second tower
4. Moon
5. Stars
6. Sky
Although the bottom of the tower is hidden behind the plant and the ladder, each of
your multiplane layers should be a complete drawing. This is because hidden portions
may show up during a camera movement later on in the scene.
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Distributing Elements on the Z-Axis
Now you can place the layers along the Z-axis to set the distance between them. Make
use of the Side and Top views to position the layers.
Positioning an element closer the camera will make the element bigger. Using the
Maintain Size tool, you will be able to drag your element toward the camera while
keeping the same aspect ratio in the Camera view.
NOTE: It is a good idea to keep a Camera view opened to see what your scene looks
like while positioning your element in the Top or Side view.

Positioning Elements in the Top and Side Views
To position your element in the Top and Side views:
1. In the Advanced Animation toolbar, select the Maintain Size tool. The default
keyboard shortcut is [Alt]+[6].
2. In the Side view, select one of the layers in the thumbnails section of the Top or Side
view. You can also select your layer from the Timeline view.
The selected layer will be highlighted in the camera cone.
3. Click and drag the layer to the correct depth position in the camera cone. Your
element aspect will remain the same in the Camera view.
4. In the Tools toolbar, select the Transform tool, or select the Translate tool in the
Advanced Animation toolbar and select a layer from the thumbnails section of the
Top or Side view. You can also select your layer from the Timeline view.
If you choose the Transform tool, make sure that the Peg Selection Mode option is
disabled in the Transform Tool Properties view.
The selected layer will be highlighted in the camera cone.
5. In the Top view, drag the element sideways to position horizontally. You can press
and hold [Shift] while dragging the element to make sure it only moves along the Xaxis.
6. In the Side view, drag the selected element up or down to position it vertically. You
can press and hold [Shift] while dragging the element to make sure it only moves
along the Y-axis.
NOTE: To maintain the size of your element when positioning it along the Z-axis in the
Top or Side view, you can also press and hold [Shift]+[Alt] while using the Transform tool.
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Enabling the 3D Option

By default, when you create layers in Animate Pro, you can only move them as flat layers.
To rotate layers in three axes instead of two, you must enable the 3D option in the layer
properties.
To enable the 3D option:
1. In the Timeline view, select the layer you want to move in the 3D space.

2. Click on the selected layer once to display its properties in the Layer Properties view
or double-click on it to open properties in a dialog box.
3. In the Layer Properties dialog box, click on the Transform tab.

4. Click on the Enable 3D option checkbox to display the 3D parameters for that
particular layer.
5. Click on the Close button.
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New parameters appear in the Layer Properties window showing the 3D
parameters.
Layer Properties window
showing the 3D parameters

3D Parameters
When you enable the 3D option, you will notice that three sets of parameters are
modified:
•

Scale

•

Rotation

•

Pivot

Scale

Locked 3D Scale

Separate 3D Scale

When the 3D option is enabled, the Z-axis parameter is added to the list of settings. You
can either have the Scale to be locked or separated.
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When the Scale is locked, the object you are scaling is uniformly resized in three
directions.
When the Scale is separated, the object you are scaling can be squashed and stretched
in any direction without affecting the other ones.

Two-dimensional Scale

Note: you cannot add thickness to an object by scaling in the third dimension. Threedimensional scaling is used to scale objects that were rotated on their axes or group of
objects laid out in three-dimensions.

Three-dimensional Scale
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Rotation

Rotation is the main parameter you will use when working in 3D. Without using the 3D
rotation, you are simply working using the multiplane technique.
3D rotation can be used in two ways:
•

Quaternion Rotation

•

Euler Angles Rotation

Quaternion Rotation

Quaternion Rotation is very similar to the 3D path position parameters. A Quaternion is
composed of three rotation functions: X, Y and Z to be able to rotate on three axes and
a velocity one controlling the rotation. These X, Y and Z functions are linked together,
when you add a keyframe on one of them it also adds it on the two others.
If you are planning to animate an element such as the camera, you should use the
Quaternion rather than the Euler Angles. Quaternion creates smooth trajectory and
interpolation since the path is controlled by the same keyframes and a single velocity.
Euler Angles Rotation

The Euler Angles Rotation is very similar to the Separate position parameters. The Euler
Angles parameter is composed of three functions: X, Y and Z to be able to rotate on the
three axes. The three functions are independent from one another, each having its own
velocity.
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When you add a keyframe on one function the other ones do not receive it, allowing you
to control each axis independently.
Euler Angles are principally used to position elements with specific coordinates and
rotating elements on a single axis. The interpolation between the keyframes will not be
as smooth as the Quaternion ones since each function works individually.

Pivot

When you enable the 3D option, the drawing or layer pivot becomes a location that can
move on three axes. When you work in two-dimensions, the pivot is mainly an anchor
point somewhere in the drawing from where the transformations will be performed.
Once you switch to the 3D mode, the transformations are made on three axes, so the
centre of rotation and scaling also becomes three-dimensional.

By default, the pivot is positioned at the centre of the stage: (0,0,0). When you use the
Pivot tool to reposition the centre of transformation, the pivot position is changed on
the X and Y axes, but the Z-axis remains at zero until you change it in the Top, Side or
Perspective view using the transformation tools.
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3D Tools

Enabling the 3D option changes the Transform tool and the transformation tools found
in the Advanced Animation toolbars into 3D transformation tools. You can now
manipulate elements on the X, Y and Z axes.
You will see here how the following tools behave in 3D mode:
•

Translate Tool

•

Rotate Tool

•

Scale Tool

•

Transform Tool
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Translate Tool

When you enable the 3D option, the 3D Translate tool becomes available and axis
direction arrows appear around the pivot points.
You can click on the direction arrows to move your layer onto an axis. If you click
anywhere else, the layer can move freely on two axes at once. Selected arrows turn pink.
Note: if you move the layers in the Perspective view, it maybe difficult to control the
motion since your point of view on your stage may not be the best one to understand
the setup, so it is best to use the direction arrows.
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Rotate Tool

Once you enable the 3D option, the 3D Rotate tool becomes available and a rotation
sphere appears around the pivot points indicating the different axes.
You can click on the direction ellipses to rotate your layer on an axis. If you click anywhere
else, the layer rotates freely on two axes at once. Selected ellipses turn pink.
Note: if you move the layers in the Perspective view, it maybe difficult to control the
motion since your point of view on your stage may not be the best one to understand
the setup, so it is best to use the direction ellipses.

457

Animate Pro 2 - Student Workbook

Scale Tool
Once you enable the 3D option, the 3D Scale tool is available. You will see one of two
things:
•

A scaling rectangle appears if your drawing is flat.

•

A scaling cube appears if your object has some rotated layers around the pivot
points, indicating the different axes.

Click on one of the three control points to scale the shape on an axis. Hold down the
[Shift] key to proportionally scale the object. Selected control points turn pink.
Note: if you move the layers in the Perspective view, it maybe difficult to control the
motion since your point of view on your stage may not be the best one to understand
the setup.
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Transform Tool

Once you enable the 3D option, the 3D Transform tool become available. This tool is a
combination of the 3D Translate, 3D Rotate and 3D Scale tools.
•

To translate an element, grab the direction arrows the same way you would with
the Translate tool.

•

To rotate an element, grab the rotation ellipses the same way you would with the
Rotate tool.

•

To scale an element, grab the scaling control points the same way as you would
with the Scale tool.
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Positioning Elements in 3D Space

To position elements in 3D space, you need to understand what you what you are
building and how complex it is to create.
Simple sets like the above one are easy to build, light to manage and probably what you
will use 3D staging for most often.
If you have a project based in a room, it can be useful to build it in 3D. This saves you
having to redraw the background for each scene and it will be entirely vector based.
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Here are a couple of different backgrounds you can get from this set in only a few
seconds.

Planning Your Pieces
When you are building a room, there only a few pieces to prepare and it will be fairly
light to run. Most of the time one drawing layer per wall or part to be contained is
sufficient.

Map out the parts you need before you start to build the set
For a complex set, you need to plan more and, as it is a much more intricate design, it
will require careful thought. You not only have to list the pieces you need, but you also
need to think of what can be reused. If you have a series of windows, you do not want
to copy paste the drawing all over. Instead, you should create a Symbol out of it. This
way, if you need to make a correction to the design, you only need to do it once and it
will be corrected throughout. You can do the same for every piece of your set.
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Here is an example of all the source drawings required to build the castle.

These are the only drawings required to build the entire castle. Considering the final
result there are not many parts. The rest is constructed by assembling Symbols and
through reuse. However, keep in mind that although you are using simple drawings and
Symbols to optimize your set, the more your add to your project, the heavier the toll it
takes on your machine’s RAM. While the scene’s package itself is really light, running the
scene places heavy demands on the RAM and video card.
Using the drawings above, here are a couple of pieces that were put together.
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Using Complex Sets in Production Scenes

When your main set is built, you will want to store it in the Library. It is important to know
that when you import such a large structure in one of your production scenes, the set
maybe slow to run. To avoid long rendering sessions or slow manipulation, remove all
faces and planes that are not visible in your scene.

Positioning the Layers
Once you have your drawings and Symbols assembled, it is time to position them. This
section explains how this is done using the simple room shown previously.
To position your layers, you require the following elements:
•

Camera View

•

Top View

•

Side View

•

Perspective View

•

Library View

•

Timeline View

•

3D Transformation Tools

•

Layer Properties View or dialog box
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To position layers in the 3D space:
1. From the Library view, import the first Symbol to position into your Timeline view’s
left side.

2. In the Timeline view, double-click on the new layer to open the Layer Properties
dialog box.
3. In the Transformation tab, check the Enable 3D option.

4. In the Rotation section, enable the Euler Angle option.

5. Type 90 in the Rotation’s (x) Axis field to flip the floor so that it is flat on the ground.

6. To position the height of the floor, you can type values in the Position section of the
Layer Properties, use the 3D Translate tool or the 3D Transform tool.
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7. Repeat the process for the other pieces to import.
8. If you have parallel walls, once you have positioned one, select the Wall layer in the
Timeline view.
9. In the top menu, select Edit > Duplicate to duplicate the layer.

NOTE: If the drawing is contained inside a Symbol, the Symbol will not be duplicated,
only the layer containing the Symbol. This way you are still using the same drawing.
10.Once the layer is duplicated, use either the Layer Properties window to type the
positioning values, or use the 3D transformation tools.
11.When you are using the transformation tools, use the Camera, Top or Side view to
position the elements instead of the Perspective view to position your layers
precisely.
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12.If the walls are touching you should make them intersect by having an extra piece of
one wall extend through the other, this prevents any visible gap in the joint between
them.

Now have a complete 3D room.
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3D Camera Motion
Once you have a 3D set, the exciting part is to do a camera motion in it. This section
teaches you the main steps required to perform a 3D camera motion. Once you know
how to do this you can enjoy the delights of working in 3D space and travelling through
your creations.
To create a 3D camera motion:
1. In the Tool toolbar, enable the Animate

mode.

2. In the Timeline view, click on the Add Layers
a camera to your scene.

button and select Camera to add

3. In the Timeline view, select the new camera layer.
4. In the Timeline Layer toolbar, click on the Add
to the camera.

Peg button to add a parent peg

5. In the Timeline view, double-click on the new Peg layer to open the Layer Properties
dialog box.

6. In the Layer Properties dialog box, go to the Transformation tab and check off the
Enable 3D option.

7. In the Rotation section, enable the Quaternion option.
8. In the Perspective view, click on the Show/Hide Camera button to see your camera
cone.
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9. Setup your workspace to display the Camera view and Perspective view at the same
time so you can compare the results.

10.In the Tools toolbar, select the Transform

tool.

11.In the Timeline view, select the Camera-Peg layer first frame and select
Insert > Keyframe.

12.In the Timeline view, select the Camera-Peg layer.

13.In the Timeline view, go to the last frame.
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14.In the Perspective view, grab one of the rotation ellipses and rotate the camera on
only one axis. Always do one axis at the time, this keeps control of the positioning.

15.Once the camera is rotated to the correct angle, grab one of the direction arrows to
move the camera to the correct position.

16.In the Playback toolbar, press the Play button to see the result.
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Locking Flat Drawings to the Camera Angle

When you create a 3D camera motion in your scene, you will notice that layers are
treated as flat objects, animation layers that are supposed to face the camera at all times
will look like a flat sheet of rotating paper. Use the Ortholock layer when mixing flat
animation layers with a set built in 3D. Ortholock forces your drawing layer to always
follow the Camera angle. It does not follow its position or zooming level, only the
rotation. This prevents drawings from being distorted by the camera motion.
Note: adding an Ortholock layer in a Symbol will not give the proper result. The
Ortholock contained inside a Symbol does not consider the position of the camera
contained in the root scene. Keep your Ortholock layers in the root scene.
To add an Ortholock layer in Animate Pro:
1. In the Module Library view, go to the Move tab.
2. Select an Ortholock module and drag it to the Network view.
3. In the Network view, drag an output cable from the Ortholock module and connect
it to the module you want to keep facing the camera.
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Activity 1: The 3D Room

Learn how to build sets by rotating and repositioning planes in three dimensional space.
Apply textures, patterns and gradients and see them mapped in perspective onto your
drawing objects. Discover how to use a camera to explore the 3D area, including the use
of fully rotational pivots, as well as how to give the illusion of 3D by panning a multiplane’s layers.
You can practice this chapter on material you create from scratch or you can also use the
sample material.
Undone_example_Sample_material > Chapter3PRO_Sample_Material.tpl

Setting Up Your Workspace

You might be concerned that thinking in a 3D mind-set will be complicated. Never fear.
In this lesson, we will take you step by step on how to construct in and move through
this new frontier.
When you open the sample scene and look at it in the Perspective view, it will look like
the picture above, with all the layers flattened on the same x, y, z planes.
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In the Timeline view, take a moment to examine the layers and to get an idea of what
kind of movements you might need to make to separate them.

It will occur to you that the floor, ceiling, left and right walls need to rotate outwards at
a 90 degree angle from the Back_Wall.
To perform these operations, you will need the following views:
•

Layer Properties View

•

Perspective View

•

Top View

•

Side View



In the top menu, select Window > the desired window.

In the Layers Properties view, you will be able to set the position coordinates and enable
the 3D movements.
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The Side view allows you to see your scene’s elements from the side and move them on
the Y-axis and Z-axis.

The Top view allows you to see your scene’s elements from the top and move them on
the X-axis and Z-axis.
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Building the Structure

At this point, you should have all the layers necessary to build your 3D set. In this case,
we have three walls, a ceiling and a floor. Later on, we will also include an outdoor
background to see through the window.
By default, the 3D motions are disabled on your drawing layers, this prevents you from
accidentally rotating them when you need your drawings to stay perfectly flat and
aligned with the camera. So, when you want to rotate layers in the 3D space, you need
to enable the 3D motions.
To enable the 3D motions:

1. In the Timeline view, select the layer you want to enable the 3D motion for.
2. In the Layer Properties view, check the Enable 3D option.
You will notice a series of changes in the Layer Properties view, mainly regarding the
Rotation section. You now have the Quaternion and the Euler Angles options.
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There is a substantial difference between the Quaternion and Euler Angles options. They
will not be covered in this guide.
To give you a basic idea, you will mainly use the Quaternion rotation when you want to
create a smooth trajectory over the three axes, such as a camera move, and you will use
the Euler Angles when you have a precise position in mind for a stationary object such
as a wall.
To build our room structure, we will use the Euler Angles rotation.
To position the floor:
1. In the Timeline view, select the Floor layer.
2. In the Layer Properties view, check the Enable 3D option.
3. In the Rotation section, enable the Euler Angles option.
4. In the (x) Axis field, type -90 to give the backward rotation to the floor.
5. In the Position section, enable the Separate option to control the three axis
separately.
6. In the (y) Axis field, type -12.25 to send the floor to the ground.
Rotation
(x) Axis: -90

Position
(y) Axis: -12.25

Repeat the same process for the back wall, ceiling and side walls.
Back Wall: Position (z) Axis = -4.55
Left Side Wall: Position (x) Axis = -12.3, (z) Axis = -1.55, Rotation (y) Axis = -90
Right Side Wall: Position (x) Axis = 12.3, (z) Axis = -1.55, Rotation (y) Axis = 90
Ceiling: Position (y) Axis = 12.25, Rotation (x) Axis = 90
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Filming Your Set

Now is the really exciting part: adding a camera and filming on a 3D trajectory.
To do so, you will need to add a Peg to your camera and set the trajectory, the same as
the camera rail used in live-action shooting.
To animate a 3D camera move:

1. In the top menu, select Insert > Camera.
2. In the Timeline view, select the Camera layer.
3. In the Timeline toolbar, click on the Add Peg
your camera.

button to parent a peg layer to

4. Select the Camera Peg layer.
5. In the Layer Properties view, check the Enable 3D option.
6. In the Rotation section, enable the Quaternion option.

7. In the top menu, select Window > Toolbars > Advanced Animation to display the
Advanced Animation toolbar.
8. In the Timeline view, go to the first frame.
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9. In the Tools toolbar, enable the Animate

Mode.

10.In the Advanced Animation toolbar, select the Rotate
tool.

tool or the Translate

11.In the Camera, Top and Side views, set your camera’s first position.
12.In the Timeline view, go to the last frame.

13.In the Camera, Top and Side views, set your camera’s last position.
14.If you do not have interpolation between your frames, select the camera’s first
keyframe and use the Set Motion Keyframe shortcut [Ctrl] + [K] (Windows) or
[a] + [K] (Mac OS X).
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Adding an Outdoor Decor

To enhance the look of your scene, include what you previously learned about the
multiplane.
When your camera is moving, having a multiplane background outside the window will
add that little something special to your scene.
You will find in the Symbol library of your sample scene a multiplane background that
you can import in your Timeline view’s left side.

1. In the Playback toolbar, click on the Play button to playback your scene.
2. Adjust your camera move to get the look you want.
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You can start adding more elements to your scene such as props in the room or effects
on your layers.

Once you are comfortable with the 3D scene setup, you can start building houses,
buildings and beyond.
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M22: Symbols

In this lesson, you will learn how to import sound files, edit audio and create lip-sync.
This module is divided into the following topics:
•

Theory, on page 482

•

Activity 1: Using Symbols to Animate a Skateboard, on page 484

Animate Pro 2 - Student Workbook

Theory
This topic is divided as follows:
•

About Symbols and Libraries, on page 482

•

Understanding the Library Concept, on page 482

About Symbols and Libraries
You can share and reuse any elements you create in Animate Pro using Symbols and
Templates. Animate Pro has a library where you can store several different elements such
as puppets, backgrounds, animations and keyposes. In fact, anything you create in
Animate Pro can be stored in the library.

Understanding the Library Concept
Use the Library view to reuse your artwork and animation in other scenes or to build
props and puppets.

What is a Library?
A library is a folder where you store your Templates and Symbols, you can access these
folders from different projects. Using the library is easy, just drag the content into the
library to store your artwork and then drag it into your Timeline view when you want to
reuse it.
Organize your library using subfolders, you can keep several different library folders on
your hard drive or network.
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What is a Symbol?

A Symbol is a container or construction block used to build your props, puppets and
looping clips. Use Symbols to contain artwork and animation, to manipulate them as a
single object, or as a case holder where you will put a series of different drawings for
each body part of your puppets.
To create a Symbol, drag your artwork to the Symbol library. When you drag a Symbol
from the Symbol Library into your scene, it is linked to the original one. If you drag a
Symbol into your scene several times in the Timeline view, they are all linked to the
original one. If you modify one, they are all modified.
A Symbol is local to the project and cannot be accessed directly from other scenes. To
reuse a Symbol’s content into another scene, you must create a template out of it.
When a Symbol is exposed in the Timeline view, the Symbol’s cells are represented as a
movie strip.
Regular Drawing Cells
Symbol Cells

What is a Template?
A template is an individual copy of the artwork stored in the library, this package can be
reused in different scenes. Once a template is stored in the library it can be accessed
from any project.
Dragging a template into your scene copies the content in your Timeline and does not
link it to the original. This individual copy can be modified at will.
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Activity 1: Using Symbols to Animate a Skateboard

With Symbols, Toon Boom extends Animate Pro’s spectacular animation capabilities
even further. For example, by using Symbols, you can build animated props and
manipulate them as a unified object.
This chapter contains the following topics where you will learn how to create, combine,
extend, edit, cycle and animate Symbols.

Creating the Skateboard
1. In the Timeline view, add a new layer and rename it as Skateboard.

2. Using the tools you learned about in the previous lessons, draw the board without
the wheels. The wheels will be drawn on a separate layer.

3. In the Timeline view, add a new layer and rename it as Wheel.

484

Symbols

4. In the Camera view, draw a wheel to match the scale of your board. There is no
need to draw it in any particular location as you will reposition it later.

Animating the Smoke Cycle
You will create a three drawing animation cycle. The animation cycle will be done later
after you have imported the smoke symbol back into your scene. For now, just create
the three main drawings.

1. In the Timeline view, add a new layer and rename it Smoke.

2. In the Camera view, draw the first smoke drawing.
3. Using the Onion Skin feature, draw the second and third drawings.
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4. To change the number of drawings visible in the Onion Skin display, push or pull on
the Onion Skin blue arrows.

Creating Symbols

Animate Pro has a library where you can store your drawings and animation for reuse in
your scene or sharing in your projects.
To reuse drawings or animation in another scene, you need to create a template out of
them.
A good example of reuse is shown in the skateboard you are building, it has four wheels.
However, you only need to draw one wheel and then reuse it three more times to create
the three missing wheels. To do this, you must create a Symbol out of the wheel and then
reimport it into your scene.
Creating a Symbol is easy. You only need to select the drawings or layers you want to
transform and drag them to your Library view.
You can either select:
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•

A single drawing

•

Several drawings in a row on a single layer

•

Several drawings in a row on many layers

•

A single layer

•

Several layers

Symbols

To build your skateboard:
1. In the Timeline view, select the skateboard drawing and drag it to the Library view
inside the Symbols folder.
2. Select the wheel drawing and drag it to the Library view inside the Symbols folder.
3. Select the three smoke drawings and drag them to the Library view inside the
Symbols folder. Or use the default keyboard shortcut [F8].
All your skateboard elements should now be in the Library as Symbols.
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Adding Smoke to the Wheels
To add the smoke to each wheel and cycle it, you will enter the Wheel Symbol and add
the smoke animation. This way all the wheels will receive the smoke cycle simultaneously.
1. In the Library, double-click on the Wheel Symbol. You should now be inside the
Wheel Symbol where you can edit it.

Before importing the Smoke Symbol, you will need to extend the symbol length.
2. In the Timeline view, pull on the scene length red bracket and extend it to frame 3.

You will now import the Smoke Symbol:
3. In the Library, select the Smoke Symbol.
4. Drag and drop the Smoke Symbol into the Timeline’s left section to create a new
layer.

You should now see the three smoke frames in your Timeline.
5. In the Tools toolbar, disable the Animate mode and select the Transform tool.
6. In the Camera view, position the Smoke layer. If the smoke needs to be resized, use
the Transform tool’s corner anchor points to resize it. The whole animation will be
scaled together.
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As you can see, the wheel‘s exposure is only one frame long. You must extend it to
three frames.
7. In the Timeline, select the wheel’s last cell and press the [F5] key to extend the
wheel’s exposure.

Your Wheel Symbol now contains your Smoke Symbol.
In the Library, click on the Wheel Symbol to preview it and press the Play
button to view the animation.

Building the Skateboard
Now you need to add the completed wheels inside the Skateboard Symbol. This will
enable you to manage your skateboard as a single object instead of many.
1. In the Library, double-click on the skateboard Symbol.
You will see the name of the Symbol at the top of the Camera view. You should now be
inside the Skateboard Symbol.
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Before importing the Wheel Symbols, you will need to extend the Skateboard Symbol’s
length.
2. In the Timeline view, pull on the scene length red bracket and extend it to frame 3.

3. From the library, import four Wheel Symbols. Place two of the wheel layers above
and two more below the Skateboard layer. Remember to rename your layers
correctly.

4. In the Tools toolbar, disable the Animate
tool.

mode and select the Transform

5. In the Camera view, position the wheels. If the wheel is the wrong size, use the
Transform tool’s corner anchor points to scale it.
To modify the Wheel Symbol, double-click on a wheel. Once inside the Wheel
Symbol, modify whatever you want to and the four wheels on your skateboard will
be automatically updated to include the modification.
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The skateboard’s exposure is only one frame long. Change it to three frames long to
match the wheel’s exposure.
6. In the Timeline view, select the board’s third cell and press the [F5] key to extend
the skateboard’s exposure.

You now have a complete skateboard which you can manage as a single object. Get
ready to add it to your scene and do some tricks!

Importing the Skateboard
Your completed Skateboard Symbol is ready to animate, but first, you must clear the
content of the Timeline.
To clear the Timeline:
1. In the Camera view top area, click on the Top
root.

button to go back to the scene’s

2. In the Timeline view, select all of your layers.
3. In the Timeline view toolbar, click on the Delete Layers

button.

4. In the Confirm Delete dialog box, click on the OK button.
You are now ready to import your skateboard from the library, but before dropping it
into your Timeline, you will perform an extra operation called: Paste Special. The Paste
Special command allows to expose the symbol’s full length and then create a cycle from
it in a several different ways.
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Before importing the Skateboard Symbol, you will need to extend the scene length.
To import the Skateboard Symbol:
1. In the Timeline view, pull on the scene length red bracket and extend it to frame 60.

2. In the Library, select the Skateboard Symbol.
3. Start dragging the Skateboard Symbol toward your Timeline view.

4. Press and Hold down the [Alt] (Windows) or [Ctrl] (Mac) key before releasing the
Symbol.
5. Drop the symbol in your Timeline’s left side while holding down the [Alt] (Windows)
or [Ctrl] (Mac) key.

6. In the Paste Special dialog box, enable the Paste All Frames of the Symbol (full
movie).
7. Set the Number of Cycles field to 20.
8. Click on the OK button.
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If you forgot to use the Paste Special command when you imported, do the following:
1. In the Timeline view, select the symbol’s frame.
2. In the top menu, select Edit > Copy.
3. In the Timeline, right-click in Windows or [Ctrl] + click in Mac OS and select Paste
Special.

Animating the Skateboard

To complete your project, animate the Skateboard Symbol’s position.

1. In the Tools toolbar, enable the Animate
tool.

mode and select the Transform

2. In the Timeline view, go to the first frame.
3. In the Camera view, select the Skateboard and position it to the left side of the
screen.
4. In the Timeline view, go to the last frame.
5. In the Camera view, select the Skateboard and position it to the right side of the
screen.
6. In the Playback toolbar, click on the Play
animation.

button to view your completed
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M23: Effects in Animate Pro

In this lesson, you will learn how to enhance your project by adding effects.
This module is divided into the following topics:
•

Theory, on page 496

•

Activity 1: The Boy and the Shadow Monster, on page 510

•

Activity 2: Creating a Lighting Effect, on page 516

•

Activity 3: Using the Tone and Highlight Effects, on page 524

Animate Pro 2 - Student Workbook

Theory
This topic is divided as follows:
•

Creating Ambience, on page 496

•

Adding Effects in Animate Pro, on page 499

•

About the Module Library, on page 502

•

Animating an Effect Over Time, on page 505

•

How Does an Effect Layer Work?, on page 507

•

Previewing and Playing Back Effects, on page 508

Creating Ambience

Creating mood and atmosphere in a project is simpler than you may think. Give your
animation the warm glow of a sunbeam, the sinister red tint of danger or the funky flare
of disco lights. Either way, you can achieve the feeling you are looking to convey, from
happiness and warmth, fear and dread, to excitement and energy.

Creating Depth Through Lighting

Effects are not just built-in software filters. Effects are anything that can enhance the look
of your animation. Lighting is one of the first special effects you should consider when
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looking to elevate your animation. If done properly, lighting effects will add a lot of
volume and depth to your character, contributing to a more realistic environment and a
more convincing animation.
In this section, you will learn how to add tones, highlights and shadows to your elements.

Highlights and Tones

Highlights are areas of reflected light on the surface of an object. The more reflective
the surface is, the more the object will contain highlights. Highlights are small, very
bright areas of an object. Highlights can typically be pure white.
In animation, tones are placed on an object and shadows are placed on the ground. They
both essentially mean the same thing: darker areas caused by absence of light. This
process is also called shading.

Drop Shadow
Adding a drop shadow to elements on your animation project is a great way to give
depth to it. However, you must be careful about the angle of the drop shadow so that it
fits with the angle of your highlights and tones. If you don’t pay special attention to it,
you might end up with a scene in which the lighting isn’t consistent and you will lose the
feeling of depth that you wanted to acquire by doing the lighting in the first place.

Example of a bad shadow. We can tell
by the highlights that the light source
is overhead and slightly behind the
character. This would put the shadow
in front and not behind the character.

Example of where the shadow
should be.
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Painting versus Effects
When trying to create a certain ambiance, something to think about are the shadows in
your scene. Your shadows need to correspond to the lighting effect that you have
created, not only the direction of the lighting source, but also the mood. If the light is
soft and dreamy, then the shadows should be equally so. If the light of the day is hard
and scorching, then your shadows might be sharper with greater contrast to the
atmosphere.
There are two ways of creating shadows in Animate Pro.
•

The first is to carefully consider your objects and their placement in the scene
when you are painting.

•

The second is to use the Shadow effect.

In the image below, the chairs legs were painted with different tones to indicate a base
colour and light and dark shadow areas. The Shadow effect used in the image has a low
Alpha value of 50 to give the shadow a softer feeling.
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Adding Effects in Animate Pro
In Animate Pro, effects are added using the Network view and the Module Library. You
cannot add effects through the Timeline view.

About the Network View
In the Network view, you can connect effects and compositing modules to form a
network. The organization of modules determines the flow of data during the
compositing process and how your animation elements will be composited.
7

Input Port

Editor

5
6
1

Thumbnail

4
3

Output Port
2

•

Drawing Module

•

Write and Display Modules

•

Composite Module

•

Effect Module

•

Matte Drawing

•

Position Ports

•

Peg Module

Drawing Module
Input
Click to view
Properties Editor

Click to view thumbnail display

Output Port

This module has an Input Port (top) that allows information to flow through it. It has an
Output Port (bottom) that exports its information in a downward flow. On the left side,
there is a yellow box that brings up the module’s Properties Editor, where all its available
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parameters can be adjusted. Lastly, there is a dark arrow that displays a Thumbnail of
what the module contains.

Write and Display Modules
In this instance, both the Write and Display module do not have output ports. This is
because the information that flows into them can go no further in the network.

Composite Module
The Composite module combines multiple source images (Drawing modules), including
all transformations and effects, into a single bitmap or vector image for each frame.
The Composite module layers the image based on the composition order rule. First, the
Z-value of the elements are analyzed to determine depth. When multiple elements have
the same Z-value, the Depth values in the Drawing modules are consulted. If the Depth
values are also the same between elements, the composition order is determined by the
cable order of modules on the Composite module. By default, modules connected to
the right are rendered below those connected to the left. You can override this default
in the Composite module editor. The Composite module is an example of a module that
can have an infinite number of Input Ports that can take-in multiple, individual sources
of information. The left-most Input Port on the Composite module is always green. This
lets the user know that is terms of stacking order, whatever is plugged into this port will
appear on top of the composite after the z-depth is taken into account.

Effect Module
An Effect module can often be found with two Input Ports. The right most Input Port is
for the drawing layer that is to be acted upon by this effect, while the left port is usually
reserved for a matte. If an effect has a Matte port, it is required and not to be considered
optional.
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Matte Drawing
A matte, also called mask, is the shape that will be used by the effect module to modify
the original image. The effect will only be applied where the matte overlaps with the
original image. Sometimes the matte will act as a negative shape that the effect will
exclude. This all depends on the nature and editing properties of the effect in question.

Position Ports
Some Effects will contain three Input Ports. If the Input Ports are green, then they require
a Peg module. In this case, the Effect can accommodate two pegs.

Peg Module
The Peg modules control the transformation of elements (position, scale, skewing and
rotation) over time. The green ports at the top and bottom of the module indicate that
it accepts position information and can then pass this information on.
One Peg can be used to control many different module or one module can accept more
than one Peg. In a situation like the latter, one Peg might be used to modify the rotation,
while the other used to modify the position of the effect and then animated differently
over time.
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About the Module Library

If you need to add new modules to the Network view, you will need to get them from
the Module Library.
When you create a new project in Animate Pro, the default network that appears in the
Network view looks something like the diagram below.

The bare bones basics of a Drawing, Composite, Write and Display modules.
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Importing a Module
To bring a module into your Network view, just drag it from the Module Library and drop
it into the Network view. Once in the Network view, you can click on either the Input Port
or Output Port of a module and drag out a cable. You can then connect this cable to
either the Output Port or Input Port of another module.

If you would like to connect a module between two connected modules, you can use the
[Alt] key as you drag the new module over the existing cable connection.

If you want to remove a module you can click on it to select it and press [Delete] to
remove it from the Network view.
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Animate Pro Effects
Here is a list of the effects available in Animate Pro:
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•

Anti-Flicker

•

Cutter

•

Multi-Port-Out

•

Apply Image
Transformation

•

Dither

•

Negate Module

•

Apply Peg
Transformation

External

•

•

Note

•

Field Chart

•

Overlay Layer

•

Blending

•

Focus

•

•

Blur Directional

•

Focus Multiplier

•

Blur Radial

•

Glow

Particle Effects,
Crowd Simulation
and More
Pixelate

Blur Variable

Glue

•

•

•

Placeholder

Brightness and
Contrast

Gradient

•

•

•
•

Grain

•

Quadmap

Channel Selector

•

Greyscale

•

•

Refract

Colour Art

•

Highlight

•

•

Remove
Transparency

•

Colour Card

•

Layer Selector

•

Shadow

•

Colour Override

•

Line Art

•

Sparkle

•

Colour Scale

•

Matte Blur

•

Tone

•

Colour Screen

•

Matte Resize

•

Transparency

•

Composite- Generic

•

Motion Blur

•

Underlay Layer

•

Contrast

•

Multi-Port-In
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Animating an Effect Over Time
In Animate Pro, to animate an effect over time, create a function curve by adding
keyframes to the parameters you want to animate. To do this, you will use the Layer
Properties view, the Network view and the Timeline view. You can fine tune your
animation using the Function view.
To animate an effect over time:
1. In the Network view, drag an Effect module from the Module Library and drop it
into the Network view.

2. Plug the effect element between the drawing element that you would like to apply
the effect to and a composite module. You can either do this manually by
unplugging and plugging, or by holding down [Alt] as you drag it through a
connection.
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The Effect should also appear in the Timeline view as well.

3. To create the function curve:


In the Layer Properties view, click on the Function
animate to create a function curve.

button you want to

OR


You can also expand the effect layer’s parameters in the Timeline view by clicking
on the Expand Function
button and add a keyframe using the [Ctrl]+[F6]
(Windows®) or [a]+[F6] (Mac OS® X) key to the parameter you want to animate.

4. In the Timeline view, click on the Show Data

view button.

5. In the Timeline view, go to the frame where you want to start animating the effect.

6. In the Data view, click on the Add Keyframe

button.

7. In the Value field scroll to the keyframe value or type the value in the field.



If your keyframes are Stop-Motion keyframes, In the Timeline view, select the
new keyframes. Right-click (Windows®) or [Ctrl]+click (Mac OS® X) on the
selection and select Set Motion Keyframe.

8. Repeat this process for each keyframe to be added.
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How Does an Effect Layer Work?
An effect module always needs a drawing connection and sometimes a matte or shape
connection. A matte provides drawing information that will be used to determine the
area where the effect will be applied on the drawing. The details and colours within the
matte drawing do not matter, as the system will only use the shape and transparencies
in it. A matte is also known as mask.
The matte principle can be demonstrated on the Tone effect.

©Nelvana Limited

The drawing layer is connected in the right port of the effect module and the matte
(mask) in the left port. The Tone effect then applies darker colours where the matte
overlaps the image, blurs the tone edge, and finally clips out the extra tone zone outside
of the drawing before outputting a final drawing with a tone.
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The tone’s parameters can be adjusted in the module editor and any of them can be
linked to a function column to be animated over time. This means that all of the effects
can be customized.

Previewing and Playing Back Effects
To preview your effects, you will have to perform a quick render. Effects must be
calculated before they can be viewed in real time.
To preview your effects:
1. In the Playback toolbar, press the Render and Play

button.

The Play module opens and loads the frames.

2. Once the frames are loaded, press the Play

508

button in the Play window.
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Preview Resolution
So that your previews calculate faster, you may want to render them out at a smaller
resolution. You can use the Preview Resolution command so you will not have to modify
the resolution of your scene every time you make a check preview.
The Preview Resolution command allows you to quickly ask for a preview at either a
quarter, half or three-quarters of the scene resolution. You can even customize the
preview resolution size.
To use the Preview Resolution command:
1. In the top menu, select View > Preview Resolution.
2. From the drop-down menu, select either:







Same as Scene Resolution
3/4 of Scene Resolution
1/2 of Scene Resolution
1/3 of Scene Resolution
1/4 of Scene Resolution
Custom.

If you selected the Custom option, the Custom Preview Resolution dialog box
opens.

3. In the dialog box, select a resolution from the presets or type a new X-Y value.
4. Click on the OK button.
5. Preview your effects animation.

509

Animate Pro 2 - Student Workbook

Activity 1: The Boy and the Shadow Monster
Learning how to add atmosphere to your scene is an easy trick that can be used again
and again. Use the sample scene to explore and play with the effects and options. After,
add ambiance to one of your scenes using some of the same effects.
All you have to do is:
•

Create the shape you want: a beam, halo or the negative shapes from an object
that is blocking the light. In the sample scene, the shape represents sunbeams.

•

Then colour the shape to convey a certain mood, such as red for sinister or pale
yellow for warmth.

•

Add a Blending effect to your shape, attach it to a Blur effect and set the
parameters.

It’s easier than you think.
We will do exactly this with the scene of the Boy and the Shadow Monster. We will add
effects to the monster so that it feels like he is creeping out of a corner of the room. We
want it to be subtle but menacing.
1. Launch Animate Pro.
2. From the Welcome Screen, click Open Scene and select the Boy_and_Monster.anim
scene from your project folder.
3. Once the scene is open, make sure to save it in a different folder by clicking the
Save As

510

button.
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4. You’ll notice that your scene contains 5 drawing layers. It should look like this:

As you can see, the monster’s not subtle at all. It doesn’t blend in. It looks a little
odd. After adding a few effects module though, it will change the scene completely.
5. Go to the Network View. You will see that each layer has a module assigned in this
view. The names are the same as the layer names so it’s easy to find what you are
looking for.
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6. You will also need the Module Library, so open right away. Make sure the window is
next to the Network View. You can then drag and drop modules directly to the
Network View.

7. Now, for our Monster, we will need two effect modules: A Blur-Radial module and a
Transparency Module. Drag and drop each of these modules to the Network View.
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8. You will need to connect those new modules to the Shadow_Monster drawing layer.
To do this, you simple need to hold [Alt] while dragging the module to the
connector under the Shadow_Monster module. It will connect automatically.

Hold
[Alt]

9. Do this for both effect modules. Once they are set, click the little yellow square on
each module. This will bring up the Layer Properties window. This is where you can
adjust the settings of your effect module. Keep these windows opened and switch
to the Camera View.
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10.As you can see, even though the effects are connected, not much is going on in the
Camera View. This is because you need to switch to the Render View
setting to
see your effects. If you switch to the Render View settings in the Camera View, your
scene should now look like this:

11.Now the monster is transparent. We are getting closer to the look we want! We can
now play with the Layer Properties settings of each module. Start with the
Transparency. Play with the number. Notice how if you put it at 0, the monster will
be completely opaque, then if you change it to 100, it will disappear completely. For
now we will leave it at 50. Take the time also to rename the module TransparencyMonster. You can close this window.
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12.Moving on to the Blur-Radial settings. Start by renaming it Blur-Radial-Monster.
Then you need to change the Radius setting. This will create the blur effect. The
higher the number you input, the stronger the blur. Set the Radius to 4.

Now your scene should look like this. The monster is much more convincing.

13.Make sure to save your project by clicking the Save

button.
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Activity 2: Creating a Lighting Effect
In this activity, you will use highlights, tones and shadows to create a convincing lighting
effect in either the sample scene or a scene from your own animation project.
Before you begin adding any lighting effects, you should plan where your light source is
located, its angle and its level of intensity. This preparation is essential to prevent bad
shading or incorrect shadow positioning and direction. The best method is to make a
quick map of your scene (from the top and the front view) and position the light on the
map. This will help you determine the origin and angle of the light and where the shadow
will fall.

Using the Stroke Tool to Define Highlights and Shadows
The Brush tool
or Stroke tool
are fast ways to create some highlights and tones
for your drawings. The Stroke tool is typically used to close elements that have gaps, but
in this case we will use it to define zones where we want highlights.
The first step is to define the colour of the highlights and tones that you are going to
use. A great way to choose colours for the highlight and tone is to use the Colour Picker
in the colour palette.

To create a highlight or tone:
1. Launch Animate Pro.
2. In the welcome screen, click on Open Scene and select the
Creating_a_Lighting_Effect.anim file to open the project.
3. Make sure to click the Save As

button and save your scene on another folder.

4. Go to the Colour View and select the colour you want to create a highlight or tone
for.
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5. Click on the Add Colour
button to create a new colour swatch based on the
selected colour, in other words to duplicate the colour.
6. Double-click on the new swatch and rename it in the Colour Picker window and add
either an “_h” for highlights or a “_t” for tones to the original colour name. This will
let you identify which colours are associated to each other.
7. The bar to the left of the Dropper is the currently selected colour. The colours below
it are different shades of the same colour. By clicking on the shades at either end,
you can get lighter or darker shades of colours. If the colours shown don’t fit your
needs you can also choose a colour selecting a specific colour from the left part of
the window.
After you have chosen your colours, define the zones that have highlights and shadows
with the Stroke tool
. To see the strokes that have been made so far, activate the
Show Strokes option by selecting View > Show Strokes, or by using the keyboard
shortcut [D].
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Make sure that your line touches both edges of the drawing. If it doesn’t, the software
won’t isolate the zone and repainting the zone will result in the whole surface being
repainted.

Once you have defined your tone and highlight zones, use the Repaint tool
change the colour to the ones that you defined earlier.

to

Remember that once you have defined the colour, you can always change it in
the color palette and it will be automatically updated in your scene.
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Using the Shadow Effect to Make a Drop Shadow
To make a convincing drop shadow:
1. In the Timeline view, right-click on the Drawing layer of your character or object and
select > Duplicate Selected Layers.
2. In the Tools toolbar, select the Perspective tool

.

3. In the Camera view, select your duplicate object and then in the Tool Properties
panel, click on the Flip Vertical

button.

4. Drag the duplicate layer object downwards until the top of the duplicate object is
touching the bottom of the original object. If you have difficulties selecting your
duplicated drawing object, remember that you can lock
such as the background, in the Timeline view.

other layers,
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5. Use the Perspective tool to click and drag the white squares of the bounding box in
different directions until you get the angle that you desire.

Remember to keep your light source in mind. In our case, the light source (the sun)
is high in the sky and towards the right-top corner of our scene. The red arrows
converge to a point high in the sky that is out of view for our scene. It is up to you,
to use your judgement as to where the light hits and the shadows fall.
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6. Drag and drop a Shadow effect module from the Module Library to the Network
View.

7. Drag the module while holding the [Alt] key to the duplicated character layer
connector. This will apply the effect to the layer.

Hold
[Alt]
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Your duplicated drawing object should now look more like a real shadow
(semi-transparent and dark).

8. Double-click on the Shadow effect layer to bring up its Layer Properties dialog box.

9. Adjust the parameters in this dialog box to make the shadow sharper or more blurry
(Radius), more or less transparent (Alpha) or double-click on the colour swatch to
change its colour entirely.
10. To view these parameter adjustments, in the Camera view, click on the Render
Mode
522
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11. Continue adding highlights and shadows in your scene where needed until you are
satisfied.
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Activity 3: Using the Tone and Highlight Effects
To use this method, you will need to make multiple layers. Even though this might sound
more complicated, it allows you to easily animate the intensity of the light. Follow the
steps below to create your own Highlight and Tone effects.
To create a Highlight effect:
Use the Highlight effect to make an area of a drawing lighter in order to simulate a light
source. Draw a shape to control where the highlight will appear on the original drawing.

The Highlight effect uses a matte to determine the shape and position of the highlight
on another element and can blur the edges to create a softer effect. The highlight should
be draw on another Drawing layer, just like in our example. You should make it bleed
(see the green highlight in our example) so that it cover the character or item correctly.
Once the matte is ready, you can go to the Network View to connect all the modules
accordingly.
The Matte
should always
be connected
to the left of the
Highlight
module.
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The Drawing
layer the
highlight is
applied on,
always
connected to
the right.
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Use the Highlight editor to control the type and amount of blur, as well as the colour of
the highlight effect. Once applied, the highlight should look something like this:

To create a Tone effect:
The Tone effect works very much like the highlight effect. Use a Tone effect to add a
shaded region to your drawing and to simulate the absence of light. To produce the tone
effect, create a drawing to control where the tone will appear. The Tone effect uses a
matte to determine the shape and position of the tone on your drawing and can be
blurred at the edges to create a softer effect.
The Matte
drawing layer
should be
connected to the
left.

The drawing layer
on which the tone
is applied to
should be
connected to the
right.

Use the Tone editor to control the type and amount of blur, as well as the colour of the
tone.
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M24: Creating Cut-out Character
Designs

Like a puppet, a cut-out character is made from many independent parts, such as hands,
arms, a head, legs and feet. In Animate Pro, these parts can be linked together at the
joints and then animated using pegs, which are like the strings that move puppets.
Instead of re-drawing your entire character each time it moves, you can isolate changes
to specific body parts; for example, the arm. Instead of redrawing the entire character
when the position of the arm changes, you create an arm drawing and change only the
arm when it moves.
Cut-out animation will reduce the amount of work you do. However, it does require
some planning and work before you begin animating.
This module is divided into the following topics:
•

Activity 1: Character Design for Cut-out Animation, on page 528
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Activity 1: Character Design for Cut-out Animation
When designing a character for cut-out animation, you should consider the different
components that are required to build your character. A character can be complex,
requiring many different components. The complexity of your animation should be
established before you complete the design of your characters.
If you are able to use a graphic tablet, or eager to learn how to use one, this lesson will
show you how to adapt to a paperless workflow for cut-out character development.
This is the Model
Sheet for the Ralph
character.

The first step in any character design are some sketches. This is followed by creating a
model sheet, a reference drawing of the character design in various poses. You will be
drawing a character in an enhanced version of a model sheet: a model scene. You will
get used to sketching in Animate Pro by drawing a turnaround of a character; you will
create side, three-quarter and front views.

Opening and Saving Your Scene
A scene created specifically for this lesson has been included in the lesson download. In
order to begin creating artwork, you must first open Animate Pro and save your scene.
1. Launch the Animate Pro application.
2. In the Welcome Screen, click on the Browse button.
If you have disabled the Welcome screen, just click on the Open

button.

3. Browse to the location of the Projects folder which you downloaded.
4. Inside that folder, open the turnaround scene folder.
5. Then click on the Animate Pro project file.
6. Click Open.
7. Select File > Save As, doing this maintains a backup of the original source file.
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8. Rename the file my_turnaround and save it to a directory on your computer.
Remember the location of this directory.
Don’t forget to save your project often.

The Character Turnaround
A character turnaround describes multiple poses of the same character aligned in a
model sheet to show the way the character looks from multiple angles.
For cut-out animation, the three poses most commonly used poses for main character
positions reference are:
•

Side view

•

Three-quarter view

•

Front view

Additional poses may be added along the way, but an animator will likely need at least
these to start.
A character model sheet
showing the character
turnaround

Side view

Three-quarter view

Front view

The Guide Drawing
Use a guide when sketching to keep track of the size of your character from all views.
A guide has been saved in your project, this guide will help you keep the height of your
character consistent as you design.
This guide was created especially for the Ralph character, but you could use a more
generic guide for designing your own characters.
The guide element
contains these lines, use
them to align the drawing
of the Ralph character.
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Preparing to Sketch
Sometimes animators are not used to drawing directly into vector-based software. This
section shows you how to customize the look and feel of the drawing tools so that they
become second nature to you.
For example, you’ll create a palette specifically for sketching that will allow you to see
overlapping lines, simulating the feel of free sketching on paper.
A good way to simplify each step in the animation process is to determine which settings
are required for your current task, and to set up these tools in a way that makes them
easy to access.

Renaming the Drawing Element
A drawing element was created in the scene by default, and now you will change its
name.
1. Double-click the default drawing element name in the Timeline and type the new
name Ralph_sketch.

2. Press Enter.

Creating a Palette for Sketching
Before you start, you will create a palette specifically for sketching. There are a few
things you need to do when you set up a new palette.
•

Creating a new palette

•

Renaming the colour

•

Changing the colour and alpha values

Creating a new palette
To create a new palette:
1. In the Colour View menu, select Palettes > New or click on the New Palette
button.
The Create Palette window opens.
2. Enter the Palette Name. For this palette, it should be called Sketch.

3. Click on the OK button.
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The palette appears in the drawing element’s palette list.

Renaming the colour
1. Double-click on the colour swatch name and type sketch blue to rename this
default colour.

Double-click here to
rename this swatch

Changing the colour and alpha values
For this sketch palette, we have selected a blue colour that is partially transparent, but
you can choose any colour you like.
1. Double click on the colour swatch beside the blue colour in your new sketch palette.
The Colour Picker appears.
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2. Use the slider or enter the RGB values directly in the Colour Picker to add the
correct colour to your colour palette. Choose a colour similar to the one shown
below.

3. Set the colour’s Alpha value to 150 using the slider or by typing the amount directly
into the Alpha field. This makes the colour slightly transparent.

4. Close the Colour Picker.
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Sketching
Now that you have set up your workspace and created your palette, it is time to start
sketching. First, you will draw the Ralph character from a side view. Then you will use
keyboard shortcuts to “flip” between this side position and two other positions to
complete a character turnaround. These three poses will be tidied up, later on they will
be as a reference for building the cut-out character components.

Selecting the Right Brush
Drawing with the Brush tool and a graphic tablet and pen provides the same experience
as drawing with pen and paper. You can change the width of your stroke by applying
varying amounts of pressure to the pen as you draw.
1. In the Tool Properties tab, choose one of the preset pens. If you like, you can also
select a different pen shape for added detail.

Preset pens
Choose different
pen shapes here

Drawing the Side Pose for the Ralph character
Now it’s time to start drawing Ralph.
1. Go to the Camera View. You should be able to see the Ralph Reference and the
Guide.
2. Click on the Grid

button to turn the grid on or off.

3. Make sure to select frame 1 of the Ralph_Sketch element in the Timeline.
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4. In the Pen and Colour Palette tabs and double check the following:
•

Your new sketch colour is selected from your sketch palette.

•

Your brush options are set.

5. Select the Brush
tool and start sketching in the Drawing View. Once you start
your sketch, a new drawing will automatically be created in the Timeline.

6. Using the following sketch as a reference, practice using your new sketch palette by
drawing Ralph in his side pose. Draw as rough as you need to, and make use of
whatever drawing tools are necessary.

Ralph should line
up with the top and
bottom of the
guide layer.

534

Creating Cut-out Character Designs

Completing the Turnaround
Now that your first pose has been established, repeat the same steps to create the
three-quarter and front poses on frames 2 and 3.
Use the keyboard shortcuts [,] and [.] to flip between these three drawings while you
modify them. Flipping through the drawings like this while you draw will allow you to see
Ralph turn, and help you keep his proportions consistent.
Use the following images as reference for your drawings:

Three-quarter pose on frame 2

Front pose on frame 3
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Tidying up the Vectors
The sketchy, overlapping look of the brush strokes is a simple technique used to
maintain a loose style while sketching in the software. Once the drawings are complete,
some of the extra lines can be removed. As you will see, additional lines can create many
extra vectors.
1. Using the Select

tool, drag a selection area around one of your poses.

If you take a look at your drawings after making the selection, you will see that they
consist of many overlapping brush strokes.

2. If you switch tools, and select your drawing, this time with the Contour Editor
you will see that your drawing has many vector points.

3. Switch back to the Select tool, and reselect your drawing element.
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4. In the Tool Properties window, click the Flatten
button.This will turn all your
brush strokes into one stroke, removing the overlapping lines, but keeping the
colour’s transparency.

Renaming Ralph’s Poses
A cut-out animation character is created with each of its components separated in their
own layer. It is important that you keep track of these items. Naming your drawings and
elements correctly makes all the difference when managing your work.
Setting up this naming system will help you through this lesson, when you start creating
the different cut-out components.
1. Go to the Xsheet window. Double-click the first frame to rename it.
2. Name this drawing “s” for side.
3. Repeat this procedure, naming your three-quarter pose “q”, and your front pose
“f”.

4. Save your scene.
Now that you have created labels for the three views, you will be able to use them as
prefixes for naming your drawings. Using this naming system will help you keep things
organized when you start adding many elements and drawings.
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Cut-out Character Components

Now that Ralph has his three main views set up, you are ready to start building your cutout character. In this part of the lesson, you will learn one of the ways in which you can
create and save all your character’s elements. You will also learn how to keep the
elements organized within a character model scene, ready for reuse for when you start
to animate. When you have finished this part, your character should be ready to paint.

Drawing Cut-out Elements
At this stage of cut-out character design, you will clean up all the cut-out pieces
separately, using the light table and the sketches as reference.

Creating your Character Palette
You’ve already created a palette for sketching. Now you will create a brand new
character palette and name it accordingly for the finished version of Ralph. You’ll create
a line colour for cleaning up the character. Then, when you are ready to paint, you will
add new colours as you go.
1. In the Colour tab, create a new palette.
2. Rename your palette Ralph, as this is the name of your character.
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3. The default colour black in the palette is fine for Ralph’s outline, just rename it
line. You can do this by double clicking on the colour name and typing the new
name for the colour.
Double click the
colour name, then
type the new
name line.

Drawing the Ralph character’s hat
Now that you have created the character palette, it’s time to draw all the cut-out pieces
separately.
Ralph’s hat is a good place to start. You will draw the hat for all three views, and rename
the drawings to match the sketch prefixes. When the drawings are completed, you will
get an overview of how Animate Pro stores these drawings in the Library for later reuse.
Adding a new drawing layer
1. From the Timeline, click on the Add Drawing Layer

button.

2. Rename your new element RA_Hat, and click on frame 1.
The “RA” prefix, as in RA_Hat, will be used to identify this as being part of the Ralph
character. This is very helpful when you have a scene with more than one character to be
animated.
Drawing Ralph’s hat from the side
3. Hide the guide element if you don’t want to see it while you clean up the hat.

Uncheck this box in the
Timeline if you don’t want
to see the guide layer.

4. Make sure you have your new line colour selected from the Ralph palette. With your
Brush tool, start drawing Ralph’s hat on frame 1 of the RA_Hat element.
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Use the following image as reference:

Ralph’s hat, side pose.
You will rename this
drawing s1 in the next
step. The prefix “s”
represents the side
pose.

Renaming the Drawing
Rename your cut-out components while you work to keep things organized, as you did
with the sketch drawings. Use the prefix “s” for the side view to keep track of all the
drawings created for this particular view.
5. In the XSheet view, double-click on your RA_Hat layer’s side pose to rename it.
6. Name this drawing s1 using the prefix “s” to represent side pose.

If you were to create additional drawings for the hat in this side view, you could name
them s2, s3 and so on.
Drawing the hat in three-quarter and front poses
Now that you have drawn and named the first pose, continue and draw the three-quarter
and front poses on frames 2 and 3.
7. Follow the same guidelines and tips as before to draw these two hats. When
finished, rename them q1 and f1.
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Use the following images as reference:

Ralph’s hat, threequarter pose.
You will rename this
drawing q1. The prefix
“q” represents threequarter pose.

Ralph’s hat, front pose.
You will rename this
drawing f1.The prefix f
represents the front
pose.

Your cleaned up version does not have to be identical to the rough sketch. If you need
to make any changes, feel free to make them as you go, using the sketch as a reference.
8. Make sure to Save

your project when you are done.

Cell Substitution and Automatic Lip-sync
As drawings are created they are stored within that element for later reuse. Using the
Cells tab, you will be able to scrub through your drawings while animating, and swap
drawings on specific frames. This section covers some of the things you’ll need to get to
know if you want to become a cut-out animator in Animate Pro.

Cell Substitution
Use the Cells window to replace drawings at specific frames, with another drawing
stored in your scene.
1. Click on frame 1 of your RA_Hat element to make this drawing element active.
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2. Open the Cells tab, Window > Cells.
3. In the Cells tab, you should now see the RA_Hat element. Drag the slider to view all
of the drawings you have created of your hat. Make sure the preview box is
checked.
When you change the drawing here in the Cells window, it updates the exposure in the
scene. Here is an example of different hands which can be stored in the library and used
later in the animation.

4. Drag the slider back to s1 to reset the drawing on frame 1.
5. Save and close your scene. You will be using a new project, Ralph_Mouth.tbp, in
the next section.

Setting up the Mouths for Automatic Lip-sync
If you are planning to use Animate Pro’s lip-sync feature, you should create and name
your mouth drawings in the same way as the drawings in the lip assignment chart that
the program will use to generate the breakdown. Naming your mouth drawings this way
is slightly different from the way you name other cut-out pieces, but it will simplify the
lip-synching process.
Opening the Lip-sync Scene
The Ralph_Mouth scene is the completed Ralph character. It contains all the basic
components which were created for each pose and renamed according to the prefixes.
1. Click the File Open

button.

2. In your Projects folder, browse to the Ralph_Mouth project folder. Select the
Ralph_Mouth project file and click Open.
3. Select File > Save As. Rename your scene as my_Ralph_Mouth.anim and save the
scene.
4. Browse through the different elements to see how each of the pieces was created.
Note how each element’s drawings were placed in the Exposure Sheet to keep all
the pieces for each view within the same frame range.
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The Lip Chart
The Lip Chart is part of the Sound Element Editor. Animate Pro’s lip sync feature analyses
the contents of a sound element and generates a lip chart based on eight distinct
language sounds. Each of these sounds is designated by one of the following letters; A,
B, C, D, E, F, G, and X (which represents silence).
Refer to this chart when creating and naming your mouth shapes:
The Lip Chart

The Lip Chart as in the layer
properties window.

The shapes shown in the Lip Chart are universal and can be used with any language.
Naming the Mouth Shapes
The mouths are named using the same view prefix as the other drawings, but have an
additional letter corresponding to the mouth shape as it is represented in the lip chart.
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When you are ready for the task of synching your character’s mouth to sound, you’ll
simply type in the names of the mouth shapes you created.
Notice the naming
system for the
mouths. These now
correspond to
Animate Pro’s
Automatic Lip-Sync
chart.

When you’re ready to
sync your character’s
voice to sound, use
this window to map
the sound to the
different mouth
drawings.
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Drawing the Missing Mouth
Ralph’s Mouth layer has many more than just three positions. The eight mouth shapes
from Animate Pro’s lip sync chart have been drawn for each of the three views. All except
the side “D” mouth shape. It is your task to create this drawing.
Disabling the Layers
Remember, you can hide other layers that you do not need to see displayed in the
camera view. This will make drawing Ralph’s mouth much easier. All you need is for the
mouth layer and the head layer to show. Everything else can be disabled.
1. In the Timeline, click the Enable/Disable All

button until all layers are disabled.

¸

2. Next, enable the Mouth and Head layers.

When you start drawing the missing mouth shape, you will be able to see Ralph’s head
so that you can match the mouth to it.
3. In the Colour Palette tab, choose the Ralph line colour, then set your Brush options
in the Tool Properties window.
4. In the Timeline, click on frame 5 of the RA_Mouth element.
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5. Using the lip chart and the following drawing as a reference, draw Ralph’s sd mouth
shape.
Here is the pasted part of
Ralph’s nose, copied from
the head drawing using
the Cutter.

Use the Contour Editor to
align the lines correctly.

6. When you’re drawing is done, rename it sd.
7. Save your scene.

Palettes and Painting

In the final part, you will work with painting and palette systems. You will work with
Animate Pro's painting tools and techniques, and learn how to create and manage
different versions of your character palettes.
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Painting Your Character
Once you have completely built your cut-out character, it will be ready for you to paint.
For the following steps most of the colouring has been done for you. You will fill in what
is left to be done.
I find it easier to build my cut-out character before colouring it. Once all the pieces have
been drawn, then I colour them.
Adding Colours to Ralph’s Palette
To begin painting, you need to add some colours to Ralph’s palette. Most of Ralph’s
elements have already been coloured, except for his hat and one mouth drawing.
1. Go to the Colour tab.
2. From the top section, select the Ralph_Paint palette.

3. Add a colour to this palette by clicking on the Add Colour

button.

4. Double-click the new colour and rename it Hat.
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5. Open the Colour Picker by double clicking the colour swatch next to your new
colour.
6. You can select any colour you want for Ralph’s hat. Here are the colour values we
used:

Our RGB values for Ralph’s
hat are:
R - 65
G - 72
B - 52

7. Add one more colour to the palette. Name this one Hat Trim use the following
RGB values:
•

R - 164

•

G - 74

•

B-9

Painting Ralph’s Hat
Animate Pro offers a number of painting tools to colour your line art, including the Paint
tool (you can also work with the Paint Unpainted and Unpaint tools).
8. Select the Paint

tool.

9. Choose the colour of Ralph’s Hat from the Colour Palette.
10.Select the Hat drawing s1 in the exposure sheet.
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11.In the Camera View move the Paint bucket into the top part of Ralph’s hat, and click
to fill the zone.
Use the paint
tool to fill the
zone with the
selected colour.

12.Select the Hat Trim colour from the palette, and this time click to fill the trim of
Ralph’s hat.

13. Now paint the other Hat drawings in the same way.
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Painting the Mouth
If a drawing element has lines that aren’t closed, you can use the Stroke
tool to
draw a vector line to close the gap so that you can paint it. Overlapping pieces (such as
a head and mouth) often use strokes so that they will match seamlessly.
1. In the Timeline View, select drawing s1 of Ralph’s Head level to see it in the Camera
View. This head has already been painted using the Stroke tool technique.
You see Ralph’s side head is
painted, even though the
lines around his mouth are
not closed.

But if you press the keyboard
shortcut [K], you will see that a
vector was drawn with the
Stroke tool to close the gap
between Ralph’s nose and his
jaw.
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2. In the Timeline View, click on drawing sx of Ralph’s Mouth layer. You can disable all
layers that are in the way so that you only see the head and the mouth layer. This is
what you should see in your Camera View:
The painted section of the
mouth should overlap the
painted section of the head
underneath so there will be
no gaps in between.

Now you will to add a stroke to the mouth element and paint the drawing.
3. Select the Stroke

tool.

4. In the Camera View, use the keyboard shortcut [K] to see strokes.
5. Draw a line with the Stroke tool connecting the nose and the jaw line. Make sure
that it overlaps the painted area of the head underneath.
Draw your vector here. Then
when you paint the mouth,
the colour will overlap the
painted area of the head
underneath.

6. Use the shortcut [K] once more to toggle off strokes.
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7. From the Colour Palette, choose Ralph’s skin colour, and with the Paint
tool,
click and fill this mouth drawing. Now this mouth will match seamlessly with the
Head drawing underneath.

Now that you have
added the stroke, click
here to fill so that this
mouth drawing matches
the head.

Palette Styles
After you create the swatches in a palette, you can make multiple copies of this palette
style and customize them to suit different lighting and colour settings.
Multiple palette styles allow you to adjust a character’s colours instantly instead of
recolouring each section manually.

Creating a New Palette Style
So far you have not set up any styles for Ralph’s palette. In this step, you will rename the
current palette style and call it Day. This will correspond to a daytime palette.
Once you have renamed the current style you will make a clone of it and call it Night.
This will correspond to a nighttime palette.
After you have done this you will adjust the Night palette to correspond with a nighttime
style. The Day palette will remain as it is.
1. In the Colour tab, make sure the Ralph palette is active.
2. Right-click the Ralph palette and select Rename.
3. Type the new name Ralph-Day into the field. Click OK.
Now you have a daytime palette created for Ralph.
4. Select the Day palette in the Colour tab. This makes the palette active.
5. With the Day style active, right-click it again and select Clone.
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A new palette appears. This clone contains copies of all the swatches found in the
original Day palette style.
The clone palette is a copy of the master palette. The colours in each palette have
the same properties. The colours have the same identification number pointing to
the same colour zones, but they can have different names and RGBA values. The
painted drawing will update according to the activated palette (night or day). So
there is no need to repaint the animation, only to create or import a clone palette
(palette style).
6. Rename this palette Ralph-Night.
Now you have a nighttime palette style created for Ralph.

Making Adjustments to the Night Palette
Ralph’s Night palette should have the look of a nighttime character. The colours in the
Night palette style should all be darker than the swatches in the Day style. This is very
easy to do as Animate Pro provides you with a powerful feature for tinting and blending
the colour properties of all swatches in a palette style simultaneously. This eliminates the
need to make time-consuming individual adjustments to each swatch.
1. Set the Camera View to Render View. Click on the Render View button in the
bottom left corner of the Camera View.

With the Render View option you can see the effects of the palette adjustments on
all the character parts.
You should see something like the image below. Notice some of the cut-out elements
are in the wrong order. This is not important for now.
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2. Select the Ralph-Night palette from the Colour tab.
3. Right-click the palette and select Tint Panel.

4. Select the type of adjustment you want to make to the current palette:




Offset
Blend
Mixer

5. For this lesson, select the Offset option.
6. First, click on Reset so that all the values are at 0.
7. On the left side of the Tint Offset/Blend window, select all the colours that need to
be changed.

8. On the right side, click the Preview option. This will allow you so preview the results
in the Camera View. Next, set the Amount to 100.
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9. Reduce the Value to -20 using the V slider.This darkens the palette to a nighttime
feel.

Move this Slider.
View the colour tint changes in real time.

10.Once you are satisfied with the new colours click Apply to apply your changes to
the Night palette.

Using palettes in this way saves time. When Ralph is placed in a night scene, switch to
the Night palette and he automatically becomes darker. You can create many different
styles, depending on your character’s situations.
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M25: Building a Cut-out Puppet

This module is divided into the following topics:
•

Theory, on page 558

•

Activity 1: Creating a Cut-out Puppet, on page 599
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Theory
This topic is divided as follows:
•

Building a Cut-Out Character, on page 558

•

Analyzing the model, on page 560

•

Breaking the Main Pieces, on page 563

•

Breaking the Secondary Pieces, on page 568

•

Fixing the Articulations, on page 571

•

Fixing the Articulations, on page 574

•

Rigging, on page 577

•

Adding the Master Peg, on page 586

•

Creating the Keyframes, on page 588

•

Adding the Main Extra Drawings, on page 588

•

Setting the Pivots, on page 590

•

Sharing the Puppet, on page 596

Building a Cut-Out Character
In the following pages, you will find information on how to create and build your own
cut-out character. Read these pages carefully and refer to them when you are building
your own design.

Relative Size
It is important to understand the relative size of every character and prop in order to
maintain consistency and structure throughout the project.
A production may contain many characters and props. It is not unusual for these to have
been created by different people. If there is no control over the size implemented, the
characters and elements created by different artists can vary greatly in size. When this
occurs, the characters that are put together in a scene will be out of proportion. The
animator or person doing the scene setup will then have to scale them to the correct
size.
When a character or a prop is scaled down, the outline will become increasingly thinner.
By the time that the element is scaled to its proper size, the outline may be so thin that
the difference between one character’s outline and another’s will not look very good.
These following tips can be used to create a determine the correct relative sizes for each
puppet:
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•

Line Up, on page 559

•

Field Chart, on page 559

•

Brush Size, on page 560
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Line Up

A line up consists of copying and pasting all of your character designs into the same
drawing and then scaling them so they are in proportion with each other. This line up is
very important and should be handed to any animator, layout and posing artist, or scene
set up person working on the project.
For the prop design, it is recommended that you paste one of the main character’s hands
or even the full body beside the prop. This enables the animator to know what size to
draw or set the prop.
In your character design scene, it is a good idea to create a column for the character
line up. The line up is usually done during the Character Design step. When the character
builder imports the model to the break down scene, the size relation should be correct.

Field Chart

Animate Pro has a field chart included in its Camera and Drawing views. This tool is very
useful in setting the height of the characters and props. You can display the field chart
using the Show Grid option.
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To display the field chart:


In the top menu, select View > Grid > Show Grid. The default keyboard shortcut is
[Ctrl]+[‘] (Windows®) or [a]+[‘] (Mac OS® X). You can also click on the Show Grid
button available in the Camera view and Drawing view toolbars.

Brush Size
Animate Pro provides a variety of pens and brushes and also allows you to create and
save your own. It is a good idea to create and save pens with exact sizes and parameters
to trace and design your models and break downs.

Analyzing the model

Now that you have imported or designed your colour model, the next step is to observe
the model. This is done to determine which parts will be broken apart and how they will
be divided. Will the hair be separated into one, two or three sections? Will the hand be
separated from the sleeve? To determine what is best for your character, observe the
model in the Camera or Drawing view.
To help you improve the quality of your break down, here are some tips and tricks. The
following examples are from “Grossology”, a production by Nelvana Limited:
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•

Eyelids and Pupils, on page 561

•

Creating Mouth Shapes Directly on the Head, on page 561

•

Keeping Fingers Attached to the Hand, on page 561

•

Mixing Hand-Drawn Animation, on page 562

•

Flipping Logos, on page 562

•

Complete and Overlapping Pieces, on page 563
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Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers:
the eyeball, the pupil and the eyelid. The eyelid layer is used for the blink and to cut the
pupil when it gets too close to the side of the eyeball. For a more advanced break down,
the two eyes are separated on their own individual three-layer sets.

Creating Mouth Shapes Directly on the Head

To animate more realistic lip-synching and facial expressions, you can create the mouth
shapes on the head layer. Just deform the jaw to match the mouth opening.

Keeping Fingers Attached to the Hand

To avoid needlessly complicating the break down, the fingers are not usually separated
from the hand. The full hand is a single layer with a bank of different hands stored inside.
This technique is easy to work with and produces a less mechanical effect.
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Mixing Hand-Drawn Animation

For more advanced cut-out animation and a more traditional animation look, some users
will keep full arms and full legs. This means that only hands and feet are separated from
the limbs. The animator will create extra drawing shapes and substitute them during the
animation.

The animator may temporarily combine some parts to facilitate the work and produce a
higher quality animation. For example, combining both full legs and hips into a single
drawing to create poses that would be difficult using cut-out pieces. Both full legs could
be drawn on the hip level and legs and feet exposure removed. This technique is a mix
of cut-out and hand-drawn animation.

Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you
to flip and reuse a character’s puppet.
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Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that they have to
be properly overlapping and complete. A common mistake is to trace the part just as it
appears on the model.

Breaking the Main Pieces

There are many techniques you can use to break down a puppet. In this section, you will
learn about one of the most common methods. For your first character break down,
follow these instructions so that you can get an idea of the way Animate Pro works. Once
you are used to the software and understand its basic functions and commands, you will
be able to create your own techniques to satisfy the needs of your production.
•

Selecting and Creating a New Layer, on page 564
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Selecting and Creating a New Layer
Head
Left Arm

Right Arm
Body

Right Leg

Left Leg

The first step in breaking down your character is to do a rough cut down of the main
parts such as the body, arms, legs and head. Use the Create Drawing from Drawing
Selection feature to automatically create your layers and copy your selection in it.
This section is divided as follows:
•

Naming Conventions, on page 564

•

Breaking Down the Main Parts, on page 565

Naming Conventions
Before breaking down your pieces, you should think of a naming convention for your
layers in order to keep your work organized.
When naming your layers, you should include the following information:
•

Character’s name

•

Right or left side

•

Part’s name

An example of that naming convention for a character named Mark is:
•

mk_r_arm
This would be the layer name for his right arm.
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Breaking Down the Main Parts
To break down the main body parts, you will use the Create Drawing From Drawing
Selection feature. There is no need to create any layers prior to this process, you need
to have your model well centred and sized in the Camera view.
You do not need to make clean cuts around your parts; a rough one is quite sufficient as
long as it includes all of the artwork of the part you want to break down. You will clean
the extra bits and pieces later.
You will use the Cutter
Select

tool to roughly cut the main sections. You can also use the

tool to select exact lines and colour zones.

To break down the main parts:
1. In the Timeline view, select the model’s cell that corresponds to the first view to
break down.

2. In the Tools toolbar, select the Cutter

tool.



If you prefer to use the Select
tool, choose the Select tool from the Tools
toolbar. The default keyboard shortcut is [Alt]+[V].



In the Cutter’s Tool Properties view, you can switch to the Lasso
mode.

selection
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3. In the Camera view, create a selection around the first part to break down. If you
click on a zone, the Cutter tool will select the zone. It will end the selection at the
first point of intersection that it meets.
Cut the entire arm, not just the hand
or forearm.



If you hold down [Shift], you can create a new lasso selection around another
zone and add it to your previous selection.
[Shift]

4. In the top menu, select Edit > Create Drawing From Drawing Selection. The
default keyboard shortcut is [F9] (Windows).
The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, type the name of the layer you want to create following the
naming convention you established previously.
6. Make sure to disable the Cut Artwork From Source option in order to keep the
selected artwork on your original drawing. You do not want to cut the artwork from
your colour model.
7. Click on the OK button to complete the operation.

566

Building a Cut-out Puppet

The new layer is created and your selection is copied in it. The drawing is created in
the same frame number as the cell it was taken from.

bl_l_arm

8. Repeat Step 1 to Step 7 for each main body part.
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Breaking the Secondary Pieces

Arm

Forearm

Hand

You should now have a layer for each main part of the character for the first view to break
down. You are now ready to break down those main pieces into smaller ones.
Breaking down the secondary parts is similar to the process used for the main part break
down except that you will cut away the artwork from the layer it has been selected from.
To break down the secondary parts:
1. In the Timeline view, lock your model layer by clicking on its Lock

button.

2. In the Timeline view, select the cell that corresponds to the main part you want to
break down.

3. In the Tools toolbar, select the Cutter
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tool.

If you prefer to use the Select
tool, choose the Select tool from the Tools
toolbar. The default keyboard shortcut is [Alt]+[V].
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4. In the Camera view, create a selection around the part to break down.
Cut the forearm from the
arm layer.



If you click on a zone, the Cutter
tool will select the zone. It will end the
selection at the first point of intersection that it meets.

Click on a line with the
Cutter tool to select it
up to the next
intersection.

5. In the top menu, select Edit > Create Drawing From Drawing Selection. The
default keyboard shortcut is [F9] (Windows).
The Create Drawing From Drawing Selection dialog box opens.

6. In the Layer Name field, enter the name of the layer you want to create, following
the naming convention you previously established.
7. Enable the Cut Artwork From Source option in order to remove the selected
artwork from your original drawing. In this case, you want to cut the artwork from
your colour model.
8. Click on the OK button to complete the operation.
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The new layer is created and your selection is copied in it. The drawing is created in
the same frame number as the cell it was taken from.

bl_l_forearm

9. Repeat Step 2 to Step 8 for each body part.
Cut the hand from the
Forearm layer.

If you forgot to add some artwork to a layer you previously created, you can always
add it later.
In the Camera view, select the artwork to send to the existing layer and press [F9]
(Windows) to open the Create Drawing from Drawing Selection dialog box. In the dialog
box, select an existing layer from the drop-down list instead of typing a new name. When
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you click on the OK button, the artwork will be added to the existing drawing in the layer
you selected.

Fixing the Articulations

Now that all of your layers are created and your parts are basically broken down, it is
time to clean up your parts and complete the articulation.
This topic is divided as follows:
•

Cleaning the Parts, on page 572

•

Fixing the Articulations, on page 574
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Cleaning the Parts
To clean the parts you will need to use several drawing tools:
•

Brush Tool

•

Eraser Tool

•

Select Tool

•

Cutter Tool

•

Contour Editor Tool

•

Paint Tool

•

Close Gap Tool

To clean your drawings:
1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

2. In the Timeline or Xsheet view, select the cell containing the drawing to fix.

3. In the Camera view, delete the extra bits using the Select or Cutter tool. You can
also use the Eraser tool.
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4. Draw the missing lines using the Brush tool. If you use the Brush tool, it is
recommended that you enable the Auto-Flatten
option in the Tool Properties
view.

5. Using the Paint tool, paint the gaps. You can close some gaps with invisible lines
using the Close Gap tool.

6. Reshape your lines using the Contour Editor tool.

7. Using the Select tool, select your entire drawing and click on the Flatten
in the Tool Properties view to flatten your drawings.

button
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8. In the top menu, select View > Show > Show Strokes to display the invisible lines
that could be present in your drawing. The default keyboard shortcut is [D].

9. In the top menu, select Drawing > Optimize > Remove Extra Strokes. This
operation will remove any unnecessary invisible lines in your drawing.
10.Repeat this entire process for each drawing to fix.

Fixing the Articulations

Once your pieces are cleaned up, you can proceed to the completion of the
articulations.
Articulations are an important aspect of any cut-out break down, without them a puppet
cannot move properly and will not look good.

Classical Articulation
In this section, you will learn about classical articulation.
Classical articulation is the most popular technique. It is quite simple and produces
excellent results, but it is not the most efficient method. In many instances, it causes
limitations and extra drawing corrections. For example, there may be a gap in the
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articulation if the part is bent too far. Joint design is usually designed as a circle; the
overlapping part cannot be sent behind without showing the joint.

Classical articulation is done by erasing a part of the line from the overlay layer, leaving
the colour overlapping the bottom one.
Repeat the following instructions for all the articulations on your puppet.
To create a classical articulation:
1. In the Xsheet or Timeline view, select the cell containing the first part to modify,
such as the arm.

2. In the Tools toolbar, select the Polyline, Brush, Pencil, Ellipse, or Contour Editor
tool.
3. In the Colour view, select the outline colour.

4. In the Drawing or Camera view, use your drawing tool to make sure that the joint is
overlapping the other part in a half-circle shape.



If you are working in the Drawing view, click on the Light Table
button
located in the Drawing View toolbar. The default keyboard shortcut is [Shift]+[L].

5. Using the Select tool, select your entire drawing and click on the Flatten
in the Tool Properties view to flatten your drawings.

button
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6. In the top menu, select View > Show > Show Strokes to display the invisible lines
that could be present in your drawing. The default keyboard shortcut is [D].
7. In the top menu, select Drawing > Optimize > Remove Extra Strokes. This
operation will remove any unnecessary invisible lines in your drawing.
8. Repeat Step 1 to Step 7 for the other part of the joint.
9. In the Timeline or Xsheet view, select the cell of the part that will be on top of the
joint.

10.In the Tools toolbar, choose the Select, Cutter or Eraser tool.
11.In the Drawing or Camera view, remove a part of the overlapping outline in order to
have only the filling colour overlapping the joint.

[Delete]

NOTE: When placing rotation pivots later on, make sure they are positioned at the
centre of the articulation.
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Rigging

The rigging process is where building a puppet can take several different directions.
In this section, you will learn how to create a simple rig. Afterward, you will learn how to
add pegs and create a hierarchy.
This section is divided as follows:
•

Rigging Basics, on page 577

•

Rigging the Head, on page 580

•

Rigging the Body, on page 582

•

Creating Hierarchy, on page 583

•

Ordering the Layers, on page 584

Rigging Basics
The Rigging Basics topic is divided as follows:
•

Simple Rigging, on page 577

•

Parenting Layers, on page 578

•

Rigging using Pegs, on page 580

•

Rigging the Head, on page 580

Simple Rigging
Simple rigging is very fast and easy to do. It is built as follows:
•

All the body parts are independent

•

All the timeline’s layers are attached to a master peg layer (trajectory layer)
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The advantage of using this technique is that you are free to move any part around
without being influenced by any parent layer.

However, since the parts are not parented to each other, the parts will move from point
A to point B along a straight trajectory. The hand will not follow the arm’s rotation. You
will have to set more keyframes for the hand to move along a curved path.

A

A

B

B

Parenting Layers

When you want a part to follow another one, such as the forearm following the arm, you
can attach the layers one to the other. For example, you can attach the forearm layer to
the arm layer without having to encapsulate the forearm into the arm layer. They will still
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be parented, but you will be able to access the forearm directly without having to enter
the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly
without having to select them or create a series of keyframes.

A
B
A
B

The disadvantage of parenting layers is that you are not able to move the parent
independently of its children, since the child layers receive all the transformation
information from their parent.

Parenting layers such as the arms and legs and letting the torso and hips independent
from those is often a good solution.
To attach one layer to another, you have to drag the desired layer onto the other one in
the Timeline view.
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Animate Pro offers powerful techniques to create hierarchies between your layers
without having to encapsulate Symbols into each other. These techniques are a great
improvement over the less efficient and time consuming method of creating parenting
between your layers by inserting Symbols into other Symbols. Therefore, rigging with
Symbols inside Symbols is NOT recommended.
Symbols Hierarchy

Up to Arm
Up to Forearm

This method is NOT recommended.
For efficiency in your production, do not
encapsulate Symbols inside Symbols.

Rigging using Pegs
When you are doing more advanced puppet rigging, you can use peg layers. Peg layers
are trajectory layers that do not contain drawings. They are motion paths that you can
use to control your entire puppet or advanced hierarchies.
Parenting a drawing layer to a peg layer allows you to divide your motions on two
separated levels. You can scale your body part directly on the drawing layer. This way,
you do not affect any child layers that could be attached to that part. Then, you can
perform your translation and rotation on the peg layer so that all the parts attached to
that peg layer will follow the same trajectory.

Translation and Rotation on
the forearm and hand

Scale, Squash and Stretch on
the forearm, independently
from the hand

Rigging the Head
You will start by attaching the facial features to the head.
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The advantage of parenting the features to the head layer is that you can easily animate
each facial feature, and they will all follow the head motion.

To parent the facial features to the head:
1. In the Timeline view, undo the parenting to the Head layer to have all of your head
layers at the same parenting level.

2. In the Timeline view, unselect any layer that could be selected.
3. In the Timeline View Layer toolbar, click on the Add Peg
button to add a new
peg layer to your timeline. You can rename the Peg to keep your work organized.
4. Select all the head and facial features layer and drag them ONTO the peg layer to
parent them.

581

Animate Pro 2 - Student Workbook

5. Select the Head layer and drag it below all the facial feature layers. Make sure it
stays connected to the peg.

Rigging the Body
Now that the character’s head is ready, you can move on to the body. You can do a
simple rigging where all of the body parts are independent one from the other, or create
some parenting between some of the layers.
Simple Body Rigging
Simple rigging consists of leaving the layers in the Timeline view without doing any kind
of parenting. Later on, you will attach those layers to a master peg and organize them
in the correct order.
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Creating Hierarchy
Animate Pro lets you extend your rigging techniques beyond normal boundaries and
sets new standards. You can create hierarchies without encapsulating your Symbols
inside each other by creating a linked structure between your layers.
You should create a hierarchy on your arms and legs and keep the arms and legs
separated from the body. This gives you more animation freedom. This way, when you
need to scale or skew the torso, it will not affect the entire body.
Head Hierarchy
Left Arm Hierarchy

Right Arm Hierarchy

Independent Torso
and Hips

Right Leg Hierarchy

Left Leg Hierarchy

To create a hierarchy in the Timeline view:


Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you
can drag the parent (forearm) piece onto another parent piece (arm).
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Ordering the Layers

At this point, it is possible that your character’s pieces may show up in the incorrect
order.
There are two ways to fix this.
First, you can reorder your layers by dragging them to a higher or lower level in the
Timeline view. The top layer is displayed in front of the others and the bottom one is
displayed behind. Second, you can use the Z-axis nudging (forward and backward) for
the extra views.
•

Ordering the Timeline Layers, on page 584

•

Nudging Parts Backwards and Forwards, on page 585

Ordering the Timeline Layers
The layers should be ordered to match the view you will use the most often, generally
the three-quarter front. Do not worry if the other views are still in the wrong order, you
will order them in the next step. Do not move the drawings to other layers.
To order the layers:


584

In the Timeline view, drag a layer to reorder it and drop it between the other layers.
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If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it
between layers.

Nudging Parts Backwards and Forwards
If you created a hierarchy on your arms, legs or other body parts, it is possible that you
will want a part, such as the hand, to appear in front of its parent. Yet, if you move the
hand layer above the arm layer, you will break the hierarchy. To reorder a layer rigged in
a hierarchy, nudge it backwards or forwards.

You will do the same for the layers that are not in the right order on the extra views. Do
not place the drawing on another layer. You want to keep all your drawings of the body
parts in the same layers like a box containing all of the hands or all of the shoes.
Animate Pro allows you to move your elements in three dimensions:
•

Up and Down (Y-axis)

•

Left and Right (X-axis)

•

Backwards and Forwards (Z-axis)

In the same way you create multiplane backgrounds (depth), you can do a micro nudge
of the part to be reordered and see it in front of the other elements, even if its layer is
actually behind the other ones in the Timeline view. The Forward-Backward position can
also be animated over time.
Repeat the following instructions for all the views.
To nudge your parts backward and forward:
1. In the Tools toolbar, select the Transform
Animate
mode.

tool. Make sure to enable the
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2. In the Camera view, select the element that you want to reorder.

3. To move the element forward, use the default keyboard shortcut
[Alt]+[Down Arrow] and to move the element backward, use the default keyboard
shortcut [Alt]+[Up Arrow].

Adding the Master Peg

When you animate your character, you will probably need to resize and reposition it to
fit your scene. When you need to scale down or move your character, it is a good idea
to hook (attach) the whole puppet to a trajectory.
Attaching your puppet to a peg will allow you to scale it and reposition it without having
to do this to your different parts and pieces. Only one layer will contain the position
information, this makes your animation easier to modify and control.
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To add a Master peg:
1. In the Timeline view, click on the Add Peg
plus the character’s name.

button. Name the new peg Master

2. In the Timeline view, select all of the layers you want to attach to your new peg.
3. Drag your selection ON the peg layer to parent all your character’s pieces to the
peg.
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Creating the Keyframes
Once all of your drawings are ordered and your master peg is added, you need to insert
keyframes on each cell to create all of the function curves and block your pose in place.
To create the keyframes:
1. In the Timeline view, collapse the master peg by clicking on the Expand arrow.

2. In the Timeline view, select the first cell.

3. In the top menu, select Insert > Keyframe. The default keyboard shortcut is
[Ctrl]+[F6] (Windows®)
or [a]+[F6] (Mac OS® X).You can also click on the Add Keyframe
button located
in the Timeline view toolbar. Note: If you use the [F6] shortcut when working the
Flash keyboard shortcuts, this not only creates a keyframe but also duplicates a
drawing.

Adding the Main Extra Drawings

Your break down is now complete. You can move on to adding the main extra drawings
your character needs, such as principal hand positions and mouth shapes.
If ever you forget to add extra drawings in your main character’s template, you will easily
be able to add them later.
Add your extra drawings in the layer corresponding to the part which you are
drawing. You should see the layers as containers for the different pieces. Each part of
the body has its own container where you can add more drawings of the same part.
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To add the main extra drawings:
1. In the Timeline view, collapse the master peg by clicking on the Expand arrow.

2. In the Timeline view, select all the keyposes following the one you need to extend.

3. Click and drag your selection to extend the keypose.

4. Repeat the last operation for each keypose.

5. Click on the Expand

arrow to expand the master peg.

6. In the Timeline view, select the cell where you want to add your new drawing

7. Select Drawing > Duplicate Drawings, you can also use the keyboard shortcut
[Alt]+[Shift]+[D].
This creates a new drawing in the selected cell, automatically extended to the next
one. This new drawing is a duplicate of the one that was selected so it contains a
duplicate of the art. You can modify it to create your new drawing or delete its
contents in the Camera or Drawing view and start from scratch.
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8. In the Tools toolbar, select the drawing tool you need to draw your extra part.

9. In the Camera or Drawing view, draw your new drawing.

10.Using the Select
tool, select your drawing and flatten your lines by clicking on
the Flatten
button located in the Tool Properties view.

Setting the Pivots

The last step before storing the character in the library is to set the pivots for the
different parts.
Animate Pro has two types of pivots:
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•

Drawing Pivot

•

Symbol Pivot
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You can set a different pivot for each one of your drawings. For example, if you have a
series of drawings from different views, they are not likely to rotate from the same
location. In that case, you can set a different pivot for these drawings.

This topic is divided as follows:
•

Pivot Tool, on page 591

•

Setting the Pivots, on page 592

•

Setting Pivots on a Frame Range, on page 593

•

Setting the Master Peg’s Pivot, on page 595

Pivot Tool
Use the Pivot
tool to set the pivots on your character. This can be used to set the
pivots on the drawings and Symbols.
In the Pivot’s Tool Properties view, you will find a series of options.

Set the Pivot for Symbol on All Frames
This option is enabled by default. When you set a pivot on a Symbol, all of its cells will
use the same pivot. This means you do not have to set a pivot on all frames. You set it
once, and it is done.
If you prefer to set a different pivot for a series of cells, you can disable the option and
set your pivots on each cell or cell range.
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If you have already set several different pivots on your Symbol’s cells and enabled
the Set the Pivot for Symbol on All Frames option, once you set a new pivot on the same
Symbol, all of its pivots will be reset and will use your new pivot.

Snapping
When you drag the pivot around, you can enable a snap option when the pivot is
released it either snaps to the reference grid, drawing’s contour or aligns with an existing
drawing stroke.

Reset Pivot
When you click on the Reset Pivot option, the pivot of the selected drawing or Symbol
is reset to the centre of the Camera view (stage).

Copying Pivot on Parent Symbol
When you import new extra drawings such as hands and mouths, use the pivot that was
set on your drawings and report them to the Symbol’s cells. Use the Copy Pivot to Parent
Symbol command for this.
NOTE: When you copy your pivots to the parent Symbol, there is no link between the
drawings’ pivots and the Symbol’s pivots. If you modify the drawing pivot later, it will not
link to the Symbol. You would need to do the operation again. If you need to modify the
Symbol’s pivots, do it directly on the Symbol’s cells.

Setting the Pivots
If you want your puppet’s pieces to rotate correctly, you need to set the pivot points
right in the middle of an articulation such as an elbow or a knee.
Do the following steps for each layer in the Timeline view.
To set the pivots:
1. In the Tools toolbar, select the Pivot

tool.

2. In the Camera or Timeline view, select the drawing you want to set the pivot for.
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3. In the Camera view, click where you want to the pivot to be. You can also drag the
pivot marker to the desired location.

4. If you want to set a different pivot for another drawing, select the drawing or cell
and in the Camera view, set the new pivot.

Setting Pivots on a Frame Range
If some elements need the same drawing pivot, such as all of the three-quarter hands,
you can select all of these hands cells and set the pivot all at once. If your pivot is already
correctly set on your first drawing, copy and paste that pivot onto the other drawings in
the Timeline or Xsheet view.

You must have the same drawing pivots on the extra parts from the same angle. If you
substitute a drawing while the part is rotating, the animation risks popping out of place
if the pivot is uneven.
To set the pivot on a frame range:
1. In the Timeline view, select the cell where you want to set the same pivot. The cells
have to be part of the same layer.

593

Animate Pro 2 - Student Workbook

2. In the Camera view, click where you want to the pivot to be. You can also drag the
pivot marker to the desired location.

To copy and paste drawing pivots:
1. In the Drawing or Camera view, set the first drawing pivot of the series. For
example, set it on hand-1.
2. In the Timeline view, select the cell that contains the correct pivot.

3. In the top menu, select Edit > Copy.
4. In the Timeline view, select the cell range that requires the same pivot.

5. In the top menu, select Edit > Paste Special. The default keyboard shortcut is
[Ctrl]+[Shift]+[B] (Windows®) or [a]+[Shift]+[B] (Mac OS® X).
The Paste Special dialog box opens.

6. In the Paste Special dialog box, go to the Advanced tab.
7. In the Drawings section, enable the Update Drawing Pivot option.
8. Click on the OK button.
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Setting the Master Peg’s Pivot

By default, your Master peg pivot is placed at the centre of the Camera view, which
generally equates to your character’s hips. A good way to set your peg’s pivot is to move
it between your character’s feet.
To permanently move a peg pivot, use the Rotation or Scale tool. While animating, you
are easily able to temporarily move this pivot to another location with the Transform tool.
The Transform tool is designed to move the pivot temporarily during the animation
process. It also permits you to select multiple pegs and apply a common temporary
pivot.
To set the peg pivot:
1. In the Advanced Animation toolbar, select the Rotate
default keyboard shortcuts are [Alt]+[3] and [Alt]+[4].

or Scale

tool. The

2. In the Timeline view, select the Master peg layer.

3. In the Camera view, click on the peg pivot and move it to its new location.

If you added other pegs to your rig, you must set their pivot following the same
method.
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Sharing the Puppet
To be able to reuse your character in different scenes, you have to store a template in
the Library. You can create different kinds of templates. You can create templates with
all the views included, a template for each view or even some containing only the head.
To create a template containing all the character’s views:
1. In the Library view, right-click (Windows®) or [Ctrl]+click (Mac OS® X) on the desired
library folder and
select Right To Modify.
2. In the Timeline view, collapse the Master peg layer.

3. If your scene has a series of blank cells, they will also be included in the template if
you drag the layer to the library. Reduce the scene length to have no empty cells
before creating your template.
4. To create your template:


In Animate Pro, select the collapsed layers from the Timeline view’s left side and
drag them into the Library view.

The Rename dialog box opens.

5. In the Name field, name the new template.
6. Click on the OK button.
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To create a template containing a single character’s views:
1. In the Library view, right-click (Windows®) or [Ctrl]+click (Mac OS® X) on the desired
library folder and
select Right To Modify.
2. In the Timeline view, collapse the Master peg layer.

3. Select the cell containing the desired view and drag it into the desired library folder.

The Rename dialog box opens.

4. In the Name field, name the new template.
5. Click on the OK button.
To create a template containing only the character’s head:
1. In the Library view, right-click (Windows®) or [Ctrl]+click (Mac OS® X) on the desired
library folder and select Right To Modify.
2. In the Timeline view, expand the Master peg layer.
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3. In the Timeline view, collapse the head layer if it has any child layers.

4. Select the head cell containing the desired view and drag it into the desired library
folder.

The Rename dialog box opens.

5. In the Name field, name the new template.
6. Click on the OK button.
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Activity 1: Creating a Cut-out Puppet
You’re now ready to take the drawn design and to cut and build it into a puppet.

Step 1: Analysing the Design

Start by analyzing your character. What are the main parts? If you look at this sample
character, Limpa, you can identify five main pieces:
•

Body

•

Left Arm

•

Right Arm

•

Left Leg

•

Right Leg

Later on, you will break those sections in smaller pieces such as right hand, left foot, right
eye, mouth, head, etc.
Before starting any breaking down, try to decide what will be separated from what. For
example, to keep this puppet simple, we will keep the hat attached to the head, but you
could decide to separate it from the head to be able to animate it independently.
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Step 2: Breaking Down the Main Parts

To breakdown your character, use the Select

tool and the Cutter

tool.

You do not need to create new layers when you break down your character. They will be
created as you go. Start by creating the main pieces of your character. In this case, the
body, arms and legs.
Use the Cutter
and Select
tools to extract the parts, such as the arms, from the
body and send them to separate layers. It does not matter if there are bits from other
parts or gaps. You will fill and fix those later.
Keep this activity simple by doing only the three-quarter view.
1. In the Tools toolbar, select the Cutter

tool.

2. In the Tool Properties view, select the Lasso Selection
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3. In the Camera view, trace a selection around the first part to separate it. In this case,
we will do the right arm.
•

You can hold down the [Shift] key if you want to create a second area.

•

If you simply click on a line, it will be entirely selected until it meets an
intersection.

4. In the top menu, select Edit > Create Drawing from Drawing Selection. The
default keyboard shortcut is [F9] (Windows) or [a]+[F9] (Mac OS X).
5. In the dialog box, type the new layer name.
6. Disable the Cut Artwork from Source option. When you create layers out of your
colour model, you do not want to cut out the artwork. Then press the OK button to
validate.

7. Repeat the process for each main piece: body, legs, arms, head, etc.

Once your main pieces are separated, you can start to break them down.
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8. In the Camera view, select the hand from the new arm layer. Do not select it from
the model.

9. In the top menu, select Edit > Create Drawing from Drawing Selection.
10. In the dialog box, type the new layer name.

11. Enable the Cut Artwork from Source option. You want to cut the hand away from
the arm. Click on the OK button.

12. Repeat the process for each part in the character to be broken down.
All of the parts should now be in separate layers.
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Step 3: Fixing Articulations and Gaps

Now that all your parts are in their respective layers, it is time to fix the rough cuts you
did earlier and draw nice articulations. To do so, you will use tools such as:
•

Eraser tool

•

Paint tool

•

Contour Editor tool

•

Brush tool

•

Select tool

The body artwork continues
underneath the arm drawing.
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When you fix the joints, make sure they overlap properly. Remember that the puppet will
be animated and each part will move and rotate, so make sure not to leave a gap in the
part underneath.
Top part

Bottom part

Overlapping zone

The easiest articulation to make is the classic joint. The classic joint consists in removing
a portion of the outline on the overlapping part. For example, the outline around the
elbow can be erased on the forearm piece. The arm placed beneath the forearm will
keep its entire outline.
When you assemble those two pieces together, the joint is seamless and it looks like a
single drawing!
There are other ways to build articulations that are even more efficient. This one is the
simplest and is often quite sufficient.

When you assemble the two
parts, the joint is seamless.
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Step 4: Ordering the Puppet’s Layers

At this point it is possible that your character’s pieces may show up in the wrong order.
There are two ways to fix this.
To reorder your layers drag them to a higher or lower level in the Timeline view. The top
layer is displayed in front of the others and the bottom one is displayed behind.
Displayed in front

Displayed behind

•

In the Timeline view, drag the layer to reorder it and drop it in-between the
other layers.

•

If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it
in-between layers.
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Step 5: Setting the Pivots

If you want your puppet’s pieces to rotate properly, you need to set the pivot points.
Even the eyes and mouth require you to set their pivots.
Do the following steps for each layer in the Timeline view.
To set the pivots for the Body parts:
1. In the Tools toolbar, select the Pivot

tool.

2. In the Timeline view, select the cell you want to set the pivot for.
3. In the Camera view, click where you want the pivot to be. You can also drag the
pivot marker to the desired location.
4. To test your pivot, make sure to turn the Animate
Transform

Tool, test your pivot by rotating the piece. If the piece doesn’t quite

fit right, you can go back tot eh Pivot
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Step 6: Creating Hierarchies

To create a hierarchy:
1. Simply drag the child piece (hand) and drop it ON the parent piece (forearm). Then,
you can drag the parent (forearm) piece on another parent piece (arm).

You should create a hierarchy of your arms and legs and keep the arms and legs
separate from the body. This gives you more animation freedom.
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Step 7: Ordering Layer Hierarchy
If you created a hierarchy of your arms, legs or other body parts, it is possible that you
will want a child part, such as the hand, to appear in front of its parent. If you move the
hand layer above the arm layer, you will break the hierarchy.

Therefore, to reorder a layer rigged in a hierarchy, nudge it forward or backward.
Animate Pro allows you to move your elements in the three dimensions:
•

Up and Down (Y)

•

Left and Right (X)

•

Forward and Backward (Z)

In the same way you can create multiplane backgrounds (depth), you can do a micro
nudge on the part to be reordered. This makes possible for a reordered part to appear
in front of the other elements even if its layer is behind the other ones in the Timeline
view. The Forward-Backward position can also be animated over time.

Normal ordering

Forward - Backward ordering

1. In the Tools toolbar, select the Transform

tool. Make sure to disable the Animate

mode.
2. In the Camera view, select the element to reorder.
3. To move the element forward, user the default keyboard shortcut [Alt] + [Down
Arrow] and to move the element backward, use the default keyboard shortcut
[Alt] + [Up Arrow].
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Step 8: Adding a Master Peg

To control all your puppet’s pieces together, you will need to add a peg layer at the top
of your hierarchy. A peg layer is a trajectory on which you can attach your character. This
way you can scale and reposition your complete character for the entire scene or over
time.
1. In the Timeline view, click on the Add Peg

button. Name the new peg Master.

2. In the Timeline view, select all of the layers you want to attach to your new peg.

3. Drag your selection right on the peg layer to parent all your character’s pieces to
the peg.
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Step 9: Storing the Puppet in the Library

To store your character in the library you need to create a position keyframe on all your
layers and then store it as a template in a sharing library.
1. In the Timeline view, select the first frame of every layer.
2. In the top menu, select Insert > Keyframe or use the default keyboard shortcut
[Ctrl] + [F6] (WIndows) or [a]+[F6] (Mac).
3. In the Library view, select the Animate Pro Library folder, right-click (Windows) or
[Ctrl]+click (Mac OS) and select Right To Modify.
4. In the Timeline view, select all of your layers and drag them into the Animate Pro
Library.
You now have a complete cut-out puppet!
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M26: Library and Symbol
Management

In this lesson, you will learn Symbols and Libraries.
This lesson covers the following topics:
•

About Symbols and Libraries, on page 612

•

Library View, on page 614

•

Structuring the Library, on page 616

•

Using Paste Special, on page 621
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About Symbols and Libraries
You can share and reuse any elements you create in Animate Pro using Symbols and
Templates. Animate Pro has a library where you can store several different elements such
as puppets, backgrounds, animations and keyposes. In fact, anything you create in
Animate Pro can be stored in the library.

Understanding the Library Concept
Use the Library view to reuse your artwork and animation in other scenes or to build
props and puppets.

What is a Library?
A library is a folder where you store your Templates and Symbols, you can access these
folders from different projects. Using the library is easy, just drag the content into the
library to store your artwork and then drag it into your Timeline view when you want to
reuse it.
Organize your library using subfolders, you can keep several different library folders on
your hard drive or network.

What is a Symbol?

A Symbol is a container or construction block used to build your props, puppets and
looping clips. Use Symbols to contain artwork and animation, to manipulate them as a
single object, or as a case holder where you will put a series of different drawings for
each body part of your puppets.
To create a Symbol, drag your artwork to the Symbol library. When you drag a Symbol
from the Symbol Library into your scene, it is linked to the original one. If you drag a
Symbol into your scene several times in the Timeline view, they are all linked to the
original one. If you modify one, they are all modified.
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A Symbol is local to the project and cannot be accessed directly from other scenes. To
reuse a Symbol’s content into another scene, you must create a template out of it.
When a Symbol is exposed in the Timeline view, the Symbol’s cells are represented as a
movie strip.
Regular Drawing Cells
Symbol Cells

What is a Template?
A template is an individual copy of the artwork stored in the library, this package can be
reused in different scenes. Once a template is stored in the library it can be accessed
from any project.
Dragging a template into your scene copies the content in your Timeline and does not
link it to the original. This individual copy can be modified at will.
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Library View

You use the Library view to create and manage your Symbols and templates, display the
folders and manage all of the content.
The Library View menu lets you access commands specific to the Library view such as
opening a Library or getting the rights to modify a library folder.

Preview and Drawing Substitution

The Preview window, allows you to preview the content of a Symbol or template and to
swap between drawings and Symbol cells in your Timeline view. This window is also used
as the Drawing Substitution window.
To preview a template or Symbol’s content:
1. In the Library view’s right side, click on double-click on the Symbol or template to
preview.
2. In the Preview window, click on the Play
through the frames.
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Library List

The Library List is used to navigate through the different libraries and subfolders. You
can also open, close and create new libraries from here.
The Library folders have these default libraries:
•

Symbols
The only library folder containing Symbols for your project. You can organize the
Symbols library folder using subfolders, but you cannot create a second Library
for your Symbols. This library is local to your project.

•

Animate Pro Library
This folder contains templates and is stored on your hard drive. You can organize
the Animate Pro library folder using subfolders. This folder does not contain
Symbols.

Templates and Symbols List

The Symbols and templates contained in the selected Library list are displayed on the
right side of the Library view as thumbnails, in a list or as details.
To change the templates and Symbols list display:


In the Library view’s right side, right-click (Windows) or [Ctrl]+click (Mac OS X)
and select View > List, Thumbnails or Details.
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Structuring the Library
As you will probably create a large number of Symbols and templates you will soon
realize that they need to be organized. You can create different libraries and subfolders
so that you can gain easy access to your assets. For example, create a different library
for each project and divide it into several categories, such as:
•

Characters

•

Props

•

Backgrounds

Although you can only have one Symbol library folder, you can organize it by creating
subfolders.

Creating a Library
There are two ways to create Library folders.
•

Using the Animate Pro interface.

•

Directly through your operating system.

To create a library using your operating system, create a new folder with a relevant name
in the location where you want the library to be stored. This can be opened in Animate
Pro when you require it, see Opening a Library to find out how.
To create a library from Animate Pro:
1. In the Library view click on the Menu
Folders > Open Library.

button and select

The Browser window opens.
2. Browse for the location where you want to store your new library.
3. Click on the Make New Folder button.
The new folder appears.
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4. Give the new library a relevant name.

5. Click on the OK button.
The new library appears in the Library List section.

Opening a Library
You can open any folder on your hard drive or network as a library. Opening a library
means linking the folder to your Library view. You only need to open the library once.
The library folder is available every time you open the application until you decide to
close the library and unlink it.
To open a library:
1. In the Library View menu, select Folders > Open Library.
The Browser window opens.
2. Browse to the location of the library folder.
3. Select the folder
4. Click on the OK button.
The new library appears in the Library Folders section.

Closing a Library
You may not always require all of the library folders in the Library List, if this is the case
you can close the ones you do not need. Closing a folder does not delete it, but unlinks
it from the Library view. If you want to reopen it, locate it on your hard drive or network
and open it in the Library view.
To close a library:
1. In the Library view’s right side, select the library folder to close.
2. In the Library View menu, select Folders > Close Library.
The library closes.
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Creating a Folder
Symbols and templates libraries need to be organized, you can create different
subfolders on your hard drive or in the Library view so that you can gain easy access to
your assets. By default, any new library you link to your Library view is locked, this
prevents the accidental deletion or modification of templates and Symbols. You must
obtain the right to modify it before being able to add a new folder to it.
To create a folder:
1. In the Library view’s left side, select the library folder to which you want to add a
subfolder.
2. In the Library View menu, select Edit > Right to Modify.
3. In the Library View menu, select Folders > New Folder.
The new folder appears in the Library. Click on the library containing the new folder
and click on the [+] sign to expand it.

Deleting a Folder
You can delete a folder from the library if its contents are no longer needed.
WARNING: ALL THE TEMPLATES OR SYMBOLS CONTAINED IN THE FOLDER WILL BE
DELETED FROM YOUR HARD DRIVE. ONCE DELETED THE DATA CAN NOT BE
RETRIEVED.
To delete a folder:
1. In the Library view’s left side, select the folder to delete.
2. In the Library View menu, select Edit > Right to Modify.
3. In the Library View menu, select Folders > Delete Folder. The default keyboard
shortcut is [Delete].

Renaming a Folder
Once you add a folder, you can rename it, this also renames the folder on your hard
drive.
To rename a folder:
1. In the Library view’s left side, select the folder to rename.
2. In the Library View menu, select Edit > Right to Modify.
3. In the Library View menu, select Folders > Rename Folder.
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4. Rename the selected folder.

5. Press [Return] to validate the operation.

Refreshing the Library
If you update the content of your libraries through your operating system, you will need
to refresh you library folders in the Library view.
To refresh a library:
1. In the Library view’s left side, select the folder to refresh.
2. In the Library View menu, select Folders > Refresh. The default keyboard shortcut is
[F5]. The library now displays the new content.
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Importing a Network Template
To import a network template:
1. In the Library view, select the template or Symbol you want to import.
2. Drag the selected template to the Network, Camera or Timeline view’s left side.

3. If necessary, in the Network view, connect your template into the Composite
module.

Do this by clicking it’s Out Port and dragging the connection to the Composite
module until an In Port appears.
If the template you are importing was created in the Network view, make sure to
import it first and to drop it in the Network view or in the Timeline left side or some
network connections could be broken.
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Previewing Symbol in the Network View
In Animate Pro, when you import a symbol in your scene, you can navigate through it in
the Network view.
To navigate in your symbol:
1. In the Network view, select the symbol you want to open and press the default
keyboard shortcut [Ctrl]+[E] (Windows) or [Command]+[E] (Mac) to use the
Edit Selected Symbol command.

2. In the Network view, inside the symbol’s top module you will find the composition
of your symbol. In this example, a group module was turned into a symbol.
1

2

3

3. Click on the Top
button in the Network view’s top left corner to return to the top
module.
You can also use the Leave Current Symbol command’s default keyboard shortcut
[Ctrl]+[Shift]+[E] (Windows) or [Command]+[Shift]+[E] (Mac).

Using Paste Special
When you import a Symbol in your scene its full length is exposed by default. If you
import your Symbol in the Timeline view’s left side all the frames will be exposed.
However, if you import it into an existing layer, you can use the Paste Special command
to adjust the import behaviour to fit your requirements.
When you import a template in the Timeline view, all layers are created as well as
drawings and keyframes. It is possible that you will want to import only the keyframes
without the drawings or import only the drawings that are not already in your layers. You
can adjust the behaviour using the Paste Special command.
Once you set the parameters, Animate Pro will reuse them each time you import a
Symbol in the Timeline view’s right side until you set new parameters.
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To open the Paste Special dialog box:
1. In the Library view, select the Symbol or template to import.
2. While dragging the selection to the Timeline view, hold down the [Alt] key
(Windows®) or [Option] key (Mac OS® X).
Note: Drop the selection in the Timeline view before releasing the hot key.
The Paste Special window opens.
3. Set the parameters.
4. Click on the OK button.

Basic tab
Advanced
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Paste Special - Basic Tab
Drawings
•

Only create drawing files when they do not exist: When adding exposures to a
drawing layer, new drawings will only be created if drawings of the same name
do not already exist at the destination.

•

Always create drawing files: When adding exposures to a drawing layer, new
drawings will always be created. If drawing files with the same name already
exist, Animate Pro will create a new name for the drawing.

•

Extend Exposure: Extends the exposure of drawings to fill the range of cells to
the destination frame.

•

Paste all Frames of the Symbols (full movie): When enabled, the Paste Special
command exposes all the Symbol’s frames instead of only the first.

Cycle
•

Number of Cycles: Use the up and down arrows to increase or decrease the
number of cycles you want to paste. You can also type the value directly in the
field.

Cycle Type





Normal (forward): This pastes your selection as it is, starting with the first cell
and ending with the last one.
Reverse: This pastes your selection in reverse, starting with the last cell and
ending with the first one.
Forward -> Reverse: This pastes your selection as a yo-yo, starting with the first
cell, going to the last one and ending with the first cell.
Reverse -> Forward: This pastes your selection as a reverse yo-yo, starting with
the last cell, going to the first one and ending with the last cell.
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M27: Animating a Cut-out Puppet

This module is divided into the following topics:
•

Theory, on page 626

•

Activity 1: Animating the Puppet, on page 652
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Theory
This topic is divided as follows:
•

Animating a Cut-Out Puppet, on page 626

•

Getting the Character, on page 626

•

Keyframes and Drawings, on page 629

•

Creating a Simple Cut-out Animation, on page 632

•

Selecting Layers to Animate or Position, on page 634

•

Navigating the Hierarchy, on page 636

•

Animating using the Transform Tool, on page 638

•

Animating in Stop-Motion, on page 640

•

Animating using Computer Generated Interpolation, on page 641

•

Adjusting the Velocity, on page 642

•

Flipping Through Poses, on page 646

•

Swapping Images, on page 647

•

Adding a New Drawing, on page 649

•

Ordering Layers Over Time, on page 650

Animating a Cut-Out Puppet
In the following pages, you will find information on how to animate your own cut-out
character. Make sure to read these pages carefully and refer to them when you are
animating your own character.

Getting the Character
The first step in animating your character is to import a master template from the library.
This topic is divided as follows:
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•

Importing a Character from the Library, on page 627,

•

Selecting the Pose, on page 628

•

Extending the Exposure, on page 629
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Importing a Character from the Library
To import your character from the library:
1. Create your new Animate Pro project.
2. In the Library view, select the character’s master template you want to animate.

3. Drag the selected template to the Camera or Timeline view’s left side.

4. In the Timeline view, drag the scene length bracket to extend or shorten your scene
length.
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Selecting the Pose

If the template you imported contains several poses, you must choose which pose you
will use to start your animation and remove the other ones.
To select the character’s pose:
1. In the Timeline view, collapse your character’s layers.

2. In the Timeline view’s right side, select the keyframe corresponding to the pose you
want to keep.

3. Drag the selected keyframe to the first frame.

4. Select all of the extra drawings and keyframes that you do not need and press the
[Delete] key.
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Extending the Exposure
Once your pose is chosen, all that is left to do is to extend the exposure of your character
to the end of your scene.
To extend the exposure of your character:
1. In the Timeline view, collapse your character.

2. In the Timeline view’s right side, select the last cell of your character.

3. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the select and select Extend
Exposure. The default keyboard shortcut is [F5]. You can also copy the first pose
and paste it in the last cell.
The drawing exposure is extended to the end. You will not see any changes in your
timeline while the master peg is collapsed.

Keyframes and Drawings
In Animate Pro, the drawings and keyframes are separate items. You can manipulate the
exposure of the drawings independently from the position keyframes.

Keyframes and Drawing Blocks
When you extend the exposure of a drawing it is represented by a grey block in the
Timeline view. When you expose a second drawing, a second grey block is displayed.
You can consider these blocks as Drawing Blocks.

To animate the position of a block over time, you do not need to create a second block,
you simply need to add a position keyframe.
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The position keyframes are coordinates indicating the position of your drawing on a
particular frame. These appear as black squares in the Timeline view.
If you refer to the example below, you can see that the keyframes are positioned on
frames independently from the beginning and end of each Drawing Block.
Kf 1

Dr 1

Kf 2

Dr 2

Kf 3

Dr 3

Dr 4

Kf 4

Dr 5

Kf 5

Dr 6

You can keyframe three different positions for your drawing in the same Drawing Block
and create a motion path between them.

Timeline Behaviour
In the Timeline view, you can see how the Timeline behaves differently depending on
whether you either create a new drawing, a new keyframe, or both at the same time.

Creating a Drawing in the Timeline view
You can use the Create Empty Drawing command to add a new drawing in the Timeline
view. This will automatically insert a new drawing block.
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•

Select Drawing > Create Empty Drawing.

•

You can also use the Create Empty Drawing
toolbar.

button from the Timeline View
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Creating a Keyframe in the Timeline view
You can use the Add Keyframe command to add a new keyframe in the Timeline view.
This will automatically create a keyframe in your layer.
•

Select Insert > Keyframe or use the default keyboard shortcut [Ctrl]+[F6]
(Windows) or
[a]+[F6] (Mac OS X).

•

You can also use the Add Keyframe

button from the Timeline View toolbar.

Creating a Drawing and a Keyframe in the Timeline view at the same time
You can use the Insert Keyframe and Duplicate Drawing command to add a keyframe
and a drawing at the same time. This will create a drawing block containing copies of the
selected drawing and a keyframe.
•

Select Insert > Keyframe and Duplicate Drawing or use the default keyboard
shortcut [F6].

631

Animate Pro 2 - Student Workbook

Creating a Simple Cut-out Animation

To create a simple cut-out animation, follow these steps so you can try out the animation
tools you will learn in the next topics.
By default, when you select an object in the Timeline or Camera view, the trajectory for
your motion path is displayed.
If you do not want to see the trajectory by default, you can disable the Show Control
Points on Selected Layers preference.
To disable the Show Control Points on Selected Layers preference:
1. In the top menu, select Edit > Preferences (Windows) or Animate Pro >
Preferences (Mac OS X). The default keyboard shortcut is [Ctrl]+[U] (Windows) or
[a]+[,] (Mac OS X). The Preferences panel opens.
2. Go to the Camera tab in the Preferences panel.
3. In the Control Points section disable the Show Control Points on Selected Layers
preference.
4. Click on the OK button.
To create a simple cut-out animation:
1. In the Tools toolbar, select the Transform
[Alt]+[Q].

tool. The default keyboard shortcut is

2. In the Transform tool Properties view, make sure that the Peg Selection Mode
disabled.
3. In the Tools toolbar, enable the Animation
will be key framed automatically.

mode so that everything you move

4. In the top menu, select Animation > Stop-Motion Keyframe so that the
interpolation is not created automatically between your keyframes.
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5. In the Timeline view, collapse your character.

6. In the Timeline view, go to the frame where you want to set your first pose.

7. In the Camera view, select the parts to animate.

8. Using the Transform
position.

tool, rotate, skew, scale or translate the selection to its new

A new keyframe appears in the Timeline view.
9. If you want to make sure that nothing will move on your new pose, in the Timeline
view, select the frame corresponding to the pose, right-click (Windows) or
[Ctrl]+click (Mac OS X) and select Insert Keyframe. The default keyboard shortcut is
[Ctrl]+[F6] (Windows) or [a]+[F6] (Mac OS X).
10.In the Tools toolbar, enable the Onion Skin

feature.

11.In the Timeline view, go to the frame where you want to set your second keyframe.
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12.In the Camera view, animate your character.

13.Repeat this process until all your poses are done.

Selecting Layers to Animate or Position
When you are animating characters, it is important to understand how the Animate
mode allows you to create keyframes on the current frame or to reposition the entire
layer.
This topic is divided as follows:
•

Animate Mode, on page 634

•

Selecting Drawing Layers using the Transform Tool, on page 635

Animate Mode
The Animate

button, in the Tools toolbar, toggles the key framing option on or off.

When you enable the Animate mode, as soon as your move an element in your Camera
view, a keyframe is positioned on the current frame in the Timeline view to indicate the
new position.

When you disable the Animate mode, and you select and move an element, the entire
animation in the layer will be offset at once.
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This means that when you are animating your character, you must enable the Animate
mode.
If you are scaling down your puppet to fit the scene composition and want to resize the
entire animation, you must disable the Animate mode.
To enable and disable the Animate mode:


In the Tools toolbar, click on the Animate
button. You can also enable and
disable the Animate mode in the top menu under Animation > Animate.

Selecting Drawing Layers using the Transform Tool
To manipulate your drawing layers in order to animate them, you must use the
Transform
tool. The Select tool is used to modify the drawing strokes and not the
actual drawing layer.
When selecting your drawing layers with the Transform tool, make sure that the Peg
Selection Mode option is disabled in the Transform Tool Properties view. If this option is
enabled it will limit the selection in the Camera view to pegs only.
To select using the Transform tool:
1. In the Tools toolbar, click on the Transform
tool. The default keyboard shortcut is
[Alt]+[Q]. You can also select the Transform tool in the top menu under
Animation > Tools > Transform.
2. In the Transform Tool Properties view, make sure that the Peg Selection Mode
disabled.

is

3. In the Camera view, select the element to animate.

Selecting an element in the Camera View using the Transform Tool
When you select an element in the Camera view using the Transform tool, make sure that
the Peg Selection Mode
is disabled in the Transform Tool Properties view, the
element selected is the actual drawing layer corresponding to the selected element. If
you have a peg parented to that layer, you must either use the keyboard shortcuts to go
up the hierarchy chain, select it in the Timeline view, or enable the Peg Selection Mode
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option in the Transform Tool Properties view, this will limit the selection in the
Camera view to pegs only.

If the layer has child layers, they will also be highlighted.
child
selected
parent

Selecting a Layer in the Timeline View
When you select a layer in the Timeline view, the corresponding element will be
highlighted in the Camera view. If the selected layer has child layers, they will also be
highlighted.

Navigating the Hierarchy
If you created a layer hierarchy when you built your puppet, you can use the keyboard
shortcuts to travel up and down the parent-child chain. You can also travel between the
children in a layer.
To select the parent or child layer:
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode
disabled.
3. In the Camera or Timeline view, select a layer attached to a hierarchy.
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4. Select Animation > Select Parent or press the keyboard shortcut [B] to select the
parent layer and select Animation > Select Child or press the keyboard shortcut
[Shift]+[B] to select the child layer.

[B]

[B]

To select the children layers:
1. In the Tools toolbar, select the Transform

tool.

2. In the Camera or Timeline view, a layer attached to a parent layer with several
children or not parented at all.

3. Select Animation > Select Previous Brother or press the keyboard shortcut [/] to
select the previous child layer and select Animation Select Next Brother or press
the keyboard shortcut [?] to select the next child layer. You can also select
Animation > Select Children, to select all child layers at once.
[/]

[?]
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Animating using the Transform Tool
The transform tool is the main tool you use when working with a Cut-out character. The
Transform tool has many useful functions:
Horizontal Skew

Vertical and Horizontal
Scale
Vertical Skew

Horizontal Scale

Temporary
Pivot Offset

Angle Rotation
Vertical Scale

The Transform tool will create a global selection, so when many parts are selected, the
Transform tool will move it as one. The Transform tool is highly recommended for Cutout.
We do not recommend using the individual Rotate, Translate, Scale and Skew tools
as these are compositing tools, and move each piece from their own pivot point.
When animating with the Transform tool, make sure to select the right selection
mode. In this example, make sure that the Peg Selection Mode
is disabled in the
Transform Tool Properties view or it will limit the selection in the Camera view to pegs
only.

Transform Tool
Rotate Tool
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If you have hierarchy connections in your cut-out character, the Transform tool will also
be used as the Forward Kinematics equivalent.
The Transform tool can be used on any kind of rigging.
When many parts are selected with the Transform tool, the first selected part’s pivot will
be used as the global selection’s pivot. This pivot can be moved temporarily for the
animation. When you offset the pivot, the permanent pivot is displayed as a ghost. The
interpolation of your animation poses is always calculated from the permanent pivot.
To use the Transform tool:
1. In the Tools toolbar, click on the Transform
[Alt]+[Q].

tool. The default keyboard shortcut is

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode
disabled.

is

3. In the Camera view, select the element to animate and move it.

4. In the Timeline view, go to the frame where you want to set your next position.

5. In the Camera view, animate the character.
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Animating in Stop-Motion
To start animating your character, start by doing your key poses. In fact, most of your
time will be spent doing your key poses. It is better to work with Stop-Motion keyframes
as Animate Pro will not automatically create the interpolation between your keyframes.
When using Stop-Motion keyframes, also known as Step keyframes, the segment
between two keyframes is constant. There is no animation generated by the computer
between the poses. The drawing will remain in position until the next keyframe, then
pops to its new position.

Constant Segment
Keyframe
Pops to next
position

Keyframe

Creating a Stop-Motion Keyframe
You can create a Stop-Motion keyframe in several different ways. You can have Animate
Pro create it automatically, transform a Motion keyframe into a Stop-Motion keyframe,
or even switch your preferences to get Animate Pro to always create Stop-Motion
keyframes by default.
To automatically create Stop-Motion keyframes:
1. In the top menu, make sure that the Animation > Stop-Motion Keyframe option is
disabled.
2. In the Timeline view, select the cell where you want to add a keyframe.

3. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Add
Keyframe. The default keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac
OS X). You can also click on the Add Keyframe
button available in the Timeline
View toolbar.
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In the Camera view, if the Animate mode is enabled, as soon as you move the
selected element, a keyframe is automatically created on the current frame.
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To convert a Motion keyframe into a Stop-Motion keyframe:
1. In the Timeline view, select the Motion keyframes to convert into Stop-Motion
keyframes. The default keyboard shortcut is [S].

2. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Set
Stop-Motion Keyframes. The default keyboard shortcut is [Ctrl]+[L] (Windows) or
[a]+[L] (Mac OS X). You can also click on the Stop-Motion Keyframe
button
available in the Timeline View toolbar.

Animating using Computer Generated Interpolation
After you have created the key poses you can animate the in-between poses yourself or
let Animate Pro do it using Motion keyframes. When you use Motion keyframes, your
drawings will gradually move to the next position instead of staying on the spot until the
next keyframe.

Keyframe
Gradually moves to
the next position

Keyframe

Keyframe

Creating a Motion Keyframe
You can create a Motion keyframe in several different ways. You can have Animate Pro
create it automatically, transform a Stop-Motion keyframe into a Motion keyframe and
even switch your preferences to get Animate Pro to always create Motion keyframes by
default.
To automatically create Stop-Motion keyframes:
1. In the top menu, make sure that the Animation > Stop-Motion Keyframe option is
disabled.
2. In the Timeline view, select the cell where you want to add a keyframe.
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3. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Add
Keyframe. The default keyboard shortcut is [Ctrl]+[F6] (Windows) or [a]+[F6] (Mac
OS X). You can also click on the Add Keyframe
button available in the Timeline
View toolbar.


In the Camera view, if the Animate mode is enabled, as soon as you move the
selected element, a keyframe will be automatically created on the current frame.

To convert a Stop-Motion keyframe into a Motion keyframe:
1. In the Timeline view, select the Stop-Motion keyframes to convert into Motion
keyframes.

2. Right-click (Windows) or [Ctrl]+click (Mac OS X) on the selection and select Set
Motion Keyframes. The default keyboard shortcut is [Ctrl]+[K] (Windows) or [a]+[K]
(Mac OS X). You can also click on the Motion Keyframe
button available in the
Timeline View toolbar.

Adjusting the Velocity

To add ease in and ease out on your motion paths, you can display the function curve
and modify the Bezier or Ease curve. To apply an ease to multiple functions and
keyframes, you can use the Set Ease for Multiple Parameters feature and set the amount
desired.
The Velocity, or ease, is used on motion keyframes. The Velocity has to be adjusted
directly on the function curve in either the Function view or the Function editor. When a
keyframe is selected, easing values appear in the right handle and left handle fields, as
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well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them to
adjust the ease in and ease out, or type values in the fields.

Adjusting the Velocity in the Function View
To adjust the velocity in the Function view:
1. In the Timeline View, click on the Expand Function
layer’s functions.

button to display all of the

2. Double-click on the desired function.

The Function Editor opens.

NOTE: that the Function Editor will not be displayed if the function does not already
exist.
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3. Select a keyframe and pull on its Bezier handles or Ease wheel to adjust the velocity.

Adjusting the Velocity on Multiple Elements Concurrently
If you have several functions you would like to adjust the velocity for at the same
time, such as the hand, forearm and arm of a cut-out character, you can use the Set
Ease for Multiple Parameters dialog box. It allows you to apply the same velocity
parameters to all the selected keyframes in one frame.
To set eases on multiple parameters:
1. In the Timeline View, select a keyframe from one or many layers.

NOTE: only the first keyframe selected on a given layer will be considered when
using the Set Ease For Multiple Parameter function. If many keyframes are selected on
the same layer, the ease values will be applied only to the first one and the rest will be
ignored.
1. In the Timeline view, right-click (Windows) or [Ctrl]+click (Mac OS X) and select Set
Ease For Multiple Parameters. In the Timeline View toolbar, you can click on the
Set Ease For Multiple Parameters
button. If the button is not in the Timeline
View menu by default, you can add it through the Toolbar Manager.
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The Set Ease For Multiple Parameters dialog box opens.

4
3

5
6

2. In the graph interface, pull on the Bezier handle to adjust the velocity for all the
selected functions.

3. If you want to apply these easing parameters to a certain type of function only, such
as Rotation or Scale, in the Filters section, disable the function types you do not
want to affect.








Motion: If this option is enabled, the easing parameters will be applied to the
selected Position X, Position Y, Position Z and 3D Path functions
Rotation: If this option is enabled, the easing parameters will be applied to the
selected Angle functions.
Scale: If this option is enabled, the easing parameters will be applied to the
selected Scale functions.
Skew: If this option is enabled, the easing parameters will be applied to the
selected Skew functions.
Morphing: If this option is enabled, the easing parameters will be applied to the
selected Morphing Velocity functions. Note that it applied to the Morphing
velocity function found in the Layer Properties dialog and not to the basic
Morphing ease in the Tool Properties view.
Other: If this option is enabled, the easing parameters will be applied to all the
other selected functions such as all functions created to animate effect
parameters.
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4. You can also adjust the easing by typing values in the Time Ratio and Value Ratio
fields. The values are calculated in percentage.






In the Left Time Ratio and Right Time Ratio fields, type the percentage value
corresponding to the length of time you want the easing to last for. The value
must be between 0% and 100%.
In the Left Value Ratio and Right Value Ratio fields, type the percentage value of
how strong you want the easing out to be. The value must be between 0% and
100%.
If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

5. Once done, click on one of the following button:





Apply: This will apply the easing parameters to the selected keyframes.
Apply/Previous: This will apply the easing parameters to the selected keyframes
and then selects the previous keyframe in the timeline.
Apply/Next: This will apply the easing parameters to the selected keyframes
and then selects the next keyframe in the timeline.
Close: This closes the dialog box. If you did not apply the modifications, they will
be cancelled.

Flipping Through Poses

When animating, it is useful to flip through your poses to see the flow of your animation
without going through each frame in your Timeline. Animate Pro lets you flip between
the selected element’s keyframes.
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To flip through your poses:
1. In the Camera or Timeline view, select the layer you want to see the poses for.

2. In the top menu, select Animation > Go to Previous Keyframe or Go to Next
Keyframe. The default keyboard shortcuts are; [‘] Go to Previous Keyframe and [;]
Go to Next Keyframe.

Swapping Images

Cut-out animation is not only about moving parts around, it’s also about swapping
drawings to give the animation a more traditional animation look.
You can add as many new drawings as you want in your character parts Symbols and use
them in your current animation. You can also add new drawings directly in your scene or
import them from the library.
You do not need to remember the frame on which you drew or imported the drawings
as you will be able to see them in the Drawing Substitution’s interface.
You cannot swap a Symbol for another one, only the Symbol’s frames or layer’s drawings.
You can swap images in the Timeline or Library view. When you use the Drawing
Substitution window in the Library view, you are not selecting drawings from the Library
but from drawings contained in your scene’s layers.
To swap images in the Library view:
1. In the Camera view, with the Transform

tool.

2. In the Transform Tool Properties view, make sure that the Peg Selection Mode
option is disabled.
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3. In the Camera view, select the part you want to swap using the Transform

tool.

4. In the Library view, go to the Drawing Substitution panel.

5. Move the substitution slider to the right or left to scroll through the Symbol’s frames
or drawings. You can also use the keyboard shortcuts [ [ ] and [ ] ] to perform the
scroll, or from the top menu select
Animation > Substitute Drawing Previous or Substitute Drawing Next.

The drawing or Symbol’s cell on the current frame is replaced by the selected one.
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To swap images in the Timeline view:
1. In the Timeline view, click on the Show Data View
view.

button to expand the Data

2. In the Timeline view’s right side, select the cell containing the drawing or Symbol’s
cell to swap.

3. In the Data view, drag the pointer left or right to change the cell or drawing
exposed for another one. You can also directly type the drawing name or Symbol’s
cell number if you know it.

Adding a New Drawing
If you need to add a new drawing in your scene, you can either do it inside the body
part’s Symbol or, if you do not use Symbols, directly on the part’s layer by duplicating
the existing drawing on the current frame.

Duplicating a Drawing
If your character does not use Symbols, you need to duplicate the drawing on the cell
where you need to use a new drawing. You could also create a new blank drawing, but
duplicating the existing drawing allows you to keep the pivot you previously set and you
can also reuse a portion of the existing artwork. When you create a new drawing, you
get a blank cell with a pivot set at the centre of the Camera view.
To duplicate a drawing:
1. In the Timeline or Camera view, select the drawing to duplicate.
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2. In the top menu, select Drawing > Duplicate Drawing. The default keyboard
shortcut is [Alt]+[Shift]+[D].
The new drawing appears in the currently selected cell.

3. In the Camera view, draw the new piece.

Ordering Layers Over Time

The layer ordering system in Animate Pro saves time and simplifies your work. There is
no need to create a new layer or to copy and paste artwork into other layers to change
the order. The Z-axis (forward - backward) allows the user to create a multiplane and
move elements closer or farther from the camera. This allows the puppet’s pieces to be
moved in front or behind the other ones without physically changing the layer position.

Animate Pro provides you with a shortcut to move the piece with a micro nudge on the
Z-axis. The program creates a keyframe where different Z values can be entered. This
allows for the piece to move forward and backwards in space without you having to
change the drawing’s original position or break the layer hierarchy.
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This also means that the layer ordering is maintained throughout the whole scene. You
can combine animation assets so that the system can interpolate them.
To nudge elements on the Z-axis:
1. In the Tools toolbar, select the Transform
[Alt]+[Q].

tool. The default keyboard shortcut is

2. In the Tools toolbar, enable the Animate

Mode.

3. In the Camera View, click on the part to be repositioned and hold down the [Alt]
key. Using the [Up] or [Down] arrow keys, nudge the part until it moves to the
desired position.
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Activity 1: Animating the Puppet
In this activity, you will be using the character you created in the previous module
Building a Cut-out Puppet to do an animation. Plan your project ahead, storyboard a
small action that you will then do in Animate Pro. Keep it simple, no need for a
background or accessories in this activity. Just think a small but fun action for your
character.

Step 1: Creating a Scene and Importing Your Puppet.
1. Start the software by double-clicking the icon.
2. In the Welcome Screen, name your project Puppet_Animation followed by your
initials.
3. From the library, drag your character template into the Timeline view’s left side.
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Before starting your animation, you may want to enable the Onion Skin feature to
see your previous and next frames as a reference.

Current Image
Onion Skin 1
Onion Skin 2

•

In the Tools toolbar, enable the Onion Skin

option.

•

You can also enable individual layer’s onion skin by clicking on their Onion Skin
icon in the Timeline view.

Step 2: Repositioning the Character

Now that you have your puppet on your stage, you probably need to resize and
reposition it to fit your scene. When you need to scale down or move your character it’s
a good idea to hook (attach) the whole puppet to a trajectory.
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In Animate Pro, there is a type of layer you can add to your timeline allowing you to
create a motion path or to reposition drawings. This trajectory layer is called a Peg. Any
drawing or layer you hook to a peg will follow the defined motion path, rotation, scaling
and skewing information.
Attaching your puppet to a peg will allow you to scale it and reposition it without having
to do it on all of your different parts and pieces. Only one layer will contain the position
information, this makes your animation easier to modify and control.
If you do not have a top peg layer to control your character, you can add one at any time.
A peg layer is a trajectory on which you can attach your character. This way you can scale
and reposition your character for the entire scene or over time.
1. In the Timeline view, click on the Add Peg
called Master.

button. The new peg should be

2. In the Timeline view, select all of the layers you want to attach to your new peg.
3. Drag your selection right on the peg layer to parent all your character’s pieces to
the peg.

Next, you need to position your character on the stage by moving and scaling it to
the correct size. You will not scale each layer individually. You either want to do it on
the top symbol or top peg layer.
4. In the Timeline view, select the top peg layer (master peg).
5. In the Tools toolbar, select the Transform
mode.

654

tool and disable the Animate

Animating a Cut-out Puppet

6. In the Camera view, position the character.
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Step 3: Animating Using the Transform Tool

From now on, the Transform

tool will become your most useful tool. You will use it

to do most of your animation. With the Transform
rotate, skew, squash and stretch.

tool, you can select, move, scale,

1. In the Timeline view, go to the frame where you want to animate your first pose. At
this point, it is generally the first frame.

2. In the Tools toolbar, select the Transform
mode.

tool and enable the Animate

3. In the Camera view, select the part you want to animate and using the Transform
tool’s anchor points, move it to its new position.
The pose you are doing is automatically retained. There is no need to set a keyframe
before moving your parts. As soon as you move an element in your Camera view, a
keyframe is set on the current frame in the Timeline view.
Remember, animation keyframes and drawings are not the same thing. If you swap a
drawing, you do not need to insert a keyframe in your timeline.
4. Once your first pose is ready, move on to your next key pose. In the Timeline view,
move to the frame where you want your second pose.
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If you need to, you can temporarily move the Transform tool’s pivot to provide a
better rotation or scale centre. Simply drag it to where you need it. Next time you
select your element, it will be back to its original place.

You can also select your current selection’s parent layer by using the default
keyboard shortcut [B]. If you press on it repeatedly, you will go up the entire parent
chain until the master peg or highest layer in the tree.

[B]
[B]
To lock all the parts in place, we recommend that you collapse your master peg and
add a keyframe after your pose is set. You only need to do this once.

5. In the Timeline view, select the pose and press [F6].
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Step 4: Motion and Stop-Motion

By default, your keyframes will be created as Motion Keyframes. This means that
Animate Pro automatically generates the animation between your poses.

Because you may not necessarily want that, you can set your keyframe creation mode to
create Stop-Motion Keyframes. Later on, you will be able to convert the desired
keyframes to Motion Keyframes.
To switch between Motion and Stop-Motion Keyframes:
1. In the Timeline view, select the keyframes to 1. convert.
2. Right-click (Windows) or [Ctrl] + click (Mac OS X) 2. and select Set Stop-Motion
Keyframe
3. Press the
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.

button to see your animation.
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Step 5: Swapping Images

Cut-out animation is not only about moving pieces around, it’s also about switching
some drawings around. For example, the ballerina wants to point her toes.
Instead of rotating the foot, you can swap the regular foot drawing for another one that
you drew when you built your character. You could also create an empty drawing on your
foot layer and draw a new foot while animating.
To swap a drawing:
1. In the Camera view, with the Transform

tool, select the part you want to swap.

2. In the Library view, go to the Drawing Substitution section.
3. Move the substitution slider to the right or left to scroll through the symbol’s frames
or drawings. You can also use the keyboard shortcuts [ [ ] and [ ] ].

Step 6: Easing
Slow

Slow
If you use Motion Keyframes in your animation, you will want to add some ease in and
ease out to smooth out your movements and avoid having a robotic animation.
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There are two ways to set an ease on your animation:
•

Directly on the Function Curve

•

Using the Set Ease For Multiple Parameters script

Directly on the Function Curve
1. In the Timeline view, expand the layer corresponding to the part you want to set the
ease on by clicking on the Show Functions
button. If the layer is a parent, make
sure to expand its children by clicking on the Expand Hierarchy
arrow.

2. Double-click on the function corresponding to the movement you want to ease,
such as Angle, for the rotation of the thigh. This opens the Function Editor.
In the Function Editor, you can see all of the keyframes corresponding to the thigh
rotation animation.
3. In the function curve, locate the keyframe corresponding to the animation you want
to ease.
4. Select the keyframe and pull on the Bezier handle.

•

The more you pull on the Bezier handle, the stronger the ease will be.

This technique is good when you have to do a simple ease. However, when you have a
series of layers you want to set to the same ease it can be tedious and repetitive. Instead,
you will use the Set Ease for Multiple Parameters function.

Using the Set Ease For Multiple Parameters script
1. In the Timeline view, collapse the parent peg layer containing all of the layers you
want to ease.
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2. Right-click (Windows) or [Ctrl]+click (Mac) and select Set Ease for Multiple
Parameters.

3. Pull on the Bezier handle and adjust the keyframe’s velocity.
4. Click on the Apply button and then on the Close button.
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M28: Sound and Lip-sync in Cut-Out
Animation

This module is divided into the following topics:
•

Theory, on page 664

•

Activity 1: Importing a Sound, on page 666

Animate Pro 2 - Student Workbook

Theory
This topic is divided as follows:
•

Lip-sync, on page 664

Lip-sync
Adding a lip-sync to a project can really enhance its quality and storytelling. However, it
can be difficult to shape a character’s mouth so that it matches the sound at the precise
frame.
To solve this problem Animate Pro provides a lip-sync feature which analyses the
contents of a sound element and generates a mouth chart (see below) based on the
eight animation phonemes (A, B, C, D, E, F, G, and X, which is used to represent silence).

Here is an approximation of which sound each mouth shape can produce:
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•

Mouth Shape A: b,m, p

•

Mouth Shape B: d, h, i, j, k, s, t

•

Mouth Shape C: a, e

•

Mouth Shape D: A, E

•

Mouth Shape E: o

•

Mouth Shape F: oo, u

•

Mouth Shape G: f, ph

•

Mouth Shape X: Silence, undetermined sound

Sound and Lip-sync in Cut-Out Animation

The mouth shapes used by Animate Pro are based on the conventional mouth chart used
in the animation industry. The letters used to represent the shapes do NOT correspond
to an actual sound and are only used for identification of the mouth shape.
Adding lip-sync to a project can really enhance its quality and storytelling. There are
many useful features available to help you complete this task quickly and efficiently.
You can lip-sync the traditional way or let the system automatically create the basic
detection.
You can use your own lip-sync ready cut-out character and sound file or use the ones
provided to you in the sample material package.
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Activity 1: Importing a Sound

The first step in lip-synching an animation is importing the dialogue into your scene. The
dialogue is a sound file which only contains your character’s voice. It is important to only
have the sound of the voice in this file as it will be the only sound which the lip-sync
process will detect. In this example, the dialogue we will use is cartoon_monster-01.wav.
To import a sound:
1. File > Import > Sound.
2. In the Select Sound File browser, select your sound file and click on the OK button.

The sound layer will appear in the Timeline view and be displayed as a waveform.
You can play your sound in the Timeline view and Sound Editor.
1. In the Timeline view, double-click on the sound layer to open the Sound Editor.
2. In the Sound Editor, press on the Play
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button to listen to your sound.
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Decoding your Sound

You can use the Auto Lip-Sync Detection feature to determine the timing of the mouth
animation. It automatically detects each phoneme and assigns a mouth shape to it.
1. In the Sound Editor, right-click (Windows) or [Ctrl]+Click (Mac OS X) in the Sound
Element space and select Auto Lip-Sync Detection.
2. Press on the Play

button to view the result in the preview space.

An X mouth shape appears when no sound has been detected for a frame.

You can also detect your sound or fine tune the automated detection using the
Sound Scrubbing feature. This feature lets you scroll through the character’s voice
waveform in the Timeline view and listen to the sound one frame at a time.
1. In the Playback toolbar, click on the Sound Scrubbing

button.

2. In the Timeline view, click and drag the red marker to scroll through the scene and
scrub the sound.
Read the upcoming section on How to Swap Mouths to learn how to assign your
mouth shapes as you decode your sound manually.
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Assigning the Mouth Shapes
The automatic
detection supports
seven sound mouth
shapes and one
silent mouth shape.

Now it is time to assign the detected mouth shape to your actual character mouth
shapes layer.
1. In the Timeline view’s right side, right-click (Windows) or [Ctrl]+Click (Mac OS X) on
the sound layer and select Lip-Sync > Map Lip-Sync.
2. In the Mapping Lip-Sync dialog box, choose the layer that contains your character’s
mouths in the Destination Layer drop-down menu.

3. In the Mapping fields, enter the name of each of the drawings of your layer’s mouth
shapes. In this example, the actual drawing names, match the mouth shapes
convention, so there is no need to change it.
4. Click on the OK button.
The lip-sync timing is now all set in the mouth_shapes layer of the Timeline view,
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How to Swap Mouths
You can use the drawing swap feature to time your lip-sync from the start, or use it
to quickly complete the Auto Lip-Sync Detection and Map Lip-Sync results.
1. In the Timeline view, click on the Expand

button to display the Data view.

2. In the Timeline view, select the cell containing the mouth shape you want to
exchange.
3. In the Data view space, place your cursor on top of the drawing name until it
changes to the swapping pointer, and choose the mouth shape you want to expose.
You can also use the Drawing Substitution panel to swap drawings.

1. In the Timeline view, select the cell containing the mouth shape you want to swap.
2. In the Drawing Substitution space of the Library view, click and drag the slider to
choose the desired mouth shape. This automatically exchanges the current drawing
for the one displayed in the preview window. You can also use the default keyboard
shortcuts [ [ ] or [ ] ].
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Playing Back and Exporting

Now it is time to play back the result and export the finished animation to a QuickTime
movie file.
1. In the Playback toolbar, click on the Enable Sound
the sound of your scene during playback.
2. In the Playback toolbar, click on the Play
Camera view.

button. This will let you hear

button and view your animation in the

To export a QuickTime movie:
1. Select File > Export > Movie.
2. In the Export to QuickTime movie dialog box, click on the Browse button to name
the movie and select where you want to save the file.
3. Select either a specific frame range or the entire animation to export.
4. You can also set the Video and Sound options as required.
5. Click on the OK button to export your animation to a QuickTime format.
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M29: Cut-out Four-legged Walk-cycle

This module is divided into the following topics:
•

Theory, on page 672

•

Activity 1: Four-legged Walk-cycle, on page 676

•

Activity 2: A Galloping Donkey, on page 698
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Theory
This topic is divided as follows:
•

Understanding How Four-legged Animals Move, on page 672

•

The Basics of a Four-Legged Walk Cycle, on page 673

Understanding How Four-legged Animals Move
In order to create a believable animation of any living creature, you must carefully
research and study the movements that creature makes when it is in motion and when it
is at rest. Only by doing this will you be able to record, and later animate the subtle
differences that will give your animated character its own specific personality. Even
watching a subject for a few minutes can give you insight into its motion. But where do
you start?
There are a many sources of reference for four-legged creatures, and many ways that you
can use this information to enhance your animation. Some of these are mentioned here,
but you just need look around your surroundings and you will soon find examples you
can study. For example, if you want to animate a cat or dog, you may see one in your
neighbourhood that you can observe.

Anatomy of the Animal

Here we have a sketched in the
approximate skeletal structure of the
horse’s legs. This helps to get the
position of the legs correct as they
bend at the joints.

Why should you study the anatomy of the creature you are trying to animate? First, each
creature looks physically different. This, combined with its weight and size, determines
how an animal moves. For example, a very heavy, lumbering animal like a hippopotamus
moves much differently than a lightweight cheetah would.
Secondly, the underlying skeletal structure is important as this allows the creature to
move and flex its body in different ways. Different skeletal structures allow for different
levels of agility, limb movement and speed. Studying this structure will allow you to see
how a creature moves through its surroundings.
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Photo and Video References

This is a typical example of an
animal locomotion study. You
can see the placement of the
feet, the positioning of the legs
and the body posture from this
one illustration.

If you are going to study creatures moving, such as running or leaping, it may benefit
you to watch live-action video. You can find footage on television shows about animals
or wildlife. These may also be available for rental from video stores or local libraries.
Having a live-action video has certain advantages as you can replay the action and
movements you want to study and pause frames to observe certain poses.
Studying the compiled works of Eadweard Muybridge, an British photographer who
extensively researched and produced photographic studies of walk cycles and animal
locomotion, is invaluable. These works are an amazing resource for anyone intent on
animating realistic character movements.
His studies consist of sequences of images of human and animal movements, shown
against a calibrated background, enabling movement over time to be measured. These
should easily be found in bookstores or at local libraries.

The Basics of a Four-Legged Walk Cycle
Every animal will walk slightly different than another, but there are a few things that most
four-legged walks will have in common. We’ll use a panther animation to go over the
basics.

Movement with Two Sets of Legs
The panther’s legs work together in two groups; back legs and front legs. The back legs
work together and follow a certain pattern, and the front legs will follow a similar
pattern, but the cycle will be ½ step behind the back legs. At the same time, each one
of the panther’s legs will have its own cycle that is slightly offset from the other legs, but
are all dependent on the others.
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The Contact Positions

Both paws at the
front are in the
contact position.

Both the front and back legs have two contact positions. The contact positions in this
walk cycle will be when both feet (paws) in the set (front or back) are making contact with
the ground.

The Passing Positions

Compared to the
previous image, the
front paws are now in
a passing position.

The passing positions show where the leg is going between the contact poses, from the
point when it lifts off the ground to the point when it touches again, between the contact
poses.
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The Keys
Here is what you should reference yourself to before doing Activity 1: Four-legged Walkcycle, carefully study these poses and see how they are different:

The first key. Passing position for the back
legs, contact for the front.

The second key. Contact position for the back
legs, passing for the front.

The third key. Passing position for the back
legs, contact for the front.

The fourth key. Contact position for the back
legs, passing for the front.

Secondary Actions of the Four-legged Walk
Besides the main movement of the feet that propel the body forward, there are the
secondary elements that have to also be considered, such as the up-and-down
movement of the head, or the side-to-side movement of the tail with the rear of the
panther.
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Activity 1: Four-legged Walk-cycle
In this activity, you will animate the four-legged puppet using the sample provided.

Creating your Scene in Animate Pro and Opening the Project
1. Launch Animate Pro by double-clicking on the icon.
2. In the Welcome Screen, click the Open Scene button.
Following your teacher’s instructions, open the donkey_tweens animate scene that
was prepared for you.
This is the scene that should be opening. You will have the donkey cut-out character
and the floor on which he must walk.

Setting Your Preferences as Stop-Motion Keyframes
Before animating anything, you will need to change some settings in your preferences.
1. In the Top Menu, select Edit > Preferences.
2. In the Preferences window, go to the General tab.
3. In the Settings section, make sure that the Stop-Motion Keyframes option is
activated.
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Start with the First Keyframe
Now it is time for you to create the first key in the walk cycle. For the starting position
of this walk cycle, the donkey’s back legs will be in their fully extended contact position,
and the front legs will be in their passing position, a 1/2 step behind in the cycle.
These are elements you will have to move to correctly position the donkey for this
keyframe:
The donkey’s rear quarters
should go down a little on
this keyframe.

His neck will tilt
forward slightly.

Original position

Back legs are in the fully
extended, contact position. Use
the floor to line up the feet.

The donkey’s front legs are in the
passing position. His front feet should
also line up with the floor boards.
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The following steps will guide you through setting the first keyframe. As you go through
these steps you should remember:
•

With the Transform
tool selected, click on an element in the Camera View to
select it, then use the handles to modify its position.

•

Stay on frame 1

1. Rotate the donkey’s body so that his rear moves down a little.
To use the rotate option of the
transform tool, go to any corner until
you see the following cursor appear.

Once the body is rotated, you’ll have to readjust the position of his head and legs to
match the new placement of the body.
2. Tilt the donkey’s whole head down a little by rotating the element that controls his
neck.
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3. Place the donkey’s back legs in their extreme contact position, then place the front
legs in the passing position. Use the image below and the lines on the floor as
guides for lining up the feet:

Keyframe 1 should be good for now. You will probably have to make small
adjustments to this keyframe later, after you’ve started working on the others.
4. Save your work with the Save

Button.

Setting the Second Keyframe
Now that you have set the first keyframe you need to set the second one. This keyframe
will be the opposite of keyframe 1. The donkey’s rear quarters will rotate upwards to
accommodate the back legs in the passing position. The head will also rotate back up
and his front legs will now move to their fully extended, contact position.
1. In the Timeline, make sure the whole donkey hierarchy is collapsed and add a
keyframe to frame 2 before you start to make any changes.
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These are the items you need to move to correctly position the donkey for keyframe
2:
Rotate his body to
move his rear back up.

The head should be back up
compared to keyframe 1.

Starting

Now his back legs are in
the passing position.

And the his front legs are in their
fully extended, contact position.

2. Start by rotating the body forward slightly, so that this time you move the donkey’s
rear quarters up a little.
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3. Reposition and rotate the donkey’s head back only slightly.

4. Move and rotate the legs so that the back legs are in the passing position, and the
front ones are in their extended contact position.

Remember, it is important to:
•

Keep the feet aligned

•

Maintain the original proportions of the character

Flipping Through Keyframes
In traditional animation the term flipping is used when referring to the animator going
through his drawings rapidly to see the animation of the keys. This is a very useful trick
when animating, and can be applied to cutout animation. You can use the Previous
Frame and Next Frame commands to make this easy.
681

Animate Pro 2 - Student Workbook

Setting Keyframes Three and Four
Now that you have set the first two keyframes you need to set up keyframes 3 and 4.
However, this time you will learn a new technique that will save you time.

Copying the Keyframes
The first two extreme poses have been set, and the next two will be very similar to these
first ones. So similar in fact, that we are going to copy and paste the keyframe
information from the first two keys, into keyframes 3 and 4 to save a little time.
1. With the character’s hierarchy collapsed, click to select keyframe 1.
2. Use the keyboard shortcut [Ctrl]+[C] to copy this keyframe. On Mac use
[Command]+[C].
3. Now click to select frame 3 and use [Ctrl]+[V] to paste the information from the first
keyframe here. On Mac use [Command]+[V].
4. Repeat Step 1 to Step 3 to copy keyframe 2 and paste it into frame 4.

Reversing the Leg Positions
Now you must reverse the position of the legs for keyframes 3 and 4. All of the other
elements are fine and do not need to be touched. Carefully study the next two steps and
see how the positions change from pose to pose.
1. On keyframe 3, reverse the position of the front and back legs.

From this pose...
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2. Repeat Step 1, and do the same for keyframe 4.

From this pose...

... to this pose.

Adjusting the Feet for a Pan Background
Now you will add a pan movement to the background elements so you will need to
animate the donkey walking on one spot. Because of this, the donkey’s feet will have to
slide backwards at the same speed as the background is panning. This will help avoid
the look of the donkey’s feet losing synchronization when we add a background and pan.
For now, you should adjust his feet so they move in even increments and then adjust the
speed of the pan to match the speed of the walk later. To make these changes, use some
of the following tools and tricks to help you.
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Show/Hide Elements
When making adjustments to certain parts of the character, it’s helpful to hide all other
elements to make things clearer.
1. In Camera View, use the Transform tool to select the donkey’s back right leg.

Be sure to select all
the pieces in the
select together first
as showed here

2. From the Timeline, right-click and select choose Enable > Disable All Others.
Now you should only see the back leg in Camera View, making it easier to see
mistakes and make adjustments.

3. When you’re done, make sure the object is still selected and once go to the Display
menu, but this time choose Enable All.
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Using the Onion Skinning Feature
As in traditional animation, you’ll use the Onion Skinning feature so that you can see the
drawings on the frames before and after your current selection. This is a great way to
help you to make adjustments to elements in relation to other keyframes.
To enable the Onion Skinning feature:
1. You can activate the Onion Skinning feature on by clicking this button

.

2. To include more frames into the Onion Skinning feature, you will need to drag the
blue handles that are over the frames in the Timeline.

Depending on how many frames you decide to include in your onion skin, you should
now be able to see the previous and next drawings in Camera View.
3. You can also choose to see your onion skin levels as outlines. From the Top menu,
choose Edit > Preferences, than go to the Drawing tab.
4. In the Light Table options, change the Onion Skin Render Style to Outline Only.

685

Animate Pro 2 - Student Workbook

Adjusting Pan Increments
Now that your keys are basically set, you may have to make adjustments to the feet as
they are planted on the ground. Use the Onion Skinning and the Show/Hide tools to
make sure that your feet are evenly spaced.
Flip through the keys and make any adjustments necessary to the legs and feet so that
they are evenly spaced. Use the following drawing as reference.

5. Once you have made all adjustments to the back right leg, adjust the back left leg in
the same way.
6. Use the following drawing to make adjustments to both front legs.
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Previewing Your Animation
Before you preview your animation, you need to extend the exposure of your keyframes.
If you try to preview your animation before doing this, you won’t be able to judge the
timing properly because each keyframe is only held for one frame. Once your timing is
determined, you should know exactly how many inbetweens will be necessary.

Extending the Animation
At this point you need to make an exact copy of keyframe 1 at keyframe 5. This makes
sure the animation will loop seamlessly by returning the walk cycle to the starting point.
1. Copy keyframe 1 and paste it into frame 5.
Remember, if you make additional changes to keyframe 1, you’ll have to repeat this
step so that both keyframes are identical.
2. Make sure your donkey’s hierarchy is collapsed in the Timeline.
3. Click to select the last keyframe on frame 5.
4. Drag this keyframe to frame 13.

With the Timeline collapsed you’ll be dragging all the keyframe underneath as well.
5. Repeat this step and spread out your keyframes evenly as in the image below:

6. Click the Loop button so that the animation will replay more than once, then hit the
Play button to preview your animation in Camera View.

You will probably notice that your animation seems to stick. That’s because
keyframe 1 is being held for an extra frame because of the copy on frame 13.
7. In the Timeline, drag the little black triangle back one frame so that frame 13 isn’t
included in the playback.

8. Play back your animation again.
9. Make sure that you save your work often!
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Inbetweening
Animate Pro’s automatically generated keyframes are a great tool for cut-out animation,
and can save an immense amount of time and effort on your part. And though you will
most likely have to adjust some of the inbetweens generated by Animate Pro, it’s far
easier than having to create keyframes for all the inbetween poses yourself.

Modifying the Cut-out Preferences
In the previous chapter we were working with Stop-Motion Keyframes. Now that we’ve
moved on to inbetweening, we will want to create Motion keyframes.
1. From the menu bar menu, choose Edit > Preferences.
2. Navigate to the General tab.
3. In the Settings options, uncheck the Stop-Motion Keyframes box.

Changing to Stop-Motion Keyframes
In order for Animate Pro to generate inbetween drawings, we have to change the
segments between each keyframe from stop-motion to motion keyframes.
1. In the Timeline, make sure that the donkey character is completely collapsed.
2. Select the first walk cycle keyframe.

3. In the Timeline, click on the Set to Motion Keyframe

Button.

You’ll now see a arrow in between the first two keys on this peg. This line indicates that
Animate Pro has automatically created the inbetween drawings for keyframes 1 and 2
for you.
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As you applied the change while the entire character was collapsed, an inbetween pose
has been created for all of the donkey’s keyframes, on all his elements.

4. Select one keyframe at a time and repeat Step 1 to Step 3 to add all the inbetweens
to your scene. Make sure you collapse your Timeline again before you do this.
Your Timeline should look like this when you’re done:

5. Preview your animation.

Making Adjustments to the Inbetweens
Animate Pro has just created inbetween drawings for your entire animation. What you
have to do now is take a closer look at what the software has created, make sure it’s what
you were looking for and make any adjustments necessary.
1. Using the current frame slider, scrub between frames to see the inbetweens that
were generated by Animate Pro
2. You can also preview your animation to see the results.

Keeping the Feet Aligned
The main problem you’ll have with these generated inbetweens is that the donkey’s feet
will seem to slide around, or move up and down between keys. His feet will sometimes
also appear to be going right through the floor. This won’t be difficult to fix, but it is a
very important factor in creating a realistic, believable walk.
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Also, keep in mind the placement of the feet in perspective, and make sure you are
consistent.

Example of the donkey’s foot
going through the floor.

Modifying the Inbetweens
Now that you’ve determined what needs to be fixed, it’s time to go and make those
adjustments.
Before we go ahead with the changes, however, we’ll want to add new keyframes. This
will help keep your keys organized.
1. In the Timeline, make sure that the donkey character is completely collapsed.
2. Add a keyframe using the Insert Keyframe

Button, to frame 2.

Make sure to repeat these steps every time you adjust an inbetween.
3. One foot at a time, make adjustments to the inbetweens.
When modifying your inbetweens remember:
•

Pay attention to what frame you are on while making adjustments.

•

Use the Show/Hide option to isolate parts of the character.

•

Flip through your animation and make use of the Onion Skinning feature.

•

Add a keyframe before you make the adjustments to each inbetween.

4. Preview your animation. Continue adding keyframes and adjusting your inbetweens
until you get the walk cycle just the way you want it.
5. Watch the donkey_final.mov to see our animation.
6. Save your work using the Save
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Uploading the Templates in the Scene
Follow the steps here to load the necessary templates into your scene’s local library.
1. In the library tab, right click on the right side window and select Open Library. In the
Browse For Folder window, select the template folder provided by your teacher.
2. Once the folder is imported, it will be added to the Library. You can then select it to
see the templates it contains. These templates can now be used in your scene.

Cycling The Animation
You now have a complete, twelve-frame, four-legged walk ready to be looped as many
times as you need.
Follow the upcoming steps to add background elements and extend the length of your
scene. Then you’ll be ready to animate the background elements to finish off the walk
cycle.

Adding Background Elements
In your library there are three background elements for you to add to your scene. Add
the elements now, then later in this part attach them to a peg and pan them all together.
1. In the Library, select the new added folder with the templates.
2. Click to select the temple.tpl.
3. Drag the template into your Timeline and drop it below the ground layer.

4. Repeat Step 2 and Step 3 to add the mountains below the temple, and then the sky
below the mountains.
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Your Camera View should look like this:

Different Z-Axis Values for the Background Elements
When the templates for these background elements were created, each piece was
placed in a different spot along the Z-axis. This will create an automatic multiplaning
effect later when you create the pan.
1. Look at your scene in the Top View to see all the elements and their distances from
the camera.

Removing the Duplicate Keyframe
The key on frame 13 of the donkey’s walk is a copy of the key on frame 1. This was placed
here for inbetweening purposes, and is no longer necessary. You now need to remove
this keyframe before we copy the animation.
1. Make sure your character is completely collapsed in the Timeline.
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2. Click to select the last keyframe on frame 13.

3. Press [Delete] on your keyboard to remove this keyframe.

Now we have one complete, 12 frame walk cycle.

Copying the Animation
Now that the duplicate keyframe has been removed, these 12 frames of animation, when
duplicated, will loop together seamlessly to create the walk cycle. These steps will show
you an easy way to copy your keyframes and repeat the walk cycle as many times as you
need. For this project, we’re going to loop the animation four times.
1. First, make sure you have enough frames in your scene. In your Timeline, drag the
red bar up to frame 48.

2. Click to select the first keyframe, then [Shift]+click frame 12. This should select all
the keyframes.

3. Use the keyboard shortcut [Ctrl]+[C] to copy these 12 frames.
On Mac use [Command]+[C].
4. Click on the blank frame 13, then use the keyboard shortcut [Ctrl]+[V] to paste the
12 keyframes starting here. On Mac use [Command]+[V].
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5. Repeat Step 3, this time selecting frame 25 to paste your animation into.

6. Repeat one last time, pasting this fourth set into frame 37.

Now your donkey’s animation will repeat four times and be exposed until frame 48.

Extending Background Elements
With your scene extended to frame 48, you also need to extend your background
elements.
1. [Shift]+click frames 48 for all four background elements.

2. Right-click your selection, and choose Extend Exposure from the popup menu.
On Mac use [Ctrl]- click. In the Extend Exposure window, enter 48, then click on OK.

3. The background elements have now been extended to frame 48.

4. Make sure the playback triangle is back to frame 48.
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Panning the Background Elements
In order to finalize your animation, we are going to add a side movement of the
background elements called a pan. It is important to match the timing of the walk to the
timing of the background pan, so that the character appears to walk at the correct
speed.

Adding a Parent Peg for the Pan
To move the background elements, we’ll attach them all to one parent peg and set the
keys there.
1. Create a new peg with the Add Peg

Button.

2. Double-click your new peg, and rename it Peg-PanBG. Hit Enter when you’re done.

3. [Shift]+click to select all background elements, then drag and drop them onto the
new peg.

Doing so will make all the selected elements children of this parent peg.
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Moving the Background Elements
With the automatically generated inbetweens, it’s a breeze to do camera movements.
1. First, be sure that the Animate

Button is activated. Then, choose the Transform

tool.
2. Click on keyframe at frame 1 of the new PanBG peg.
3. Click the Add Keyframe

Button to add a keyframe to the peg.

4. Drag the red time slider to the end of the animation, frame 48, and make sure to
have Peg-PanBG still selected.
5. Hold down [Shift] and use the left arrow key to move the background elements as
far to the left as you can.

Because you have the Transform tool selected, you will be adding a new keyframe. Your
Timeline will now look like this:
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6. Make sure to save the progress of your work by clicking the Save
7. Play back the animation of the walk cycle with the Play

button.

button and test/correct

your work. You can also activate the Loop
button, to view your animation in
loops while noting the corrections you will have to do.
Because all your elements have varying Z-axis values, they will all appear to move at
different speeds as they move past the camera, creating an automatic multiplaning
effect.
8. Watch the donkey_pan.mov file to see the final results.
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Activity 2: A Galloping Donkey

Using the provided Donkey_tweens.anim project start another animation of the donkey,
but this time, make him gallop.
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•

Just like with the previous project, you will need to animate the donkey puppet
with the transform tool.

•

Animate the puppet, then import the background templates.

•

The timing of the peg for the background elements will be different from the
previous walk cycle. Try adjusting it so that it works with the new animation.

•

Remember that a run cycle requires less frames than a walk cycle.

M30: Output and Rendering Options

This module is divided into the following topics:
•

Exporting a QuickTime Movie, on page 700

•

Exporting an SWF Movie (Flash), on page 705

•

Exporting an FLV Movie, on page 707
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Exporting a QuickTime Movie
To export a QuickTime Movie:
1. From the top menu, select File > Export > Movie.
The Export to QuickTime Movie dialog box opens.

2. From the dialog box, click on the Browse button to choose a destination path to
where your movie will be saved and an appropriate filename for the export.
3. Click on the Save button when you are finished.
4. In Animate Pro, the Display Source section is where you can select which Display
module you want to use to render out your project. If there is no Display module in
the scene, the drop-down list will indicate Display All and will render out the scene
in the same order as the Timeline view. It is always recommended to render out
from the Display module, located under the final Composite module, unless you
want to render out a specific section displayed by a particular Display module.
In the drop-down list, select the desired Display module.
5. From the Export Range section, decide whether you would like to export the entire
scene (All) or just a selected frame range. If you decide on the latter, be sure to
enter in the frame range in the fields provided.
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6. In the Options section, click on the Movie Options button.
1
2
3
4

5
6

7
8

•

1. Video: Check this box to enable the customization of the video settings,
filters and size.
D
D
D

•

5. Sound: Check this box to enable the customization of the sound settings.
D

•

2. Settings: Opens the Standard Video Compression Settings dialog box (see
below).
3. Filter: Opens the Choose Video Filter dialog box, where you can select
from a range of filters to apply to your video export.
4. Size: Opens the Export Size Settings dialog box, where you can choose a
different export size from the settings predefined for your project.
6. Settings: Opens the Sound Settings dialog box (see below).

7. Prepare for Internet Streaming: Check this box to enable the customization
of the internet streaming options.
D

8. Internet Streaming drop-down: Select from the drop-down menu options
for the type of streaming best suited for your needs.

7. In the Video section, click on the Settings button.
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The Standard Video Compression Settings dialog box opens.

8. From the Compression Type drop-down menu, select a codec.
The availability of certain Compression Settings depends on the Compression
Type selected. For example, Animation is the default compression type and as a
result the Data Rate option is greyed out.
9. In the Motion section, choose your Frames per second from the drop-down menu.
By default, it will be set to match the frames-per-second (fps) of your Animate Pro
project. If you choose a lower frame rate, your export play back will be faster than
your actual project. The reverse is also true for a higher frame rate.
10.From the same section decide whether you would like key frames inserted by
checking the Key Frames Every box, and if so, the number per frame.
This is the option is recommended by QuickTime. A further description of this topic
is cited below.
Many compressors use "frame differencing" to compress moving images.
Frame differencing is the process of determining what information has changed
from a starting frame (called a "key frame") to subsequent frames. The key frame
contains all of the information for an image. Subsequent frames contain only the
information that has changed.
Depending on the compressor you use, you can specify how often you want key
frames to occur. If you don't have enough key frames, the quality of your movie
might be lower because most frames are generated from others. However, more
key frames result in a larger movie with a higher data rate. With some compressors,
an additional key frame is inserted automatically if too much of the image has
changed from one frame to the next.
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A good rule of thumb for general use is to have one key frame every 5 seconds
(multiply the frames per second by 5). If you are creating a file for RTSP streaming
and have concerns about the reliability of the delivery network (as with the public
Internet), you may want to increase key frame frequency to one key frame every 1 or
2 seconds.
11.From the Compressor section, choose a Depth based on your movie’s needs, for
example, Millions of Colours+ houses an alpha channel.
12.In the Quality section, use the slider to choose a quality setting. Remember that the
better the quality of the export, the larger the file.

13.From the Data Rate section, either choose to allow the program to automatically
select the most optimal bit rate, or enter in a Restricted rate to save space and allow
for faster downloading at a cost to the quality of your export.
14.In the same section, from the Optimized for drop-down list, select the intended
viewing method for your export.
15.Click the OK button when you are finished.
16.From the Movie Settings dialog box, click-on the Sound Settings button.
The Sound Settings dialog box opens.

17.From the Compressor drop-down menu, choose a compression type.
The default setting is None. This will preserve your original sound file, without the
loss of information. However, an uncompressed sound file will inevitably add
“weight” to the overall size of your video export.
18.Select a Rate by pressing the down arrow button next to kHz.
It is best to check and match the original properties of your sound file. For example,
if your file has an audio sample rate of 48 kHz and you choose a conversion rate of
22.05 kHz, the sound will play at the same speed, but with higher frequencies
missing.
For a standard film sound quality, choose 44.1 kHz, or 48 kHz for DVD quality.
Anything less will make the sound “dull” or less bright. For things like recorded
voice this doesn't matter so much, but for music it can make an audible difference.
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If file size is a consideration, such as with videos for the internet, then a lower rate
might be more practical.
19.Next, choose the Size and the Use, which are related. Once again, it is advisable to
check your original sound file properties. If the file was recorded in one channel
(mono), there is little point in choosing the two channel (stereo) option.
Although Mono can support a 16-bit channel, the extra information is unnecessary.
Mono is generally paired with 8-bit and Stereo with 16-bit.
20.Click on the OK button when you are done.
21.In the Export to QuickTime Movie dialog box, click the OK button.
A progress bar appears.

22.Browse to the location on your computer where you saved your QuickTime video
and double-click on it to view your export.
If you feel that your exported video is either to small or too large, change the your
project size from the top menu under Scene > Scene Settings. This will change the size
of the video output.

Exporting a QuickTime Movie with Transparency
To render out a QuickTime movie with transparency, you need to set the Depth to
Millions of Colours +.
To select Millions of Colours +, do the following: Movie Options > (Video) Settings >
(Compressor) Depth and select Millions of Colours +.
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Exporting an SWF Movie (Flash)
The SWF export now supports both bitmap effects (which can be previewed in Render
View
mode) and SWF Blend Modes (vector effects which can be previewed in
OpenGL View
mode). If you have not already done so, you should preview the SWF
by using the SWF preview
button to see what the two types of effects look like when
blended together. Once you are satisfied with the results, continue to the Export to SWF
Movie procedure.
To export a SWF Movie:
1. From the top menu, select File > Export > SWF.
The Export to Flash Movie (SWF) dialog box opens.

2. To choose an appropriate filename and a destination path where your movie will be
saved to, from the dialog box, click on the Browse button.
3. From the Export Range section, decide whether you would like to export all the
frames of your movie or just a selected frame range. If you decide on the latter, be
sure to enter in the frame range in the fields provided.

4. In the Options section, enter your Frames rate (fps) into the field provided. By
default, it will be set to match the fps of your Animate Pro project. If you choose a
lower frame rate, your export play back will be faster than your actual project. The
reverse is also true for a higher frame rate.
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5. In the same section, select the JPEG quality.






100 = full quality
50 = average quality at about 1/5th of the size.
25 = medium quality where loss of high image resolution starts to occur.
10 = low quality where “macro-blocking” or large pixelation become obvious.
1 = lowest quality where there is extreme loss of colour and detail and where the
image becomes nearly unrecognizable.

6. If you want to protect your movie to be imported in another application, enable the
Protect from Import option.
7. Enable the Compress Movie option if you want to get a lighter format. The movie
may lose some quality, but in turn create a lighter file.
8. In the Disabled Effects section, check the boxes of the vector-based effects that you
would NOT like to see in the SWF render.
Note that certain Animate Pro effects will not be listed in this section as they are not
vector-based and therefore not available for SWF export. These effects will not
appear in the SWF render.
9. Press the OK button when you are finished.
10.Browse to the location on your computer where you saved your Flash Movie and
double-click on it to view your export.
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Exporting an FLV Movie
Animate Pro can also export FLV movie files, this is an Adobe®Flash® format.
To export a Flash Video:
1. From the top menu, select File > Export > Flash Video.
The Export to Flash Video dialog box opens.

2. To choose an appropriate filename and a destination path where your movie will be
saved to, from the dialog box, click on the Browse button.
3. Click on the Save button when you are finished.
4. The Display Source section is where you can select which Display module you want
to use to render out your project. If there is no Display module is the scene, the
drop-down list will indicate Display All and will render out the scene in the same
order as the Timeline view. It is always recommended to render out from the Display
module, located under the final Composite module, unless you want to render out a
specific section displayed by a particular Display module.
5. In the drop-down list, select the desired Display module.
6. From the Export Range section, decide whether you would like to export the entire
scene (All) or just a selected frame range. If you decide on the latter, be sure to
enter the frame range in the fields provided.

7. In the Options section, click on the Video Options button.
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The Video Options dialog box opens.

8. Select the Bit Rate (compression) in Kbits/sec.


Between 400 to 900 is the optimal range. For Flash Videos, which are primarily
used for the web, 500 or 512 is considered standard.

9. Enter the Frames per Second in the field provided. It is advised that you check the
frame rate of your project and try to match it.
If you choose a lower frame rate, your export will appear faster than your project
and vice versa is true for a higher frame rate.
10.Click on the OK button.
11.In the Options section, click on the Sound Options button.
The Sound Options dialog box opens.

12.Select the Sample Rate in kHz from the drop-down menu.
It is best to check and match the original properties of your sound file. For example,
if your file has an audio sample rate of 44.1 kHz and you choose a conversion rate of
22.05 kHz, the sound will play at the same speed, but with higher frequencies
missing.
For a standard film sound quality, choose 44.1 kHz. Anything less will make the
sound “dull” or less bright. For things like recorded voice this doesn't matter so
much, but for music it can make an audible difference.
If file size is a consideration, such as with videos for the internet, than a lower rate
might be more practical.
13.Select the Channel size, either 8 or 16-bit.
16-bit can store more sound information than 8-bit, however, if your original sound
sample was recorded on a mono channel, then this extra space is unnecessary. Once
again, it is best to refer to the properties of your sound file.
14.Select a Channel Count, either mono or stereo.
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Stereo supports two channels and therefore requires at least 16-bits. However, if
your original sound sample was recorded on a mono channel, then this option is
moot. It is best to refer to the properties of your sound file.
15.Click the OK button.
16.In the Export to Flash Video dialog box, press OK.
A progress bar will appear.
17.Browse to the location on your computer where you saved your Flash Video and
double-click on it to view your export.
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